36ec43592b498d5cafeda29edf44bc7bad5dd224
[apps/native/bluetooth-share-ui.git] / packaging / org.tizen.bluetooth-share-ui.spec
1 %define _usrdir /usr
2 %define _appdir %{_usrdir}/apps
3
4 Name:       org.tizen.bluetooth-share-ui
5 Summary:    bluetooth share UI application
6 Version:    0.6.0
7 Release:    1
8 Group:      TO_BE_FILLED
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(appcore-efl)
15 BuildRequires:  pkgconfig(bundle)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(edbus)
18 BuildRequires:  pkgconfig(edje)
19 BuildRequires:  pkgconfig(elementary)
20 BuildRequires:  pkgconfig(efl-extension)
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(capi-appfw-application)
24 BuildRequires:  pkgconfig(capi-network-bluetooth)
25 BuildRequires:  pkgconfig(bluetooth-share-api)
26 BuildRequires:  pkgconfig(notification)
27
28 BuildRequires:  cmake
29 BuildRequires:  edje-tools
30 BuildRequires:  gettext-devel
31 BuildRequires:  hash-signer
32
33 %define PKG_NAME %{name}
34
35 %description
36 bluetooth share UI application
37
38
39 %prep
40 %setup -q
41
42 %build
43 export CFLAGS+=" -fpie -fvisibility=hidden"
44 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
45
46 cmake . -DCMAKE_INSTALL_PREFIX=%{_appdir}/org.tizen.bluetooth-share-ui
47 make %{?jobs:-j%jobs}
48
49
50 %install
51 rm -rf %{buildroot}
52 %make_install
53 PKG_ID=%{name}
54 %define tizen_sign 1
55 %define tizen_sign_base /usr/apps/${PKG_ID}
56 %define tizen_sign_level platform
57 %define tizen_author_sign 1
58 %define tizen_dist_sign 1
59
60 %post
61
62 %postun
63
64
65 #%files
66 #%defattr(-,root,root,-)
67
68 %files
69 %manifest bluetooth-share-ui.manifest
70 %license LICENSE
71 %defattr(-,root,root,-)
72 %{_appdir}/%{name}/res/edje/bt-share-layout.edj
73 %{_appdir}/%{name}/res/edje/images.edj
74 %{_appdir}/%{name}/bin/bluetooth-share-ui
75 %{_appdir}/%{name}/author-signature.xml
76 %{_appdir}/%{name}/signature1.xml
77 %{_usrdir}/share/icons/default/small/%{name}.png
78 %{_usrdir}/share/packages/%{name}.xml
79