Update package version to 1.0.26
[platform/core/uifw/autofill-daemon.git] / packaging / org.tizen.autofilld.spec
1 Name:       org.tizen.autofilld
2 Summary:    Autofill Daemon
3 Version:    1.0.26
4 Release:    1
5 Group:      Graphics & UI Framework/Input
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  tidl
10 BuildRequires:  pkgconfig(libtzplatform-config)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(efl)
13 BuildRequires:  pkgconfig(eina)
14 BuildRequires:  pkgconfig(ecore)
15 BuildRequires:  pkgconfig(rpc-port)
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(capi-appfw-service-application)
18 BuildRequires:  pkgconfig(capi-appfw-preference)
19 BuildRequires:  pkgconfig(capi-appfw-app-manager)
20
21 %if "%{?profile}" == "tv"
22   %define __hash_signing 0
23 %else
24   %define __hash_signing 1
25 %endif
26
27 %if 0%{?__hash_signing}
28 BuildRequires:  hash-signer
29 %endif
30
31 %description
32 Autofill Daemon
33
34
35 %prep
36 %setup -q
37
38 tidlc -s -l C -i tidl/autofill.tidl -o autofill_stub
39 mv autofill_stub.h ./src/
40 mv autofill_stub.c ./src/
41
42 tidlc -p -l C -i tidl/autofill_service.tidl -o autofill_service_proxy
43 mv autofill_service_proxy.h ./src/
44 mv autofill_service_proxy.c ./src/
45
46 tidlc -s -l C -i tidl/autofill_manager.tidl -o autofill_manager_stub
47 mv autofill_manager_stub.h ./src/
48 mv autofill_manager_stub.c ./src/
49
50
51 %build
52 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden -Werror"
53 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden -Werror"
54 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
55
56 rm -rf CMakeFiles
57 rm -rf CMakeCache.txt
58 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
59 %cmake . -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
60
61 make %{?jobs:-j%jobs}
62
63 %install
64 rm -rf %{buildroot}
65 %make_install
66
67 %if 0%{?__hash_signing}
68 %define tizen_sign 1
69 %define tizen_sign_base /usr/apps/%{name}
70 %define tizen_sign_level platform
71 %define tizen_author_sign 1
72 %define tizen_dist_sign 1
73 %else
74   install -m 0644 sign/tv/author-signature.xml "%{buildroot}"/%{TZ_SYS_RO_APP}/%{name}
75   install -m 0644 sign/tv/signature1.xml "%{buildroot}"%{TZ_SYS_RO_APP}/%{name}
76 %endif
77
78 %post
79
80 %files
81 %manifest %{name}.manifest
82 %{TZ_SYS_RO_PACKAGES}/%{name}.xml
83 %{TZ_SYS_RO_APP}/%{name}/*