Bump to openfst 1.8.1
[platform/upstream/openfst.git] / packaging / openfst.spec
1 %define         soname 0
2
3 Name:           openfst
4 Version:        1.8.1
5 Release:        0
6 Summary:        Weighted finite-state transducer library
7 License:        Apache-2.0
8 Group:          Development/Tools/Other
9 Url:            http://www.openfst.org/
10 Source0:        %{name}-%{version}.tar.gz
11 Source1:        LICENSE.APACHE2.0
12 Source2:        Add-pie-compile-option.patch
13 Source1001:     openfst.manifest
14
15 BuildRequires:  gcc-c++
16 BuildRequires:  pkgconfig(zlib)
17 BuildRequires:  python-devel
18
19 %description
20 OpenFst is a library for constructing, combining, optimizing and
21 searching weighted finite-state transducers (FSTs).
22
23 %package devel
24 Summary:        Development files for OpenFst
25 License:        Apache-2.0
26 Group:          Development/Libraries/C and C++
27 Requires:       %{name} = %{version}-%{release}
28
29 %description devel
30 OpenFst is a library for constructing, combining, optimizing and
31 searching weighted finite-state transducers (FSTs).
32
33 %package tools
34 Summary:        Command-line tools for working with FSTs
35 Group:          Development/Tools/Other
36 Requires:       %{name} = %{version}-%{release}
37
38 %description tools
39 OpenFst is a library for constructing, combining, optimizing and
40 searching weighted finite-state transducers (FSTs).
41
42 This package contains command-line tools that give access to OpenFst
43 functionality.
44
45 %prep
46 %setup -q
47 cp %{SOURCE1} .
48 cp %{SOURCE1001} .
49 %{__patch} -p1 < %{SOURCE2}
50
51 %build
52 export CXXFLAGS+=" -fPIC"
53 autoreconf -fi
54 %configure
55 %{__make} %{?_smp_mflags}
56
57 %install
58 %{__make} install DESTDIR=%{buildroot}
59
60 find  %{buildroot}%{_libdir} -name '*.la' -delete
61
62 %remove_docs
63
64 %post -p /sbin/ldconfig
65
66 %postun -p /sbin/ldconfig
67
68 %files
69 %manifest openfst.manifest
70 %license LICENSE.APACHE2.0
71 %{_libdir}/*.so.*
72
73 %files devel
74 %manifest openfst.manifest
75 %license LICENSE.APACHE2.0
76 %{_includedir}/fst
77 %{_libdir}/*.so
78
79 %files tools
80 %manifest openfst.manifest
81 %license LICENSE.APACHE2.0
82 %{_bindir}/*