tizen 2.3 release
[framework/multimedia/openal-soft.git] / packaging / openal-soft.spec
1 Name:       openal-soft
2 Summary:    OpenAL library software implementation
3 Version:    1.14
4 Release:    1
5 Group:      Multimedia/openal-soft
6 License:    LGPLv2+
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: cmake
9 BuildRequires: pkgconfig(mm-session)
10 BuildRequires: pkgconfig(libpulse)
11 BuildRequires: pkgconfig(audio-session-mgr)
12 BuildRequires: pkgconfig(vconf)
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15
16
17 %description
18 OpenAL library software implementation
19
20
21
22 %package devel
23 Summary:    OpenAL library software implementation (devel)
24 Group:      Development/Libraries
25 Requires:   %{name} = %{version}-%{release}
26
27 %description devel
28 OpenAL library software implementation development package
29
30
31 %prep
32 %setup -q
33
34 %build
35
36 %ifarch %arm
37 export CFLAGS+=" -DARM_ARCH -O3 -ftree-vectorize -ffast-math -fsingle-precision-constant -DUSE_ASM_IN_PULSEAUDIO -DUSE_DLOG "
38 %else
39 export CFLAGS+=" -DI386_ARCH -DUSE_ASM_IN_PULSEAUDIO "
40 %endif
41
42 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
43 make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 mkdir -p %{buildroot}/usr/share/license
48 cp COPYING %{buildroot}/usr/share/license/%{name}
49 %make_install
50
51
52 %post -p /sbin/ldconfig
53
54 %postun -p /sbin/ldconfig
55
56
57
58 %files
59 %manifest openal-soft.manifest
60 %{_libdir}/*.so*
61 %{_bindir}/*
62 /etc/openal/alsoft.conf
63 /usr/share/license/%{name}
64
65 %files devel
66 %{_includedir}/*
67 %{_libdir}/pkgconfig/*
68