Revert "Set PKG_CONFIG_CFLAGS properly"
[platform/upstream/openal-soft.git] / packaging / openal-soft.spec
1 Name:           openal-soft
2 Version:        1.17.2
3 Release:        16
4 License:        LGPL-2.0+
5 Summary:        A cross-platform 3D audio API
6 URL:            http://connect.creativelabs.com/openal/
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source1001:     openal-soft.manifest
10 BuildRequires:  cmake
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(libpulse)
13 BuildRequires: pkgconfig(capi-media-sound-manager)
14
15 %description
16 OpenAL is a cross-platform 3D audio API appropriate for use with gaming
17 applications and many other types of audio applications.
18
19 %package devel
20 Summary:        openal-soft development package
21 Group:          Development/Libraries
22 Requires:       %{name} = %{version}
23
24 %description devel
25 Development package for OpenAL, a cross-platform 3D audio API
26 appropriate for use with gaming applications and many other types of
27 audio applications.
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} .
32
33 %build
34
35 export CFLAGS+=" -D__TIZEN__ -DUSE_DLOG "
36 export TIZEN_BUILD=1
37
38 %cmake .
39 make %{?_smp_mflags}
40
41 %install
42 %make_install
43
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49
50 %files
51 %manifest %{name}.manifest
52 %license COPYING
53 %{_bindir}/openal-info
54 %{_bindir}/altonegen
55 %{_libdir}/libopenal.so.*
56 /etc/openal/alsoft.conf
57 %exclude /usr/lib/debug/.build-id/*
58 %exclude %{_datadir}/openal/hrtf/*
59
60 %files devel
61 %manifest %{name}.manifest
62 %{_includedir}/AL/*.h
63 %{_libdir}/libopenal.so
64 %{_libdir}/pkgconfig/openal.pc