1fe4d747b42d3289d741dbd9bf44e767acf26634
[platform/upstream/openal-soft.git] / packaging / openal-soft.spec
1 Name:           openal-soft
2 Version:        1.17.2
3 Release:        2
4 License:        LGPL-2.0+
5 Summary:        A cross-platform 3D audio API
6 URL:            http://connect.creativelabs.com/openal/
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source1001:     openal-soft.manifest
10 BuildRequires:  cmake
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(libpulse)
13
14 %description
15 OpenAL is a cross-platform 3D audio API appropriate for use with gaming
16 applications and many other types of audio applications.
17
18 %package devel
19 Summary:        openal-soft development package
20 Group:          Development/Libraries
21 Requires:       %{name} = %{version}
22
23 %description devel
24 Development package for OpenAL, a cross-platform 3D audio API
25 appropriate for use with gaming applications and many other types of
26 audio applications.
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32 %build
33
34 export CFLAGS+=" -D__TIZEN__ -DUSE_DLOG "
35
36 %cmake .
37 make %{?_smp_mflags}
38
39 %install
40 %make_install
41
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48 %files
49 %manifest %{name}.manifest
50 %license COPYING
51 %{_bindir}/openal-info
52 %{_bindir}/altonegen
53 %{_libdir}/libopenal.so.*
54 /etc/openal/alsoft.conf
55 %exclude /usr/lib/debug/.build-id/*
56 %exclude %{_datadir}/openal/hrtf/*
57
58 %files devel
59 %manifest %{name}.manifest
60 %{_includedir}/AL/*.h
61 %{_libdir}/libopenal.so
62 %{_libdir}/pkgconfig/openal.pc