Merge "Update changelog"
[profile/ivi/ofono.git] / packaging / ofono.spec
1 Name:       ofono
2 Summary:    Open Source Telephony
3 Version:    1.8
4 Release:    6
5 Group:      Communications/Connectivity Adaptation
6 License:    GPLv2
7 URL:        http://ofono.org
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1:    init_ofono
10
11 Requires(post): /bin/ln
12 Requires:   dbus
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(dbus-1)
15 BuildRequires:  pkgconfig(libudev) >= 145
16 BuildRequires:  pkgconfig(bluez) >= 4.85
17 BuildRequires:  libtool
18 BuildRequires:  automake
19 BuildRequires:  autoconf
20 BuildRequires:  pkgconfig(mobile-broadband-provider-info)
21
22
23 %description
24 Telephony stack
25
26
27 %package devel
28 Summary:    Headers for oFono
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 Development headers and libraries for oFono
34
35 %package test
36 Summary:    Test Scripts for oFono
37 Group:      Development/Libraries
38 Requires:   %{name} = %{version}-%{release}
39 Requires:   dbus-python
40 Requires:   pygobject
41 Requires:   python-xml
42
43 %description test
44 Scripts for testing oFono and its functionality
45
46
47 %prep
48 %setup -q -n %{name}-%{version}
49
50 %build
51 autoreconf --force --install
52
53 %configure --disable-static \
54     --enable-test \
55     --with-systemdunitdir="/usr/lib/systemd/system"
56
57 make %{?jobs:-j%jobs}
58
59 %install
60 %make_install
61
62 mkdir -p %{buildroot}/usr/lib/systemd/system/network.target.wants
63 ln -s ../ofono.service %{buildroot}/usr/lib/systemd/system/network.target.wants/ofono.service
64
65 %post
66 systemctl daemon-reload
67 systemctl restart ofono.service
68
69 %preun
70 systemctl stop ofono.service
71
72 %postun
73 systemctl daemon-reload
74
75 %docs_package
76
77 %files
78 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/*.conf
79 %{_sbindir}/*
80 /usr/lib/systemd/system/network.target.wants/ofono.service
81 /usr/lib/systemd/system/ofono.service
82 /etc/ofono/phonesim.conf
83
84 %files devel
85 %{_includedir}/ofono/*.h
86 %{_libdir}/pkgconfig/ofono.pc
87
88 %files test
89 %{_libdir}/%{name}/test/*
90