fix packaging and add ofono.manifest
[platform/upstream/ofono.git] / packaging / ofono.spec
1 Name:           ofono
2 Version:        1.12
3 Release:        0
4 License:        GPL-2.0
5 Summary:        Open Source Telephony
6 Url:            http://ofono.org
7 Group:          Telephony/Cellular
8 Source0:        %{name}-%{version}.tar.bz2
9 Source1012:     ofono.manifest
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libtool
13 BuildRequires:  pkgconfig(bluez) >= 4.85
14 BuildRequires:  pkgconfig(dbus-1)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(libudev) >= 145
17 BuildRequires:  pkgconfig(mobile-broadband-provider-info)
18 Requires:       dbus
19 Requires:       systemd
20 Requires(post):   systemd
21 Requires(preun):  systemd
22 Requires(postun): systemd
23
24
25 %description
26 Open Source Telephony stack.
27
28 %package devel
29 Summary:        Headers for oFono
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}
32
33 %description devel
34 Development headers and libraries for oFono
35
36 %package test
37 Summary:        Test Scripts for oFono
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}
40 Requires:       dbus-python
41 Requires:       python-gobject
42 Requires:       python-xml
43
44 %description test
45 Scripts for testing oFono and its functionality
46
47 %prep
48 %setup -q
49
50 cp %{SOURCE1012} .
51
52 %build
53 autoreconf --force --install
54
55 %configure --disable-static \
56     --enable-test \
57     --with-systemdunitdir=%{_unitdir}
58
59 make %{?_smp_mflags}
60
61 %install
62 %make_install
63
64 mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/network.target.wants
65 ln -s ../ofono.service %{buildroot}%{_prefix}/lib/systemd/system/network.target.wants/ofono.service
66
67 %install_service multi-user.target.wants ofono.service
68
69 %docs_package
70
71 %files
72 %manifest ofono.manifest
73 %config %{_sysconfdir}/dbus-1/system.d/*.conf
74 %{_sbindir}/*
75 %{_unitdir}/network.target.wants/ofono.service
76 %{_unitdir}/ofono.service
77 %{_unitdir}/multi-user.target.wants/ofono.service
78 %config %{_sysconfdir}/ofono/phonesim.conf
79
80 %files devel
81 %{_includedir}/ofono/*.h
82 %{_libdir}/pkgconfig/ofono.pc
83
84 %files test
85 %{_libdir}/%{name}/test/*
86