packaging: Initial packaging for Tizen on 1.12
[platform/upstream/ofono.git] / packaging / ofono.spec
1 Name:           ofono
2 Version:        1.12
3 Release:        0
4 License:        GPL-2.0
5 Summary:        Open Source Telephony
6 Url:            http://ofono.org
7 Group:          Telephony/Cellular
8 Source0:        %{name}-%{version}.tar.bz2
9
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libtool
13 BuildRequires:  pkgconfig(bluez) >= 4.85
14 BuildRequires:  pkgconfig(dbus-1)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(libudev) >= 145
17 BuildRequires:  pkgconfig(mobile-broadband-provider-info)
18 Requires:       dbus
19
20 %description
21 Oprn Source Telephony stack.
22
23 %package devel
24 Summary:        Headers for oFono
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}
27
28 %description devel
29 Development headers and libraries for oFono
30
31 %package test
32 Summary:        Test Scripts for oFono
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}
35 Requires:       dbus-python
36 Requires:       python-gobject
37 Requires:       python-xml
38
39 %description test
40 Scripts for testing oFono and its functionality
41
42 %prep
43 %setup -q
44
45 %build
46 autoreconf --force --install
47
48 %configure --disable-static \
49     --enable-test \
50     --with-systemdunitdir="/usr/lib/systemd/system"
51
52 make %{?_smp_mflags}
53
54 %install
55 %make_install
56
57 mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/network.target.wants
58 ln -s ../ofono.service %{buildroot}%{_prefix}/lib/systemd/system/network.target.wants/ofono.service
59
60 %docs_package
61
62 %files
63 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/*.conf
64 %{_sbindir}/*
65 %{_prefix}/lib/systemd/system/network.target.wants/ofono.service
66 %{_prefix}/lib/systemd/system/ofono.service
67 %config %{_sysconfdir}/ofono/phonesim.conf
68
69 %files devel
70 %{_includedir}/ofono/*.h
71 %{_libdir}/pkgconfig/ofono.pc
72
73 %files test
74 %{_libdir}/%{name}/test/*
75