Fixed compile issues with Tizen contacts
[profile/ivi/lemolo.git] / packaging / ofono-efl.spec
1 Name:       ivi-dialer
2 Summary:    IVI Dialer
3 Version:    0.1.0
4 Release:    1
5 Group:      System/Libraries
6 License:    MIT
7 URL:        http://www.tizen.org
8 Source0:    %{name}-%{version}.tar.bz2
9 BuildRequires:  pkgconfig(ecore)
10 BuildRequires:  pkgconfig(evas)
11 BuildRequires:  pkgconfig(elementary)
12 BuildRequires:  pkgconfig(ofono)
13 BuildRequires:  pkgconfig(ecore-x)
14 BuildRequires:  pkgconfig(appcore-efl)
15 BuildRequires:  pkgconfig(ui-gadget-1)
16 BuildRequires:  pkgconfig(capi-social-contacts)
17 BuildRequires:  pkgconfig(vconf)
18 BuildRequires:  pkgconfig(capi-system-power)
19 BuildRequires:  pkgconfig(utilX)
20 BuildRequires:  pkgconfig(aul)
21 BuildRequires:  pkgconfig(appsvc)
22 BuildRequires:  pkgconfig(notification)
23 BuildRequires:  libug-contacts-devel
24 BuildRequires:  edje-tools
25
26
27 %description
28 Provides a dialer application for an In-Vehicle Infotainment (IVI) system, where
29 the primary modem access is via a mobile device connected to the head unit via the
30 handsfree profile over bluetooth.  In addition to basic phone calls, this dialer will
31 also expose the contacts from the connected mobile device via the Phone Book Access
32 Protocol (PBAP) over bluetooth when supported.
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37 %build
38
39 %autogen --enable-tizen
40
41 make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46
47 %files
48 %defattr(-,root,root,-)
49 %{_bindir}/answer_daemon
50 %{_bindir}/dialer
51 %{_bindir}/messages
52 %{_bindir}/dialer_daemon
53 %{_bindir}/dialer_open
54 %{_bindir}/message_daemon
55 %{_datadir}/ofono-efl/examples/contacts.csv
56 %{_datadir}/ofono-efl/scripts/ofono-efl-contacts-db-create.py
57 %{_datadir}/ofono-efl/themes/default-sd.edj
58 %{_datadir}/ofono-efl/themes/default.edj
59 %{_datadir}/dbus-1/services/org.tizen.dialer.service
60 %{_datadir}/ofono-efl/tizen-examples/order
61 /opt/share/applications/answer_daemon.desktop
62 /opt/share/applications/dialer.desktop
63 /opt/share/applications/org.tizen.call.desktop
64 /opt/share/applications/org.tizen.phone.desktop