upload tizen1.0 source
[profile/ivi/obexd.git] / packaging / obexd.spec
1 Name:       obexd
2 Summary:    OBEX Server A basic OBEX server implementation
3 Version:    0.44
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    GPL-2.0
7 Source0:    obexd-%{version}.tar.gz
8 BuildRequires:  pkgconfig(bluez) 
9 BuildRequires:  pkgconfig(dbus-1)
10 BuildRequires:  pkgconfig(glib-2.0) 
11 BuildRequires:  pkgconfig(dbus-glib-1)
12
13
14 %description
15 OBEX Server A basic OBEX server implementation.
16
17
18 %prep
19 %setup -q
20
21
22 %build
23 export CFLAGS+=" -DDEBUG -DTIZEN_PATCH -DOPENSOURCE_PATCH"
24 chmod +x bootstrap
25 ./bootstrap && \
26     ./configure \
27                 --enable-debug \
28                 --enable-usb \
29                 --prefix=/usr \
30                 --libexec=/usr/lib/obex \
31                 --mandir=/usr/share/man \
32                 --sysconfdir=/etc \
33                 --with-phonebook=tizen \
34                 --with-messages=tizen
35 make %{?jobs:-j%jobs}
36
37
38 %install
39 %make_install
40
41
42 %files
43 /usr/lib/obex/obex-client
44 /usr/lib/obex/obexd
45 /usr/share/dbus-1/services/obex-client.service
46 /usr/share/dbus-1/services/obexd.service