add tbm bo allocation for tizen waylandsink
[platform/adaptation/nexell/nx-video-api.git] / packaging / nx-video-api.spec
1 Name:    nx-video-api
2 Version: 1.0.2
3 Release: 2
4 License: LGPLv2+
5 Summary: Nexell video APIs
6 Group: Development/Libraries
7 Source:  %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig automake autoconf libtool
10 BuildRequires:  pkgconfig(libdrm)
11 BuildRequires:  pkgconfig(libtbm)
12
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15
16 %description
17 Nexell video APIs
18
19 %package devel
20 Summary: Nexell video API development
21 Group: Development/Libraries
22 License: Apache 2.0
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26 Nexell scaler (devel)
27
28 %prep
29 %setup -q
30
31 %build
32 export CFLAGS="-I/usr/include/libdrm"
33 autoreconf -v --install || exit 1
34 %configure
35 make %{?_smp_mflags}
36
37 %postun -p /sbin/ldconfig
38
39 %install
40 rm -rf %{buildroot}
41 make install DESTDIR=%{buildroot}
42
43 find %{buildroot} -type f -name "*.la" -delete
44
45 %files
46 %{_libdir}/libnx_video_api.so
47 %{_libdir}/libnx_video_api.so.*
48 %license LICENSE.LGPLv2+
49
50 %files devel
51 %{_includedir}/*
52 %license LICENSE.LGPLv2+