Change flag to allocate contiguous memory
[platform/adaptation/nexell/nx-video-api.git] / packaging / nx-video-api.spec
1 Name:    nx-video-api
2 Version: 1.1.1
3 Release: 0
4 License: LGPL-2.1+
5 Summary: Nexell video APIs
6 Group: Development/Libraries
7 Source:  %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig automake autoconf libtool
10 BuildRequires:  pkgconfig(libdrm)
11 BuildRequires:  pkgconfig(libtbm)
12 BuildRequires:  pkgconfig(dlog)
13
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16
17 %description
18 Nexell video APIs
19
20 %package devel
21 Summary: Nexell video API development
22 Group: Development/Libraries
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26 Nexell scaler (devel)
27
28 %prep
29 %setup -q
30
31 %build
32 export CFLAGS="-I/usr/include/libdrm"
33 autoreconf -v --install || exit 1
34 %configure
35 make %{?_smp_mflags}
36
37 %postun -p /sbin/ldconfig
38
39 %install
40 rm -rf %{buildroot}
41 make install DESTDIR=%{buildroot}
42
43 find %{buildroot} -type f -name "*.la" -delete
44
45 %files
46 %manifest nx-video-api.manifest
47 %defattr(-,root,root,-)
48 %{_libdir}/libnx_video_api.so
49 %{_libdir}/libnx_video_api.so.*
50 %license LICENSE.LGPLv2+
51
52 %files devel
53 %{_includedir}/*
54 %license LICENSE.LGPLv2+