resetting manifest requested domain to floor
[platform/upstream/nss-mdns.git] / packaging / nss-mdns.spec
1 Name:           nss-mdns
2 Version:        0.10
3 Release:        0
4 Url:            http://0pointer.de/lennart/projects/nss-mdns/
5 Summary:        Host Name Resolution Via Multicast DNS (Zeroconf) for glibc
6 License:        LGPL-2.1+
7 Group:          Productivity/Networking/DNS/Utilities
8 Source:         %{name}-%{version}.tar.bz2
9 Source1:        nss-mdns-config
10 Source2:        baselibs.conf
11 Source1001:     nss-mdns.manifest
12
13 %description
14 nss-mdns is a plug-in for the GNU Name Service Switch (NSS)
15 functionality of the GNU C Library (glibc) providing a hostname
16 resolution via Multicast DNS (aka Zeroconf, aka Apple Rendezvous, aka
17 Apple Bonjour), and effectively allowing name resolution by common
18 Unix/Linux programs in the ad-hoc mDNS domain .local.
19
20 nss-mdns provides only client functionality, which means that you have
21 to run a mDNS responder daemon separately from nss-mdns if you want to
22 register the local hostname via mDNS. I recommend Avahi.
23
24 By default, nss-mdns tries to contact a running avahi-daemon to resolve
25 hostnames and addresses and makes use of its superior record cacheing.
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31 %build
32 %configure --libdir=/%{_lib}
33
34 %install
35 %make_install
36 install -D -m0755 %{SOURCE1} %{buildroot}%{_sbindir}/nss-mdns-config
37
38 %post
39 /sbin/ldconfig
40 if [ "$1" -eq 1 ] ; then
41     nss-mdns-config --enable
42 fi
43
44 %preun
45 if [ "$1" -eq 0 ] ; then
46     nss-mdns-config --disable
47 fi
48
49 %postun -p /sbin/ldconfig
50
51 %files
52 %manifest %{name}.manifest
53 %defattr(-,root,root)
54 %doc LICENSE
55 %{_sbindir}/nss-mdns-config
56 /%{_lib}/libnss_mdns.so.2
57 /%{_lib}/libnss_mdns_minimal.so.2
58 /%{_lib}/libnss_mdns4.so.2
59 /%{_lib}/libnss_mdns4_minimal.so.2
60 /%{_lib}/libnss_mdns6.so.2
61 /%{_lib}/libnss_mdns6_minimal.so.2