679aec85345c41af8043a3d378a9778e101c3048
[platform/adaptation/npu/trix-engine.git] / packaging / npu-engine.spec
1 %define neexampledir %{_libdir}/npu-engine/bin
2
3 Name:           npu-engine
4 Summary:        NPU Engine
5 Version:        2.3.16
6 Release:        0
7 Group:          System Environment/Daemons
8 Packager:       MyungJoo Ham <myungjoo.ham@samsung.com>
9 License:        Proprietary
10 Source0:        npu-engine-%{version}.tar.gz
11 Source1001:     npu-engine.manifest
12
13 BuildRequires:  meson
14 BuildRequires:  ninja
15 BuildRequires:  pkg-config
16
17 BuildRequires:  linux-npu-headers
18
19 # NE-CONF uses iniparser
20 BuildRequires:  pkgconfig(iniparser)
21
22 # utils
23 BuildRequires:  ncurses-devel
24 BuildRequires:  fuse-devel
25
26 # test
27 BuildRequires:  gtest-devel
28 BuildRequires:  pkgconfig(libdrm)
29 BuildRequires:  pkgconfig(tinyxml2)
30 BuildRequires:  pkgconfig(dlog)
31
32 %if 0%{?npu_cuse}
33 BuildRequires:  libmrpsim-devel
34 %endif
35
36 %if 0%{?npu_emul}
37 BuildRequires:  libmrpsim-devel
38 %define enable_npu_emul -Denable_npu_emul=true
39 %else
40 %define enable_npu_emul -Denable_npu_emul=false
41 %endif
42
43 %if 0%{?npumgr_plugin}
44 BuildRequires:  glib2-devel
45 %define enable_plugin_npumgr -Denable_plugin_npumgr=true
46 %else
47 %define enable_plugin_npumgr -Denable_plugin_npumgr=false
48 %endif
49
50 %if 0%{?nns_plugin}
51 BuildRequires:  nnstreamer-devel
52 %define enable_plugin_nns -Denable_plugin_nns=true
53 %else
54 %define enable_plugin_nns -Denable_plugin_nns=false
55 %endif
56
57 %global debug_package %{nil}
58 %global __debug_install_post %{nil}
59
60 %description
61 This provides in-NPU software control daemon, NPU-Engine.
62
63 %prep
64 %setup -q
65 cp %{SOURCE1001} .
66 %build
67
68 meson --buildtype=plain --bindir=%{neexampledir} --prefix=%{_prefix} \
69       --libdir=%{_libdir} --includedir=%{_includedir} \
70       --datadir=%{_datadir} --sysconfdir=%{_sysconfdir} \
71       -Dtarget_platform=tizen -Denable_data_manip=true \
72       %{enable_npu_emul} %{enable_plugin_npumgr} %{enable_plugin_nns} \
73       build
74 ninja -C build %{?_smp_mflags}
75
76 %install
77
78 # Install Core (NPU-Engine)
79 DESTDIR=%{buildroot} ninja install -C build %{?_smp_mflags}
80
81 %files
82 %manifest npu-engine.manifest
83 %defattr(-,root,root,-)
84 %{_libdir}/libnpu-engine*.so
85 %{_sysconfdir}/npu-engine.ini
86
87 %package devel
88 Summary:        Development Support for NPU Engine Library
89 Requires:       npu-engine = %{version}-%{release}
90 %description devel
91 Developmental packages to develop programs using npu-engine.
92 This contains corresponding header files and .pc pkgconfig file.
93 %files devel
94 %manifest npu-engine.manifest
95 %defattr(-,root,root,-)
96 %{_includedir}/npu-engine/*.h
97 %{_libdir}/libnpu-engine*.a
98 %{_libdir}/pkgconfig/*.pc
99
100 %package example
101 Summary:        NPU Engine Example Package
102 Requires:       npu-engine = %{version}-%{release}
103 %description example
104 Example application package for NPU Engine, including UnitTests and AppTest with realistic scenarios.
105 %files example
106 %manifest npu-engine.manifest
107 %defattr(-,root,root,-)
108 %{neexampledir}/unittests/*
109 %{neexampledir}/apptests/*
110
111 %package utils
112 Requires:       npu-engine = %{version}-%{release}
113 Summary:        NPU Engine Example Package
114 %description utils
115 This provides utility packages for NPU Engine, including metadata extraction of model files.
116 %files utils
117 %manifest npu-engine.manifest
118 %defattr(-,root,root,-)
119 %{neexampledir}/utils/*
120
121 %if ( 0%{?npumgr_plugin} || 0%{?nns_plugin} )
122 %package example-plugins
123 Requires:       npu-engine = %{version}-%{release}
124 Summary:        NPU Engine Example Package for Plugins
125 %description example-plugins
126 Example application package for NPU Engine plugins
127 %files example-plugins
128 %manifest npu-engine.manifest
129 %defattr(-,root,root,-)
130 %if 0%{?npumgr_plugin}
131 %{neexampledir}/plugins/npumgr/*
132 %endif
133 %if 0%{?nns_plugin}
134 %{neexampledir}/plugins/nnstreamer/*
135 %endif
136 %endif
137
138 %if 0%{?npumgr_plugin}
139 %package -n npumgr-srnpu
140 Summary:        Tizen NPU Manager plugin for SR-NPU device family
141 Requires:       npu-engine
142 %description -n npumgr-srnpu
143 Reference implementation of Tizen NPU Manager TRIV2 plugin, including a dummy NPU Manager module.
144 %files -n npumgr-srnpu
145 %manifest npu-engine.manifest
146 %{_libdir}/libnpumgr*.so
147 %{_datadir}/dbus-1/system.d/*
148 %endif
149
150 %if 0%{?nns_plugin}
151 %package -n nnstreamer-srnpu
152 Summary:        NNStreamer subplugin for SR-NPU device family
153 Requires:       npu-engine
154 Requires:       nnstreamer
155 %description -n nnstreamer-srnpu
156 Reference implementation of NNStreamer filter subplugin for SR-NPU (for now, TRIV2 only).
157 %files -n nnstreamer-srnpu
158 %manifest npu-engine.manifest
159 %{_prefix}/lib/nnstreamer/filters/libnnstreamer_filter_srnpu.so
160 %endif
161
162 %changelog
163 * Thu Aug 12 2021 Dongju Chae <dongju.chae@samsung.com>
164 - npu-engine v2.3.16 release; See ./CHANGES for details
165
166 * Fri Aug 06 2021 Dongju Chae <dongju.chae@samsung.com>
167 - npu-engine v2.3.15 release; See ./CHANGES for details
168
169 * Wed Jul 21 2021 Dongju Chae <dongju.chae@samsung.com>
170 - npu-engine v2.3.14 release; See ./CHANGES for details
171
172 * Mon Jul 12 2021 Dongju Chae <dongju.chae@samsung.com>
173 - npu-engine v2.3.13 release; See ./CHANGES for details
174
175 * Fri Jul 02 2021 Dongju Chae <dongju.chae@samsung.com>
176 - npu-engine v2.3.12 release; See ./CHANGES for details
177
178 * Fri Jun 25 2021 Dongju Chae <dongju.chae@samsung.com>
179 - npu-engine v2.3.11 release; See ./CHANGES for details
180
181 * Fri Jun 18 2021 Dongju Chae <dongju.chae@samsung.com>
182 - npu-engine v2.3.10 release; See ./CHANGES for details
183
184 * Thu Jun 03 2021 Dongju Chae <dongju.chae@samsung.com>
185 - Release of 2.3.9
186
187 * Wed May 26 2021 Dongju Chae <dongju.chae@samsung.com>
188 - Release of 2.3.8
189
190 * Fri May 14 2021 Dongju Chae <dongju.chae@samsung.com>
191 - Release of 2.3.7
192
193 * Tue Apr 27 2021 Dongju Chae <dongju.chae@samsung.com>
194 - Release of 2.3.6
195
196 * Tue Apr 06 2021 Dongju Chae <dongju.chae@samsung.com>
197 - Release of 2.3.5
198
199 * Wed Mar 24 2021 Dongju Chae <dongju.chae@samsung.com>
200 - Release of 2.3.4
201
202 * Tue Mar 16 2021 Dongju Chae <dongju.chae@samsung.com>
203 - Release of 2.3.3
204
205 * Fri Feb 19 2021 Dongju Chae <dongju.chae@samsung.com>
206 - Release of 2.3.2
207
208 * Tue Feb 02 2021 Dongju Chae <dongju.chae@samsung.com>
209 - Release of 2.3.1
210
211 * Fri Jan 15 2021 Dongju Chae <dongju.chae@samsung.com>
212 - Release of 2.3.0
213
214 * Mon Jan 04 2021 Dongju Chae <dongju.chae@samsung.com>
215 - Release of 2.2.10
216
217 * Mon Dec 14 2020 Dongju Chae <dongju.chae@samsung.com>
218 - Release of 2.2.9
219
220 * Fri Dec 04 2020 Dongju Chae <dongju.chae@samsung.com>
221 - Release of 2.2.8
222
223 * Mon Nov 23 2020 Dongju Chae <dongju.chae@samsung.com>
224 - Release of 2.2.7
225
226 * Wed Nov 18 2020 Dongju Chae <dongju.chae@samsung.com>
227 - Release of 2.2.6
228
229 * Wed Nov 04 2020 Dongju Chae <dongju.chae@samsung.com>
230 - Release of 2.2.5
231
232 * Wed Oct 21 2020 Dongju Chae <dongju.chae@samsung.com>
233 - Release of 2.2.4
234
235 * Wed Sep 23 2020 Dongju Chae <dongju.chae@samsung.com>
236 - Release of 2.2.3
237
238 * Fri Aug 21 2020 Dongju Chae <dongju.chae@samsung.com>
239 - Release of 2.2.2
240
241 * Wed Aug 19 2020 Dongju Chae <dongju.chae@samsung.com>
242 - Release of 2.2.1
243
244 * Fri Aug 07 2020 Dongju Chae <dongju.chae@samsung.com>
245 - Release of 2.2.0
246
247 * Mon Jul 06 2020 Dongju Chae <dongju.chae@samsung.com>
248 - Release of 2.0.5
249
250 * Fri Jun 19 2020 Dongju Chae <dongju.chae@samsung.com>
251 - Release of 2.0.4
252
253 * Wed Jun 17 2020 Dongju Chae <dongju.chae@samsung.com>
254 - Release of 2.0.2
255
256 * Tue May 26 2020 Dongju Chae <dongju.chae@samsung.com>
257 - Release of 2.0.1
258
259 * Fri May 15 2020 Dongju Chae <dongju.chae@samsung.com>
260 - Release of 2.0.0
261
262 * Tue Mar 10 2020 Dongju Chae <dongju.chae@samsung.com>
263 - Release of 1.2.0
264
265 * Fri Mar 06 2020 Dongju Chae <dongju.chae@samsung.com>
266 - Release of 1.1.4
267
268 * Thu Mar 05 2020 Dongju Chae <dongju.chae@samsung.com>
269 - Release of 1.1.3
270
271 * Tue Mar 03 2020 Dongju Chae <dongju.chae@samsung.com>
272 - Release of 1.1.2
273
274 * Mon Mar 02 2020 Dongju Chae <dongju.chae@samsung.com>
275 - Release of 1.1.1
276
277 * Fri Feb 21 2020 Dongju Chae <dongju.chae@samsung.com>
278 - Release of 1.1.0
279
280 * Wed Feb 19 2020 Dongju Chae <dongju.chae@samsung.com>
281 - Release of 1.0.1
282
283 * Fri Feb 14 2020 Dongju Chae <dongju.chae@samsung.com>
284 - Release of 1.0.0
285
286 * Fri Feb 07 2020 Dongju Chae <dongju.chae@samsung.com>
287 - Release of 0.0.7
288
289 * Tue Jan 07 2020 Dongju Chae <dongju.chae@samsung.com>
290 - Release of 0.0.6
291
292 * Tue Dec 17 2019 Dongju Chae <dongju.chae@samsung.com>
293 - Release of 0.0.5
294
295 * Thu Nov 28 2019 Wook Song <wook16.song@samsung.com>
296 - Release of 0.0.4
297
298 * Wed Nov 27 2019 Wook Song <wook16.song@samsung.com>
299 - Release of 0.0.3
300
301 * Fri Nov 22 2019 Dongju Chae <dongju.chae@samsung.com>
302 - Release of 0.0.2