3 Summary: Notification library
8 Source0: %{name}-%{version}.tar.gz
9 BuildRequires: pkgconfig(sqlite3)
10 BuildRequires: pkgconfig(db-util)
11 BuildRequires: pkgconfig(vconf)
12 BuildRequires: pkgconfig(bundle)
13 BuildRequires: pkgconfig(dbus-1)
14 BuildRequires: pkgconfig(dlog)
15 BuildRequires: pkgconfig(aul)
16 BuildRequires: pkgconfig(appsvc)
17 BuildRequires: pkgconfig(dbus-glib-1)
18 BuildRequires: pkgconfig(appcore-common)
19 BuildRequires: pkgconfig(capi-appfw-application)
20 BuildRequires: pkgconfig(capi-appfw-app-manager)
21 BuildRequires: pkgconfig(capi-appfw-package-manager)
22 BuildRequires: pkgconfig(pkgmgr-info)
23 BuildRequires: pkgconfig(libtzplatform-config)
24 BuildRequires: pkgconfig(gio-2.0)
25 BuildRequires: pkgconfig(glib-2.0)
28 Requires(post): /sbin/ldconfig
29 Requires(post): %{TZ_SYS_BIN}/sqlite3
30 Requires(postun): /sbin/ldconfig
33 Client/Server library for sending notifications.
39 Summary: Notification library (devel)
40 Group: Development/Libraries
41 Requires: %{name} = %{version}-%{release}
44 Development files needed to build software that needs to system a system notification.
47 %if 0%{?tizen_build_binary_release_type_eng}
48 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
49 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
50 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
52 %if 0%{?sec_build_binary_debug_enable}
53 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
54 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
55 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
57 export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--as-needed"
60 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DHAVE_WAYLAND=On
62 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DHAVE_X11=On
70 mkdir -p %{buildroot}%{TZ_SYS_SHARE}/license
71 cp -f LICENSE %{buildroot}%{TZ_SYS_SHARE}/license/%{name}
79 if [ ! -d %{TZ_SYS_DB} ]
84 %postun -p /sbin/ldconfig
87 %manifest notification.manifest
88 %defattr(-,root,root,-)
89 %{_libdir}/libnotification.so*
90 %{TZ_SYS_SHARE}/license/%{name}
93 %defattr(-,root,root,-)
94 %{_includedir}/notification/notification.h
95 %{_includedir}/notification/notification_db.h
96 %{_includedir}/notification/notification_internal.h
97 %{_includedir}/notification/notification_error.h
98 %{_includedir}/notification/notification_type.h
99 %{_includedir}/notification/notification_list.h
100 %{_includedir}/notification/notification_ongoing.h
101 %{_includedir}/notification/notification_ongoing_flag.h
102 %{_includedir}/notification/notification_text_domain.h
103 %{_includedir}/notification/notification_status.h
104 %{_includedir}/notification/notification_status_internal.h
105 %{_includedir}/notification/notification_setting.h
106 %{_includedir}/notification/notification_setting_internal.h
107 %{_includedir}/notification/notification_ipc.h
108 %{_includedir}/notification/notification_noti.h
109 %{_includedir}/notification/notification_setting_service.h
110 %{_libdir}/pkgconfig/notification.pc