Introduce the display plugin system
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
1 %bcond_with wayland
2
3 Name:       notification-service
4 Summary:    Simple notification service
5 Version:    0.0.3
6 Release:    1
7 Group:      Application Framework/Notifications
8 License:    Flora
9 Source0:    %{name}-%{version}.tar.bz2
10 BuildRequires: pkgconfig(eina)
11 BuildRequires: pkgconfig(ecore)
12 BuildRequires: pkgconfig(com-core)
13 BuildRequires: pkgconfig(notification)
14 BuildRequires: pkgconfig(notification-service)
15 BuildRequires: pkgconfig(dbus-1)
16 BuildRequires: pkgconfig(dbus-glib-1)
17 BuildRequires: pkgconfig(bluetooth-api)
18 BuildRequires: pkgconfig(dlog)
19 BuildRequires: pkgconfig(bundle)
20 BuildRequires: pkgconfig(libwlmessage)
21 %{?systemd_requires}
22
23 %description
24 Headless notification service that collects incoming notifications from the
25 the platform, maintains a database of active notifications, and broadcast updates
26 to all listeners.
27
28 %package test
29 Summary: Test clients for %{name}
30 Group:   Application Framework/Notifications
31 %description test
32 This package provides unit test used in the development of the notification service.
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37 %build
38 %autogen
39 make %{?_smp_mflags}
40
41 %install
42 %make_install
43 %install_service graphical.target.wants notifications.service
44 %install_service graphical.target.wants notifications-display.service
45
46 %post
47 %systemd_post notifications.service
48
49 %preun
50 %systemd_preun notifications.service
51
52 %postun
53 %systemd_postun notifications.service
54
55 %files
56 %defattr(-,root,root,-)
57 %{_bindir}/notification-service
58 %{_bindir}/notification-display-service
59 %{_libdir}/notification-service/plugins/wlmessage.so
60 %{_unitdir}/notifications.service
61 %{_unitdir}/notifications-display.service
62 %{_unitdir}/graphical.target.wants/notifications.service
63 %{_unitdir}/graphical.target.wants/notifications-display.service
64
65 %files test
66 %defattr(-,root,root,-)
67 %{_bindir}/sample-display-client
68 %{_bindir}/send-notification
69 %{_bindir}/bluetooth_notification_client