Modify license comment in spec file
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       notification-service
5 Summary:    Simple notification service
6 Version:    0.0.3
7 Release:    1
8 Group:      Application Framework/Notifications
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.bz2
11 BuildRequires: pkgconfig(eina)
12 BuildRequires: pkgconfig(ecore)
13 BuildRequires: pkgconfig(com-core)
14 BuildRequires: pkgconfig(cynara-client)
15 BuildRequires: pkgconfig(cynara-session)
16 BuildRequires: pkgconfig(cynara-creds-socket)
17 BuildRequires: pkgconfig(notification)
18 BuildRequires: pkgconfig(dbus-1)
19 BuildRequires: pkgconfig(dbus-glib-1)
20 BuildRequires: pkgconfig(dlog)
21 BuildRequires: pkgconfig(bundle)
22 BuildRequires: pkgconfig(libwlmessage)
23 BuildRequires: pkgconfig(vconf)
24 BuildRequires: pkgconfig(vconf-internal-keys)
25 %{?systemd_requires}
26
27 %description
28 Headless notification service that collects incoming notifications from the
29 the platform, maintains a database of active notifications, and broadcast updates
30 to all listeners.
31
32 %package test
33 Summary: Test clients for %{name}
34 Group:   Application Framework/Notifications
35 %description test
36 This package provides unit test used in the development of the notification service.
37
38 %prep
39 %setup -q -n %{name}-%{version}
40
41 %build
42
43 %reconfigure
44 make %{?_smp_mflags}
45
46
47 %install
48 %make_install
49 %install_service graphical.target.wants notifications.service
50
51 %post
52 %systemd_post notifications.service
53
54 %preun
55 %systemd_preun notifications.service
56
57 %postun
58 %systemd_postun notifications.service
59
60 %files
61 %defattr(-,root,root,-)
62 %{_bindir}/notification-service
63 %{_libdir}/notification-service/plugins/wlmessage.so
64 %{_unitdir}/notifications.service
65 %{_unitdir}/graphical.target.wants/notifications.service
66
67 %files test
68 %defattr(-,root,root,-)
69 %{_bindir}/sample-display-client
70 %{_bindir}/send-notification