[4.0] stat syscall: Support large file more than 2GB.
[platform/upstream/ninja.git] / packaging / ninja.spec
1 Name:           ninja
2 Version:        1.7.0
3 Release:        0
4 License:        Apache-2.0
5 Summary:        Ninja build system
6 Url:            http://martine.github.com/ninja/
7 Group:          System/Utilities
8 Source:         %{name}.tar.bz2
9 Source1001:     ninja.manifest
10
11 BuildRequires:  python
12
13 %description
14 Ninja is a small build system with a focus on speed.
15 http://martine.github.com/ninja/
16
17 See the manual -- http://martine.github.com/ninja/manual.html or
18 doc/manual.asciidoc included in the distribution -- for background
19 and more details.
20
21 %prep
22 %setup -q
23 cp %{SOURCE1001} .
24
25
26 %build
27 # Support large file more than 2GB. (e.g., for stat syscall).
28 export CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE=1"
29
30 python ./bootstrap.py 
31
32 %install
33 mkdir -p %{buildroot}%{_bindir}
34 install -m 0755 ninja %{buildroot}%{_bindir}/ninja
35
36 %files
37 %manifest %{name}.manifest
38 %defattr(-,root,root)
39 %{_bindir}/ninja
40 %license COPYING
41