Revert "Moved *.so file to devel package"
[platform/upstream/nghttp2.git] / packaging / nghttp2.spec
1 %define _unpackaged_files_terminate_build 0
2 Prefix: %{_usr}
3 Name: nghttp2
4 Version: 1.20.0
5 Release: 1
6 Summary: This is an experimental implementation of Hypertext Transfer Protocol version 2.
7 Group: System Environment/Libraries
8 License: MIT
9 URL: https://nghttp2.org/
10 Source0: %{name}-%{version}.tar.gz
11 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12
13 BuildRequires: pkgconfig >= 0.20, zlib >= 1.2.3, gcc, gcc-c++, make
14 BuildRequires: openssl-devel
15 BuildRequires: libxml2-devel
16
17 %description
18
19 %package devel
20 Summary: Development files for %{name}
21 Group: Development/Libraries
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25 The %{name}-devel package contains libraries and header files for
26 developing applications that use %{name}.
27
28 %prep
29 %setup -q
30
31 %build
32 autoreconf -i
33 %{__automake}
34 %{__autoconf}
35 %configure --disable-static --disable-xmltest
36 %{__make} %{?_smp_mflags}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__make} install DESTDIR=$RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49 %files
50 %defattr(-,root,root,-)
51 %{_libdir}/*.so*
52 %exclude %{_libdir}/*.la
53 #%{_includedir}/*
54 %license COPYING
55
56 %files devel
57 %defattr(-,root,root,-)
58 %doc /usr/share/doc/%{name}
59 %{_includedir}/*
60 %{_libdir}/*.so
61 %{_libdir}/pkgconfig/*.pc