merge with master
[adaptation/devices/nfc-plugin-nxp.git] / packaging / nfc-plugin-nxp.spec
1 #sbs-git:slp/pkgs/n/nfc-plugin-nxp nfc-plugin-nxp 0.0.1 373e1f7d458128eca88b9f4ea73d798394449e18
2 %define _optdir /opt
3 %define _appdir %{_optdir}/apps
4 %define _ugdir  %{_optdir}/ug
5
6
7 Name:       nfc-plugin-nxp
8 Summary:    NFC Plugin for NXP Solution
9 Version:    0.0.7
10 Release:    0
11 Group:      TO_BE/FILLED_IN
12 License:    TO BE FILLED IN
13 Source0:    %{name}-%{version}.tar.gz
14 BuildRequires: cmake
15 BuildRequires: pkgconfig(glib-2.0)
16 BuildRequires: pkgconfig(vconf)
17 BuildRequires: pkgconfig(dlog)
18 BuildRequires: pkgconfig(nfc-common-lib)
19
20 %description
21 Description: NFC Plugin for NXP Solution
22
23
24 %prep
25 %setup -q
26
27 %build
28 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
29
30 make %{?jobs:-j%jobs}
31
32
33 %install
34 rm -rf %{buildroot}
35 %make_install
36
37 %post 
38 # file owner
39 if [ "${USER}" = "root" ]
40 then
41         vconftool set -t string memory/private/nfc-plugin-nxp/eeprom "" -g 6517 -i -f
42 else
43         vconftool set -t string memory/private/nfc-plugin-nxp/eeprom "" -f
44 fi
45
46
47 %files
48 %manifest nfc-plugin-nxp.manifest
49 %defattr(-,root,root,-) 
50 /usr/lib/libnfc-plugin.so