merge with master
[adaptation/devices/nfc-plugin-65nxp.git] / packaging / nfc-plugin-65nxp.spec
1 %define _optdir /opt
2 %define _appdir %{_optdir}/apps
3 %define _ugdir  %{_optdir}/ug
4
5
6 Name:       nfc-plugin-65nxp
7 Summary:    NFC Plugin for NXP Solution 65N
8 Version:    0.0.3
9 Release:    0
10 Group:      TO_BE/FILLED_IN
11 License:    TO BE FILLED IN
12 Source0:    %{name}-%{version}.tar.gz
13 BuildRequires: cmake
14 BuildRequires: pkgconfig(glib-2.0)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: pkgconfig(dlog)
17 BuildRequires: pkgconfig(nfc-common-lib)
18
19 %description
20 Description: NFC Plugin for NXP Solution
21
22
23 %prep
24 %setup -q
25
26 %build
27 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
28
29 make %{?jobs:-j%jobs}
30
31
32 %install
33 rm -rf %{buildroot}
34 %make_install
35
36 %post 
37 # file owner
38 if [ "${USER}" = "root" ]
39 then
40         vconftool set -t string memory/private/nfc-plugin-nxp/eeprom "" -g 6517 -i -f
41 else
42         vconftool set -t string memory/private/nfc-plugin-nxp/eeprom "" -f
43 fi
44
45
46 %files
47 %manifest nfc-plugin-65nxp.manifest
48 %defattr(-,root,root,-) 
49 /usr/lib/libnfc-plugin-65nxp.so