2 Summary: NFC framework manager
5 Group: Network & Connectivity/NFC
6 License: Flora Software License
7 Source0: %{name}-%{version}.tar.gz
8 Source1: %{name}.service
9 Source1001: %{name}.manifest
11 BuildRequires: pkgconfig(aul)
12 BuildRequires: pkgconfig(glib-2.0)
13 BuildRequires: pkgconfig(gobject-2.0)
14 BuildRequires: pkgconfig(security-server)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: pkgconfig(dlog)
17 BuildRequires: pkgconfig(tapi)
18 BuildRequires: pkgconfig(bluetooth-api)
19 BuildRequires: pkgconfig(capi-network-wifi)
20 BuildRequires: pkgconfig(mm-sound)
21 BuildRequires: pkgconfig(appsvc)
22 BuildRequires: pkgconfig(svi)
23 BuildRequires: pkgconfig(capi-media-wav-player)
24 BuildRequires: pkgconfig(libssl)
25 BuildRequires: pkgconfig(pkgmgr)
26 BuildRequires: pkgconfig(pkgmgr-info)
27 BuildRequires: pkgconfig(ecore-x)
28 BuildRequires: pkgconfig(pmapi)
30 BuildRequires: python-xml
31 BuildRequires: gettext-tools
32 Requires(post): /sbin/ldconfig
33 Requires(post): /usr/bin/vconftool
34 Requires(postun): /sbin/ldconfig
35 Requires: nfc-common-lib = %{version}
36 Requires: nfc-client-lib = %{version}
40 Tizen NFC framework manager.
47 %package -n nfc-common-lib
48 Summary: NFC common library
49 Group: Network & Connectivity/Development
52 %description -n nfc-common-lib
56 %package -n nfc-common-lib-devel
57 Summary: NFC common library (devel)
58 Group: Network & Connectivity/Development
59 Requires: nfc-common-lib = %{version}
62 %description -n nfc-common-lib-devel
63 NFC manager common library for internal development.
66 %package -n nfc-client-lib
67 Summary: NFC client library
68 Group: Network & Connectivity/NFC
69 Requires: nfc-common-lib = %{version}
72 %description -n nfc-client-lib
73 NFC manager Client library for NFC client applications.
76 %package -n nfc-client-lib-devel
77 Summary: NFC client library (devel)
78 Group: Network & Connectivity/Development
79 Requires: nfc-client-lib = %{version}
82 %description -n nfc-client-lib-devel
83 NFC manager Client library for developing NFC client applications.
87 #%%package -n nfc-client-test
88 #Summary: NFC client test
89 #Group: Network & Connectivity/NFC
90 #Requires: %%{name} = %%{version}
93 #%%description -n nfc-client-test
94 #NFC client test (devel)
98 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
99 %cmake . -DMAJORVER=${MAJORVER} -DFULLVER=%{version}
105 mkdir -p %{buildroot}/opt/usr/share/nfc_debug
107 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
108 cp -af %{SOURCE1} %{buildroot}%{_libdir}/systemd/system/
109 ln -s ../%{name}.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/%{name}.service
114 systemctl daemon-reload
116 systemctl restart %{name}.service
119 %post -n nfc-common-lib -p /sbin/ldconfig
121 %post -n nfc-client-lib
123 vconftool set -t bool db/nfc/feature 0 -u 5000 -f
124 vconftool set -t int db/nfc/se_type 0 -u 5000 -f
125 vconftool set -t bool db/nfc/predefined_item_state 0 -u 5000 -f
126 vconftool set -t string db/nfc/predefined_item "None" -u 5000 -f
127 vconftool set -t bool db/nfc/enable 0 -u 5000 -f
132 systemctl stop %{name}.service
134 systemctl daemon-reload
136 %postun -n nfc-common-lib -p /sbin/ldconfig
138 %postun -n nfc-client-lib -p /sbin/ldconfig
142 %manifest %{name}.manifest
143 %defattr(-,root,root,-)
144 %{_bindir}/nfc-manager-daemon
145 #%%{_bindir}/ndef-tool
146 %{_libdir}/systemd/system/%{name}.service
147 %{_libdir}/systemd/system/multi-user.target.wants/%{name}.service
148 %{_datadir}/dbus-1/services/org.tizen.NetNfcService.service
149 %{_datadir}/packages/%{name}.xml
150 %{_datadir}/nfc-manager-daemon/sounds/*
151 %attr(0775,-,5000) %dir /opt/usr/share/nfc_debug
152 %license LICENSE.Flora
155 %files -n nfc-client-lib
156 %manifest %{name}.manifest
157 %defattr(-,root,root,-)
158 %{_libdir}/libnfc.so.*
159 %license LICENSE.Flora
162 %files -n nfc-client-lib-devel
163 %defattr(-,root,root,-)
165 %{_libdir}/pkgconfig/nfc.pc
166 %{_includedir}/nfc/*.h
169 %files -n nfc-common-lib
170 %manifest %{name}.manifest
171 %defattr(-,root,root,-)
172 %{_libdir}/libnfc-common.so.*
173 %license LICENSE.Flora
176 %files -n nfc-common-lib-devel
177 %defattr(-,root,root,-)
178 %{_libdir}/libnfc-common.so
179 %{_libdir}/pkgconfig/nfc-common.pc
180 %{_includedir}/nfc-common/*.h
183 #%%files -n nfc-client-test
184 #%%manifest nfc-client-test.manifest
185 #%%defattr(-,root,root,-)
186 #%%{_bindir}/nfc_client
187 #%%license LICENSE.Flora