Modified directory path by tizen platform config
[platform/core/connectivity/net-popup.git] / packaging / net.netpopup.spec
1 Name:       net.netpopup
2 Summary:    Network Notification Popup applicationa
3 Version:    0.2.81
4 Release:    1
5 Group:      App/Network
6 License:    Flora-1.1
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: cmake
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(bundle)
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(ecore)
13 BuildRequires: pkgconfig(edje)
14 BuildRequires: pkgconfig(elementary)
15 BuildRequires: pkgconfig(evas)
16 BuildRequires: pkgconfig(syspopup)
17 BuildRequires: pkgconfig(syspopup-caller)
18 BuildRequires: pkgconfig(capi-appfw-application)
19 BuildRequires: pkgconfig(gio-2.0)
20 BuildRequires: pkgconfig(glib-2.0)
21 BuildRequires: pkgconfig(notification)
22 BuildRequires: pkgconfig(appsvc)
23 BuildRequires: pkgconfig(vconf)
24 BuildRequires: pkgconfig(efl-extension)
25 BuildRequires: gettext
26 BuildRequires: edje-tools
27
28 %description
29 Network Notification Popup application
30
31 %prep
32 %setup -q
33
34
35 %build
36 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
37
38 make %{?_smp_mflags}
39
40
41 %install
42 %make_install
43
44 mkdir -p %{buildroot}%{_sysconfdir}/smack/accesses.d/
45 cp -v net.netpopup.efl %{buildroot}%{_sysconfdir}/smack/accesses.d/
46
47 #License
48 mkdir -p %{buildroot}%{_datadir}/license
49 cp LICENSE %{buildroot}%{_datadir}/license/net.netpopup
50
51
52 %files
53 %manifest net.netpopup.manifest
54 %{_bindir}/net-popup
55 %{_datadir}/packages/net.netpopup.xml
56 /usr/ug/res/edje/net-popup/*.edj
57 %{_datadir}/locale/*/LC_MESSAGES/net-popup.mo
58 %{_datadir}/license/net.netpopup
59 %{_sysconfdir}/smack/accesses.d/net.netpopup.efl