Add license file
[platform/upstream/ncurses.git] / packaging / ncurses.spec
1 #
2 # spec file for package ncurses
3 #
4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 #
16
17
18 Name:           ncurses
19 #!BuildIgnore: terminfo
20 BuildRequires:  gcc-c++
21 BuildRequires:  pkg-config
22 %define terminfo() %{_datadir}/%{0}/%{1}
23 %define tabset()   %{_datadir}/%{0}/%{1}
24 Version:        5.9
25 Release:        0
26 Summary:        New curses Libraries
27 License:        MIT
28 Group:          Base/Libraries
29 Url:            http://invisible-island.net/ncurses/ncurses.html
30 Source0:        ncurses-%{version}.tar.gz
31 Source2:        handle.linux
32 Source4:        ncurses-rpmlintrc
33 Source6:        edit.sed
34 Source7:        baselibs.conf
35 Source1001:     ncurses.manifest
36 %global         _sysconfdir /etc
37 %global         _miscdir    %{_datadir}/misc
38 %global         _incdir     %{_includedir}
39 %global         root        %{_tmppath}/%{name}-%{version}-store
40
41 %description
42 As soon as a text application needs to directly control its output to
43 the screen (if it wants to place the cursor at location (x,y) then
44 write text), ncurses is used. The panel and the forms libraries are
45 included in this package. These new libraries support color, special
46 characters, and panels.
47
48
49 %package -n ncurses-utils
50 Summary:        Tools using the new curses libraries
51 License:        MIT
52 Group:          Base/Utilities
53 Provides:       ncurses:%{_bindir}/tput
54
55 %description -n ncurses-utils
56 The ncurses based utilities are as follows:
57
58 clear -- emits clear-screen for current terminal
59
60 tabs -- set tabs on a terminal
61
62 toe   -- table of entries utility
63
64 tput  -- shell-script access to terminal capabilities.
65
66 tset  -- terminal-initialization utility
67
68 reset -- terminal initialization utility
69
70 %package -n terminfo-base
71 Summary:        A terminal descriptions database
72 License:        MIT
73 Group:          Base/Utilities
74 Provides:       ncurses:%{_datadir}/tabset
75
76 %description -n terminfo-base
77 This is the terminfo basic database, maintained in the ncurses package.
78 This database is the official successor to the 4.4BSD termcap file and
79 contains information about any known terminal. The ncurses library
80 makes use of this database to use terminals correctly.
81
82
83 %package -n libncurses
84 Summary:        The New curses Libraries
85 License:        MIT
86 Group:          Base/Libraries
87 Requires:       terminfo-base
88 Provides:       ncurses = %{version}
89 Obsoletes:      ncurses < %{version}
90 Recommends:     ncurses-utils = %{version}
91
92 %description -n libncurses
93 The ncurses library is used by the most curses based terminal
94 applications for controling its output and input to the screen.
95
96
97 %package -n libncurses6
98 Summary:        The New curses Libraries
99 License:        MIT
100 Group:          Base/Libraries
101 Requires:       terminfo-base
102 Provides:       ncurses = 6.0
103
104 %description -n libncurses6
105 The ncurses library is used by the most curses based terminal
106 applications for controling its output and input to the screen.
107
108 %package -n terminfo
109 Summary:        A terminal descriptions database
110 License:        Public-Domain
111 Group:          Base/Utilities
112
113 %description -n terminfo
114 This is the terminfo reference database, maintained in the ncurses
115 package. This database is the official successor to the 4.4BSD termcap
116 file and contains information about any known terminal. The ncurses
117 library makes use of this database to use terminals correctly. If you
118 just use the Linux console, xterm, and VT100, you probably will not
119 need this database -- a minimal /usr/share/terminfo tree for these
120 terminals is already included in the terminfo-base package.
121
122 %package -n ncurses-devel
123 Summary:        Include Files and Libraries mandatory for Development
124 License:        MIT
125 Group:          Base/Development
126 Provides:       ncurses:%{_incdir}/ncurses.h
127 Requires:       ncurses = %{version}-%{release}
128 Requires:       libncurses = %{version}-%{release}
129 Requires:       libncurses6 = %{version}-%{release}
130
131 %description -n ncurses-devel
132 This package contains all necessary include files and libraries needed
133 to develop applications that require these.
134
135 %prep
136 %setup -q -n ncurses-%{version}
137 cp %{SOURCE1001} .
138 rm -vf include/ncurses_dll.h
139 rm -vf mkdirs.sh
140 rm -vf tar-copy.sh
141 rm -vf mk-dlls.sh
142
143 %build
144     cflags ()
145     {
146         local flag=$1; shift
147         local var=$1; shift
148         test -n "${flag}" -a -n "${var}" || return
149         case "${!var}" in
150         *${flag}*) return
151         esac
152         set -o noclobber
153         case "$flag" in
154         -Wl,*)
155             if echo 'int main () { return 0; }' | \
156                ${CC:-gcc} -Werror $flag -o /dev/null -xc - > /dev/null 2>&1 ; then
157                 eval $var=\${$var:+\$$var\ }$flag
158             fi
159             ;;
160         *)
161             if ${CC:-gcc} -Werror $flag -S -o /dev/null -xc /dev/null > /dev/null 2>&1 ; then
162                 eval $var=\${$var:+\$$var\ }$flag
163             fi
164             if ${CXX:-g++} -Werror $flag -S -o /dev/null -xc++ /dev/null > /dev/null 2>&1 ; then
165                 eval $var=\${$var:+\$$var\ }$flag
166             fi
167         esac
168         set +o noclobber
169     }
170
171     test ! -f /.buildenv || . /.buildenv
172        OPATH=$PATH
173       FALLBK="xterm,linux,vt100,vt102"
174           CC=gcc
175          CXX=g++
176     CFLAGS="${RPM_OPT_FLAGS} -pipe -D_REENTRANT"
177     if [[ "$BUILD_BASENAME" = debug-* ]] ; then
178         CFLAGS="${CFLAGS} -g -DTRACE"
179     fi
180     cflags -Wl,-O2                  LDFLAGS
181     cflags -Wl,-Bsymbolic-functions LDFLAGS
182     cflags -Wl,--hash-size=8599     LDFLAGS
183     cflags -Wl,--as-needed          LDFLAGS
184     CXXFLAGS=$CFLAGS
185     test -n "$TERM" || TERM=linux
186     GZIP="-9"
187     export CC CFLAGS CXX CXXFLAGS GZIP TERM LDFLAGS
188     #
189     # Detect 64bit architecures and be sure that
190     # we use an unsigned long for chtype to be
191     # backward compatible with ncurses 5.4
192     #
193     echo 'int main () { return !(sizeof(void*) >= 8); }' | gcc -x c -o test64 -
194     if ./test64 ; then
195         WITHCHTYPE="--with-chtype=long"
196     else
197         WITHCHTYPE=""
198         CFLAGS="${CFLAGS} -D_LARGEFILE64_SOURCES -D_FILE_OFFSET_BITS=64"
199     fi
200     rm -f ./test64
201     #
202     # For security of some configure and install scripts
203     #
204     TMPDIR=$(mktemp -d /tmp/ncurses.XXXXXXXX) || exit 1
205     trap 'rm -rf ${TMPDIR}' EXIT
206     export TMPDIR
207     #
208     # No --enable-term-driver as this had crashed last time
209     # in ncurses/tinfo/lib_setup.c due to the fact that
210     # _nc_globals.term_driver was a NULL function pointer
211     #
212     # No --enable-tcap-names because we may have to recompile
213     # programs or foreign programs won't work
214     #
215     # No --enable-safe-sprintf because this seems to
216     # crash on some architectures
217     #
218     # No --enable-xmc-glitch because this seems to break yast2
219     # on console/konsole (no magic cookie support on those?)
220     #
221     # No --with-termlib=tinfo because libncurses depend on
222     # libtinfo (is linked with) and therefore there is no
223     # advantage about splitting of a libtinfo (IMHO).
224     #
225     touch --reference=README config.sub config.guess
226     %configure \
227         --without-ada           \
228         --without-debug         \
229         --without-profile       \
230         --without-manpage-tbl   \
231         --with-shared           \
232         --with-normal           \
233         --with-manpage-format=gzip \
234         --with-manpage-renames=${PWD}/man/man_db.renames \
235         --with-manpage-aliases  \
236         --with-ospeed=speed_t   \
237         --with-gpm              \
238         --with-dlsym            \
239         --with-termlib=tinfo    \
240         --with-ticlib=tic       \
241         --with-xterm-kbs=del    \
242         --disable-root-environ  \
243         --disable-termcap       \
244         --disable-overwrite     \
245         --disable-rpath         \
246         --disable-leaks         \
247         --disable-xmc-glitch    \
248         --enable-symlinks       \
249         --enable-big-core       \
250         --enable-const          \
251         --enable-hashmap        \
252         --enable-no-padding     \
253         --enable-symlinks       \
254         --enable-sigwinch       \
255     --enable-pc-files \
256     --with-pkg-config-libdir=%{_libdir}/pkgconfig \
257     --with-pkg-config \
258         --enable-colorfgbg      \
259         --enable-sp-funcs       \
260         --without-pthread       \
261         --disable-reentrant     \
262         --disable-ext-mouse     \
263         --disable-widec         \
264         --disable-ext-colors    \
265         --enable-weak-symbols   \
266         --enable-wgetch-events  \
267         --enable-pthreads-eintr \
268         --enable-string-hacks   \
269         --prefix=%{_prefix}     \
270         --exec-prefix=%{_prefix}\
271         --libdir=%{_libdir}     \
272         --datadir=%{_datadir}   \
273         --mandir=%{_mandir}     \
274         --includedir=%{_incdir} \
275         "${WITHCHTYPE}"         \
276         --disable-widec         \
277         --disable-tic-depends   \
278         --with-ticlib=tic
279     #--with-pkg-config-libdir=%{_libdir}/pkgconfig \
280     #
281     #  The configure line
282     #
283     c=$(grep '^ *$ *\./configure' config.log)
284     #
285     # This is a hack to be able to boot strap
286     # a libncurses with correct fallback.c.
287     #
288     make %{?_smp_mflags} -C include
289     make %{?_smp_mflags} -C ncurses fallback.c FALLBACK_LIST=""
290     make %{?_smp_mflags} -C progs   termsort.c transform.h infocmp tic
291     rm   -f ncurses/fallback.c
292     PATH=$PWD/progs:$OPATH
293     LD_LIBRARY_PATH=$PWD/lib
294     export LD_LIBRARY_PATH PATH
295     pushd ncurses/
296         TERMINFO=$PWD/tmp
297         export TERMINFO
298         mkdir -p $TERMINFO
299 %if 0%{?_crossbuild}
300 export BUILD_TIC=/usr/bin/tic
301 %else
302 export BUILD_TIC=$PWD/../progs/tic
303 %endif
304         $BUILD_TIC -I -r -e $FALLBK ../misc/terminfo.src > terminfo.src
305         $BUILD_TIC -o $TERMINFO -s terminfo.src
306         sh -e ./tinfo/MKfallback.sh $TERMINFO ../misc/terminfo.src $BUILD_TIC ${FALLBK//,/ } > fallback.c
307         rm -rf $TERMINFO
308         unset  TERMINFO
309         cp -p fallback.c ../fallback.c.backup
310     popd
311     PATH=$OPATH
312     unset LD_LIBRARY_PATH
313     #
314     # Refresh second install path
315     #
316     rm -rf %{root}
317     mkdir  %{root}
318     #
319     # Now rebuild libncurses and do the rest of this job
320     #
321     find -name fallback.o | xargs -r rm -vf
322     cp fallback.c.backup ncurses/fallback.c
323     make %{?_smp_mflags}
324     lib=%{_libdir}
325     inc=%{_incdir}/ncurses
326     # must not use %jobs here (would lead to: ln: ncurses.h already exists)
327     make install DESTDIR=%{root} includedir=${inc} libdir=${lib}
328     ln -sf ${inc##*/}/{curses,ncurses,term,termcap}.h %{root}${inc%%/*}/
329     sh %{S:6} --cflags "-I${inc}" --libs "-lncurses" --libs "-ltinfo" %{root}%{_bindir}/ncurses5-config
330     #
331     # Now use --with-pthread for reentrant pthread support (abi > 5).
332     #
333     eval ./${c#*./} --with-pthread --enable-reentrant --enable-ext-mouse --disable-widec --disable-ext-colors --without-progs
334     find -name fallback.o | xargs -r rm -vf
335     cp fallback.c.backup ncurses/fallback.c
336     make %{?_smp_mflags}
337     lib=%{_libdir}/ncurses6
338     inc=%{_incdir}/ncurses6/ncurses
339     # must not use %jobs here (would lead to: ln: ncurses.h already exists)
340     make install.libs install.includes DESTDIR=%{root} includedir=${inc} libdir=${lib}
341     ln -sf ${inc##*/}/{curses,ncurses,term}.h %{root}${inc%%/*}/
342     sh %{S:6} --cflags "-I${inc} -I${inc%%/*}" --libs "-L${lib} -lncurses" --libs "-ltinfo" %{root}%{_bindir}/ncurses6-config
343     pushd man
344         sh ../edit_man.sh normal installing %{root}%{_mandir} . ncurses6-config.1
345     popd
346     #
347     # Now use --enable-widec for UTF8/wide character support.
348     # The libs with 16 bit wide characters are binary incompatible
349     # to the normal 8bit wide character libs.
350     #
351     eval ./${c#*./} --disable-ext-mouse --enable-widec --disable-ext-colors --without-progs
352     find -name fallback.o | xargs -r rm -vf
353     cp fallback.c.backup ncurses/fallback.c
354     make %{?_smp_mflags}
355     lib=%{_libdir}
356     inc=%{_incdir}/ncursesw
357     # must not use %jobs here (would lead to: ln: ncurses.h already exists)
358     make install.libs install.includes DESTDIR=%{root} includedir=${inc} libdir=${lib}
359     sh %{S:6} --cflags "-I${inc}" --libs "-lncursesw" --libs "-ltinfo" %{root}%{_bindir}/ncursesw5-config
360     pushd man
361         sh ../edit_man.sh normal installing %{root}%{_mandir} . ncursesw5-config.1
362     popd
363     #
364     # Do both --enable-widec and --with-pthread (abi > 5).
365     #
366     eval ./${c#*./} --with-pthread --enable-reentrant --enable-ext-mouse --enable-widec --enable-ext-colors --without-progs
367     find -name fallback.o | xargs -r rm -vf
368     cp fallback.c.backup ncurses/fallback.c
369     make %{?_smp_mflags}
370     lib=%{_libdir}/ncurses6
371     inc=%{_incdir}/ncurses6/ncursesw
372     # must not use %jobs here (would lead to: ln: ncurses.h already exists)
373     make install.libs install.includes DESTDIR=%{root} includedir=${inc} libdir=${lib}
374     sh %{S:6} --cflags "-I${inc} -I${inc%%/*}" --libs "-L${lib} -lncursesw" --libs "-ltinfo" %{root}%{_bindir}/ncursesw6-config
375     pushd man
376         sh ../edit_man.sh normal installing %{root}%{_mandir} . ncursesw6-config.1
377     popd
378
379 %install
380     GZIP="-9"
381     export GZIP
382     (cd %{root}/; tar -cpSf - *)|tar -xpsSf - -C %{buildroot}/
383     rm -rf %{root}
384     #mkdir -p %{buildroot}/%{_lib}
385     for model in libncurses libncursest libncursesw libncursestw libtinfo
386     do
387         #for lib in %{buildroot}%{_libdir}/${model}.so.* ; do
388         #    test   -e "${lib}" || continue
389         #    mv "${lib}" %{buildroot}/%{_lib}/ || continue
390         #done
391         for lib in %{buildroot}/%{_libdir}/${model}.so.5 ; do
392             test -e "${lib}" || continue
393             test -L "${lib}" || continue
394             lib=${lib#%{buildroot}}
395             lnk=%{buildroot}%{_libdir}/${model}.so
396             case "${lib##*/}" in
397             libncurses*)
398                 rm -f ${lnk}
399                 echo '/* GNU ld script */'              >  ${lnk}
400                 echo "INPUT(${lib} AS_NEEDED(-ltinfo))" >> ${lnk}
401                 ;;
402             #*) ln -sf ${lib} %{buildroot}%{_libdir}/${model}.so
403             esac
404         done
405     done
406     chmod 0755 %{buildroot}/%{_libdir}/lib*.so.*
407     chmod 0755 %{buildroot}/%{_libdir}/lib*.so.*
408     chmod a-x  %{buildroot}/%{_libdir}/lib*.a
409     if test -d %{buildroot}%{_libdir}/ncurses6 ; then
410         mv %{buildroot}%{_libdir}/ncurses6/*.so.6*   %{buildroot}%{_libdir}/
411         for lib in %{buildroot}%{_libdir}/ncurses6/*.so
412         do
413             lnk=$lib
414             lib=/%{_libdir}/${lib##*/}.6
415             case "${lib##*/}" in
416             libncurses*)
417                 rm -f "${lnk}"
418                 echo '/* GNU ld script */'              >  ${lnk}
419                 echo "INPUT(${lib} AS_NEEDED(-ltinfo))" >> ${lnk}
420                 ;;
421             libtinfo*)
422                 test -L "${lnk}" || continue
423                 ln -sf ${lib} ${lnk}
424                 ;;
425             *)
426                 test -L "${lnk}" || continue
427                 ln -sf ../${lib##*/} ${lnk}
428             esac
429         done
430         for model in libncurses libncursest libncursesw libncursestw libtinfo
431         do
432             for lib in %{buildroot}%{_libdir}/${model}.so.* ; do
433                 test   -e "${lib}" || continue
434                 #mv "${lib}" %{buildroot}/%{_lib}/ || continue
435             done
436             for lib in %{buildroot}/%{_libdir}/${model}.so.6 ; do
437                 test -e "${lib}" || continue
438                 test -L "${lib}" || continue
439                 lib=${lib#%{buildroot}}
440                 lnk=%{buildroot}%{_libdir}/ncurses6/${model}.so
441                 case "${lib##*/}" in
442                 libncurses*)
443                     rm -f ${lnk}
444                     echo '/* GNU ld script */'              >  ${lnk}
445                     echo 'SEARCH_DIR(%{_libdir}/ncurses6)'  >> ${lnk}
446                     echo "INPUT(${lib} AS_NEEDED(-ltinfo))" >> ${lnk}
447                     ;;
448                 *)  : #ln -sf ${lib} %{buildroot}%{_libdir}/ncurses6/${model}.so
449             esac
450             done
451         done
452         chmod 0755 %{buildroot}/%{_libdir}/lib*.so.6*
453         chmod 0755 %{buildroot}/%{_libdir}/lib*.so.6*
454         chmod a-x  %{buildroot}/%{_libdir}/ncurses6/lib*.a
455     fi
456     test -n "%{buildroot}" || ldconfig -N
457     mkdir -p %{buildroot}%{_defaultdocdir}/ncurses
458     bzip2 -c misc/terminfo.src > misc/terminfo.src.bz2
459     install -m 644 misc/terminfo.src.bz2        %{buildroot}%{_defaultdocdir}/ncurses/
460     install -m 644 doc/html/*.html              %{buildroot}%{_defaultdocdir}/ncurses/
461     bzip2 doc/ncurses-intro.doc -c > doc/ncurses-intro.txt.bz2
462     install -m 644 doc/ncurses-intro.txt.bz2    %{buildroot}%{_defaultdocdir}/ncurses/
463     bzip2 doc/hackguide.doc -c > doc/hackguide.txt.bz2
464     install -m 644 doc/hackguide.txt.bz2        %{buildroot}%{_defaultdocdir}/ncurses/
465     install -m 644 README                       %{buildroot}%{_defaultdocdir}/ncurses/
466     install -m 644 NEWS                         %{buildroot}%{_defaultdocdir}/ncurses/
467     mkdir -p %{buildroot}%{_sysconfdir}
468     mkdir -p %{buildroot}%{_miscdir}
469     LD_LIBRARY_PATH=$PWD/lib
470     export LD_LIBRARY_PATH
471     pushd ncurses/
472         { echo "# See annotated version in %{_defaultdocdir}/ncurses/terminfo.src.bz2"
473 %if 0%{?_crossbuild}
474         BUILD_TIC=/usr/bin/tic
475 %else
476         BUILD_TIC=$PWD/../progs/tic
477 %endif
478         $BUILD_TIC -C -r ../misc/terminfo.src | grep -E -v '^#'; } > termcap
479         # Gererate new termcap entries for various linux consoles
480         TERMCAP=termcap \
481         TERMINFO=%{buildroot}%{_datadir}/terminfo \
482             bash %{SOURCE2}
483         install -m 0644 termcap.new %{buildroot}%{_miscdir}/termcap
484     popd
485     unset LD_LIBRARY_PATH
486     if test `%{_bindir}/id -u` = '0' ; then
487         chown root:root %{buildroot}%{_miscdir}/termcap
488         chmod 0644      %{buildroot}%{_miscdir}/termcap
489     fi
490     ln -sf %{_miscdir}/termcap %{buildroot}%{_sysconfdir}/termcap
491     (cat > default.list) <<-EOF
492         %{tabset std}
493         %{tabset stdcrt}
494         %{tabset vt100}
495         %{tabset vt300}
496         %{terminfo a/ansi}
497         %{terminfo d/dumb}
498         %{terminfo g/gnome}
499         %{terminfo g/gnome-rh72}
500         %{terminfo k/klone+color}
501         %{terminfo k/kvt}
502         %{terminfo l/linux}
503         %{terminfo l/linux-m}
504         %{terminfo l/linux-nic}
505         %{terminfo m/mlterm}
506         %{terminfo n/nxterm}
507         %{terminfo r/rxvt}
508         %{terminfo s/screen}
509         %{terminfo s/screen-w}
510         %{terminfo s/screen-256color}
511         %{terminfo s/sun}
512         %{terminfo u/unknown}
513         %{terminfo v/vt100}
514         %{terminfo v/vt102}
515         %{terminfo v/vt220}
516         %{terminfo v/vt220-8}
517         %{terminfo v/vt220-8bit}
518         %{terminfo v/vt320}
519         %{terminfo v/vt52}
520         %{terminfo x/xterm}
521         %{terminfo x/xterm-color}
522         %{terminfo x/xterm-256color}
523         %{terminfo x/xterm-basic}
524         %{terminfo x/xterm-nic}
525         %{terminfo x/xterm-r6}
526         EOF
527     find %{buildroot}%{tabset ""} %{buildroot}%{terminfo ""} \
528         \( -type f -or -type l \) | \
529         sed "s@^%{buildroot}@@g" | \
530         grep -v -F -x -f default.list \
531         > extension.list
532     rm -f %{buildroot}%{_prefix}/lib/terminfo
533
534 %post   -n libncurses -p /sbin/ldconfig
535
536 %postun -n libncurses -p /sbin/ldconfig
537
538 %post   -n libncurses6 -p /sbin/ldconfig
539
540 %postun -n libncurses6 -p /sbin/ldconfig
541
542 %files -n terminfo-base -f default.list
543 %manifest %{name}.manifest
544 %defattr(-,root,root)
545 %license package/debian/copyright
546 %{_sysconfdir}/termcap
547 %config %{_miscdir}/termcap
548 %dir %{_datadir}/tabset/
549 %dir %{_datadir}/terminfo/
550 %dir %{_datadir}/terminfo/*/
551
552 %files -n ncurses-utils
553 %manifest %{name}.manifest
554 %defattr(-,root,root)
555 %license package/debian/copyright
556 %{_bindir}/clear
557 %{_bindir}/reset
558 %{_bindir}/tabs
559 %{_bindir}/toe
560 %{_bindir}/tput
561 %{_bindir}/tset
562
563 %files -n libncurses
564 %manifest %{name}.manifest
565 %defattr(-,root,root)
566 %license package/debian/copyright
567 %{_libdir}/lib*.so.5*
568
569 %files -n libncurses6
570 %manifest %{name}.manifest
571 %defattr(-,root,root)
572 %license package/debian/copyright
573 %{_libdir}/lib*.so.6*
574
575 %files -n ncurses-devel
576 %manifest %{name}.manifest
577 %defattr(-,root,root)
578 %license package/debian/copyright
579 %{_bindir}/ncurses*-config
580 %{_bindir}/captoinfo
581 %{_bindir}/infocmp
582 %{_bindir}/infotocap
583 %{_bindir}/tic
584 %dir %{_incdir}/ncurses/
585 %dir %{_incdir}/ncursesw/
586 %dir %{_incdir}/ncurses6/
587 %dir %{_incdir}/ncurses6/ncurses/
588 %dir %{_incdir}/ncurses6/ncursesw/
589 %{_incdir}/*.h
590 %{_incdir}/ncurses*/*.h
591 %{_incdir}/ncurses*/*/*.h
592 %dir %{_libdir}/ncurses6/
593 %{_libdir}/lib*.a
594 %{_libdir}/lib*.so
595 %{_libdir}/pkgconfig/*.pc
596 %{_libdir}/ncurses6/lib*.a
597 %{_libdir}/ncurses6/lib*.so
598
599 %files -f extension.list -n terminfo
600 %manifest %{name}.manifest
601 %defattr(-,root,root)
602 %license package/debian/copyright
603
604 %docs_package
605 %license package/debian/copyright
606 %dir %{_defaultdocdir}/ncurses/
607 %doc %{_defaultdocdir}/ncurses/*
608
609 %changelog