remove hardcoded conf
[profile/ivi/murphy.git] / packaging / murphy.spec
1 %bcond_with icosyscon
2
3 # By default we build with distro-default compilation flags which
4 # enables optimizations. If you want to build with full debugging
5 # ie. with optimization turned off and full debug info (-O0 -g3)
6 # pass '--with debug' to rpmbuild on the command line. Similary
7 # you can chose to compile with/without pulse, ecore, glib, qt,
8 # dbus, and telephony support. --without squashpkg will prevent
9 # squashing the -core and -plugins-base packages into the base
10 # murphy package.
11
12
13 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
14 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
15 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
16 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
17 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
18 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
19 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
20 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
21 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
22 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
23 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
24 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
25 %{!?_with_icoweston:%{!?_without_icoweston:%define _without_icoweston 1}}
26 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
27 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
28
29 #
30 # Abnormalize _with_icosyscon to _enable_icosyscon
31 #
32 # Since some people seem to have a hard time understanding that
33 #
34 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
35 #    undefined as opposed to defining it to 0
36 #
37 # 2) if you decide to do it the wrong way at least you should be consistent
38 #    about it and not randomly change between the conventions
39 #
40 # we need to roll this butt-ugly hack to make sure that we always go with
41 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
42 # on how _with_icosyscon happens to be set (or unset).
43 #
44
45 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
46 %if %{_with_icosyscon}
47 %define _enable_icosyscon 1
48 %else
49 %define _enable_icosyscon 0
50 %endif
51 %else
52 %define _enable_icosyscon 0
53 %endif
54
55 Summary: Resource policy framework
56 Name: murphy
57 Version: 0.0.57
58 Release: 1
59 License: BSD-3-Clause
60 Group: System/Service
61 URL: http://01.org/murphy/
62 Source0: %{name}-%{version}.tar.gz
63 Source1001: %{name}.manifest
64 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
65 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
66 Requires: %{name}-core = %{version}
67 %endif
68
69 Requires(post): /bin/systemctl
70 Requires(post): libcap-tools
71 Requires(postun): /bin/systemctl
72
73 BuildRequires: flex
74 BuildRequires: bison
75 BuildRequires: pkgconfig(lua)
76 BuildRequires: pkgconfig(libsystemd-daemon)
77 BuildRequires: pkgconfig(libsystemd-journal)
78 BuildRequires: pkgconfig(libcap)
79 BuildRequires: pkgconfig(libtzplatform-config)
80
81 %if %{?_with_pulse:1}%{!?_with_pulse:0}
82 BuildRequires: pkgconfig(libpulse)
83 %endif
84 %if %{?_with_ecore:1}%{!?_with_ecore:0}
85 BuildRequires: pkgconfig(ecore)
86 BuildRequires: mesa-libEGL
87 BuildRequires: mesa-libGLESv2
88 %endif
89 %if %{?_with_glib:1}%{!?_with_glib:0}
90 BuildRequires: pkgconfig(glib-2.0)
91 %endif
92 %if %{?_with_qt:1}%{!?_with_qt:0}
93 BuildRequires: pkgconfig(QtCore)
94 %endif
95 %if %{?_with_dbus:1}%{!?_with_dbus:0}
96 BuildRequires: pkgconfig(dbus-1)
97 %endif
98 %if %{?_with_telephony:1}%{!?_with_telephony:0}
99 BuildRequires: pkgconfig(ofono)
100 %endif
101 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
102 BuildRequires: pkgconfig(audio-session-mgr)
103 BuildRequires: pkgconfig(aul)
104 %endif
105 %if %{?_with_websockets:1}%{!?_with_websockets:0}
106 BuildRequires: libwebsockets-devel
107 %endif
108 BuildRequires: pkgconfig(json)
109
110 %if %{?_with_smack:1}%{!?_with_smack:0}
111 BuildRequires: pkgconfig(libsmack)
112 %endif
113
114 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
115 # %%if %%{_with_icosyscon} # gbs can't, so don't bother...
116 BuildRequires: ico-uxf-weston-plugin-devel
117 BuildRequires: weston-ivi-shell-devel
118 BuildRequires: genivi-shell-devel
119 BuildRequires: pkgconfig(ail)
120 BuildRequires: pkgconfig(aul)
121 BuildRequires: libxml2-devel
122 # %%endif
123 %endif
124
125 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
126 %package core
127 Summary: Murphy core runtime libraries
128 Group: System/Libraries
129
130 %package plugins-base
131 Summary: The basic set of Murphy plugins
132 Group: System/Service
133 Requires: %{name} = %{version}
134 Requires: %{name}-core = %{version}
135 %endif
136
137 %package devel
138 Summary: The header files and libraries needed for Murphy development
139 Group: System/Libraries
140 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
141 Requires: %{name}-core = %{version}
142 %else
143 Requires: %{name} = %{version}
144 %endif
145 Requires: libjson-devel
146
147 %package doc
148 Summary: Documentation for Murphy
149 Group: SDK/Documentation
150
151 %if %{?_with_pulse:1}%{!?_with_pulse:0}
152 %package pulse
153 Summary: Murphy PulseAudio mainloop integration
154 Group: System/Libraries
155 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
156 Requires: %{name}-core = %{version}
157 %else
158 Requires: %{name} = %{version}
159 %endif
160
161 %package pulse-devel
162 Summary: Murphy PulseAudio mainloop integration development files
163 Group: System/Libraries
164 Requires: %{name}-pulse = %{version}
165 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
166 Requires: %{name}-core = %{version}
167 %else
168 Requires: %{name} = %{version}
169 %endif
170 %endif
171
172 %if %{?_with_ecore:1}%{!?_with_ecore:0}
173 %package ecore
174 Summary: Murphy EFL/ecore mainloop integration
175 Group: System/Libraries
176 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
177 Requires: %{name}-core = %{version}
178 %else
179 Requires: %{name} = %{version}
180 %endif
181
182 %package ecore-devel
183 Summary: Murphy EFL/ecore mainloop integration development files
184 Group: System/Libraries
185 Requires: %{name}-ecore = %{version}
186 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
187 Requires: %{name}-core = %{version}
188 %else
189 Requires: %{name} = %{version}
190 %endif
191 %endif
192
193 %if %{?_with_glib:1}%{!?_with_glib:0}
194 %package glib
195 Summary: Murphy glib mainloop integration
196 Group: System/Libraries
197 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
198 Requires: %{name}-core = %{version}
199 %else
200 Requires: %{name} = %{version}
201 %endif
202
203 %package glib-devel
204 Summary: Murphy glib mainloop integration development files
205 Group: System/Libraries
206 Requires: %{name}-glib = %{version}
207 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
208 Requires: %{name}-core = %{version}
209 %else
210 Requires: %{name} = %{version}
211 %endif
212 %endif
213
214 %if %{?_with_qt:1}%{!?_with_qt:0}
215 %package qt
216 Summary: Murphy Qt mainloop integration
217 Group: System/Libraries
218 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
219 Requires: %{name}-core = %{version}
220 %else
221 Requires: %{name} = %{version}
222 %endif
223
224 %package qt-devel
225 Summary: Murphy Qt mainloop integration development files
226 Group: System/Libraries
227 Requires: %{name}-qt = %{version}
228 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
229 Requires: %{name}-core = %{version}
230 %else
231 Requires: %{name} = %{version}
232 %endif
233 %endif
234
235 %package gam
236 Summary: Murphy support for Genivi Audio Manager
237 Group: System/Libraries
238 Requires: %{name} = %{version}
239
240 %package gam-devel
241 Summary: Murphy support for Genivi Audio Manager development files
242 Group: System/Libraries
243 Requires: %{name}-gam = %{version}
244
245 %package tests
246 Summary: Various test binaries for Murphy
247 Group: System/Testing
248 Requires: %{name} = %{version}
249 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
250 Requires: %{name}-core = %{version}
251 %else
252 Requires: %{name} = %{version}
253 %endif
254
255 %package ivi-resource-manager
256 Summary: Murphy IVI resource manager plugin
257 Group: System/Service
258
259 %if %{_enable_icosyscon}
260 %package system-controller
261 Summary: Murphy IVI System Controller plugin
262 Group: System/Service
263 Requires: ico-uxf-homescreen
264 Conflicts: murphy-ivi-resource-manager
265 Provides: system-controller
266 Conflicts: ico-uxf-homescreen-system-controller
267 %endif
268
269 %description
270 This package contains the basic Murphy daemon.
271
272 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
273 %description core
274 This package contains the core runtime libraries.
275
276 %description plugins-base
277 This package contains a basic set of plugins.
278 %endif
279
280 %description devel
281 This package contains header files and libraries necessary for development.
282
283 %description doc
284 This package contains documentation.
285
286 %if %{?_with_pulse:1}%{!?_with_pulse:0}
287 %description pulse
288 This package contains the Murphy PulseAudio mainloop integration runtime files.
289
290 %description pulse-devel
291 This package contains the Murphy PulseAudio mainloop integration development
292 files.
293 %endif
294
295 %if %{?_with_ecore:1}%{!?_with_ecore:0}
296 %description ecore
297 This package contains the Murphy EFL/ecore mainloop integration runtime files.
298
299 %description ecore-devel
300 This package contains the Murphy EFL/ecore mainloop integration development
301 files.
302 %endif
303
304 %if %{?_with_glib:1}%{!?_with_glib:0}
305 %description glib
306 This package contains the Murphy glib mainloop integration runtime files.
307
308 %description glib-devel
309 This package contains the Murphy glib mainloop integration development
310 files.
311 %endif
312
313 %if %{?_with_qt:1}%{!?_with_qt:0}
314 %description qt
315 This package contains the Murphy Qt mainloop integration runtime files.
316
317 %description qt-devel
318 This package contains the Murphy Qt mainloop integration development
319 files.
320 %endif
321
322 %description tests
323 This package contains various test binaries for Murphy.
324
325 %description ivi-resource-manager
326 This package contains the Murphy IVI resource manager plugin.
327
328 %if %{_enable_icosyscon}
329 %description system-controller
330 This package contains the Murphy IVI resource manager plugin.
331 %endif
332
333 %description gam
334 This package contains the Murphy plugins for necessary for supporting
335 Genivi Audio Manager.
336
337 %description gam-devel
338 This package contains development files for Murphy Genivi Audio Manager
339 plugins.
340
341 %prep
342 %setup -q
343 cp %{SOURCE1001} .
344
345 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
346 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
347
348 %build
349 %if %{?_with_debug:1}%{!?_with_debug:0}
350 export CFLAGS="-O0 -g3"
351 V="V=1"
352 %endif
353
354 CONFIG_OPTIONS=""
355 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
356
357 %if %{?_with_pulse:1}%{!?_with_pulse:0}
358 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
359 %else
360 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
361 %endif
362
363 %if %{?_with_ecore:1}%{!?_with_ecore:0}
364 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
365 %else
366 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
367 %endif
368
369 %if %{?_with_glib:1}%{!?_with_glib:0}
370 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
371 %else
372 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
373 %endif
374
375 %if %{?_with_qt:1}%{!?_with_qt:0}
376 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
377 %else
378 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
379 %endif
380
381 %if %{?_with_dbus:1}%{!?_with_dbus:0}
382 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
383 %else
384 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
385 %endif
386
387 %if %{?_with_telephony:1}%{!?_with_telephony:0}
388 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
389 %else
390 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
391 %endif
392
393 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
394 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
395 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
396 %else
397 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
398 %endif
399
400 %if %{?_with_websockets:1}%{!?_with_websockets:0}
401 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
402 %else
403 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
404 %endif
405
406 %if %{?_with_smack:1}%{!?_with_smack:0}
407 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
408 %else
409 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
410 %endif
411
412 %if %{_enable_icosyscon}
413 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
414 %else
415 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
416 %endif
417
418 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
419 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
420 %else
421 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
422 %endif
423
424 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
425 grep '^processor *:' | wc -l`"
426 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
427
428 ./bootstrap && \
429 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
430 %__make clean && \
431 %__make -j$(($NUM_CPUS + 1)) $V
432
433 %install
434 rm -rf %{buildroot}
435 %make_install
436
437 # Make sure we have a plugin dir even if all the basic plugins
438 # are configured to be built in.
439 mkdir -p %{buildroot}%{_libdir}/murphy/plugins
440
441 # Get rid of any *.la files installed by libtool.
442 rm -f %{buildroot}%{_libdir}/*.la
443
444 # Clean up also the murphy DB installation.
445 rm -f %{buildroot}%{_libdir}/murphy/*.la
446
447 # Generate list of linkedin plugins (depends on the configuration).
448 outdir="`pwd`"
449 pushd %{buildroot} >& /dev/null && \
450 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
451 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
452 popd >& /dev/null
453 echo "Found the following linked-in plugin files:"
454 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
455
456 # Generate list of header files, filtering ones that go to subpackages.
457 outdir="`pwd`"
458 pushd %{buildroot} >& /dev/null && \
459 find ./%{_includedir}/murphy | \
460 grep -E -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
461 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
462 popd >& /dev/null
463
464 # Replace the default sample/test config files with the packaging ones.
465 rm -f %{buildroot}%{_sysconfdir}/murphy/*
466 cp packaging.in/murphy-lua.conf %{buildroot}%{_sysconfdir}/murphy/murphy.conf
467 cp packaging.in/murphy.lua      %{buildroot}%{_sysconfdir}/murphy/murphy.lua
468
469 # Copy plugin configuration files in place.
470 mkdir -p %{buildroot}%{_sysconfdir}/murphy/plugins/amb
471 cp packaging.in/amb-config.lua \
472 %{buildroot}%{_sysconfdir}/murphy/plugins/amb/config.lua
473
474 # Copy tmpfiles.d config file in place
475 mkdir -p %{buildroot}%{_tmpfilesdir}
476 cp packaging.in/murphyd.conf %{buildroot}%{_tmpfilesdir}
477
478 # Copy the systemd files in place.
479 mkdir -p %{buildroot}%{_unitdir}
480 mkdir -p %{buildroot}%{_unitdir_user}
481 cp packaging.in/murphyd.service %{buildroot}%{_unitdir}
482 %if %{_enable_icosyscon}
483 cp packaging.in/ico-homescreen.service %{buildroot}%{_unitdir_user}
484 cp packaging.in/murphy-wait-for-launchpad-ready.path \
485     %{buildroot}%{_unitdir_user}
486 %endif
487
488 %if %{?_with_dbus:1}%{!?_with_dbus:0}
489 mkdir -p %{buildroot}%{_sysconfdir}/dbus-1/system.d
490 sed "s/@TZ_SYS_USER_GROUP@/%{TZ_SYS_USER_GROUP}/g" \
491     packaging.in/org.Murphy.conf.in > packaging.in/org.Murphy.conf
492 cp packaging.in/org.Murphy.conf \
493     %{buildroot}%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
494 %endif
495
496 # copy (experimental) GAM resource backend configuration files
497 mkdir -p %{buildroot}%{_sysconfdir}/murphy/gam
498 cp packaging.in/gam-*.names packaging.in/gam-*.tree \
499     %{buildroot}%{_sysconfdir}/murphy/gam
500
501 %clean
502 rm -rf %{buildroot}
503
504 %post
505 /bin/systemctl enable murphyd.service
506 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
507
508 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
509 %post core
510 %endif
511 ldconfig
512
513 %postun
514 if [ "$1" = "0" ]; then
515 /bin/systemctl disable murphyd.service
516 fi
517
518 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
519 %postun core
520 %endif
521 ldconfig
522
523 %if %{?_with_glib:1}%{!?_with_glib:0}
524 %post glib
525 ldconfig
526
527 %postun glib
528 ldconfig
529 %endif
530
531 %if %{?_with_pulse:1}%{!?_with_pulse:0}
532 %post pulse
533 ldconfig
534
535 %postun pulse
536 ldconfig
537 %endif
538
539 %if %{?_with_ecore:1}%{!?_with_ecore:0}
540 %post ecore
541 ldconfig
542
543 %postun ecore
544 ldconfig
545 %endif
546
547 %if %{?_with_qt:1}%{!?_with_qt:0}
548 %post qt
549 ldconfig
550
551 %postun qt
552 ldconfig
553 %endif
554
555 %if %{_enable_icosyscon}
556 %post system-controller
557 # prevent system controller from starting
558 rm -f %{_unitdir_user}/weston.target.wants/ico-uxf-wait-launchpad-ready.path
559 # instead launch just ico-homescreen
560 rm -f %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
561 ln -s %{_unitdir_user}/murphy-wait-for-launchpad-ready.path \
562     %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
563
564 %postun system-controller
565 if [ "$1" = "0" ]; then
566 rm -f %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
567 if [ -f %{_unitdir_user}/ico-uxf-wait-launchpad-ready.path ]; then
568     ln -sf %{_unitdir_user}/ico-uxf-wait-launchpad-ready.path \
569         %{_unitdir_user}/weston.target.wants/ico-uxf-wait-launchpad-ready.path
570 fi
571 fi
572 %endif
573
574 %post gam
575 ldconfig
576
577 %postun gam
578 ldconfig
579
580 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
581 %files -f filelist.plugins-base
582 %else
583 %files
584 %endif
585 %defattr(-,root,root,-)
586 %manifest murphy.manifest
587 %{_bindir}/murphyd
588 %config %{_sysconfdir}/murphy
589 %{_unitdir}/murphyd.service
590 %{_tmpfilesdir}/murphyd.conf
591 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
592 %{_sbindir}/asm-bridge
593 %endif
594 %if %{?_with_dbus:1}%{!?_with_dbus:0}
595 %{_sysconfdir}/dbus-1/system.d
596 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
597 %endif
598 %if %{?_with_websockets:1}%{!?_with_websockets:0}
599 %{_datadir}/murphy
600 %endif
601
602 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
603 %files core
604 %defattr(-,root,root,-)
605 %endif
606 %{_libdir}/libmurphy-common.so.*
607 %{_libdir}/libmurphy-core.so.*
608 %{_libdir}/libmurphy-resolver.so.*
609 %{_libdir}/libmurphy-resource.so.*
610 %{_libdir}/libmurphy-resource-backend.so.*
611 %if %{?_with_lua:1}%{!?_with_lua:0}
612 %{_libdir}/libmurphy-lua-utils.so.*
613 %{_libdir}/libmurphy-lua-decision.so.*
614 %endif
615 %{_libdir}/libmurphy-domain-controller.so.*
616 %{_libdir}/murphy/*.so.*
617 %{_libdir}/libbreedline*.so.*
618 %if %{?_with_dbus:1}%{!?_with_dbus:0}
619 %{_libdir}/libmurphy-libdbus.so.*
620 %{_libdir}/libmurphy-dbus-libdbus.so.*
621 %endif
622
623 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
624 %files plugins-base -f filelist.plugins-base
625 %defattr(-,root,root,-)
626 %endif
627 %{_libdir}/murphy/plugins/plugin-domain-control.so
628 %{_libdir}/murphy/plugins/plugin-resource-asm.so
629 %{_libdir}/murphy/plugins/plugin-resource-native.so
630
631 %files devel -f filelist.devel-includes
632 %defattr(-,root,root,-)
633 # %%{_includedir}/murphy/config.h
634 # %%{_includedir}/murphy/common.h
635 # %%{_includedir}/murphy/core.h
636 # %%{_includedir}/murphy/common
637 # %%{_includedir}/murphy/core
638 # %%{_includedir}/murphy/resolver
639 # %%{_includedir}/murphy/resource
640 # # hmmm... should handle disabled plugins properly.
641 # %%{_includedir}/murphy/domain-control
642 # %%{_includedir}/murphy/plugins
643 %{_includedir}/murphy-db
644 %{_libdir}/libmurphy-common.so
645 %{_libdir}/libmurphy-core.so
646 %{_libdir}/libmurphy-resolver.so
647 %{_libdir}/libmurphy-resource.so
648 %{_libdir}/libmurphy-resource-backend.so
649 %if %{?_with_lua:1}%{!?_with_lua:0}
650 %{_libdir}/libmurphy-lua-utils.so
651 %{_libdir}/libmurphy-lua-decision.so
652 %endif
653 %{_libdir}/libmurphy-domain-controller.so
654 %{_libdir}/murphy/*.so
655 %{_libdir}/pkgconfig/murphy-common.pc
656 %{_libdir}/pkgconfig/murphy-core.pc
657 %{_libdir}/pkgconfig/murphy-resolver.pc
658 # %%{_libdir}/pkgconfig/murphy-resource.pc
659 %if %{?_with_lua:1}%{!?_with_lua:0}
660 %{_libdir}/pkgconfig/murphy-lua-utils.pc
661 %{_libdir}/pkgconfig/murphy-lua-decision.pc
662 %endif
663 %{_libdir}/pkgconfig/murphy-domain-controller.pc
664 %{_libdir}/pkgconfig/murphy-db.pc
665 %{_libdir}/pkgconfig/murphy-resource.pc
666 %{_includedir}/breedline
667 %{_libdir}/libbreedline*.so
668 %{_libdir}/pkgconfig/breedline*.pc
669 %if %{?_with_dbus:1}%{!?_with_dbus:0}
670 # %%{_includedir}/murphy/dbus
671 %{_libdir}/libmurphy-libdbus.so
672 %{_libdir}/libmurphy-dbus-libdbus.so
673 %{_libdir}/pkgconfig/murphy-libdbus.pc
674 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
675 %endif
676
677 %files doc
678 %defattr(-,root,root,-)
679 %doc %{_docdir}/../murphy/AUTHORS
680 %doc %{_docdir}/../murphy/CODING-STYLE
681 %doc %{_docdir}/../murphy/ChangeLog
682 %doc %{_docdir}/../murphy/NEWS
683 %doc %{_docdir}/../murphy/README
684 %license COPYING LICENSE-BSD
685
686 %if %{?_with_pulse:1}%{!?_with_pulse:0}
687 %files pulse
688 %defattr(-,root,root,-)
689 %{_libdir}/libmurphy-pulse.so.*
690 %manifest murphy.manifest
691
692 %files pulse-devel
693 %defattr(-,root,root,-)
694 %{_includedir}/murphy/common/pulse-glue.h
695 %{_libdir}/libmurphy-pulse.so
696 %{_libdir}/pkgconfig/murphy-pulse.pc
697 %endif
698
699 %if %{?_with_ecore:1}%{!?_with_ecore:0}
700 %files ecore
701 %defattr(-,root,root,-)
702 %{_libdir}/libmurphy-ecore.so.*
703 %manifest murphy.manifest
704
705 %files ecore-devel
706 %defattr(-,root,root,-)
707 %{_includedir}/murphy/common/ecore-glue.h
708 %{_libdir}/libmurphy-ecore.so
709 %{_libdir}/pkgconfig/murphy-ecore.pc
710 %endif
711
712 %if %{?_with_glib:1}%{!?_with_glib:0}
713 %files glib
714 %defattr(-,root,root,-)
715 %{_libdir}/libmurphy-glib.so.*
716 %manifest murphy.manifest
717
718 %files glib-devel
719 %defattr(-,root,root,-)
720 %{_includedir}/murphy/common/glib-glue.h
721 %{_libdir}/libmurphy-glib.so
722 %{_libdir}/pkgconfig/murphy-glib.pc
723 %endif
724
725 %if %{?_with_qt:1}%{!?_with_qt:0}
726 %files qt
727 %defattr(-,root,root,-)
728 %{_libdir}/libmurphy-qt.so.*
729 %manifest murphy.manifest
730
731 %files qt-devel
732 %defattr(-,root,root,-)
733 %{_includedir}/murphy/common/qt-glue.h
734 %{_libdir}/libmurphy-qt.so
735 %{_libdir}/pkgconfig/murphy-qt.pc
736 %endif
737
738 %files gam
739 %defattr(-,root,root,-)
740 %{_libdir}/libmurphy-decision-tree.so.*
741 %{_libdir}/libmurphy-decision-tree.so.0.0.0
742 %{_libdir}/murphy/plugins/plugin-gam-resource-manager.so
743
744 %files gam-devel
745 %defattr(-,root,root,-)
746 %{_bindir}/decision-test
747 %{_bindir}/pattern-generator
748 %{_libdir}/libmurphy-decision-tree.so
749
750 %files tests
751 %defattr(-,root,root,-)
752 %{_bindir}/resource-client
753 %{_bindir}/resource-api-test
754 %{_bindir}/resource-api-fuzz
755 %{_bindir}/test-domain-controller
756 %{_bindir}/murphy-console
757 %manifest murphy.manifest
758
759 %files ivi-resource-manager
760 %defattr(-,root,root,-)
761 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
762 %manifest murphy.manifest
763
764 %if %{_enable_icosyscon}
765 %files system-controller
766 %defattr(-,root,root,-)
767 %{_libdir}/murphy/plugins/plugin-system-controller.so
768 %{_unitdir_user}/ico-homescreen.service
769 %{_unitdir_user}/murphy-wait-for-launchpad-ready.path
770 %manifest murphy.manifest
771 %endif
772
773 %changelog
774 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
775 - Initial build for 2.0alpha.