packaging: use gbs-kosher conditional RPM dependencies.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
22 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
23 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
24
25 # TODO: take care of /lib vs /lib64...
26 %define systemddir /lib/systemd
27
28 #
29 # Abnormalize _with_icosyscon to _enable_icosyscon
30 #
31 # Since some people seem to have a hard time understanding that
32 #
33 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
34 #    undefined as opposed to defining it to 0
35 #
36 # 2) if you decide to do it the wrong way at least you should be consistent
37 #    about it and not randomly change between the conventions
38 #
39 # we need to roll this butt-ugly hack to make sure that we always go with
40 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
41 # on how _with_icosyscon happens to be set (or unset).
42 #
43
44 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
45 %if %{_with_icosyscon}
46 %define _enable_icosyscon 1
47 %else
48 %define _enable_icosyscon 0
49 %endif
50 %else
51 %define _enable_icosyscon 0
52 %endif
53
54 Summary: Murphy policy framework
55 Name: murphy
56 Version: 0.0.54
57 Release: 1
58 License: BSD-3-Clause
59 Group: System/Service
60 URL: http://01.org/murphy/
61 Source0: %{name}-%{version}.tar.gz
62 Source1: murphy.manifest
63 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
64 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
65 Requires: %{name}-core = %{version}
66 %endif
67
68 Requires(post): /bin/systemctl
69 Requires(post): libcap-tools
70 Requires(postun): /bin/systemctl
71
72 BuildRequires: flex
73 BuildRequires: bison
74 BuildRequires: pkgconfig(lua)
75 BuildRequires: pkgconfig(libsystemd-daemon)
76 BuildRequires: pkgconfig(libsystemd-journal)
77 BuildRequires: pkgconfig(libcap)
78
79 %if %{?_with_pulse:1}%{!?_with_pulse:0}
80 BuildRequires: pkgconfig(libpulse)
81 %endif
82 %if %{?_with_ecore:1}%{!?_with_ecore:0}
83 BuildRequires: pkgconfig(ecore)
84 BuildRequires: mesa-libEGL
85 BuildRequires: mesa-libGLESv2
86 %endif
87 %if %{?_with_glib:1}%{!?_with_glib:0}
88 BuildRequires: pkgconfig(glib-2.0)
89 %endif
90 %if %{?_with_qt:1}%{!?_with_qt:0}
91 BuildRequires: pkgconfig(QtCore)
92 %endif
93 %if %{?_with_dbus:1}%{!?_with_dbus:0}
94 BuildRequires: pkgconfig(dbus-1)
95 %endif
96 %if %{?_with_telephony:1}%{!?_with_telephony:0}
97 BuildRequires: pkgconfig(ofono)
98 %endif
99 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
100 BuildRequires: pkgconfig(audio-session-mgr)
101 BuildRequires: pkgconfig(aul)
102 %endif
103 %if %{?_with_websockets:1}%{!?_with_websockets:0}
104 BuildRequires: libwebsockets-devel
105 %endif
106 BuildRequires: pkgconfig(json)
107
108 %if %{?_with_smack:1}%{!?_with_smack:0}
109 BuildRequires: pkgconfig(libsmack)
110 %endif
111
112 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
113 #%if %{_with_icosyscon} # gbs can't, so don't bother...
114 BuildRequires: ico-uxf-weston-plugin-devel
115 BuildRequires: pkgconfig(ail)
116 BuildRequires: pkgconfig(aul)
117 BuildRequires: libxml2-devel
118 #%endif
119 %endif
120
121 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
122 %package core
123 Summary: Murphy core runtime libraries
124 Group: System/Libraries
125
126 %package plugins-base
127 Summary: The basic set of Murphy plugins
128 Group: System/Service
129 Requires: %{name} = %{version}
130 Requires: %{name}-core = %{version}
131 %endif
132
133 %package devel
134 Summary: The header files and libraries needed for Murphy development
135 Group: System/Libraries
136 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
137 Requires: %{name}-core = %{version}
138 %else
139 Requires: %{name} = %{version}
140 %endif
141 Requires: libjson-devel
142
143 %package doc
144 Summary: Documentation for Murphy
145 Group: SDK/Documentation
146
147 %if %{?_with_pulse:1}%{!?_with_pulse:0}
148 %package pulse
149 Summary: Murphy PulseAudio mainloop integration
150 Group: System/Libraries
151 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
152 Requires: %{name}-core = %{version}
153 %else
154 Requires: %{name} = %{version}
155 %endif
156
157 %package pulse-devel
158 Summary: Murphy PulseAudio mainloop integration development files
159 Group: System/Libraries
160 Requires: %{name}-pulse = %{version}
161 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
162 Requires: %{name}-core = %{version}
163 %else
164 Requires: %{name} = %{version}
165 %endif
166 %endif
167
168 %if %{?_with_ecore:1}%{!?_with_ecore:0}
169 %package ecore
170 Summary: Murphy EFL/ecore mainloop integration
171 Group: System/Libraries
172 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
173 Requires: %{name}-core = %{version}
174 %else
175 Requires: %{name} = %{version}
176 %endif
177
178 %package ecore-devel
179 Summary: Murphy EFL/ecore mainloop integration development files
180 Group: System/Libraries
181 Requires: %{name}-ecore = %{version}
182 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
183 Requires: %{name}-core = %{version}
184 %else
185 Requires: %{name} = %{version}
186 %endif
187 %endif
188
189 %if %{?_with_glib:1}%{!?_with_glib:0}
190 %package glib
191 Summary: Murphy glib mainloop integration
192 Group: System/Libraries
193 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
194 Requires: %{name}-core = %{version}
195 %else
196 Requires: %{name} = %{version}
197 %endif
198
199 %package glib-devel
200 Summary: Murphy glib mainloop integration development files
201 Group: System/Libraries
202 Requires: %{name}-glib = %{version}
203 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
204 Requires: %{name}-core = %{version}
205 %else
206 Requires: %{name} = %{version}
207 %endif
208 %endif
209
210 %if %{?_with_qt:1}%{!?_with_qt:0}
211 %package qt
212 Summary: Murphy Qt mainloop integration
213 Group: System/Libraries
214 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
215 Requires: %{name}-core = %{version}
216 %else
217 Requires: %{name} = %{version}
218 %endif
219
220 %package qt-devel
221 Summary: Murphy Qt mainloop integration development files
222 Group: System/Libraries
223 Requires: %{name}-qt = %{version}
224 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
225 Requires: %{name}-core = %{version}
226 %else
227 Requires: %{name} = %{version}
228 %endif
229 %endif
230
231 %package tests
232 Summary: Various test binaries for Murphy
233 Group: System/Testing
234 Requires: %{name} = %{version}
235 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
236 Requires: %{name}-core = %{version}
237 %else
238 Requires: %{name} = %{version}
239 %endif
240
241 %package ivi-resource-manager
242 Summary: Murphy IVI resource manager plugin
243 Group: System/Service
244
245 %if %{_enable_icosyscon}
246 %package system-controller
247 Summary: Murphy IVI System Controller plugin
248 Group: System/Service
249 Requires: ico-uxf-homescreen
250 Conflicts: murphy-ivi-resource-manager
251 %endif
252
253 %description
254 This package contains the basic daemon.
255
256 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
257 %description core
258 This package contains the core runtime libraries.
259
260 %description plugins-base
261 This package contains a basic set of plugins.
262 %endif
263
264 %description devel
265 This package contains header files and libraries necessary for development.
266
267 %description doc
268 This package contains documentation.
269
270 %if %{?_with_pulse:1}%{!?_with_pulse:0}
271 %description pulse
272 This package contains the Murphy PulseAudio mainloop integration runtime files.
273
274 %description pulse-devel
275 This package contains the Murphy PulseAudio mainloop integration development
276 files.
277 %endif
278
279 %if %{?_with_ecore:1}%{!?_with_ecore:0}
280 %description ecore
281 This package contains the Murphy EFL/ecore mainloop integration runtime files.
282
283 %description ecore-devel
284 This package contains the Murphy EFL/ecore mainloop integration development
285 files.
286 %endif
287
288 %if %{?_with_glib:1}%{!?_with_glib:0}
289 %description glib
290 This package contains the Murphy glib mainloop integration runtime files.
291
292 %description glib-devel
293 This package contains the Murphy glib mainloop integration development
294 files.
295 %endif
296
297 %if %{?_with_qt:1}%{!?_with_qt:0}
298 %description qt
299 This package contains the Murphy Qt mainloop integration runtime files.
300
301 %description qt-devel
302 This package contains the Murphy Qt mainloop integration development
303 files.
304 %endif
305
306 %description tests
307 This package contains various test binaries for Murphy.
308
309 %description ivi-resource-manager
310 This package contains the Murphy IVI resource manager plugin.
311
312 %if %{_enable_icosyscon}
313 %description system-controller
314 This package contains the Murphy IVI resource manager plugin.
315 %endif
316
317 %prep
318 %setup -q
319
320 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
321 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
322
323 %build
324 %if %{?_with_debug:1}%{!?_with_debug:0}
325 export CFLAGS="-O0 -g3"
326 V="V=1"
327 %endif
328
329 CONFIG_OPTIONS=""
330 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
331
332 %if %{?_with_pulse:1}%{!?_with_pulse:0}
333 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
334 %else
335 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
336 %endif
337
338 %if %{?_with_ecore:1}%{!?_with_ecore:0}
339 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
340 %else
341 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
342 %endif
343
344 %if %{?_with_glib:1}%{!?_with_glib:0}
345 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
346 %else
347 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
348 %endif
349
350 %if %{?_with_qt:1}%{!?_with_qt:0}
351 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
352 %else
353 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
354 %endif
355
356 %if %{?_with_dbus:1}%{!?_with_dbus:0}
357 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
358 %else
359 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
360 %endif
361
362 %if %{?_with_telephony:1}%{!?_with_telephony:0}
363 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
364 %else
365 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
366 %endif
367
368 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
369 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
370 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
371 %else
372 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
373 %endif
374
375 %if %{?_with_websockets:1}%{!?_with_websockets:0}
376 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
377 %else
378 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
379 %endif
380
381 %if %{?_with_smack:1}%{!?_with_smack:0}
382 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
383 %else
384 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
385 %endif
386
387 %if %{_enable_icosyscon}
388 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
389 %else
390 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
391 %endif
392
393 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
394 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
395 %else
396 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
397 %endif
398
399 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
400 grep '^processor *:' | wc -l`"
401 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
402
403 ./bootstrap && \
404 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
405 make clean && \
406 make -j$(($NUM_CPUS + 1)) $V
407
408 %install
409 rm -rf $RPM_BUILD_ROOT
410 %make_install
411
412 # Make sure we have a plugin dir even if all the basic plugins
413 # are configured to be built in.
414 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
415
416 # Get rid of any *.la files installed by libtool.
417 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
418
419 # Clean up also the murphy DB installation.
420 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
421
422 # Generate list of linkedin plugins (depends on the configuration).
423 outdir="`pwd`"
424 pushd $RPM_BUILD_ROOT >& /dev/null && \
425 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
426 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
427 popd >& /dev/null
428 echo "Found the following linked-in plugin files:"
429 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
430
431 # Generate list of header files, filtering ones that go to subpackages.
432 outdir="`pwd`"
433 pushd $RPM_BUILD_ROOT >& /dev/null && \
434 find ./%{_includedir}/murphy | \
435 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
436 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
437 popd >& /dev/null
438
439 # Replace the default sample/test config files with the packaging ones.
440 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/murphy/*
441 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
442 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
443
444 # Copy plugin configuration files in place.
445 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
446 cp packaging.in/amb-config.lua \
447 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
448
449 # Copy tmpfiles.d config file in place
450 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
451 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
452
453 # Copy the systemd files in place.
454 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
455 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
456 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
457 %if %{_enable_icosyscon}
458 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
459 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
460 %endif
461
462 %if %{?_with_dbus:1}%{!?_with_dbus:0}
463 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
464 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
465 %endif
466
467 # copy the manifest file
468 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
469 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
470 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
471 %if %{?_with_qt:1}%{!?_with_qt:0}
472 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
473 %endif
474 %if %{?_with_glib:1}%{!?_with_glib:0}
475 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
476 %endif
477 %if %{?_with_pulse:1}%{!?_with_pulse:0}
478 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
479 %endif
480 %if %{?_with_ecore:1}%{!?_with_ecore:0}
481 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
482 %endif
483 %if %{_enable_icosyscon}
484 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
485 %endif
486
487 %clean
488 rm -rf $RPM_BUILD_ROOT
489
490 %post
491 /bin/systemctl enable murphyd.service
492 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
493
494 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
495 %post core
496 %endif
497 ldconfig
498
499 %postun
500 if [ "$1" = "0" ]; then
501 /bin/systemctl disable murphyd.service
502 fi
503
504 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
505 %postun core
506 %endif
507 ldconfig
508
509 %if %{?_with_glib:1}%{!?_with_glib:0}
510 %post glib
511 ldconfig
512
513 %postun glib
514 ldconfig
515 %endif
516
517 %if %{?_with_pulse:1}%{!?_with_pulse:0}
518 %post pulse
519 ldconfig
520
521 %postun pulse
522 ldconfig
523 %endif
524
525 %if %{?_with_ecore:1}%{!?_with_ecore:0}
526 %post ecore
527 ldconfig
528
529 %postun ecore
530 ldconfig
531 %endif
532
533 %if %{?_with_qt:1}%{!?_with_qt:0}
534 %post qt
535 lfconfig
536
537 %postun qt
538 ldconfig
539 %endif
540
541 %if %{_enable_icosyscon}
542 %post system-controller
543 # prevent system controller from starting
544 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
545 # instead launch just ico-homescreen
546 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
547 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path \
548     %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
549
550 %postun system-controller
551 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
552 if [ -f %{systemddir}/user/ico-uxf-wait-launchpad-ready.path ]; then
553     ln -sf %{systemddir}/user/ico-uxf-wait-launchpad-ready.path \
554         %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
555 fi
556 %endif
557
558 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
559 %files -f filelist.plugins-base
560 %else
561 %files
562 %endif
563 %defattr(-,root,root,-)
564 %manifest %{_datadir}/murphy.manifest
565 %{_bindir}/murphyd
566 %config %{_sysconfdir}/murphy
567 %{systemddir}/system/murphyd.service
568 %{_tmpfilesdir}/murphyd.conf
569 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
570 %{_sbindir}/asm-bridge
571 %endif
572 %if %{?_with_dbus:1}%{!?_with_dbus:0}
573 %{_sysconfdir}/dbus-1/system.d
574 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
575 %endif
576 %if %{?_with_websockets:1}%{!?_with_websockets:0}
577 %{_datadir}/murphy
578 %endif
579
580 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
581 %files core
582 %defattr(-,root,root,-)
583 %endif
584 %{_libdir}/libmurphy-common.so.*
585 %{_libdir}/libmurphy-core.so.*
586 %{_libdir}/libmurphy-resolver.so.*
587 %{_libdir}/libmurphy-resource.so.*
588 %{_libdir}/libmurphy-resource-backend.so.*
589 %if %{?_with_lua:1}%{!?_with_lua:0}
590 %{_libdir}/libmurphy-lua-utils.so.*
591 %{_libdir}/libmurphy-lua-decision.so.*
592 %endif
593 %{_libdir}/libmurphy-domain-controller.so.*
594 %{_libdir}/murphy/*.so.*
595 %{_libdir}/libbreedline*.so.*
596 %if %{?_with_dbus:1}%{!?_with_dbus:0}
597 %{_libdir}/libmurphy-libdbus.so.*
598 %{_libdir}/libmurphy-dbus-libdbus.so.*
599 %endif
600
601 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
602 %files plugins-base -f filelist.plugins-base
603 %defattr(-,root,root,-)
604 %endif
605 %{_libdir}/murphy/plugins/plugin-domain-control.so
606 %{_libdir}/murphy/plugins/plugin-resource-asm.so
607 %{_libdir}/murphy/plugins/plugin-resource-native.so
608
609 %files devel -f filelist.devel-includes
610 %defattr(-,root,root,-)
611 # %{_includedir}/murphy/config.h
612 # %{_includedir}/murphy/common.h
613 # #%{_includedir}/murphy/core.h
614 # %{_includedir}/murphy/common
615 # %{_includedir}/murphy/core
616 # %{_includedir}/murphy/resolver
617 # %{_includedir}/murphy/resource
618 # # hmmm... should handle disabled plugins properly.
619 # %{_includedir}/murphy/domain-control
620 # %{_includedir}/murphy/plugins
621 %{_includedir}/murphy-db
622 %{_libdir}/libmurphy-common.so
623 %{_libdir}/libmurphy-core.so
624 %{_libdir}/libmurphy-resolver.so
625 %{_libdir}/libmurphy-resource.so
626 %{_libdir}/libmurphy-resource-backend.so
627 %if %{?_with_lua:1}%{!?_with_lua:0}
628 %{_libdir}/libmurphy-lua-utils.so
629 %{_libdir}/libmurphy-lua-decision.so
630 %endif
631 %{_libdir}/libmurphy-domain-controller.so
632 %{_libdir}/murphy/*.so
633 %{_libdir}/pkgconfig/murphy-common.pc
634 %{_libdir}/pkgconfig/murphy-core.pc
635 %{_libdir}/pkgconfig/murphy-resolver.pc
636 #%{_libdir}/pkgconfig/murphy-resource.pc
637 %if %{?_with_lua:1}%{!?_with_lua:0}
638 %{_libdir}/pkgconfig/murphy-lua-utils.pc
639 %{_libdir}/pkgconfig/murphy-lua-decision.pc
640 %endif
641 %{_libdir}/pkgconfig/murphy-domain-controller.pc
642 %{_libdir}/pkgconfig/murphy-db.pc
643 %{_libdir}/pkgconfig/murphy-resource.pc
644 %{_includedir}/breedline
645 %{_libdir}/libbreedline*.so
646 %{_libdir}/pkgconfig/breedline*.pc
647 %if %{?_with_dbus:1}%{!?_with_dbus:0}
648 #%{_includedir}/murphy/dbus
649 %{_libdir}/libmurphy-libdbus.so
650 %{_libdir}/libmurphy-dbus-libdbus.so
651 %{_libdir}/pkgconfig/murphy-libdbus.pc
652 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
653 %endif
654
655 %files doc
656 %defattr(-,root,root,-)
657 %doc %{_docdir}/../murphy/AUTHORS
658 %doc %{_docdir}/../murphy/CODING-STYLE
659 %license %{_docdir}/../murphy/COPYING
660 %doc %{_docdir}/../murphy/ChangeLog
661 %doc %{_docdir}/../murphy/INSTALL
662 %doc %{_docdir}/../murphy/NEWS
663 %doc %{_docdir}/../murphy/README
664
665 %if %{?_with_pulse:1}%{!?_with_pulse:0}
666 %files pulse
667 %defattr(-,root,root,-)
668 %{_libdir}/libmurphy-pulse.so.*
669 %manifest %{_datadir}/murphy-pulse.manifest
670
671 %files pulse-devel
672 %defattr(-,root,root,-)
673 %{_includedir}/murphy/common/pulse-glue.h
674 %{_libdir}/libmurphy-pulse.so
675 %{_libdir}/pkgconfig/murphy-pulse.pc
676 %endif
677
678 %if %{?_with_ecore:1}%{!?_with_ecore:0}
679 %files ecore
680 %defattr(-,root,root,-)
681 %{_libdir}/libmurphy-ecore.so.*
682 %manifest %{_datadir}/murphy-ecore.manifest
683
684 %files ecore-devel
685 %defattr(-,root,root,-)
686 %{_includedir}/murphy/common/ecore-glue.h
687 %{_libdir}/libmurphy-ecore.so
688 %{_libdir}/pkgconfig/murphy-ecore.pc
689 %endif
690
691 %if %{?_with_glib:1}%{!?_with_glib:0}
692 %files glib
693 %defattr(-,root,root,-)
694 %{_libdir}/libmurphy-glib.so.*
695 %manifest %{_datadir}/murphy-glib.manifest
696
697 %files glib-devel
698 %defattr(-,root,root,-)
699 %{_includedir}/murphy/common/glib-glue.h
700 %{_libdir}/libmurphy-glib.so
701 %{_libdir}/pkgconfig/murphy-glib.pc
702 %endif
703
704 %if %{?_with_qt:1}%{!?_with_qt:0}
705 %files qt
706 %defattr(-,root,root,-)
707 %{_libdir}/libmurphy-qt.so.*
708 %manifest %{_datadir}/murphy-qt.manifest
709
710 %files qt-devel
711 %defattr(-,root,root,-)
712 %{_includedir}/murphy/common/qt-glue.h
713 %{_libdir}/libmurphy-qt.so
714 %{_libdir}/pkgconfig/murphy-qt.pc
715 %endif
716
717 %files tests
718 %defattr(-,root,root,-)
719 %{_bindir}/resource-client
720 %{_bindir}/resource-api-test
721 %{_bindir}/resource-api-fuzz
722 %{_bindir}/test-domain-controller
723 %{_bindir}/murphy-console
724 %manifest %{_datadir}/murphy-tests.manifest
725
726 %files ivi-resource-manager
727 %defattr(-,root,root,-)
728 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
729 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
730
731 %if %{_enable_icosyscon}
732 %files system-controller
733 %defattr(-,root,root,-)
734 %{_libdir}/murphy/plugins/plugin-system-controller.so
735 %{systemddir}/user/ico-homescreen.service
736 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
737 %manifest %{_datadir}/murphy-system-controller.manifest
738 %endif
739
740 %changelog
741 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
742 - Initial build for 2.0alpha.