packaging: install user.xml for system-controller.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %define _with_icosyscon 1
11
12 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
13 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
14 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
15 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
16 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
17 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
18 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
19 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
20 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
21 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
22 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
23 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
24 %{!?_with_icoweston:%{!?_without_icoweston:%define _without_icoweston 1}}
25 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
26 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
27
28 # TODO: take care of /lib vs /lib64...
29 %define systemddir /lib/systemd
30
31 #
32 # Abnormalize _with_icosyscon to _enable_icosyscon
33 #
34 # Since some people seem to have a hard time understanding that
35 #
36 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
37 #    undefined as opposed to defining it to 0
38 #
39 # 2) if you decide to do it the wrong way at least you should be consistent
40 #    about it and not randomly change between the conventions
41 #
42 # we need to roll this butt-ugly hack to make sure that we always go with
43 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
44 # on how _with_icosyscon happens to be set (or unset).
45 #
46
47 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
48 %if %{_with_icosyscon}
49 %define _enable_icosyscon 1
50 %else
51 %define _enable_icosyscon 0
52 %endif
53 %else
54 %define _enable_icosyscon 0
55 %endif
56
57 Summary: Murphy policy framework
58 Name: murphy
59 Version: 0.0.54
60 Release: 1
61 License: BSD-3-Clause
62 Group: System/Service
63 URL: http://01.org/murphy/
64 Source0: %{name}-%{version}.tar.gz
65 Source1: murphy.manifest
66 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
67 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
68 Requires: %{name}-core = %{version}
69 %endif
70
71 Requires(post): /bin/systemctl
72 Requires(post): libcap-tools
73 Requires(postun): /bin/systemctl
74
75 BuildRequires: flex
76 BuildRequires: bison
77 BuildRequires: pkgconfig(lua)
78 BuildRequires: pkgconfig(libsystemd-daemon)
79 BuildRequires: pkgconfig(libsystemd-journal)
80 BuildRequires: pkgconfig(libcap)
81 BuildRequires: pkgconfig(libtzplatform-config)
82
83 %if %{?_with_pulse:1}%{!?_with_pulse:0}
84 BuildRequires: pkgconfig(libpulse)
85 %endif
86 %if %{?_with_ecore:1}%{!?_with_ecore:0}
87 BuildRequires: pkgconfig(ecore)
88 BuildRequires: mesa-libEGL
89 BuildRequires: mesa-libGLESv2
90 %endif
91 %if %{?_with_glib:1}%{!?_with_glib:0}
92 BuildRequires: pkgconfig(glib-2.0)
93 %endif
94 %if %{?_with_qt:1}%{!?_with_qt:0}
95 BuildRequires: pkgconfig(QtCore)
96 %endif
97 %if %{?_with_dbus:1}%{!?_with_dbus:0}
98 BuildRequires: pkgconfig(dbus-1)
99 %endif
100 %if %{?_with_telephony:1}%{!?_with_telephony:0}
101 BuildRequires: pkgconfig(ofono)
102 %endif
103 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
104 BuildRequires: pkgconfig(audio-session-mgr)
105 BuildRequires: pkgconfig(aul)
106 %endif
107 %if %{?_with_websockets:1}%{!?_with_websockets:0}
108 BuildRequires: libwebsockets-devel
109 %endif
110 BuildRequires: pkgconfig(json)
111
112 %if %{?_with_smack:1}%{!?_with_smack:0}
113 BuildRequires: pkgconfig(libsmack)
114 %endif
115
116 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
117 #%if %{_with_icosyscon} # gbs can't, so don't bother...
118 BuildRequires: ico-uxf-weston-plugin-devel
119 BuildRequires: weston-ivi-shell-devel
120 BuildRequires: genivi-shell-devel
121 BuildRequires: pkgconfig(ail)
122 BuildRequires: pkgconfig(aul)
123 BuildRequires: libxml2-devel
124 #%endif
125 %endif
126
127 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
128 %package core
129 Summary: Murphy core runtime libraries
130 Group: System/Libraries
131
132 %package plugins-base
133 Summary: The basic set of Murphy plugins
134 Group: System/Service
135 Requires: %{name} = %{version}
136 Requires: %{name}-core = %{version}
137 %endif
138
139 %package devel
140 Summary: The header files and libraries needed for Murphy development
141 Group: System/Libraries
142 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
143 Requires: %{name}-core = %{version}
144 %else
145 Requires: %{name} = %{version}
146 %endif
147 Requires: libjson-devel
148
149 %package doc
150 Summary: Documentation for Murphy
151 Group: SDK/Documentation
152
153 %if %{?_with_pulse:1}%{!?_with_pulse:0}
154 %package pulse
155 Summary: Murphy PulseAudio mainloop integration
156 Group: System/Libraries
157 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
158 Requires: %{name}-core = %{version}
159 %else
160 Requires: %{name} = %{version}
161 %endif
162
163 %package pulse-devel
164 Summary: Murphy PulseAudio mainloop integration development files
165 Group: System/Libraries
166 Requires: %{name}-pulse = %{version}
167 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
168 Requires: %{name}-core = %{version}
169 %else
170 Requires: %{name} = %{version}
171 %endif
172 %endif
173
174 %if %{?_with_ecore:1}%{!?_with_ecore:0}
175 %package ecore
176 Summary: Murphy EFL/ecore mainloop integration
177 Group: System/Libraries
178 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
179 Requires: %{name}-core = %{version}
180 %else
181 Requires: %{name} = %{version}
182 %endif
183
184 %package ecore-devel
185 Summary: Murphy EFL/ecore mainloop integration development files
186 Group: System/Libraries
187 Requires: %{name}-ecore = %{version}
188 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
189 Requires: %{name}-core = %{version}
190 %else
191 Requires: %{name} = %{version}
192 %endif
193 %endif
194
195 %if %{?_with_glib:1}%{!?_with_glib:0}
196 %package glib
197 Summary: Murphy glib mainloop integration
198 Group: System/Libraries
199 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
200 Requires: %{name}-core = %{version}
201 %else
202 Requires: %{name} = %{version}
203 %endif
204
205 %package glib-devel
206 Summary: Murphy glib mainloop integration development files
207 Group: System/Libraries
208 Requires: %{name}-glib = %{version}
209 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
210 Requires: %{name}-core = %{version}
211 %else
212 Requires: %{name} = %{version}
213 %endif
214 %endif
215
216 %if %{?_with_qt:1}%{!?_with_qt:0}
217 %package qt
218 Summary: Murphy Qt mainloop integration
219 Group: System/Libraries
220 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
221 Requires: %{name}-core = %{version}
222 %else
223 Requires: %{name} = %{version}
224 %endif
225
226 %package qt-devel
227 Summary: Murphy Qt mainloop integration development files
228 Group: System/Libraries
229 Requires: %{name}-qt = %{version}
230 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
231 Requires: %{name}-core = %{version}
232 %else
233 Requires: %{name} = %{version}
234 %endif
235 %endif
236
237 %package tests
238 Summary: Various test binaries for Murphy
239 Group: System/Testing
240 Requires: %{name} = %{version}
241 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
242 Requires: %{name}-core = %{version}
243 %else
244 Requires: %{name} = %{version}
245 %endif
246
247 %package ivi-resource-manager
248 Summary: Murphy IVI resource manager plugin
249 Group: System/Service
250
251 %if %{_enable_icosyscon}
252 %package system-controller
253 Summary: Murphy IVI System Controller plugin
254 Group: System/Service
255 Requires: ico-uxf-homescreen
256 Conflicts: murphy-ivi-resource-manager
257 Provides: system-controller
258 Conflicts: ico-uxf-homescreen-system-controller
259 %endif
260
261 %description
262 This package contains the basic daemon.
263
264 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
265 %description core
266 This package contains the core runtime libraries.
267
268 %description plugins-base
269 This package contains a basic set of plugins.
270 %endif
271
272 %description devel
273 This package contains header files and libraries necessary for development.
274
275 %description doc
276 This package contains documentation.
277
278 %if %{?_with_pulse:1}%{!?_with_pulse:0}
279 %description pulse
280 This package contains the Murphy PulseAudio mainloop integration runtime files.
281
282 %description pulse-devel
283 This package contains the Murphy PulseAudio mainloop integration development
284 files.
285 %endif
286
287 %if %{?_with_ecore:1}%{!?_with_ecore:0}
288 %description ecore
289 This package contains the Murphy EFL/ecore mainloop integration runtime files.
290
291 %description ecore-devel
292 This package contains the Murphy EFL/ecore mainloop integration development
293 files.
294 %endif
295
296 %if %{?_with_glib:1}%{!?_with_glib:0}
297 %description glib
298 This package contains the Murphy glib mainloop integration runtime files.
299
300 %description glib-devel
301 This package contains the Murphy glib mainloop integration development
302 files.
303 %endif
304
305 %if %{?_with_qt:1}%{!?_with_qt:0}
306 %description qt
307 This package contains the Murphy Qt mainloop integration runtime files.
308
309 %description qt-devel
310 This package contains the Murphy Qt mainloop integration development
311 files.
312 %endif
313
314 %description tests
315 This package contains various test binaries for Murphy.
316
317 %description ivi-resource-manager
318 This package contains the Murphy IVI resource manager plugin.
319
320 %if %{_enable_icosyscon}
321 %description system-controller
322 This package contains the Murphy IVI resource manager plugin.
323 %endif
324
325 %prep
326 %setup -q
327
328 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
329 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
330
331 %build
332 %if %{?_with_debug:1}%{!?_with_debug:0}
333 export CFLAGS="-O0 -g3"
334 V="V=1"
335 %endif
336
337 CONFIG_OPTIONS=""
338 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
339
340 %if %{?_with_pulse:1}%{!?_with_pulse:0}
341 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
342 %else
343 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
344 %endif
345
346 %if %{?_with_ecore:1}%{!?_with_ecore:0}
347 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
348 %else
349 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
350 %endif
351
352 %if %{?_with_glib:1}%{!?_with_glib:0}
353 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
354 %else
355 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
356 %endif
357
358 %if %{?_with_qt:1}%{!?_with_qt:0}
359 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
360 %else
361 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
362 %endif
363
364 %if %{?_with_dbus:1}%{!?_with_dbus:0}
365 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
366 %else
367 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
368 %endif
369
370 %if %{?_with_telephony:1}%{!?_with_telephony:0}
371 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
372 %else
373 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
374 %endif
375
376 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
377 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
378 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
379 %else
380 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
381 %endif
382
383 %if %{?_with_websockets:1}%{!?_with_websockets:0}
384 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
385 %else
386 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
387 %endif
388
389 %if %{?_with_smack:1}%{!?_with_smack:0}
390 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
391 %else
392 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
393 %endif
394
395 %if %{_enable_icosyscon}
396 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
397 %else
398 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
399 %endif
400
401 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
402 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
403 %else
404 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
405 %endif
406
407 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
408 grep '^processor *:' | wc -l`"
409 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
410
411 ./bootstrap && \
412 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
413 make clean && \
414 make -j$(($NUM_CPUS + 1)) $V
415
416 %install
417 rm -rf $RPM_BUILD_ROOT
418 %make_install
419
420 # Make sure we have a plugin dir even if all the basic plugins
421 # are configured to be built in.
422 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
423
424 # Get rid of any *.la files installed by libtool.
425 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
426
427 # Clean up also the murphy DB installation.
428 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
429
430 # Generate list of linkedin plugins (depends on the configuration).
431 outdir="`pwd`"
432 pushd $RPM_BUILD_ROOT >& /dev/null && \
433 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
434 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
435 popd >& /dev/null
436 echo "Found the following linked-in plugin files:"
437 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
438
439 # Generate list of header files, filtering ones that go to subpackages.
440 outdir="`pwd`"
441 pushd $RPM_BUILD_ROOT >& /dev/null && \
442 find ./%{_includedir}/murphy | \
443 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
444 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
445 popd >& /dev/null
446
447 # Replace the default sample/test config files with the packaging ones.
448 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/murphy/*
449 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
450 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
451
452 # Copy plugin configuration files in place.
453 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
454 cp packaging.in/amb-config.lua \
455 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
456
457 # Copy tmpfiles.d config file in place
458 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
459 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
460
461 # Copy the systemd files in place.
462 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
463 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
464 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
465 %if %{_enable_icosyscon}
466 mkdir -p $RPM_BUILD_ROOT/usr/apps/org.tizen.ico.system-controller/res/config
467 cp packaging.in/ico-homescreen.service \
468     $RPM_BUILD_ROOT%{systemddir}/user
469 cp packaging.in/murphy-wait-for-launchpad-ready.path \
470     $RPM_BUILD_ROOT%{systemddir}/user
471 cp packaging.in/user.xml \
472     $RPM_BUILD_ROOT/usr/apps/org.tizen.ico.system-controller/res/config
473 %endif
474
475 %if %{?_with_dbus:1}%{!?_with_dbus:0}
476 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
477 sed "s/@TZ_SYS_USER_GROUP@/%{TZ_SYS_USER_GROUP}/g" packaging.in/org.Murphy.conf.in > packaging.in/org.Murphy.conf
478 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
479 %endif
480
481 # copy the manifest file
482 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
483 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
484 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
485 %if %{?_with_qt:1}%{!?_with_qt:0}
486 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
487 %endif
488 %if %{?_with_glib:1}%{!?_with_glib:0}
489 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
490 %endif
491 %if %{?_with_pulse:1}%{!?_with_pulse:0}
492 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
493 %endif
494 %if %{?_with_ecore:1}%{!?_with_ecore:0}
495 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
496 %endif
497 %if %{_enable_icosyscon}
498 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
499 %endif
500
501 %clean
502 rm -rf $RPM_BUILD_ROOT
503
504 %post
505 /bin/systemctl enable murphyd.service
506 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
507
508 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
509 %post core
510 %endif
511 ldconfig
512
513 %postun
514 if [ "$1" = "0" ]; then
515 /bin/systemctl disable murphyd.service
516 fi
517
518 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
519 %postun core
520 %endif
521 ldconfig
522
523 %if %{?_with_glib:1}%{!?_with_glib:0}
524 %post glib
525 ldconfig
526
527 %postun glib
528 ldconfig
529 %endif
530
531 %if %{?_with_pulse:1}%{!?_with_pulse:0}
532 %post pulse
533 ldconfig
534
535 %postun pulse
536 ldconfig
537 %endif
538
539 %if %{?_with_ecore:1}%{!?_with_ecore:0}
540 %post ecore
541 ldconfig
542
543 %postun ecore
544 ldconfig
545 %endif
546
547 %if %{?_with_qt:1}%{!?_with_qt:0}
548 %post qt
549 lfconfig
550
551 %postun qt
552 ldconfig
553 %endif
554
555 %if %{_enable_icosyscon}
556 %post system-controller
557 # prevent system controller from starting
558 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
559 # instead launch just ico-homescreen
560 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
561 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path \
562     %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
563
564 %postun system-controller
565 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
566 if [ -f %{systemddir}/user/ico-uxf-wait-launchpad-ready.path ]; then
567     ln -sf %{systemddir}/user/ico-uxf-wait-launchpad-ready.path \
568         %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
569 fi
570 %endif
571
572 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
573 %files -f filelist.plugins-base
574 %else
575 %files
576 %endif
577 %defattr(-,root,root,-)
578 %manifest %{_datadir}/murphy.manifest
579 %{_bindir}/murphyd
580 %config %{_sysconfdir}/murphy
581 %{systemddir}/system/murphyd.service
582 %{_tmpfilesdir}/murphyd.conf
583 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
584 %{_sbindir}/asm-bridge
585 %endif
586 %if %{?_with_dbus:1}%{!?_with_dbus:0}
587 %{_sysconfdir}/dbus-1/system.d
588 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
589 %endif
590 %if %{?_with_websockets:1}%{!?_with_websockets:0}
591 %{_datadir}/murphy
592 %endif
593
594 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
595 %files core
596 %defattr(-,root,root,-)
597 %endif
598 %{_libdir}/libmurphy-common.so.*
599 %{_libdir}/libmurphy-core.so.*
600 %{_libdir}/libmurphy-resolver.so.*
601 %{_libdir}/libmurphy-resource.so.*
602 %{_libdir}/libmurphy-resource-backend.so.*
603 %if %{?_with_lua:1}%{!?_with_lua:0}
604 %{_libdir}/libmurphy-lua-utils.so.*
605 %{_libdir}/libmurphy-lua-decision.so.*
606 %endif
607 %{_libdir}/libmurphy-domain-controller.so.*
608 %{_libdir}/murphy/*.so.*
609 %{_libdir}/libbreedline*.so.*
610 %if %{?_with_dbus:1}%{!?_with_dbus:0}
611 %{_libdir}/libmurphy-libdbus.so.*
612 %{_libdir}/libmurphy-dbus-libdbus.so.*
613 %endif
614
615 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
616 %files plugins-base -f filelist.plugins-base
617 %defattr(-,root,root,-)
618 %endif
619 %{_libdir}/murphy/plugins/plugin-domain-control.so
620 %{_libdir}/murphy/plugins/plugin-resource-asm.so
621 %{_libdir}/murphy/plugins/plugin-resource-native.so
622
623 %files devel -f filelist.devel-includes
624 %defattr(-,root,root,-)
625 # %{_includedir}/murphy/config.h
626 # %{_includedir}/murphy/common.h
627 # #%{_includedir}/murphy/core.h
628 # %{_includedir}/murphy/common
629 # %{_includedir}/murphy/core
630 # %{_includedir}/murphy/resolver
631 # %{_includedir}/murphy/resource
632 # # hmmm... should handle disabled plugins properly.
633 # %{_includedir}/murphy/domain-control
634 # %{_includedir}/murphy/plugins
635 %{_includedir}/murphy-db
636 %{_libdir}/libmurphy-common.so
637 %{_libdir}/libmurphy-core.so
638 %{_libdir}/libmurphy-resolver.so
639 %{_libdir}/libmurphy-resource.so
640 %{_libdir}/libmurphy-resource-backend.so
641 %if %{?_with_lua:1}%{!?_with_lua:0}
642 %{_libdir}/libmurphy-lua-utils.so
643 %{_libdir}/libmurphy-lua-decision.so
644 %endif
645 %{_libdir}/libmurphy-domain-controller.so
646 %{_libdir}/murphy/*.so
647 %{_libdir}/pkgconfig/murphy-common.pc
648 %{_libdir}/pkgconfig/murphy-core.pc
649 %{_libdir}/pkgconfig/murphy-resolver.pc
650 #%{_libdir}/pkgconfig/murphy-resource.pc
651 %if %{?_with_lua:1}%{!?_with_lua:0}
652 %{_libdir}/pkgconfig/murphy-lua-utils.pc
653 %{_libdir}/pkgconfig/murphy-lua-decision.pc
654 %endif
655 %{_libdir}/pkgconfig/murphy-domain-controller.pc
656 %{_libdir}/pkgconfig/murphy-db.pc
657 %{_libdir}/pkgconfig/murphy-resource.pc
658 %{_includedir}/breedline
659 %{_libdir}/libbreedline*.so
660 %{_libdir}/pkgconfig/breedline*.pc
661 %if %{?_with_dbus:1}%{!?_with_dbus:0}
662 #%{_includedir}/murphy/dbus
663 %{_libdir}/libmurphy-libdbus.so
664 %{_libdir}/libmurphy-dbus-libdbus.so
665 %{_libdir}/pkgconfig/murphy-libdbus.pc
666 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
667 %endif
668
669 %files doc
670 %defattr(-,root,root,-)
671 %doc %{_docdir}/../murphy/AUTHORS
672 %doc %{_docdir}/../murphy/CODING-STYLE
673 %doc %{_docdir}/../murphy/ChangeLog
674 %doc %{_docdir}/../murphy/NEWS
675 %doc %{_docdir}/../murphy/README
676 %license COPYING LICENSE-BSD
677
678 %if %{?_with_pulse:1}%{!?_with_pulse:0}
679 %files pulse
680 %defattr(-,root,root,-)
681 %{_libdir}/libmurphy-pulse.so.*
682 %manifest %{_datadir}/murphy-pulse.manifest
683
684 %files pulse-devel
685 %defattr(-,root,root,-)
686 %{_includedir}/murphy/common/pulse-glue.h
687 %{_libdir}/libmurphy-pulse.so
688 %{_libdir}/pkgconfig/murphy-pulse.pc
689 %endif
690
691 %if %{?_with_ecore:1}%{!?_with_ecore:0}
692 %files ecore
693 %defattr(-,root,root,-)
694 %{_libdir}/libmurphy-ecore.so.*
695 %manifest %{_datadir}/murphy-ecore.manifest
696
697 %files ecore-devel
698 %defattr(-,root,root,-)
699 %{_includedir}/murphy/common/ecore-glue.h
700 %{_libdir}/libmurphy-ecore.so
701 %{_libdir}/pkgconfig/murphy-ecore.pc
702 %endif
703
704 %if %{?_with_glib:1}%{!?_with_glib:0}
705 %files glib
706 %defattr(-,root,root,-)
707 %{_libdir}/libmurphy-glib.so.*
708 %manifest %{_datadir}/murphy-glib.manifest
709
710 %files glib-devel
711 %defattr(-,root,root,-)
712 %{_includedir}/murphy/common/glib-glue.h
713 %{_libdir}/libmurphy-glib.so
714 %{_libdir}/pkgconfig/murphy-glib.pc
715 %endif
716
717 %if %{?_with_qt:1}%{!?_with_qt:0}
718 %files qt
719 %defattr(-,root,root,-)
720 %{_libdir}/libmurphy-qt.so.*
721 %manifest %{_datadir}/murphy-qt.manifest
722
723 %files qt-devel
724 %defattr(-,root,root,-)
725 %{_includedir}/murphy/common/qt-glue.h
726 %{_libdir}/libmurphy-qt.so
727 %{_libdir}/pkgconfig/murphy-qt.pc
728 %endif
729
730 %files tests
731 %defattr(-,root,root,-)
732 %{_bindir}/resource-client
733 %{_bindir}/resource-api-test
734 %{_bindir}/resource-api-fuzz
735 %{_bindir}/test-domain-controller
736 %{_bindir}/murphy-console
737 %manifest %{_datadir}/murphy-tests.manifest
738
739 %files ivi-resource-manager
740 %defattr(-,root,root,-)
741 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
742 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
743
744 %if %{_enable_icosyscon}
745 %files system-controller
746 %defattr(-,root,root,-)
747 %{_libdir}/murphy/plugins/plugin-system-controller.so
748 %{systemddir}/user/ico-homescreen.service
749 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
750 %manifest %{_datadir}/murphy-system-controller.manifest
751 %{_prefix}/apps/org.tizen.ico.system-controller/res/config/user.xml
752 %endif
753
754 %changelog
755 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
756 - Initial build for 2.0alpha.