packaging: bumped version, updated changelog.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _with_icosyscon 1}}
22 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
23 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
24
25 # TODO: take care of /lib vs /lib64...
26 %define systemddir /lib/systemd
27
28 Summary: Murphy policy framework
29 Name: murphy
30 Version: 0.0.51
31 Release: 1
32 License: BSD-3-Clause
33 Group: System/Service
34 URL: http://01.org/murphy/
35 Source0: %{name}-%{version}.tar.gz
36 Source1: murphy.manifest
37 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
38 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
39 Requires: %{name}-core = %{version}
40 %endif
41
42 Requires(post): /bin/systemctl
43 Requires(postun): /bin/systemctl
44
45 BuildRequires: flex
46 BuildRequires: bison
47 BuildRequires: pkgconfig(lua)
48 BuildRequires: pkgconfig(libsystemd-daemon)
49 BuildRequires: pkgconfig(libsystemd-journal)
50
51 %if %{?_with_pulse:1}%{!?_with_pulse:0}
52 BuildRequires: pkgconfig(libpulse)
53 %endif
54 %if %{?_with_ecore:1}%{!?_with_ecore:0}
55 BuildRequires: pkgconfig(ecore)
56 BuildRequires: mesa-libEGL
57 BuildRequires: mesa-libGLESv2
58 %endif
59 %if %{?_with_glib:1}%{!?_with_glib:0}
60 BuildRequires: pkgconfig(glib-2.0)
61 %endif
62 %if %{?_with_qt:1}%{!?_with_qt:0}
63 BuildRequires: pkgconfig(QtCore)
64 %endif
65 %if %{?_with_dbus:1}%{!?_with_dbus:0}
66 BuildRequires: pkgconfig(dbus-1)
67 %endif
68 %if %{?_with_telephony:1}%{!?_with_telephony:0}
69 BuildRequires: pkgconfig(ofono)
70 %endif
71 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
72 BuildRequires: pkgconfig(audio-session-mgr)
73 BuildRequires: pkgconfig(aul)
74 %endif
75 %if %{?_with_websockets:1}%{!?_with_websockets:0}
76 BuildRequires: libwebsockets-devel
77 %endif
78 BuildRequires: pkgconfig(json)
79
80 %if %{?_with_smack:1}%{!?_with_smack:0}
81 BuildRequires: pkgconfig(libsmack)
82 %endif
83
84 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
85 BuildRequires: ico-uxf-weston-plugin-devel
86 BuildRequires: pkgconfig(ail)
87 BuildRequires: pkgconfig(aul)
88 BuildRequires: libxml2-devel
89 %endif
90
91 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
92 %package core
93 Summary: Murphy core runtime libraries
94 Group: System/Libraries
95
96 %package plugins-base
97 Summary: The basic set of Murphy plugins
98 Group: System/Service
99 Requires: %{name} = %{version}
100 Requires: %{name}-core = %{version}
101 %endif
102
103 %package devel
104 Summary: The header files and libraries needed for Murphy development
105 Group: System/Libraries
106 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
107 Requires: %{name}-core = %{version}
108 %else
109 Requires: %{name} = %{version}
110 %endif
111 Requires: libjson-devel
112
113 %package doc
114 Summary: Documentation for Murphy
115 Group: SDK/Documentation
116
117 %if %{?_with_pulse:1}%{!?_with_pulse:0}
118 %package pulse
119 Summary: Murphy PulseAudio mainloop integration
120 Group: System/Libraries
121 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
122 Requires: %{name}-core = %{version}
123 %else
124 Requires: %{name} = %{version}
125 %endif
126
127 %package pulse-devel
128 Summary: Murphy PulseAudio mainloop integration development files
129 Group: System/Libraries
130 Requires: %{name}-pulse = %{version}
131 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
132 Requires: %{name}-core = %{version}
133 %else
134 Requires: %{name} = %{version}
135 %endif
136 %endif
137
138 %if %{?_with_ecore:1}%{!?_with_ecore:0}
139 %package ecore
140 Summary: Murphy EFL/ecore mainloop integration
141 Group: System/Libraries
142 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
143 Requires: %{name}-core = %{version}
144 %else
145 Requires: %{name} = %{version}
146 %endif
147
148 %package ecore-devel
149 Summary: Murphy EFL/ecore mainloop integration development files
150 Group: System/Libraries
151 Requires: %{name}-ecore = %{version}
152 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
153 Requires: %{name}-core = %{version}
154 %else
155 Requires: %{name} = %{version}
156 %endif
157 %endif
158
159 %if %{?_with_glib:1}%{!?_with_glib:0}
160 %package glib
161 Summary: Murphy glib mainloop integration
162 Group: System/Libraries
163 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
164 Requires: %{name}-core = %{version}
165 %else
166 Requires: %{name} = %{version}
167 %endif
168
169 %package glib-devel
170 Summary: Murphy glib mainloop integration development files
171 Group: System/Libraries
172 Requires: %{name}-glib = %{version}
173 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
174 Requires: %{name}-core = %{version}
175 %else
176 Requires: %{name} = %{version}
177 %endif
178 %endif
179
180 %if %{?_with_qt:1}%{!?_with_qt:0}
181 %package qt
182 Summary: Murphy Qt mainloop integration
183 Group: System/Libraries
184 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
185 Requires: %{name}-core = %{version}
186 %else
187 Requires: %{name} = %{version}
188 %endif
189
190 %package qt-devel
191 Summary: Murphy Qt mainloop integration development files
192 Group: System/Libraries
193 Requires: %{name}-qt = %{version}
194 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
195 Requires: %{name}-core = %{version}
196 %else
197 Requires: %{name} = %{version}
198 %endif
199 %endif
200
201 %package tests
202 Summary: Various test binaries for Murphy
203 Group: System/Testing
204 Requires: %{name} = %{version}
205 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
206 Requires: %{name}-core = %{version}
207 %else
208 Requires: %{name} = %{version}
209 %endif
210
211 %package ivi-resource-manager
212 Summary: Murphy IVI resource manager plugin
213 Group: System/Service
214
215 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
216 %package system-controller
217 Summary: Murphy IVI System Controller plugin
218 Group: System/Service
219 Requires: ico-uxf-homescreen
220 Conflicts: murphy-ivi-resource-manager
221 %endif
222
223 %description
224 This package contains the basic daemon.
225
226 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
227 %description core
228 This package contains the core runtime libraries.
229
230 %description plugins-base
231 This package contains a basic set of plugins.
232 %endif
233
234 %description devel
235 This package contains header files and libraries necessary for development.
236
237 %description doc
238 This package contains documentation.
239
240 %if %{?_with_pulse:1}%{!?_with_pulse:0}
241 %description pulse
242 This package contains the Murphy PulseAudio mainloop integration runtime files.
243
244 %description pulse-devel
245 This package contains the Murphy PulseAudio mainloop integration development
246 files.
247 %endif
248
249 %if %{?_with_ecore:1}%{!?_with_ecore:0}
250 %description ecore
251 This package contains the Murphy EFL/ecore mainloop integration runtime files.
252
253 %description ecore-devel
254 This package contains the Murphy EFL/ecore mainloop integration development
255 files.
256 %endif
257
258 %if %{?_with_glib:1}%{!?_with_glib:0}
259 %description glib
260 This package contains the Murphy glib mainloop integration runtime files.
261
262 %description glib-devel
263 This package contains the Murphy glib mainloop integration development
264 files.
265 %endif
266
267 %if %{?_with_qt:1}%{!?_with_qt:0}
268 %description qt
269 This package contains the Murphy Qt mainloop integration runtime files.
270
271 %description qt-devel
272 This package contains the Murphy Qt mainloop integration development
273 files.
274 %endif
275
276 %description tests
277 This package contains various test binaries for Murphy.
278
279 %description ivi-resource-manager
280 This package contains the Murphy IVI resource manager plugin.
281
282 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
283 %description system-controller
284 This package contains the Murphy IVI resource manager plugin.
285 %endif
286
287 %prep
288 %setup -q
289
290 %build
291 %if %{?_with_debug:1}%{!?_with_debug:0}
292 export CFLAGS="-O0 -g3"
293 V="V=1"
294 %endif
295
296 CONFIG_OPTIONS=""
297 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
298
299 %if %{?_with_pulse:1}%{!?_with_pulse:0}
300 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
301 %else
302 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
303 %endif
304
305 %if %{?_with_ecore:1}%{!?_with_ecore:0}
306 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
307 %else
308 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
309 %endif
310
311 %if %{?_with_glib:1}%{!?_with_glib:0}
312 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
313 %else
314 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
315 %endif
316
317 %if %{?_with_qt:1}%{!?_with_qt:0}
318 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
319 %else
320 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
321 %endif
322
323 %if %{?_with_dbus:1}%{!?_with_dbus:0}
324 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
325 %else
326 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
327 %endif
328
329 %if %{?_with_telephony:1}%{!?_with_telephony:0}
330 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
331 %else
332 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
333 %endif
334
335 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
336 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
337 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
338 %else
339 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
340 %endif
341
342 %if %{?_with_websockets:1}%{!?_with_websockets:0}
343 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
344 %else
345 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
346 %endif
347
348 %if %{?_with_smack:1}%{!?_with_smack:0}
349 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
350 %else
351 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
352 %endif
353
354 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
355 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
356 %else
357 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
358 %endif
359
360 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
361 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
362 %else
363 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
364 %endif
365
366 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
367 grep '^processor *:' | wc -l`"
368 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
369
370 ./bootstrap && \
371 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
372 make clean && \
373 make -j$(($NUM_CPUS + 1)) $V
374
375 %install
376 rm -rf $RPM_BUILD_ROOT
377 %make_install
378
379 # Make sure we have a plugin dir even if all the basic plugins
380 # are configured to be built in.
381 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
382
383 # Get rid of any *.la files installed by libtool.
384 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
385
386 # Clean up also the murphy DB installation.
387 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
388
389 # Generate list of linkedin plugins (depends on the configuration).
390 outdir="`pwd`"
391 pushd $RPM_BUILD_ROOT >& /dev/null && \
392 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
393 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
394 popd >& /dev/null
395 echo "Found the following linked-in plugin files:"
396 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
397
398 # Generate list of header files, filtering ones that go to subpackages.
399 outdir="`pwd`"
400 pushd $RPM_BUILD_ROOT >& /dev/null && \
401 find ./%{_includedir}/murphy | \
402 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
403 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
404 popd >& /dev/null
405
406 # Replace the default sample/test config files with the packaging ones.
407 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/murphy/*
408 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
409 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
410
411 # Copy plugin configuration files in place.
412 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
413 cp packaging.in/amb-config.lua \
414 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
415
416 # Copy tmpfiles.d config file in place
417 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
418 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
419
420 # Copy the systemd files in place.
421 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
422 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
423 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
424 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
425 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
426 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
427 %endif
428
429 %if %{?_with_dbus:1}%{!?_with_dbus:0}
430 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
431 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
432 %endif
433
434 # copy the manifest file
435 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
436 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
437 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
438 %if %{?_with_qt:1}%{!?_with_qt:0}
439 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
440 %endif
441 %if %{?_with_glib:1}%{!?_with_glib:0}
442 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
443 %endif
444 %if %{?_with_pulse:1}%{!?_with_pulse:0}
445 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
446 %endif
447 %if %{?_with_ecore:1}%{!?_with_ecore:0}
448 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
449 %endif
450 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
451 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
452 %endif
453
454 %clean
455 rm -rf $RPM_BUILD_ROOT
456
457 %post
458 /bin/systemctl enable murphyd.service
459
460 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
461 %post core
462 %endif
463 ldconfig
464
465 %postun
466 if [ "$1" = "0" ]; then
467 /bin/systemctl disable murphyd.service
468 fi
469
470 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
471 %postun core
472 %endif
473 ldconfig
474
475 %if %{?_with_glib:1}%{!?_with_glib:0}
476 %post glib
477 ldconfig
478
479 %postun glib
480 ldconfig
481 %endif
482
483 %if %{?_with_pulse:1}%{!?_with_pulse:0}
484 %post pulse
485 ldconfig
486
487 %postun pulse
488 ldconfig
489 %endif
490
491 %if %{?_with_ecore:1}%{!?_with_ecore:0}
492 %post ecore
493 ldconfig
494
495 %postun ecore
496 ldconfig
497 %endif
498
499 %if %{?_with_qt:1}%{!?_with_qt:0}
500 %post qt
501 lfconfig
502
503 %postun qt
504 ldconfig
505 %endif
506
507 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
508 %post system-controller
509 # prevent system controller from starting
510 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
511 # instead launch just ico-homescreen
512 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
513 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path \
514     %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
515
516 %postun system-controller
517 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
518 if [ -f %{systemddir}/user/ico-uxf-wait-launchpad-ready.path ]; then
519     ln -sf %{systemddir}/user/ico-uxf-wait-launchpad-ready.path \
520         %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
521 fi
522 %endif
523
524 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
525 %files -f filelist.plugins-base
526 %else
527 %files
528 %endif
529 %defattr(-,root,root,-)
530 %manifest %{_datadir}/murphy.manifest
531 %{_bindir}/murphyd
532 %config %{_sysconfdir}/murphy
533 %{systemddir}/system/murphyd.service
534 %{_tmpfilesdir}/murphyd.conf
535 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
536 %{_sbindir}/asm-bridge
537 %endif
538 %if %{?_with_dbus:1}%{!?_with_dbus:0}
539 %{_sysconfdir}/dbus-1/system.d
540 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
541 %endif
542 %if %{?_with_websockets:1}%{!?_with_websockets:0}
543 %{_datadir}/murphy
544 %endif
545
546 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
547 %files core
548 %defattr(-,root,root,-)
549 %endif
550 %{_libdir}/libmurphy-common.so.*
551 %{_libdir}/libmurphy-core.so.*
552 %{_libdir}/libmurphy-resolver.so.*
553 %{_libdir}/libmurphy-resource.so.*
554 %{_libdir}/libmurphy-resource-backend.so.*
555 %if %{?_with_lua:1}%{!?_with_lua:0}
556 %{_libdir}/libmurphy-lua-utils.so.*
557 %{_libdir}/libmurphy-lua-decision.so.*
558 %endif
559 %{_libdir}/libmurphy-domain-controller.so.*
560 %{_libdir}/murphy/*.so.*
561 %{_libdir}/libbreedline*.so.*
562 %if %{?_with_dbus:1}%{!?_with_dbus:0}
563 %{_libdir}/libmurphy-libdbus.so.*
564 %{_libdir}/libmurphy-dbus-libdbus.so.*
565 %endif
566
567 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
568 %files plugins-base -f filelist.plugins-base
569 %defattr(-,root,root,-)
570 %endif
571 %{_libdir}/murphy/plugins/plugin-domain-control.so
572 %{_libdir}/murphy/plugins/plugin-resource-asm.so
573 %{_libdir}/murphy/plugins/plugin-resource-native.so
574
575 %files devel -f filelist.devel-includes
576 %defattr(-,root,root,-)
577 # %{_includedir}/murphy/config.h
578 # %{_includedir}/murphy/common.h
579 # #%{_includedir}/murphy/core.h
580 # %{_includedir}/murphy/common
581 # %{_includedir}/murphy/core
582 # %{_includedir}/murphy/resolver
583 # %{_includedir}/murphy/resource
584 # # hmmm... should handle disabled plugins properly.
585 # %{_includedir}/murphy/domain-control
586 # %{_includedir}/murphy/plugins
587 %{_includedir}/murphy-db
588 %{_libdir}/libmurphy-common.so
589 %{_libdir}/libmurphy-core.so
590 %{_libdir}/libmurphy-resolver.so
591 %{_libdir}/libmurphy-resource.so
592 %{_libdir}/libmurphy-resource-backend.so
593 %if %{?_with_lua:1}%{!?_with_lua:0}
594 %{_libdir}/libmurphy-lua-utils.so
595 %{_libdir}/libmurphy-lua-decision.so
596 %endif
597 %{_libdir}/libmurphy-domain-controller.so
598 %{_libdir}/murphy/*.so
599 %{_libdir}/pkgconfig/murphy-common.pc
600 %{_libdir}/pkgconfig/murphy-core.pc
601 %{_libdir}/pkgconfig/murphy-resolver.pc
602 #%{_libdir}/pkgconfig/murphy-resource.pc
603 %if %{?_with_lua:1}%{!?_with_lua:0}
604 %{_libdir}/pkgconfig/murphy-lua-utils.pc
605 %{_libdir}/pkgconfig/murphy-lua-decision.pc
606 %endif
607 %{_libdir}/pkgconfig/murphy-domain-controller.pc
608 %{_libdir}/pkgconfig/murphy-db.pc
609 %{_libdir}/pkgconfig/murphy-resource.pc
610 %{_includedir}/breedline
611 %{_libdir}/libbreedline*.so
612 %{_libdir}/pkgconfig/breedline*.pc
613 %if %{?_with_dbus:1}%{!?_with_dbus:0}
614 #%{_includedir}/murphy/dbus
615 %{_libdir}/libmurphy-libdbus.so
616 %{_libdir}/libmurphy-dbus-libdbus.so
617 %{_libdir}/pkgconfig/murphy-libdbus.pc
618 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
619 %endif
620
621 %files doc
622 %defattr(-,root,root,-)
623 %doc %{_docdir}/../murphy/AUTHORS
624 %doc %{_docdir}/../murphy/CODING-STYLE
625 %license %{_docdir}/../murphy/COPYING
626 %doc %{_docdir}/../murphy/ChangeLog
627 %doc %{_docdir}/../murphy/INSTALL
628 %doc %{_docdir}/../murphy/NEWS
629 %doc %{_docdir}/../murphy/README
630
631 %if %{?_with_pulse:1}%{!?_with_pulse:0}
632 %files pulse
633 %defattr(-,root,root,-)
634 %{_libdir}/libmurphy-pulse.so.*
635 %manifest %{_datadir}/murphy-pulse.manifest
636
637 %files pulse-devel
638 %defattr(-,root,root,-)
639 %{_includedir}/murphy/common/pulse-glue.h
640 %{_libdir}/libmurphy-pulse.so
641 %{_libdir}/pkgconfig/murphy-pulse.pc
642 %endif
643
644 %if %{?_with_ecore:1}%{!?_with_ecore:0}
645 %files ecore
646 %defattr(-,root,root,-)
647 %{_libdir}/libmurphy-ecore.so.*
648 %manifest %{_datadir}/murphy-ecore.manifest
649
650 %files ecore-devel
651 %defattr(-,root,root,-)
652 %{_includedir}/murphy/common/ecore-glue.h
653 %{_libdir}/libmurphy-ecore.so
654 %{_libdir}/pkgconfig/murphy-ecore.pc
655 %endif
656
657 %if %{?_with_glib:1}%{!?_with_glib:0}
658 %files glib
659 %defattr(-,root,root,-)
660 %{_libdir}/libmurphy-glib.so.*
661 %manifest %{_datadir}/murphy-glib.manifest
662
663 %files glib-devel
664 %defattr(-,root,root,-)
665 %{_includedir}/murphy/common/glib-glue.h
666 %{_libdir}/libmurphy-glib.so
667 %{_libdir}/pkgconfig/murphy-glib.pc
668 %endif
669
670 %if %{?_with_qt:1}%{!?_with_qt:0}
671 %files qt
672 %defattr(-,root,root,-)
673 %{_libdir}/libmurphy-qt.so.*
674 %manifest %{_datadir}/murphy-qt.manifest
675
676 %files qt-devel
677 %defattr(-,root,root,-)
678 %{_includedir}/murphy/common/qt-glue.h
679 %{_libdir}/libmurphy-qt.so
680 %{_libdir}/pkgconfig/murphy-qt.pc
681 %endif
682
683 %files tests
684 %defattr(-,root,root,-)
685 %{_bindir}/resource-client
686 %{_bindir}/resource-api-test
687 %{_bindir}/resource-api-fuzz
688 %{_bindir}/test-domain-controller
689 %{_bindir}/murphy-console
690 %manifest %{_datadir}/murphy-tests.manifest
691
692 %files ivi-resource-manager
693 %defattr(-,root,root,-)
694 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
695 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
696
697 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
698 %files system-controller
699 %defattr(-,root,root,-)
700 %{_libdir}/murphy/plugins/plugin-system-controller.so
701 %{systemddir}/user/ico-homescreen.service
702 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
703 %manifest %{_datadir}/murphy-system-controller.manifest
704 %endif
705
706 %changelog
707 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
708 - Initial build for 2.0alpha.