packaging: bumped version, updated changelog.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %define _with_icosyscon 1
11
12 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
13 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
14 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
15 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
16 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
17 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
18 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
19 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
20 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
21 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
22 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
23 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
24 %{!?_with_icoweston:%{!?_without_icoweston:%define _without_icoweston 1}}
25 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
26 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
27
28 # TODO: take care of /lib vs /lib64...
29 %define systemddir /lib/systemd
30
31 #
32 # Abnormalize _with_icosyscon to _enable_icosyscon
33 #
34 # Since some people seem to have a hard time understanding that
35 #
36 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
37 #    undefined as opposed to defining it to 0
38 #
39 # 2) if you decide to do it the wrong way at least you should be consistent
40 #    about it and not randomly change between the conventions
41 #
42 # we need to roll this butt-ugly hack to make sure that we always go with
43 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
44 # on how _with_icosyscon happens to be set (or unset).
45 #
46
47 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
48 %if %{_with_icosyscon}
49 %define _enable_icosyscon 1
50 %else
51 %define _enable_icosyscon 0
52 %endif
53 %else
54 %define _enable_icosyscon 0
55 %endif
56
57 Summary: Murphy policy framework
58 Name: murphy
59 Version: 0.0.55
60 Release: 1
61 License: BSD-3-Clause
62 Group: System/Service
63 URL: http://01.org/murphy/
64 Source0: %{name}-%{version}.tar.gz
65 Source1: murphy.manifest
66 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
67 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
68 Requires: %{name}-core = %{version}
69 %endif
70
71 Requires(post): /bin/systemctl
72 Requires(post): libcap-tools
73 Requires(postun): /bin/systemctl
74
75 BuildRequires: flex
76 BuildRequires: bison
77 BuildRequires: pkgconfig(lua)
78 BuildRequires: pkgconfig(libsystemd-daemon)
79 BuildRequires: pkgconfig(libsystemd-journal)
80 BuildRequires: pkgconfig(libcap)
81 BuildRequires: pkgconfig(libtzplatform-config)
82
83 %if %{?_with_pulse:1}%{!?_with_pulse:0}
84 BuildRequires: pkgconfig(libpulse)
85 %endif
86 %if %{?_with_ecore:1}%{!?_with_ecore:0}
87 BuildRequires: pkgconfig(ecore)
88 BuildRequires: mesa-libEGL
89 BuildRequires: mesa-libGLESv2
90 %endif
91 %if %{?_with_glib:1}%{!?_with_glib:0}
92 BuildRequires: pkgconfig(glib-2.0)
93 %endif
94 %if %{?_with_qt:1}%{!?_with_qt:0}
95 BuildRequires: pkgconfig(QtCore)
96 %endif
97 %if %{?_with_dbus:1}%{!?_with_dbus:0}
98 BuildRequires: pkgconfig(dbus-1)
99 %endif
100 %if %{?_with_telephony:1}%{!?_with_telephony:0}
101 BuildRequires: pkgconfig(ofono)
102 %endif
103 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
104 BuildRequires: pkgconfig(audio-session-mgr)
105 BuildRequires: pkgconfig(aul)
106 %endif
107 %if %{?_with_websockets:1}%{!?_with_websockets:0}
108 BuildRequires: libwebsockets-devel
109 %endif
110 BuildRequires: pkgconfig(json)
111
112 %if %{?_with_smack:1}%{!?_with_smack:0}
113 BuildRequires: pkgconfig(libsmack)
114 %endif
115
116 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
117 #%if %{_with_icosyscon} # gbs can't, so don't bother...
118 BuildRequires: ico-uxf-weston-plugin-devel
119 BuildRequires: weston-ivi-shell-devel
120 BuildRequires: genivi-shell-devel
121 BuildRequires: pkgconfig(ail)
122 BuildRequires: pkgconfig(aul)
123 BuildRequires: libxml2-devel
124 #%endif
125 %endif
126
127 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
128 %package core
129 Summary: Murphy core runtime libraries
130 Group: System/Libraries
131
132 %package plugins-base
133 Summary: The basic set of Murphy plugins
134 Group: System/Service
135 Requires: %{name} = %{version}
136 Requires: %{name}-core = %{version}
137 %endif
138
139 %package devel
140 Summary: The header files and libraries needed for Murphy development
141 Group: System/Libraries
142 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
143 Requires: %{name}-core = %{version}
144 %else
145 Requires: %{name} = %{version}
146 %endif
147 Requires: libjson-devel
148
149 %package doc
150 Summary: Documentation for Murphy
151 Group: SDK/Documentation
152
153 %if %{?_with_pulse:1}%{!?_with_pulse:0}
154 %package pulse
155 Summary: Murphy PulseAudio mainloop integration
156 Group: System/Libraries
157 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
158 Requires: %{name}-core = %{version}
159 %else
160 Requires: %{name} = %{version}
161 %endif
162
163 %package pulse-devel
164 Summary: Murphy PulseAudio mainloop integration development files
165 Group: System/Libraries
166 Requires: %{name}-pulse = %{version}
167 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
168 Requires: %{name}-core = %{version}
169 %else
170 Requires: %{name} = %{version}
171 %endif
172 %endif
173
174 %if %{?_with_ecore:1}%{!?_with_ecore:0}
175 %package ecore
176 Summary: Murphy EFL/ecore mainloop integration
177 Group: System/Libraries
178 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
179 Requires: %{name}-core = %{version}
180 %else
181 Requires: %{name} = %{version}
182 %endif
183
184 %package ecore-devel
185 Summary: Murphy EFL/ecore mainloop integration development files
186 Group: System/Libraries
187 Requires: %{name}-ecore = %{version}
188 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
189 Requires: %{name}-core = %{version}
190 %else
191 Requires: %{name} = %{version}
192 %endif
193 %endif
194
195 %if %{?_with_glib:1}%{!?_with_glib:0}
196 %package glib
197 Summary: Murphy glib mainloop integration
198 Group: System/Libraries
199 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
200 Requires: %{name}-core = %{version}
201 %else
202 Requires: %{name} = %{version}
203 %endif
204
205 %package glib-devel
206 Summary: Murphy glib mainloop integration development files
207 Group: System/Libraries
208 Requires: %{name}-glib = %{version}
209 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
210 Requires: %{name}-core = %{version}
211 %else
212 Requires: %{name} = %{version}
213 %endif
214 %endif
215
216 %if %{?_with_qt:1}%{!?_with_qt:0}
217 %package qt
218 Summary: Murphy Qt mainloop integration
219 Group: System/Libraries
220 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
221 Requires: %{name}-core = %{version}
222 %else
223 Requires: %{name} = %{version}
224 %endif
225
226 %package qt-devel
227 Summary: Murphy Qt mainloop integration development files
228 Group: System/Libraries
229 Requires: %{name}-qt = %{version}
230 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
231 Requires: %{name}-core = %{version}
232 %else
233 Requires: %{name} = %{version}
234 %endif
235 %endif
236
237 %package gam
238 Summary: Murphy support for Genivi Audio Manager
239 Group: System/Libraries
240 Requires: %{name} = %{version}
241
242 %package gam-devel
243 Summary: Murphy support for Genivi Audio Manager development files
244 Group: System/Libraries
245 Requires: %{name}-gam = %{version}
246
247 %package tests
248 Summary: Various test binaries for Murphy
249 Group: System/Testing
250 Requires: %{name} = %{version}
251 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
252 Requires: %{name}-core = %{version}
253 %else
254 Requires: %{name} = %{version}
255 %endif
256
257 %package ivi-resource-manager
258 Summary: Murphy IVI resource manager plugin
259 Group: System/Service
260
261 %if %{_enable_icosyscon}
262 %package system-controller
263 Summary: Murphy IVI System Controller plugin
264 Group: System/Service
265 Requires: ico-uxf-homescreen
266 Conflicts: murphy-ivi-resource-manager
267 Provides: system-controller
268 Conflicts: ico-uxf-homescreen-system-controller
269 %endif
270
271 %description
272 This package contains the basic daemon.
273
274 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
275 %description core
276 This package contains the core runtime libraries.
277
278 %description plugins-base
279 This package contains a basic set of plugins.
280 %endif
281
282 %description devel
283 This package contains header files and libraries necessary for development.
284
285 %description doc
286 This package contains documentation.
287
288 %if %{?_with_pulse:1}%{!?_with_pulse:0}
289 %description pulse
290 This package contains the Murphy PulseAudio mainloop integration runtime files.
291
292 %description pulse-devel
293 This package contains the Murphy PulseAudio mainloop integration development
294 files.
295 %endif
296
297 %if %{?_with_ecore:1}%{!?_with_ecore:0}
298 %description ecore
299 This package contains the Murphy EFL/ecore mainloop integration runtime files.
300
301 %description ecore-devel
302 This package contains the Murphy EFL/ecore mainloop integration development
303 files.
304 %endif
305
306 %if %{?_with_glib:1}%{!?_with_glib:0}
307 %description glib
308 This package contains the Murphy glib mainloop integration runtime files.
309
310 %description glib-devel
311 This package contains the Murphy glib mainloop integration development
312 files.
313 %endif
314
315 %if %{?_with_qt:1}%{!?_with_qt:0}
316 %description qt
317 This package contains the Murphy Qt mainloop integration runtime files.
318
319 %description qt-devel
320 This package contains the Murphy Qt mainloop integration development
321 files.
322 %endif
323
324 %description tests
325 This package contains various test binaries for Murphy.
326
327 %description ivi-resource-manager
328 This package contains the Murphy IVI resource manager plugin.
329
330 %if %{_enable_icosyscon}
331 %description system-controller
332 This package contains the Murphy IVI resource manager plugin.
333 %endif
334
335 %description gam
336 This package contains Murphy GAM plugins.
337
338 %description gam-devel
339 This package contains development files for Murphy GAM plugins.
340
341 %prep
342 %setup -q
343
344 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
345 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
346
347 %build
348 %if %{?_with_debug:1}%{!?_with_debug:0}
349 export CFLAGS="-O0 -g3"
350 V="V=1"
351 %endif
352
353 CONFIG_OPTIONS=""
354 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
355
356 %if %{?_with_pulse:1}%{!?_with_pulse:0}
357 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
358 %else
359 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
360 %endif
361
362 %if %{?_with_ecore:1}%{!?_with_ecore:0}
363 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
364 %else
365 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
366 %endif
367
368 %if %{?_with_glib:1}%{!?_with_glib:0}
369 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
370 %else
371 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
372 %endif
373
374 %if %{?_with_qt:1}%{!?_with_qt:0}
375 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
376 %else
377 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
378 %endif
379
380 %if %{?_with_dbus:1}%{!?_with_dbus:0}
381 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
382 %else
383 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
384 %endif
385
386 %if %{?_with_telephony:1}%{!?_with_telephony:0}
387 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
388 %else
389 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
390 %endif
391
392 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
393 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
394 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
395 %else
396 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
397 %endif
398
399 %if %{?_with_websockets:1}%{!?_with_websockets:0}
400 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
401 %else
402 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
403 %endif
404
405 %if %{?_with_smack:1}%{!?_with_smack:0}
406 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
407 %else
408 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
409 %endif
410
411 %if %{_enable_icosyscon}
412 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
413 %else
414 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
415 %endif
416
417 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
418 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
419 %else
420 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
421 %endif
422
423 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
424 grep '^processor *:' | wc -l`"
425 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
426
427 ./bootstrap && \
428 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
429 make clean && \
430 make -j$(($NUM_CPUS + 1)) $V
431
432 %install
433 rm -rf $RPM_BUILD_ROOT
434 %make_install
435
436 # Make sure we have a plugin dir even if all the basic plugins
437 # are configured to be built in.
438 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
439
440 # Get rid of any *.la files installed by libtool.
441 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
442
443 # Clean up also the murphy DB installation.
444 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
445
446 # Generate list of linkedin plugins (depends on the configuration).
447 outdir="`pwd`"
448 pushd $RPM_BUILD_ROOT >& /dev/null && \
449 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
450 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
451 popd >& /dev/null
452 echo "Found the following linked-in plugin files:"
453 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
454
455 # Generate list of header files, filtering ones that go to subpackages.
456 outdir="`pwd`"
457 pushd $RPM_BUILD_ROOT >& /dev/null && \
458 find ./%{_includedir}/murphy | \
459 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
460 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
461 popd >& /dev/null
462
463 # Replace the default sample/test config files with the packaging ones.
464 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/murphy/*
465 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
466 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
467
468 # Copy plugin configuration files in place.
469 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
470 cp packaging.in/amb-config.lua \
471 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
472
473 # Copy tmpfiles.d config file in place
474 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
475 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
476
477 # Copy the systemd files in place.
478 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
479 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
480 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
481 %if %{_enable_icosyscon}
482 mkdir -p $RPM_BUILD_ROOT/usr/apps/org.tizen.ico.system-controller/res/config
483 cp packaging.in/ico-homescreen.service \
484     $RPM_BUILD_ROOT%{systemddir}/user
485 cp packaging.in/murphy-wait-for-launchpad-ready.path \
486     $RPM_BUILD_ROOT%{systemddir}/user
487 cp packaging.in/user.xml \
488     $RPM_BUILD_ROOT/usr/apps/org.tizen.ico.system-controller/res/config
489 %endif
490
491 %if %{?_with_dbus:1}%{!?_with_dbus:0}
492 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
493 sed "s/@TZ_SYS_USER_GROUP@/%{TZ_SYS_USER_GROUP}/g" packaging.in/org.Murphy.conf.in > packaging.in/org.Murphy.conf
494 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
495 %endif
496
497 # copy the manifest file
498 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
499 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
500 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
501 %if %{?_with_qt:1}%{!?_with_qt:0}
502 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
503 %endif
504 %if %{?_with_glib:1}%{!?_with_glib:0}
505 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
506 %endif
507 %if %{?_with_pulse:1}%{!?_with_pulse:0}
508 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
509 %endif
510 %if %{?_with_ecore:1}%{!?_with_ecore:0}
511 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
512 %endif
513 %if %{_enable_icosyscon}
514 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
515 %endif
516
517 # copy (experimental) GAM resource backend configuration files
518 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/gam
519 cp packaging.in/gam-*.names packaging.in/gam-*.tree \
520     $RPM_BUILD_ROOT%{_sysconfdir}/murphy/gam
521
522 %clean
523 rm -rf $RPM_BUILD_ROOT
524
525 %post
526 /bin/systemctl enable murphyd.service
527 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
528
529 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
530 %post core
531 %endif
532 ldconfig
533
534 %postun
535 if [ "$1" = "0" ]; then
536 /bin/systemctl disable murphyd.service
537 fi
538
539 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
540 %postun core
541 %endif
542 ldconfig
543
544 %if %{?_with_glib:1}%{!?_with_glib:0}
545 %post glib
546 ldconfig
547
548 %postun glib
549 ldconfig
550 %endif
551
552 %if %{?_with_pulse:1}%{!?_with_pulse:0}
553 %post pulse
554 ldconfig
555
556 %postun pulse
557 ldconfig
558 %endif
559
560 %if %{?_with_ecore:1}%{!?_with_ecore:0}
561 %post ecore
562 ldconfig
563
564 %postun ecore
565 ldconfig
566 %endif
567
568 %if %{?_with_qt:1}%{!?_with_qt:0}
569 %post qt
570 lfconfig
571
572 %postun qt
573 ldconfig
574 %endif
575
576 %if %{_enable_icosyscon}
577 %post system-controller
578 # prevent system controller from starting
579 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
580 # instead launch just ico-homescreen
581 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
582 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path \
583     %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
584
585 %postun system-controller
586 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
587 if [ -f %{systemddir}/user/ico-uxf-wait-launchpad-ready.path ]; then
588     ln -sf %{systemddir}/user/ico-uxf-wait-launchpad-ready.path \
589         %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
590 fi
591 %endif
592
593 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
594 %files -f filelist.plugins-base
595 %else
596 %files
597 %endif
598 %defattr(-,root,root,-)
599 %manifest %{_datadir}/murphy.manifest
600 %{_bindir}/murphyd
601 %config %{_sysconfdir}/murphy
602 %{systemddir}/system/murphyd.service
603 %{_tmpfilesdir}/murphyd.conf
604 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
605 %{_sbindir}/asm-bridge
606 %endif
607 %if %{?_with_dbus:1}%{!?_with_dbus:0}
608 %{_sysconfdir}/dbus-1/system.d
609 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
610 %endif
611 %if %{?_with_websockets:1}%{!?_with_websockets:0}
612 %{_datadir}/murphy
613 %endif
614
615 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
616 %files core
617 %defattr(-,root,root,-)
618 %endif
619 %{_libdir}/libmurphy-common.so.*
620 %{_libdir}/libmurphy-core.so.*
621 %{_libdir}/libmurphy-resolver.so.*
622 %{_libdir}/libmurphy-resource.so.*
623 %{_libdir}/libmurphy-resource-backend.so.*
624 %if %{?_with_lua:1}%{!?_with_lua:0}
625 %{_libdir}/libmurphy-lua-utils.so.*
626 %{_libdir}/libmurphy-lua-decision.so.*
627 %endif
628 %{_libdir}/libmurphy-domain-controller.so.*
629 %{_libdir}/murphy/*.so.*
630 %{_libdir}/libbreedline*.so.*
631 %if %{?_with_dbus:1}%{!?_with_dbus:0}
632 %{_libdir}/libmurphy-libdbus.so.*
633 %{_libdir}/libmurphy-dbus-libdbus.so.*
634 %endif
635
636 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
637 %files plugins-base -f filelist.plugins-base
638 %defattr(-,root,root,-)
639 %endif
640 %{_libdir}/murphy/plugins/plugin-domain-control.so
641 %{_libdir}/murphy/plugins/plugin-resource-asm.so
642 %{_libdir}/murphy/plugins/plugin-resource-native.so
643
644 %files devel -f filelist.devel-includes
645 %defattr(-,root,root,-)
646 # %{_includedir}/murphy/config.h
647 # %{_includedir}/murphy/common.h
648 # #%{_includedir}/murphy/core.h
649 # %{_includedir}/murphy/common
650 # %{_includedir}/murphy/core
651 # %{_includedir}/murphy/resolver
652 # %{_includedir}/murphy/resource
653 # # hmmm... should handle disabled plugins properly.
654 # %{_includedir}/murphy/domain-control
655 # %{_includedir}/murphy/plugins
656 %{_includedir}/murphy-db
657 %{_libdir}/libmurphy-common.so
658 %{_libdir}/libmurphy-core.so
659 %{_libdir}/libmurphy-resolver.so
660 %{_libdir}/libmurphy-resource.so
661 %{_libdir}/libmurphy-resource-backend.so
662 %if %{?_with_lua:1}%{!?_with_lua:0}
663 %{_libdir}/libmurphy-lua-utils.so
664 %{_libdir}/libmurphy-lua-decision.so
665 %endif
666 %{_libdir}/libmurphy-domain-controller.so
667 %{_libdir}/murphy/*.so
668 %{_libdir}/pkgconfig/murphy-common.pc
669 %{_libdir}/pkgconfig/murphy-core.pc
670 %{_libdir}/pkgconfig/murphy-resolver.pc
671 #%{_libdir}/pkgconfig/murphy-resource.pc
672 %if %{?_with_lua:1}%{!?_with_lua:0}
673 %{_libdir}/pkgconfig/murphy-lua-utils.pc
674 %{_libdir}/pkgconfig/murphy-lua-decision.pc
675 %endif
676 %{_libdir}/pkgconfig/murphy-domain-controller.pc
677 %{_libdir}/pkgconfig/murphy-db.pc
678 %{_libdir}/pkgconfig/murphy-resource.pc
679 %{_includedir}/breedline
680 %{_libdir}/libbreedline*.so
681 %{_libdir}/pkgconfig/breedline*.pc
682 %if %{?_with_dbus:1}%{!?_with_dbus:0}
683 #%{_includedir}/murphy/dbus
684 %{_libdir}/libmurphy-libdbus.so
685 %{_libdir}/libmurphy-dbus-libdbus.so
686 %{_libdir}/pkgconfig/murphy-libdbus.pc
687 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
688 %endif
689
690 %files doc
691 %defattr(-,root,root,-)
692 %doc %{_docdir}/../murphy/AUTHORS
693 %doc %{_docdir}/../murphy/CODING-STYLE
694 %doc %{_docdir}/../murphy/ChangeLog
695 %doc %{_docdir}/../murphy/NEWS
696 %doc %{_docdir}/../murphy/README
697 %license COPYING LICENSE-BSD
698
699 %if %{?_with_pulse:1}%{!?_with_pulse:0}
700 %files pulse
701 %defattr(-,root,root,-)
702 %{_libdir}/libmurphy-pulse.so.*
703 %manifest %{_datadir}/murphy-pulse.manifest
704
705 %files pulse-devel
706 %defattr(-,root,root,-)
707 %{_includedir}/murphy/common/pulse-glue.h
708 %{_libdir}/libmurphy-pulse.so
709 %{_libdir}/pkgconfig/murphy-pulse.pc
710 %endif
711
712 %if %{?_with_ecore:1}%{!?_with_ecore:0}
713 %files ecore
714 %defattr(-,root,root,-)
715 %{_libdir}/libmurphy-ecore.so.*
716 %manifest %{_datadir}/murphy-ecore.manifest
717
718 %files ecore-devel
719 %defattr(-,root,root,-)
720 %{_includedir}/murphy/common/ecore-glue.h
721 %{_libdir}/libmurphy-ecore.so
722 %{_libdir}/pkgconfig/murphy-ecore.pc
723 %endif
724
725 %if %{?_with_glib:1}%{!?_with_glib:0}
726 %files glib
727 %defattr(-,root,root,-)
728 %{_libdir}/libmurphy-glib.so.*
729 %manifest %{_datadir}/murphy-glib.manifest
730
731 %files glib-devel
732 %defattr(-,root,root,-)
733 %{_includedir}/murphy/common/glib-glue.h
734 %{_libdir}/libmurphy-glib.so
735 %{_libdir}/pkgconfig/murphy-glib.pc
736 %endif
737
738 %if %{?_with_qt:1}%{!?_with_qt:0}
739 %files qt
740 %defattr(-,root,root,-)
741 %{_libdir}/libmurphy-qt.so.*
742 %manifest %{_datadir}/murphy-qt.manifest
743
744 %files qt-devel
745 %defattr(-,root,root,-)
746 %{_includedir}/murphy/common/qt-glue.h
747 %{_libdir}/libmurphy-qt.so
748 %{_libdir}/pkgconfig/murphy-qt.pc
749 %endif
750
751 %files gam
752 %defattr(-,root,root,-)
753 %{_libdir}/libmurphy-decision-tree.so.*
754 %{_libdir}/libmurphy-decision-tree.so.0.0.0
755 %{_libdir}/murphy/plugins/plugin-gam-resource-manager.so
756
757 %files gam-devel
758 %defattr(-,root,root,-)
759 %{_bindir}/decision-test
760 %{_bindir}/pattern-generator
761 %{_libdir}/libmurphy-decision-tree.so
762
763 %files tests
764 %defattr(-,root,root,-)
765 %{_bindir}/resource-client
766 %{_bindir}/resource-api-test
767 %{_bindir}/resource-api-fuzz
768 %{_bindir}/test-domain-controller
769 %{_bindir}/murphy-console
770 %manifest %{_datadir}/murphy-tests.manifest
771
772 %files ivi-resource-manager
773 %defattr(-,root,root,-)
774 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
775 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
776
777 %if %{_enable_icosyscon}
778 %files system-controller
779 %defattr(-,root,root,-)
780 %{_libdir}/murphy/plugins/plugin-system-controller.so
781 %{systemddir}/user/ico-homescreen.service
782 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
783 %manifest %{_datadir}/murphy-system-controller.manifest
784 %{_prefix}/apps/org.tizen.ico.system-controller/res/config/user.xml
785 %endif
786
787 %changelog
788 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
789 - Initial build for 2.0alpha.