packaging: kludge to interpret both _with_icosyscon set to 0 and left unset correctly.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
22 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
23 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
24
25 # TODO: take care of /lib vs /lib64...
26 %define systemddir /lib/systemd
27
28 #
29 # Abnormalize _with_icosyscon to _enable_icosyscon
30 #
31 # Since some people seem to have a hard time understanding that
32 #
33 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
34 #    undefined as opposed to defining it to 0
35 #
36 # 2) if you decide to do it the wrong way at least you should be consistent
37 #    about it and not randomly change between the conventions
38 #
39 # we need to roll this butt-ugly hack to make sure that we always go with
40 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
41 # on how _with_icosyscon happens to be set (or unset).
42 #
43
44 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
45 %if %{_with_icosyscon}
46 %define _enable_icosyscon 1
47 %else
48 %define _enable_icosyscon 0
49 %endif
50 %else
51 %define _enable_icosyscon 0
52 %endif
53
54 Summary: Murphy policy framework
55 Name: murphy
56 Version: 0.0.53
57 Release: 1
58 License: BSD-3-Clause
59 Group: System/Service
60 URL: http://01.org/murphy/
61 Source0: %{name}-%{version}.tar.gz
62 Source1: murphy.manifest
63 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
64 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
65 Requires: %{name}-core = %{version}
66 %endif
67
68 Requires(post): /bin/systemctl
69 Requires(post): libcap-tools
70 Requires(postun): /bin/systemctl
71
72 BuildRequires: flex
73 BuildRequires: bison
74 BuildRequires: pkgconfig(lua)
75 BuildRequires: pkgconfig(libsystemd-daemon)
76 BuildRequires: pkgconfig(libsystemd-journal)
77 BuildRequires: pkgconfig(libcap)
78
79 %if %{?_with_pulse:1}%{!?_with_pulse:0}
80 BuildRequires: pkgconfig(libpulse)
81 %endif
82 %if %{?_with_ecore:1}%{!?_with_ecore:0}
83 BuildRequires: pkgconfig(ecore)
84 BuildRequires: mesa-libEGL
85 BuildRequires: mesa-libGLESv2
86 %endif
87 %if %{?_with_glib:1}%{!?_with_glib:0}
88 BuildRequires: pkgconfig(glib-2.0)
89 %endif
90 %if %{?_with_qt:1}%{!?_with_qt:0}
91 BuildRequires: pkgconfig(QtCore)
92 %endif
93 %if %{?_with_dbus:1}%{!?_with_dbus:0}
94 BuildRequires: pkgconfig(dbus-1)
95 %endif
96 %if %{?_with_telephony:1}%{!?_with_telephony:0}
97 BuildRequires: pkgconfig(ofono)
98 %endif
99 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
100 BuildRequires: pkgconfig(audio-session-mgr)
101 BuildRequires: pkgconfig(aul)
102 %endif
103 %if %{?_with_websockets:1}%{!?_with_websockets:0}
104 BuildRequires: libwebsockets-devel
105 %endif
106 BuildRequires: pkgconfig(json)
107
108 %if %{?_with_smack:1}%{!?_with_smack:0}
109 BuildRequires: pkgconfig(libsmack)
110 %endif
111
112 %if %{_enable_icosyscon}
113 BuildRequires: ico-uxf-weston-plugin-devel
114 BuildRequires: pkgconfig(ail)
115 BuildRequires: pkgconfig(aul)
116 BuildRequires: libxml2-devel
117 %endif
118
119 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
120 %package core
121 Summary: Murphy core runtime libraries
122 Group: System/Libraries
123
124 %package plugins-base
125 Summary: The basic set of Murphy plugins
126 Group: System/Service
127 Requires: %{name} = %{version}
128 Requires: %{name}-core = %{version}
129 %endif
130
131 %package devel
132 Summary: The header files and libraries needed for Murphy development
133 Group: System/Libraries
134 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
135 Requires: %{name}-core = %{version}
136 %else
137 Requires: %{name} = %{version}
138 %endif
139 Requires: libjson-devel
140
141 %package doc
142 Summary: Documentation for Murphy
143 Group: SDK/Documentation
144
145 %if %{?_with_pulse:1}%{!?_with_pulse:0}
146 %package pulse
147 Summary: Murphy PulseAudio mainloop integration
148 Group: System/Libraries
149 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
150 Requires: %{name}-core = %{version}
151 %else
152 Requires: %{name} = %{version}
153 %endif
154
155 %package pulse-devel
156 Summary: Murphy PulseAudio mainloop integration development files
157 Group: System/Libraries
158 Requires: %{name}-pulse = %{version}
159 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
160 Requires: %{name}-core = %{version}
161 %else
162 Requires: %{name} = %{version}
163 %endif
164 %endif
165
166 %if %{?_with_ecore:1}%{!?_with_ecore:0}
167 %package ecore
168 Summary: Murphy EFL/ecore mainloop integration
169 Group: System/Libraries
170 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
171 Requires: %{name}-core = %{version}
172 %else
173 Requires: %{name} = %{version}
174 %endif
175
176 %package ecore-devel
177 Summary: Murphy EFL/ecore mainloop integration development files
178 Group: System/Libraries
179 Requires: %{name}-ecore = %{version}
180 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
181 Requires: %{name}-core = %{version}
182 %else
183 Requires: %{name} = %{version}
184 %endif
185 %endif
186
187 %if %{?_with_glib:1}%{!?_with_glib:0}
188 %package glib
189 Summary: Murphy glib mainloop integration
190 Group: System/Libraries
191 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
192 Requires: %{name}-core = %{version}
193 %else
194 Requires: %{name} = %{version}
195 %endif
196
197 %package glib-devel
198 Summary: Murphy glib mainloop integration development files
199 Group: System/Libraries
200 Requires: %{name}-glib = %{version}
201 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
202 Requires: %{name}-core = %{version}
203 %else
204 Requires: %{name} = %{version}
205 %endif
206 %endif
207
208 %if %{?_with_qt:1}%{!?_with_qt:0}
209 %package qt
210 Summary: Murphy Qt mainloop integration
211 Group: System/Libraries
212 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
213 Requires: %{name}-core = %{version}
214 %else
215 Requires: %{name} = %{version}
216 %endif
217
218 %package qt-devel
219 Summary: Murphy Qt mainloop integration development files
220 Group: System/Libraries
221 Requires: %{name}-qt = %{version}
222 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
223 Requires: %{name}-core = %{version}
224 %else
225 Requires: %{name} = %{version}
226 %endif
227 %endif
228
229 %package tests
230 Summary: Various test binaries for Murphy
231 Group: System/Testing
232 Requires: %{name} = %{version}
233 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
234 Requires: %{name}-core = %{version}
235 %else
236 Requires: %{name} = %{version}
237 %endif
238
239 %package ivi-resource-manager
240 Summary: Murphy IVI resource manager plugin
241 Group: System/Service
242
243 %if %{_enable_icosyscon}
244 %package system-controller
245 Summary: Murphy IVI System Controller plugin
246 Group: System/Service
247 Requires: ico-uxf-homescreen
248 Conflicts: murphy-ivi-resource-manager
249 %endif
250
251 %description
252 This package contains the basic daemon.
253
254 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
255 %description core
256 This package contains the core runtime libraries.
257
258 %description plugins-base
259 This package contains a basic set of plugins.
260 %endif
261
262 %description devel
263 This package contains header files and libraries necessary for development.
264
265 %description doc
266 This package contains documentation.
267
268 %if %{?_with_pulse:1}%{!?_with_pulse:0}
269 %description pulse
270 This package contains the Murphy PulseAudio mainloop integration runtime files.
271
272 %description pulse-devel
273 This package contains the Murphy PulseAudio mainloop integration development
274 files.
275 %endif
276
277 %if %{?_with_ecore:1}%{!?_with_ecore:0}
278 %description ecore
279 This package contains the Murphy EFL/ecore mainloop integration runtime files.
280
281 %description ecore-devel
282 This package contains the Murphy EFL/ecore mainloop integration development
283 files.
284 %endif
285
286 %if %{?_with_glib:1}%{!?_with_glib:0}
287 %description glib
288 This package contains the Murphy glib mainloop integration runtime files.
289
290 %description glib-devel
291 This package contains the Murphy glib mainloop integration development
292 files.
293 %endif
294
295 %if %{?_with_qt:1}%{!?_with_qt:0}
296 %description qt
297 This package contains the Murphy Qt mainloop integration runtime files.
298
299 %description qt-devel
300 This package contains the Murphy Qt mainloop integration development
301 files.
302 %endif
303
304 %description tests
305 This package contains various test binaries for Murphy.
306
307 %description ivi-resource-manager
308 This package contains the Murphy IVI resource manager plugin.
309
310 %if %{_enable_icosyscon}
311 %description system-controller
312 This package contains the Murphy IVI resource manager plugin.
313 %endif
314
315 %prep
316 %setup -q
317
318 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
319 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
320
321 %build
322 %if %{?_with_debug:1}%{!?_with_debug:0}
323 export CFLAGS="-O0 -g3"
324 V="V=1"
325 %endif
326
327 CONFIG_OPTIONS=""
328 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
329
330 %if %{?_with_pulse:1}%{!?_with_pulse:0}
331 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
332 %else
333 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
334 %endif
335
336 %if %{?_with_ecore:1}%{!?_with_ecore:0}
337 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
338 %else
339 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
340 %endif
341
342 %if %{?_with_glib:1}%{!?_with_glib:0}
343 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
344 %else
345 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
346 %endif
347
348 %if %{?_with_qt:1}%{!?_with_qt:0}
349 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
350 %else
351 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
352 %endif
353
354 %if %{?_with_dbus:1}%{!?_with_dbus:0}
355 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
356 %else
357 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
358 %endif
359
360 %if %{?_with_telephony:1}%{!?_with_telephony:0}
361 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
362 %else
363 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
364 %endif
365
366 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
367 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
368 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
369 %else
370 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
371 %endif
372
373 %if %{?_with_websockets:1}%{!?_with_websockets:0}
374 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
375 %else
376 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
377 %endif
378
379 %if %{?_with_smack:1}%{!?_with_smack:0}
380 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
381 %else
382 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
383 %endif
384
385 %if %{_enable_icosyscon}
386 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
387 %else
388 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
389 %endif
390
391 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
392 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
393 %else
394 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
395 %endif
396
397 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
398 grep '^processor *:' | wc -l`"
399 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
400
401 ./bootstrap && \
402 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
403 make clean && \
404 make -j$(($NUM_CPUS + 1)) $V
405
406 %install
407 rm -rf $RPM_BUILD_ROOT
408 %make_install
409
410 # Make sure we have a plugin dir even if all the basic plugins
411 # are configured to be built in.
412 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
413
414 # Get rid of any *.la files installed by libtool.
415 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
416
417 # Clean up also the murphy DB installation.
418 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
419
420 # Generate list of linkedin plugins (depends on the configuration).
421 outdir="`pwd`"
422 pushd $RPM_BUILD_ROOT >& /dev/null && \
423 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
424 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
425 popd >& /dev/null
426 echo "Found the following linked-in plugin files:"
427 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
428
429 # Generate list of header files, filtering ones that go to subpackages.
430 outdir="`pwd`"
431 pushd $RPM_BUILD_ROOT >& /dev/null && \
432 find ./%{_includedir}/murphy | \
433 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
434 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
435 popd >& /dev/null
436
437 # Replace the default sample/test config files with the packaging ones.
438 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/murphy/*
439 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
440 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
441
442 # Copy plugin configuration files in place.
443 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
444 cp packaging.in/amb-config.lua \
445 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
446
447 # Copy tmpfiles.d config file in place
448 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
449 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
450
451 # Copy the systemd files in place.
452 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
453 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
454 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
455 %if %{_enable_icosyscon}
456 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
457 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
458 %endif
459
460 %if %{?_with_dbus:1}%{!?_with_dbus:0}
461 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
462 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
463 %endif
464
465 # copy the manifest file
466 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
467 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
468 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
469 %if %{?_with_qt:1}%{!?_with_qt:0}
470 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
471 %endif
472 %if %{?_with_glib:1}%{!?_with_glib:0}
473 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
474 %endif
475 %if %{?_with_pulse:1}%{!?_with_pulse:0}
476 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
477 %endif
478 %if %{?_with_ecore:1}%{!?_with_ecore:0}
479 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
480 %endif
481 %if %{_enable_icosyscon}
482 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
483 %endif
484
485 %clean
486 rm -rf $RPM_BUILD_ROOT
487
488 %post
489 /bin/systemctl enable murphyd.service
490 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
491
492 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
493 %post core
494 %endif
495 ldconfig
496
497 %postun
498 if [ "$1" = "0" ]; then
499 /bin/systemctl disable murphyd.service
500 fi
501
502 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
503 %postun core
504 %endif
505 ldconfig
506
507 %if %{?_with_glib:1}%{!?_with_glib:0}
508 %post glib
509 ldconfig
510
511 %postun glib
512 ldconfig
513 %endif
514
515 %if %{?_with_pulse:1}%{!?_with_pulse:0}
516 %post pulse
517 ldconfig
518
519 %postun pulse
520 ldconfig
521 %endif
522
523 %if %{?_with_ecore:1}%{!?_with_ecore:0}
524 %post ecore
525 ldconfig
526
527 %postun ecore
528 ldconfig
529 %endif
530
531 %if %{?_with_qt:1}%{!?_with_qt:0}
532 %post qt
533 lfconfig
534
535 %postun qt
536 ldconfig
537 %endif
538
539 %if %{_enable_icosyscon}
540 %post system-controller
541 # prevent system controller from starting
542 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
543 # instead launch just ico-homescreen
544 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
545 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path \
546     %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
547
548 %postun system-controller
549 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
550 if [ -f %{systemddir}/user/ico-uxf-wait-launchpad-ready.path ]; then
551     ln -sf %{systemddir}/user/ico-uxf-wait-launchpad-ready.path \
552         %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
553 fi
554 %endif
555
556 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
557 %files -f filelist.plugins-base
558 %else
559 %files
560 %endif
561 %defattr(-,root,root,-)
562 %manifest %{_datadir}/murphy.manifest
563 %{_bindir}/murphyd
564 %config %{_sysconfdir}/murphy
565 %{systemddir}/system/murphyd.service
566 %{_tmpfilesdir}/murphyd.conf
567 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
568 %{_sbindir}/asm-bridge
569 %endif
570 %if %{?_with_dbus:1}%{!?_with_dbus:0}
571 %{_sysconfdir}/dbus-1/system.d
572 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
573 %endif
574 %if %{?_with_websockets:1}%{!?_with_websockets:0}
575 %{_datadir}/murphy
576 %endif
577
578 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
579 %files core
580 %defattr(-,root,root,-)
581 %endif
582 %{_libdir}/libmurphy-common.so.*
583 %{_libdir}/libmurphy-core.so.*
584 %{_libdir}/libmurphy-resolver.so.*
585 %{_libdir}/libmurphy-resource.so.*
586 %{_libdir}/libmurphy-resource-backend.so.*
587 %if %{?_with_lua:1}%{!?_with_lua:0}
588 %{_libdir}/libmurphy-lua-utils.so.*
589 %{_libdir}/libmurphy-lua-decision.so.*
590 %endif
591 %{_libdir}/libmurphy-domain-controller.so.*
592 %{_libdir}/murphy/*.so.*
593 %{_libdir}/libbreedline*.so.*
594 %if %{?_with_dbus:1}%{!?_with_dbus:0}
595 %{_libdir}/libmurphy-libdbus.so.*
596 %{_libdir}/libmurphy-dbus-libdbus.so.*
597 %endif
598
599 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
600 %files plugins-base -f filelist.plugins-base
601 %defattr(-,root,root,-)
602 %endif
603 %{_libdir}/murphy/plugins/plugin-domain-control.so
604 %{_libdir}/murphy/plugins/plugin-resource-asm.so
605 %{_libdir}/murphy/plugins/plugin-resource-native.so
606
607 %files devel -f filelist.devel-includes
608 %defattr(-,root,root,-)
609 # %{_includedir}/murphy/config.h
610 # %{_includedir}/murphy/common.h
611 # #%{_includedir}/murphy/core.h
612 # %{_includedir}/murphy/common
613 # %{_includedir}/murphy/core
614 # %{_includedir}/murphy/resolver
615 # %{_includedir}/murphy/resource
616 # # hmmm... should handle disabled plugins properly.
617 # %{_includedir}/murphy/domain-control
618 # %{_includedir}/murphy/plugins
619 %{_includedir}/murphy-db
620 %{_libdir}/libmurphy-common.so
621 %{_libdir}/libmurphy-core.so
622 %{_libdir}/libmurphy-resolver.so
623 %{_libdir}/libmurphy-resource.so
624 %{_libdir}/libmurphy-resource-backend.so
625 %if %{?_with_lua:1}%{!?_with_lua:0}
626 %{_libdir}/libmurphy-lua-utils.so
627 %{_libdir}/libmurphy-lua-decision.so
628 %endif
629 %{_libdir}/libmurphy-domain-controller.so
630 %{_libdir}/murphy/*.so
631 %{_libdir}/pkgconfig/murphy-common.pc
632 %{_libdir}/pkgconfig/murphy-core.pc
633 %{_libdir}/pkgconfig/murphy-resolver.pc
634 #%{_libdir}/pkgconfig/murphy-resource.pc
635 %if %{?_with_lua:1}%{!?_with_lua:0}
636 %{_libdir}/pkgconfig/murphy-lua-utils.pc
637 %{_libdir}/pkgconfig/murphy-lua-decision.pc
638 %endif
639 %{_libdir}/pkgconfig/murphy-domain-controller.pc
640 %{_libdir}/pkgconfig/murphy-db.pc
641 %{_libdir}/pkgconfig/murphy-resource.pc
642 %{_includedir}/breedline
643 %{_libdir}/libbreedline*.so
644 %{_libdir}/pkgconfig/breedline*.pc
645 %if %{?_with_dbus:1}%{!?_with_dbus:0}
646 #%{_includedir}/murphy/dbus
647 %{_libdir}/libmurphy-libdbus.so
648 %{_libdir}/libmurphy-dbus-libdbus.so
649 %{_libdir}/pkgconfig/murphy-libdbus.pc
650 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
651 %endif
652
653 %files doc
654 %defattr(-,root,root,-)
655 %doc %{_docdir}/../murphy/AUTHORS
656 %doc %{_docdir}/../murphy/CODING-STYLE
657 %license %{_docdir}/../murphy/COPYING
658 %doc %{_docdir}/../murphy/ChangeLog
659 %doc %{_docdir}/../murphy/INSTALL
660 %doc %{_docdir}/../murphy/NEWS
661 %doc %{_docdir}/../murphy/README
662
663 %if %{?_with_pulse:1}%{!?_with_pulse:0}
664 %files pulse
665 %defattr(-,root,root,-)
666 %{_libdir}/libmurphy-pulse.so.*
667 %manifest %{_datadir}/murphy-pulse.manifest
668
669 %files pulse-devel
670 %defattr(-,root,root,-)
671 %{_includedir}/murphy/common/pulse-glue.h
672 %{_libdir}/libmurphy-pulse.so
673 %{_libdir}/pkgconfig/murphy-pulse.pc
674 %endif
675
676 %if %{?_with_ecore:1}%{!?_with_ecore:0}
677 %files ecore
678 %defattr(-,root,root,-)
679 %{_libdir}/libmurphy-ecore.so.*
680 %manifest %{_datadir}/murphy-ecore.manifest
681
682 %files ecore-devel
683 %defattr(-,root,root,-)
684 %{_includedir}/murphy/common/ecore-glue.h
685 %{_libdir}/libmurphy-ecore.so
686 %{_libdir}/pkgconfig/murphy-ecore.pc
687 %endif
688
689 %if %{?_with_glib:1}%{!?_with_glib:0}
690 %files glib
691 %defattr(-,root,root,-)
692 %{_libdir}/libmurphy-glib.so.*
693 %manifest %{_datadir}/murphy-glib.manifest
694
695 %files glib-devel
696 %defattr(-,root,root,-)
697 %{_includedir}/murphy/common/glib-glue.h
698 %{_libdir}/libmurphy-glib.so
699 %{_libdir}/pkgconfig/murphy-glib.pc
700 %endif
701
702 %if %{?_with_qt:1}%{!?_with_qt:0}
703 %files qt
704 %defattr(-,root,root,-)
705 %{_libdir}/libmurphy-qt.so.*
706 %manifest %{_datadir}/murphy-qt.manifest
707
708 %files qt-devel
709 %defattr(-,root,root,-)
710 %{_includedir}/murphy/common/qt-glue.h
711 %{_libdir}/libmurphy-qt.so
712 %{_libdir}/pkgconfig/murphy-qt.pc
713 %endif
714
715 %files tests
716 %defattr(-,root,root,-)
717 %{_bindir}/resource-client
718 %{_bindir}/resource-api-test
719 %{_bindir}/resource-api-fuzz
720 %{_bindir}/test-domain-controller
721 %{_bindir}/murphy-console
722 %manifest %{_datadir}/murphy-tests.manifest
723
724 %files ivi-resource-manager
725 %defattr(-,root,root,-)
726 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
727 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
728
729 %if %{_enable_icosyscon}
730 %files system-controller
731 %defattr(-,root,root,-)
732 %{_libdir}/murphy/plugins/plugin-system-controller.so
733 %{systemddir}/user/ico-homescreen.service
734 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
735 %manifest %{_datadir}/murphy-system-controller.manifest
736 %endif
737
738 %changelog
739 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
740 - Initial build for 2.0alpha.