packaging: subpackages for ivi-resource-manager and system-controller.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _with_icosyscon 1}}
22 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
23
24 # TODO: take care of /lib vs /lib64...
25 %define systemddir /lib/systemd
26
27 Summary: Murphy policy framework
28 Name: murphy
29 Version: 0.0.40
30 Release: 1
31 License: BSD-3-Clause
32 Group: System/Service
33 URL: http://01.org/murphy/
34 Source0: %{name}-%{version}.tar.gz
35 Source1: murphy.manifest
36 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
38 Requires: %{name}-core = %{version}
39 %endif
40
41 Requires(post): /bin/systemctl
42 Requires(postun): /bin/systemctl
43
44 BuildRequires: flex
45 BuildRequires: bison
46 BuildRequires: pkgconfig(lua)
47 BuildRequires: pkgconfig(libsystemd-daemon)
48 BuildRequires: pkgconfig(libsystemd-journal)
49
50 %if %{?_with_pulse:1}%{!?_with_pulse:0}
51 BuildRequires: pkgconfig(libpulse)
52 %endif
53 %if %{?_with_ecore:1}%{!?_with_ecore:0}
54 BuildRequires: pkgconfig(ecore)
55 BuildRequires: mesa-libEGL
56 BuildRequires: mesa-libGLESv2
57 %endif
58 %if %{?_with_glib:1}%{!?_with_glib:0}
59 BuildRequires: pkgconfig(glib-2.0)
60 %endif
61 %if %{?_with_qt:1}%{!?_with_qt:0}
62 BuildRequires: pkgconfig(QtCore)
63 %endif
64 %if %{?_with_dbus:1}%{!?_with_dbus:0}
65 BuildRequires: pkgconfig(dbus-1)
66 %endif
67 %if %{?_with_telephony:1}%{!?_with_telephony:0}
68 BuildRequires: pkgconfig(ofono)
69 %endif
70 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
71 BuildRequires: pkgconfig(audio-session-mgr)
72 BuildRequires: pkgconfig(aul)
73 %endif
74 %if %{?_with_websockets:1}%{!?_with_websockets:0}
75 BuildRequires: libwebsockets-devel
76 %endif
77 BuildRequires: pkgconfig(json)
78
79 %if %{?_with_smack:1}%{!?_with_smack:0}
80 BuildRequires: pkgconfig(libsmack)
81 %endif
82
83 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
84 BuildRequires: ico-uxf-weston-plugin-devel
85 BuildRequires: pkgconfig(ail)
86 %endif
87
88 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
89 %package core
90 Summary: Murphy core runtime libraries
91 Group: System/Libraries
92
93 %package plugins-base
94 Summary: The basic set of Murphy plugins
95 Group: System/Service
96 Requires: %{name} = %{version}
97 Requires: %{name}-core = %{version}
98 %endif
99
100 %package devel
101 Summary: The header files and libraries needed for Murphy development
102 Group: System/Libraries
103 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
104 Requires: %{name}-core = %{version}
105 %else
106 Requires: %{name} = %{version}
107 %endif
108 Requires: libjson-devel
109
110 %package doc
111 Summary: Documentation for Murphy
112 Group: SDK/Documentation
113
114 %if %{?_with_pulse:1}%{!?_with_pulse:0}
115 %package pulse
116 Summary: Murphy PulseAudio mainloop integration
117 Group: System/Libraries
118 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
119 Requires: %{name}-core = %{version}
120 %else
121 Requires: %{name} = %{version}
122 %endif
123
124 %package pulse-devel
125 Summary: Murphy PulseAudio mainloop integration development files
126 Group: System/Libraries
127 Requires: %{name}-pulse = %{version}
128 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
129 Requires: %{name}-core = %{version}
130 %else
131 Requires: %{name} = %{version}
132 %endif
133 %endif
134
135 %if %{?_with_ecore:1}%{!?_with_ecore:0}
136 %package ecore
137 Summary: Murphy EFL/ecore mainloop integration
138 Group: System/Libraries
139 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
140 Requires: %{name}-core = %{version}
141 %else
142 Requires: %{name} = %{version}
143 %endif
144
145 %package ecore-devel
146 Summary: Murphy EFL/ecore mainloop integration development files
147 Group: System/Libraries
148 Requires: %{name}-ecore = %{version}
149 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
150 Requires: %{name}-core = %{version}
151 %else
152 Requires: %{name} = %{version}
153 %endif
154 %endif
155
156 %if %{?_with_glib:1}%{!?_with_glib:0}
157 %package glib
158 Summary: Murphy glib mainloop integration
159 Group: System/Libraries
160 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
161 Requires: %{name}-core = %{version}
162 %else
163 Requires: %{name} = %{version}
164 %endif
165
166 %package glib-devel
167 Summary: Murphy glib mainloop integration development files
168 Group: System/Libraries
169 Requires: %{name}-glib = %{version}
170 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
171 Requires: %{name}-core = %{version}
172 %else
173 Requires: %{name} = %{version}
174 %endif
175 %endif
176
177 %if %{?_with_qt:1}%{!?_with_qt:0}
178 %package qt
179 Summary: Murphy Qt mainloop integration
180 Group: System/Libraries
181 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
182 Requires: %{name}-core = %{version}
183 %else
184 Requires: %{name} = %{version}
185 %endif
186
187 %package qt-devel
188 Summary: Murphy Qt mainloop integration development files
189 Group: System/Libraries
190 Requires: %{name}-qt = %{version}
191 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
192 Requires: %{name}-core = %{version}
193 %else
194 Requires: %{name} = %{version}
195 %endif
196 %endif
197
198 %package tests
199 Summary: Various test binaries for Murphy
200 Group: System/Testing
201 Requires: %{name} = %{version}
202 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
203 Requires: %{name}-core = %{version}
204 %else
205 Requires: %{name} = %{version}
206 %endif
207
208 %package ivi-resource-manager
209 Summary: Murphy IVI resource manager plugin
210 Group: System/Service
211
212 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
213 %package system-controller
214 Summary: Murphy IVI resource manager plugin
215 Group: System/Service
216 %endif
217
218 %description
219 This package contains the basic daemon.
220
221 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
222 %description core
223 This package contains the core runtime libraries.
224
225 %description plugins-base
226 This package contains a basic set of plugins.
227 %endif
228
229 %description devel
230 This package contains header files and libraries necessary for development.
231
232 %description doc
233 This package contains documentation.
234
235 %if %{?_with_pulse:1}%{!?_with_pulse:0}
236 %description pulse
237 This package contains the Murphy PulseAudio mainloop integration runtime files.
238
239 %description pulse-devel
240 This package contains the Murphy PulseAudio mainloop integration development
241 files.
242 %endif
243
244 %if %{?_with_ecore:1}%{!?_with_ecore:0}
245 %description ecore
246 This package contains the Murphy EFL/ecore mainloop integration runtime files.
247
248 %description ecore-devel
249 This package contains the Murphy EFL/ecore mainloop integration development
250 files.
251 %endif
252
253 %if %{?_with_glib:1}%{!?_with_glib:0}
254 %description glib
255 This package contains the Murphy glib mainloop integration runtime files.
256
257 %description glib-devel
258 This package contains the Murphy glib mainloop integration development
259 files.
260 %endif
261
262 %if %{?_with_qt:1}%{!?_with_qt:0}
263 %description qt
264 This package contains the Murphy Qt mainloop integration runtime files.
265
266 %description qt-devel
267 This package contains the Murphy Qt mainloop integration development
268 files.
269 %endif
270
271 %description tests
272 This package contains various test binaries for Murphy.
273
274 %description ivi-resource-manager
275 This package contains the Murphy IVI resource manager plugin.
276
277 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
278 %description system-controller
279 This package contains the Murphy IVI resource manager plugin.
280 %endif
281
282 %prep
283 %setup -q
284
285 %build
286 %if %{?_with_debug:1}%{!?_with_debug:0}
287 export CFLAGS="-O0 -g3"
288 V="V=1"
289 %endif
290
291 CONFIG_OPTIONS=""
292 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
293
294 %if %{?_with_pulse:1}%{!?_with_pulse:0}
295 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
296 %else
297 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
298 %endif
299
300 %if %{?_with_ecore:1}%{!?_with_ecore:0}
301 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
302 %else
303 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
304 %endif
305
306 %if %{?_with_glib:1}%{!?_with_glib:0}
307 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
308 %else
309 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
310 %endif
311
312 %if %{?_with_qt:1}%{!?_with_qt:0}
313 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
314 %else
315 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
316 %endif
317
318 %if %{?_with_dbus:1}%{!?_with_dbus:0}
319 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-dbus"
320 %else
321 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-dbus"
322 %endif
323
324 %if %{?_with_telephony:1}%{!?_with_telephony:0}
325 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
326 %else
327 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
328 %endif
329
330 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
331 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
332 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
333 %else
334 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
335 %endif
336
337 %if %{?_with_websockets:1}%{!?_with_websockets:0}
338 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
339 %else
340 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
341 %endif
342
343 %if %{?_with_smack:1}%{!?_with_smack:0}
344 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
345 %else
346 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
347 %endif
348
349 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
350 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
351 %else
352 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
353 %endif
354
355 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
356 grep '^processor *:' | wc -l`"
357 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
358
359 ./bootstrap && \
360 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
361 make clean && \
362 make -j$(($NUM_CPUS + 1)) $V
363
364 %install
365 rm -rf $RPM_BUILD_ROOT
366 %make_install
367
368 # Make sure we have a plugin dir even if all the basic plugins
369 # are configured to be built in.
370 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
371
372 # Get rid of any *.la files installed by libtool.
373 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
374
375 # Clean up also the murphy DB installation.
376 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
377
378 # Generate list of linkedin plugins (depends on the configuration).
379 outdir="`pwd`"
380 pushd $RPM_BUILD_ROOT >& /dev/null && \
381 find ./%{_libdir}/murphy/plugins -name libmurphy-plugin-*.so* | \
382 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
383 popd >& /dev/null
384
385 # Generate list of header files, filtering ones that go to subpackages.
386 outdir="`pwd`"
387 pushd $RPM_BUILD_ROOT >& /dev/null && \
388 find ./%{_includedir}/murphy | \
389 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
390 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
391 popd >& /dev/null
392
393 # Replace the default sample/test config files with the packaging ones.
394 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
395 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
396
397 # Copy plugin configuration files in place.
398 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
399 cp packaging.in/amb-config.lua \
400 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
401
402 # Copy tmpfiles.d config file in place
403 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
404 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
405
406 # Copy the systemd service file in place.
407 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
408 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
409
410 %if %{?_with_dbus:1}%{!?_with_dbus:0}
411 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
412 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
413 %endif
414
415 # copy the manifest file
416 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
417 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
418 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
419 %if %{?_with_qt:1}%{!?_with_qt:0}
420 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
421 %endif
422 %if %{?_with_glib:1}%{!?_with_glib:0}
423 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
424 %endif
425 %if %{?_with_pulse:1}%{!?_with_pulse:0}
426 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
427 %endif
428 %if %{?_with_ecore:1}%{!?_with_ecore:0}
429 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
430 %endif
431 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
432 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
433 %endif
434
435 %clean
436 rm -rf $RPM_BUILD_ROOT
437
438 %post
439 /bin/systemctl enable murphyd.service
440
441 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
442 %post core
443 %endif
444 ldconfig
445
446 %postun
447 if [ "$1" = "0" ]; then
448 /bin/systemctl disable murphyd.service
449 fi
450
451 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
452 %postun core
453 %endif
454 ldconfig
455
456 %if %{?_with_glib:1}%{!?_with_glib:0}
457 %post glib
458 ldconfig
459
460 %postun glib
461 ldconfig
462 %endif
463
464 %if %{?_with_pulse:1}%{!?_with_pulse:0}
465 %post pulse
466 ldconfig
467
468 %postun pulse
469 ldconfig
470 %endif
471
472 %if %{?_with_ecore:1}%{!?_with_ecore:0}
473 %post ecore
474 ldconfig
475
476 %postun ecore
477 ldconfig
478 %endif
479
480 %if %{?_with_qt:1}%{!?_with_qt:0}
481 %post qt
482 lfconfig
483
484 %postun qt
485 ldconfig
486 %endif
487
488 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
489 %files -f filelist.plugins-base
490 %else
491 %files
492 %endif
493 %defattr(-,root,root,-)
494 %manifest %{_datadir}/murphy.manifest
495 %{_bindir}/murphyd
496 %config %{_sysconfdir}/murphy
497 %{systemddir}/system/murphyd.service
498 %{_tmpfilesdir}/murphyd.conf
499 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
500 %{_sbindir}/asm-bridge
501 %endif
502 %if %{?_with_dbus:1}%{!?_with_dbus:0}
503 %{_sysconfdir}/dbus-1/system.d
504 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
505 %endif
506 %if %{?_with_websockets:1}%{!?_with_websockets:0}
507 %{_datadir}/murphy
508 %endif
509
510 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
511 %files core
512 %defattr(-,root,root,-)
513 %endif
514 %{_libdir}/libmurphy-common.so.*
515 %{_libdir}/libmurphy-core.so.*
516 %{_libdir}/libmurphy-resolver.so.*
517 %{_libdir}/libmurphy-resource.so.*
518 %{_libdir}/libmurphy-resource-backend.so.*
519 %if %{?_with_lua:1}%{!?_with_lua:0}
520 %{_libdir}/libmurphy-lua-utils.so.*
521 %{_libdir}/libmurphy-lua-decision.so.*
522 %endif
523 %{_libdir}/libmurphy-domain-controller.so.*
524 %{_libdir}/murphy/*.so.*
525 %{_libdir}/libbreedline*.so.*
526 %if %{?_with_dbus:1}%{!?_with_dbus:0}
527 %{_libdir}/libmurphy-dbus.so.*
528 %endif
529
530 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
531 %files plugins-base -f filelist.plugins-base
532 %defattr(-,root,root,-)
533 %endif
534 %{_libdir}/murphy/plugins/plugin-domain-control.so
535 %{_libdir}/murphy/plugins/plugin-resource-asm.so
536 %{_libdir}/murphy/plugins/plugin-resource-native.so
537
538 %files devel -f filelist.devel-includes
539 %defattr(-,root,root,-)
540 # %{_includedir}/murphy/config.h
541 # %{_includedir}/murphy/common.h
542 # #%{_includedir}/murphy/core.h
543 # %{_includedir}/murphy/common
544 # %{_includedir}/murphy/core
545 # %{_includedir}/murphy/resolver
546 # %{_includedir}/murphy/resource
547 # # hmmm... should handle disabled plugins properly.
548 # %{_includedir}/murphy/domain-control
549 # %{_includedir}/murphy/plugins
550 %{_includedir}/murphy-db
551 %{_libdir}/libmurphy-common.so
552 %{_libdir}/libmurphy-core.so
553 %{_libdir}/libmurphy-resolver.so
554 %{_libdir}/libmurphy-resource.so
555 %{_libdir}/libmurphy-resource-backend.so
556 %if %{?_with_lua:1}%{!?_with_lua:0}
557 %{_libdir}/libmurphy-lua-utils.so
558 %{_libdir}/libmurphy-lua-decision.so
559 %endif
560 %{_libdir}/libmurphy-domain-controller.so
561 %{_libdir}/murphy/*.so
562 %{_libdir}/pkgconfig/murphy-common.pc
563 %{_libdir}/pkgconfig/murphy-core.pc
564 %{_libdir}/pkgconfig/murphy-resolver.pc
565 #%{_libdir}/pkgconfig/murphy-resource.pc
566 %if %{?_with_lua:1}%{!?_with_lua:0}
567 %{_libdir}/pkgconfig/murphy-lua-utils.pc
568 %{_libdir}/pkgconfig/murphy-lua-decision.pc
569 %endif
570 %{_libdir}/pkgconfig/murphy-domain-controller.pc
571 %{_libdir}/pkgconfig/murphy-db.pc
572 %{_libdir}/pkgconfig/murphy-resource.pc
573 %{_includedir}/breedline
574 %{_libdir}/libbreedline*.so
575 %{_libdir}/pkgconfig/breedline*.pc
576 %if %{?_with_dbus:1}%{!?_with_dbus:0}
577 #%{_includedir}/murphy/dbus
578 %{_libdir}/libmurphy-dbus.so
579 %{_libdir}/pkgconfig/murphy-dbus.pc
580 %endif
581
582 %files doc
583 %defattr(-,root,root,-)
584 %doc %{_docdir}/../murphy/AUTHORS
585 %doc %{_docdir}/../murphy/CODING-STYLE
586 %license %{_docdir}/../murphy/COPYING
587 %doc %{_docdir}/../murphy/ChangeLog
588 %doc %{_docdir}/../murphy/INSTALL
589 %doc %{_docdir}/../murphy/NEWS
590 %doc %{_docdir}/../murphy/README
591
592 %if %{?_with_pulse:1}%{!?_with_pulse:0}
593 %files pulse
594 %defattr(-,root,root,-)
595 %{_libdir}/libmurphy-pulse.so.*
596 %manifest %{_datadir}/murphy-pulse.manifest
597
598 %files pulse-devel
599 %defattr(-,root,root,-)
600 %{_includedir}/murphy/common/pulse-glue.h
601 %{_libdir}/libmurphy-pulse.so
602 %{_libdir}/pkgconfig/murphy-pulse.pc
603 %endif
604
605 %if %{?_with_ecore:1}%{!?_with_ecore:0}
606 %files ecore
607 %defattr(-,root,root,-)
608 %{_libdir}/libmurphy-ecore.so.*
609 %manifest %{_datadir}/murphy-ecore.manifest
610
611 %files ecore-devel
612 %defattr(-,root,root,-)
613 %{_includedir}/murphy/common/ecore-glue.h
614 %{_libdir}/libmurphy-ecore.so
615 %{_libdir}/pkgconfig/murphy-ecore.pc
616 %endif
617
618 %if %{?_with_glib:1}%{!?_with_glib:0}
619 %files glib
620 %defattr(-,root,root,-)
621 %{_libdir}/libmurphy-glib.so.*
622 %manifest %{_datadir}/murphy-glib.manifest
623
624 %files glib-devel
625 %defattr(-,root,root,-)
626 %{_includedir}/murphy/common/glib-glue.h
627 %{_libdir}/libmurphy-glib.so
628 %{_libdir}/pkgconfig/murphy-glib.pc
629 %endif
630
631 %if %{?_with_qt:1}%{!?_with_qt:0}
632 %files qt
633 %defattr(-,root,root,-)
634 %{_libdir}/libmurphy-qt.so.*
635 %manifest %{_datadir}/murphy-qt.manifest
636
637 %files qt-devel
638 %defattr(-,root,root,-)
639 %{_includedir}/murphy/common/qt-glue.h
640 %{_libdir}/libmurphy-qt.so
641 %{_libdir}/pkgconfig/murphy-qt.pc
642 %endif
643
644 %files tests
645 %defattr(-,root,root,-)
646 %{_bindir}/resource-client
647 %{_bindir}/resource-api-test
648 %{_bindir}/resource-api-fuzz
649 %{_bindir}/test-domain-controller
650 %{_bindir}/murphy-console
651 %manifest %{_datadir}/murphy-tests.manifest
652
653 %files ivi-resource-manager
654 %defattr(-,root,root,-)
655 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
656 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
657
658 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
659 %files system-controller
660 %defattr(-,root,root,-)
661 %{_libdir}/murphy/plugins/plugin-system-controller.so
662 %manifest %{_datadir}/murphy-system-controller.manifest
663 %endif
664
665 %changelog
666 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
667 - Initial build for 2.0alpha.