packaging: bumped the version, updated the changelog.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _with_icosyscon 1}}
22 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
23
24 # TODO: take care of /lib vs /lib64...
25 %define systemddir /lib/systemd
26
27 Summary: Murphy policy framework
28 Name: murphy
29 Version: 0.0.45
30 Release: 1
31 License: BSD-3-Clause
32 Group: System/Service
33 URL: http://01.org/murphy/
34 Source0: %{name}-%{version}.tar.gz
35 Source1: murphy.manifest
36 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
38 Requires: %{name}-core = %{version}
39 %endif
40
41 Requires(post): /bin/systemctl
42 Requires(postun): /bin/systemctl
43
44 BuildRequires: flex
45 BuildRequires: bison
46 BuildRequires: pkgconfig(lua)
47 BuildRequires: pkgconfig(libsystemd-daemon)
48 BuildRequires: pkgconfig(libsystemd-journal)
49
50 %if %{?_with_pulse:1}%{!?_with_pulse:0}
51 BuildRequires: pkgconfig(libpulse)
52 %endif
53 %if %{?_with_ecore:1}%{!?_with_ecore:0}
54 BuildRequires: pkgconfig(ecore)
55 BuildRequires: mesa-libEGL
56 BuildRequires: mesa-libGLESv2
57 %endif
58 %if %{?_with_glib:1}%{!?_with_glib:0}
59 BuildRequires: pkgconfig(glib-2.0)
60 %endif
61 %if %{?_with_qt:1}%{!?_with_qt:0}
62 BuildRequires: pkgconfig(QtCore)
63 %endif
64 %if %{?_with_dbus:1}%{!?_with_dbus:0}
65 BuildRequires: pkgconfig(dbus-1)
66 %endif
67 %if %{?_with_telephony:1}%{!?_with_telephony:0}
68 BuildRequires: pkgconfig(ofono)
69 %endif
70 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
71 BuildRequires: pkgconfig(audio-session-mgr)
72 BuildRequires: pkgconfig(aul)
73 %endif
74 %if %{?_with_websockets:1}%{!?_with_websockets:0}
75 BuildRequires: libwebsockets-devel
76 %endif
77 BuildRequires: pkgconfig(json)
78
79 %if %{?_with_smack:1}%{!?_with_smack:0}
80 BuildRequires: pkgconfig(libsmack)
81 %endif
82
83 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
84 BuildRequires: ico-uxf-weston-plugin-devel
85 BuildRequires: pkgconfig(ail)
86 BuildRequires: libxml2-devel
87 %endif
88
89 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
90 %package core
91 Summary: Murphy core runtime libraries
92 Group: System/Libraries
93
94 %package plugins-base
95 Summary: The basic set of Murphy plugins
96 Group: System/Service
97 Requires: %{name} = %{version}
98 Requires: %{name}-core = %{version}
99 %endif
100
101 %package devel
102 Summary: The header files and libraries needed for Murphy development
103 Group: System/Libraries
104 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
105 Requires: %{name}-core = %{version}
106 %else
107 Requires: %{name} = %{version}
108 %endif
109 Requires: libjson-devel
110
111 %package doc
112 Summary: Documentation for Murphy
113 Group: SDK/Documentation
114
115 %if %{?_with_pulse:1}%{!?_with_pulse:0}
116 %package pulse
117 Summary: Murphy PulseAudio mainloop integration
118 Group: System/Libraries
119 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
120 Requires: %{name}-core = %{version}
121 %else
122 Requires: %{name} = %{version}
123 %endif
124
125 %package pulse-devel
126 Summary: Murphy PulseAudio mainloop integration development files
127 Group: System/Libraries
128 Requires: %{name}-pulse = %{version}
129 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
130 Requires: %{name}-core = %{version}
131 %else
132 Requires: %{name} = %{version}
133 %endif
134 %endif
135
136 %if %{?_with_ecore:1}%{!?_with_ecore:0}
137 %package ecore
138 Summary: Murphy EFL/ecore mainloop integration
139 Group: System/Libraries
140 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
141 Requires: %{name}-core = %{version}
142 %else
143 Requires: %{name} = %{version}
144 %endif
145
146 %package ecore-devel
147 Summary: Murphy EFL/ecore mainloop integration development files
148 Group: System/Libraries
149 Requires: %{name}-ecore = %{version}
150 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
151 Requires: %{name}-core = %{version}
152 %else
153 Requires: %{name} = %{version}
154 %endif
155 %endif
156
157 %if %{?_with_glib:1}%{!?_with_glib:0}
158 %package glib
159 Summary: Murphy glib mainloop integration
160 Group: System/Libraries
161 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
162 Requires: %{name}-core = %{version}
163 %else
164 Requires: %{name} = %{version}
165 %endif
166
167 %package glib-devel
168 Summary: Murphy glib mainloop integration development files
169 Group: System/Libraries
170 Requires: %{name}-glib = %{version}
171 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
172 Requires: %{name}-core = %{version}
173 %else
174 Requires: %{name} = %{version}
175 %endif
176 %endif
177
178 %if %{?_with_qt:1}%{!?_with_qt:0}
179 %package qt
180 Summary: Murphy Qt mainloop integration
181 Group: System/Libraries
182 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
183 Requires: %{name}-core = %{version}
184 %else
185 Requires: %{name} = %{version}
186 %endif
187
188 %package qt-devel
189 Summary: Murphy Qt mainloop integration development files
190 Group: System/Libraries
191 Requires: %{name}-qt = %{version}
192 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
193 Requires: %{name}-core = %{version}
194 %else
195 Requires: %{name} = %{version}
196 %endif
197 %endif
198
199 %package tests
200 Summary: Various test binaries for Murphy
201 Group: System/Testing
202 Requires: %{name} = %{version}
203 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
204 Requires: %{name}-core = %{version}
205 %else
206 Requires: %{name} = %{version}
207 %endif
208
209 %package ivi-resource-manager
210 Summary: Murphy IVI resource manager plugin
211 Group: System/Service
212
213 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
214 %package system-controller
215 Summary: Murphy IVI System Controller plugin
216 Group: System/Service
217 %endif
218
219 %description
220 This package contains the basic daemon.
221
222 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
223 %description core
224 This package contains the core runtime libraries.
225
226 %description plugins-base
227 This package contains a basic set of plugins.
228 %endif
229
230 %description devel
231 This package contains header files and libraries necessary for development.
232
233 %description doc
234 This package contains documentation.
235
236 %if %{?_with_pulse:1}%{!?_with_pulse:0}
237 %description pulse
238 This package contains the Murphy PulseAudio mainloop integration runtime files.
239
240 %description pulse-devel
241 This package contains the Murphy PulseAudio mainloop integration development
242 files.
243 %endif
244
245 %if %{?_with_ecore:1}%{!?_with_ecore:0}
246 %description ecore
247 This package contains the Murphy EFL/ecore mainloop integration runtime files.
248
249 %description ecore-devel
250 This package contains the Murphy EFL/ecore mainloop integration development
251 files.
252 %endif
253
254 %if %{?_with_glib:1}%{!?_with_glib:0}
255 %description glib
256 This package contains the Murphy glib mainloop integration runtime files.
257
258 %description glib-devel
259 This package contains the Murphy glib mainloop integration development
260 files.
261 %endif
262
263 %if %{?_with_qt:1}%{!?_with_qt:0}
264 %description qt
265 This package contains the Murphy Qt mainloop integration runtime files.
266
267 %description qt-devel
268 This package contains the Murphy Qt mainloop integration development
269 files.
270 %endif
271
272 %description tests
273 This package contains various test binaries for Murphy.
274
275 %description ivi-resource-manager
276 This package contains the Murphy IVI resource manager plugin.
277
278 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
279 %description system-controller
280 This package contains the Murphy IVI resource manager plugin.
281 %endif
282
283 %prep
284 %setup -q
285
286 %build
287 %if %{?_with_debug:1}%{!?_with_debug:0}
288 export CFLAGS="-O0 -g3"
289 V="V=1"
290 %endif
291
292 CONFIG_OPTIONS=""
293 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
294
295 %if %{?_with_pulse:1}%{!?_with_pulse:0}
296 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
297 %else
298 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
299 %endif
300
301 %if %{?_with_ecore:1}%{!?_with_ecore:0}
302 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
303 %else
304 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
305 %endif
306
307 %if %{?_with_glib:1}%{!?_with_glib:0}
308 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
309 %else
310 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
311 %endif
312
313 %if %{?_with_qt:1}%{!?_with_qt:0}
314 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
315 %else
316 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
317 %endif
318
319 %if %{?_with_dbus:1}%{!?_with_dbus:0}
320 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
321 %else
322 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
323 %endif
324
325 %if %{?_with_telephony:1}%{!?_with_telephony:0}
326 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
327 %else
328 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
329 %endif
330
331 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
332 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
333 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
334 %else
335 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
336 %endif
337
338 %if %{?_with_websockets:1}%{!?_with_websockets:0}
339 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
340 %else
341 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
342 %endif
343
344 %if %{?_with_smack:1}%{!?_with_smack:0}
345 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
346 %else
347 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
348 %endif
349
350 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
351 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
352 %else
353 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
354 %endif
355
356 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
357 grep '^processor *:' | wc -l`"
358 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
359
360 ./bootstrap && \
361 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
362 make clean && \
363 make -j$(($NUM_CPUS + 1)) $V
364
365 %install
366 rm -rf $RPM_BUILD_ROOT
367 %make_install
368
369 # Make sure we have a plugin dir even if all the basic plugins
370 # are configured to be built in.
371 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
372
373 # Get rid of any *.la files installed by libtool.
374 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
375
376 # Clean up also the murphy DB installation.
377 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
378
379 # Generate list of linkedin plugins (depends on the configuration).
380 outdir="`pwd`"
381 pushd $RPM_BUILD_ROOT >& /dev/null && \
382 find ./%{_libdir}/murphy/plugins -name libmurphy-plugin-*.so* | \
383 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
384 popd >& /dev/null
385
386 # Generate list of header files, filtering ones that go to subpackages.
387 outdir="`pwd`"
388 pushd $RPM_BUILD_ROOT >& /dev/null && \
389 find ./%{_includedir}/murphy | \
390 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
391 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
392 popd >& /dev/null
393
394 # Replace the default sample/test config files with the packaging ones.
395 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
396 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
397
398 # Copy plugin configuration files in place.
399 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
400 cp packaging.in/amb-config.lua \
401 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
402
403 # Copy tmpfiles.d config file in place
404 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
405 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
406
407 # Copy the systemd files in place.
408 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
409 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
410 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
411 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
412 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
413 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
414 %endif
415
416 %if %{?_with_dbus:1}%{!?_with_dbus:0}
417 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
418 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
419 %endif
420
421 # copy the manifest file
422 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
423 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
424 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
425 %if %{?_with_qt:1}%{!?_with_qt:0}
426 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
427 %endif
428 %if %{?_with_glib:1}%{!?_with_glib:0}
429 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
430 %endif
431 %if %{?_with_pulse:1}%{!?_with_pulse:0}
432 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
433 %endif
434 %if %{?_with_ecore:1}%{!?_with_ecore:0}
435 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
436 %endif
437 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
438 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
439 %endif
440
441 %clean
442 rm -rf $RPM_BUILD_ROOT
443
444 %post
445 /bin/systemctl enable murphyd.service
446
447 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
448 %post core
449 %endif
450 ldconfig
451
452 %postun
453 if [ "$1" = "0" ]; then
454 /bin/systemctl disable murphyd.service
455 fi
456
457 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
458 %postun core
459 %endif
460 ldconfig
461
462 %if %{?_with_glib:1}%{!?_with_glib:0}
463 %post glib
464 ldconfig
465
466 %postun glib
467 ldconfig
468 %endif
469
470 %if %{?_with_pulse:1}%{!?_with_pulse:0}
471 %post pulse
472 ldconfig
473
474 %postun pulse
475 ldconfig
476 %endif
477
478 %if %{?_with_ecore:1}%{!?_with_ecore:0}
479 %post ecore
480 ldconfig
481
482 %postun ecore
483 ldconfig
484 %endif
485
486 %if %{?_with_qt:1}%{!?_with_qt:0}
487 %post qt
488 lfconfig
489
490 %postun qt
491 ldconfig
492 %endif
493
494 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
495 %post system-controller
496 # prevent system controller from starting
497 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
498 # instead launch just ico-homescreen
499 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
500
501
502 %postun system-controller
503 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
504 ln -s %{systemddir}/user/ico-uxf-wait-launchpad-ready.path %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
505 %endif
506
507 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
508 %files -f filelist.plugins-base
509 %else
510 %files
511 %endif
512 %defattr(-,root,root,-)
513 %manifest %{_datadir}/murphy.manifest
514 %{_bindir}/murphyd
515 %config %{_sysconfdir}/murphy
516 %{systemddir}/system/murphyd.service
517 %{_tmpfilesdir}/murphyd.conf
518 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
519 %{_sbindir}/asm-bridge
520 %endif
521 %if %{?_with_dbus:1}%{!?_with_dbus:0}
522 %{_sysconfdir}/dbus-1/system.d
523 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
524 %endif
525 %if %{?_with_websockets:1}%{!?_with_websockets:0}
526 %{_datadir}/murphy
527 %endif
528
529 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
530 %files core
531 %defattr(-,root,root,-)
532 %endif
533 %{_libdir}/libmurphy-common.so.*
534 %{_libdir}/libmurphy-core.so.*
535 %{_libdir}/libmurphy-resolver.so.*
536 %{_libdir}/libmurphy-resource.so.*
537 %{_libdir}/libmurphy-resource-backend.so.*
538 %if %{?_with_lua:1}%{!?_with_lua:0}
539 %{_libdir}/libmurphy-lua-utils.so.*
540 %{_libdir}/libmurphy-lua-decision.so.*
541 %endif
542 %{_libdir}/libmurphy-domain-controller.so.*
543 %{_libdir}/murphy/*.so.*
544 %{_libdir}/libbreedline*.so.*
545 %if %{?_with_dbus:1}%{!?_with_dbus:0}
546 %{_libdir}/libmurphy-libdbus.so.*
547 %{_libdir}/libmurphy-dbus-libdbus.so.*
548 %endif
549
550 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
551 %files plugins-base -f filelist.plugins-base
552 %defattr(-,root,root,-)
553 %endif
554 %{_libdir}/murphy/plugins/plugin-domain-control.so
555 %{_libdir}/murphy/plugins/plugin-resource-asm.so
556 %{_libdir}/murphy/plugins/plugin-resource-native.so
557
558 %files devel -f filelist.devel-includes
559 %defattr(-,root,root,-)
560 # %{_includedir}/murphy/config.h
561 # %{_includedir}/murphy/common.h
562 # #%{_includedir}/murphy/core.h
563 # %{_includedir}/murphy/common
564 # %{_includedir}/murphy/core
565 # %{_includedir}/murphy/resolver
566 # %{_includedir}/murphy/resource
567 # # hmmm... should handle disabled plugins properly.
568 # %{_includedir}/murphy/domain-control
569 # %{_includedir}/murphy/plugins
570 %{_includedir}/murphy-db
571 %{_libdir}/libmurphy-common.so
572 %{_libdir}/libmurphy-core.so
573 %{_libdir}/libmurphy-resolver.so
574 %{_libdir}/libmurphy-resource.so
575 %{_libdir}/libmurphy-resource-backend.so
576 %if %{?_with_lua:1}%{!?_with_lua:0}
577 %{_libdir}/libmurphy-lua-utils.so
578 %{_libdir}/libmurphy-lua-decision.so
579 %endif
580 %{_libdir}/libmurphy-domain-controller.so
581 %{_libdir}/murphy/*.so
582 %{_libdir}/pkgconfig/murphy-common.pc
583 %{_libdir}/pkgconfig/murphy-core.pc
584 %{_libdir}/pkgconfig/murphy-resolver.pc
585 #%{_libdir}/pkgconfig/murphy-resource.pc
586 %if %{?_with_lua:1}%{!?_with_lua:0}
587 %{_libdir}/pkgconfig/murphy-lua-utils.pc
588 %{_libdir}/pkgconfig/murphy-lua-decision.pc
589 %endif
590 %{_libdir}/pkgconfig/murphy-domain-controller.pc
591 %{_libdir}/pkgconfig/murphy-db.pc
592 %{_libdir}/pkgconfig/murphy-resource.pc
593 %{_includedir}/breedline
594 %{_libdir}/libbreedline*.so
595 %{_libdir}/pkgconfig/breedline*.pc
596 %if %{?_with_dbus:1}%{!?_with_dbus:0}
597 #%{_includedir}/murphy/dbus
598 %{_libdir}/libmurphy-libdbus.so
599 %{_libdir}/libmurphy-dbus-libdbus.so
600 %{_libdir}/pkgconfig/murphy-libdbus.pc
601 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
602 %endif
603
604 %files doc
605 %defattr(-,root,root,-)
606 %doc %{_docdir}/../murphy/AUTHORS
607 %doc %{_docdir}/../murphy/CODING-STYLE
608 %license %{_docdir}/../murphy/COPYING
609 %doc %{_docdir}/../murphy/ChangeLog
610 %doc %{_docdir}/../murphy/INSTALL
611 %doc %{_docdir}/../murphy/NEWS
612 %doc %{_docdir}/../murphy/README
613
614 %if %{?_with_pulse:1}%{!?_with_pulse:0}
615 %files pulse
616 %defattr(-,root,root,-)
617 %{_libdir}/libmurphy-pulse.so.*
618 %manifest %{_datadir}/murphy-pulse.manifest
619
620 %files pulse-devel
621 %defattr(-,root,root,-)
622 %{_includedir}/murphy/common/pulse-glue.h
623 %{_libdir}/libmurphy-pulse.so
624 %{_libdir}/pkgconfig/murphy-pulse.pc
625 %endif
626
627 %if %{?_with_ecore:1}%{!?_with_ecore:0}
628 %files ecore
629 %defattr(-,root,root,-)
630 %{_libdir}/libmurphy-ecore.so.*
631 %manifest %{_datadir}/murphy-ecore.manifest
632
633 %files ecore-devel
634 %defattr(-,root,root,-)
635 %{_includedir}/murphy/common/ecore-glue.h
636 %{_libdir}/libmurphy-ecore.so
637 %{_libdir}/pkgconfig/murphy-ecore.pc
638 %endif
639
640 %if %{?_with_glib:1}%{!?_with_glib:0}
641 %files glib
642 %defattr(-,root,root,-)
643 %{_libdir}/libmurphy-glib.so.*
644 %manifest %{_datadir}/murphy-glib.manifest
645
646 %files glib-devel
647 %defattr(-,root,root,-)
648 %{_includedir}/murphy/common/glib-glue.h
649 %{_libdir}/libmurphy-glib.so
650 %{_libdir}/pkgconfig/murphy-glib.pc
651 %endif
652
653 %if %{?_with_qt:1}%{!?_with_qt:0}
654 %files qt
655 %defattr(-,root,root,-)
656 %{_libdir}/libmurphy-qt.so.*
657 %manifest %{_datadir}/murphy-qt.manifest
658
659 %files qt-devel
660 %defattr(-,root,root,-)
661 %{_includedir}/murphy/common/qt-glue.h
662 %{_libdir}/libmurphy-qt.so
663 %{_libdir}/pkgconfig/murphy-qt.pc
664 %endif
665
666 %files tests
667 %defattr(-,root,root,-)
668 %{_bindir}/resource-client
669 %{_bindir}/resource-api-test
670 %{_bindir}/resource-api-fuzz
671 %{_bindir}/test-domain-controller
672 %{_bindir}/murphy-console
673 %manifest %{_datadir}/murphy-tests.manifest
674
675 %files ivi-resource-manager
676 %defattr(-,root,root,-)
677 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
678 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
679
680 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
681 %files system-controller
682 %defattr(-,root,root,-)
683 %{_libdir}/murphy/plugins/plugin-system-controller.so
684 %{systemddir}/user/ico-homescreen.service
685 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
686 %manifest %{_datadir}/murphy-system-controller.manifest
687 %endif
688
689 %changelog
690 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
691 - Initial build for 2.0alpha.