packaging: explicitly enable system-monitor.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _with_icosyscon 1}}
22 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
23 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
24
25 # TODO: take care of /lib vs /lib64...
26 %define systemddir /lib/systemd
27
28 Summary: Murphy policy framework
29 Name: murphy
30 Version: 0.0.45
31 Release: 1
32 License: BSD-3-Clause
33 Group: System/Service
34 URL: http://01.org/murphy/
35 Source0: %{name}-%{version}.tar.gz
36 Source1: murphy.manifest
37 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
38 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
39 Requires: %{name}-core = %{version}
40 %endif
41
42 Requires(post): /bin/systemctl
43 Requires(postun): /bin/systemctl
44
45 BuildRequires: flex
46 BuildRequires: bison
47 BuildRequires: pkgconfig(lua)
48 BuildRequires: pkgconfig(libsystemd-daemon)
49 BuildRequires: pkgconfig(libsystemd-journal)
50
51 %if %{?_with_pulse:1}%{!?_with_pulse:0}
52 BuildRequires: pkgconfig(libpulse)
53 %endif
54 %if %{?_with_ecore:1}%{!?_with_ecore:0}
55 BuildRequires: pkgconfig(ecore)
56 BuildRequires: mesa-libEGL
57 BuildRequires: mesa-libGLESv2
58 %endif
59 %if %{?_with_glib:1}%{!?_with_glib:0}
60 BuildRequires: pkgconfig(glib-2.0)
61 %endif
62 %if %{?_with_qt:1}%{!?_with_qt:0}
63 BuildRequires: pkgconfig(QtCore)
64 %endif
65 %if %{?_with_dbus:1}%{!?_with_dbus:0}
66 BuildRequires: pkgconfig(dbus-1)
67 %endif
68 %if %{?_with_telephony:1}%{!?_with_telephony:0}
69 BuildRequires: pkgconfig(ofono)
70 %endif
71 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
72 BuildRequires: pkgconfig(audio-session-mgr)
73 BuildRequires: pkgconfig(aul)
74 %endif
75 %if %{?_with_websockets:1}%{!?_with_websockets:0}
76 BuildRequires: libwebsockets-devel
77 %endif
78 BuildRequires: pkgconfig(json)
79
80 %if %{?_with_smack:1}%{!?_with_smack:0}
81 BuildRequires: pkgconfig(libsmack)
82 %endif
83
84 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
85 BuildRequires: ico-uxf-weston-plugin-devel
86 BuildRequires: pkgconfig(ail)
87 BuildRequires: libxml2-devel
88 %endif
89
90 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
91 %package core
92 Summary: Murphy core runtime libraries
93 Group: System/Libraries
94
95 %package plugins-base
96 Summary: The basic set of Murphy plugins
97 Group: System/Service
98 Requires: %{name} = %{version}
99 Requires: %{name}-core = %{version}
100 %endif
101
102 %package devel
103 Summary: The header files and libraries needed for Murphy development
104 Group: System/Libraries
105 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
106 Requires: %{name}-core = %{version}
107 %else
108 Requires: %{name} = %{version}
109 %endif
110 Requires: libjson-devel
111
112 %package doc
113 Summary: Documentation for Murphy
114 Group: SDK/Documentation
115
116 %if %{?_with_pulse:1}%{!?_with_pulse:0}
117 %package pulse
118 Summary: Murphy PulseAudio mainloop integration
119 Group: System/Libraries
120 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
121 Requires: %{name}-core = %{version}
122 %else
123 Requires: %{name} = %{version}
124 %endif
125
126 %package pulse-devel
127 Summary: Murphy PulseAudio mainloop integration development files
128 Group: System/Libraries
129 Requires: %{name}-pulse = %{version}
130 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
131 Requires: %{name}-core = %{version}
132 %else
133 Requires: %{name} = %{version}
134 %endif
135 %endif
136
137 %if %{?_with_ecore:1}%{!?_with_ecore:0}
138 %package ecore
139 Summary: Murphy EFL/ecore mainloop integration
140 Group: System/Libraries
141 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
142 Requires: %{name}-core = %{version}
143 %else
144 Requires: %{name} = %{version}
145 %endif
146
147 %package ecore-devel
148 Summary: Murphy EFL/ecore mainloop integration development files
149 Group: System/Libraries
150 Requires: %{name}-ecore = %{version}
151 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
152 Requires: %{name}-core = %{version}
153 %else
154 Requires: %{name} = %{version}
155 %endif
156 %endif
157
158 %if %{?_with_glib:1}%{!?_with_glib:0}
159 %package glib
160 Summary: Murphy glib mainloop integration
161 Group: System/Libraries
162 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
163 Requires: %{name}-core = %{version}
164 %else
165 Requires: %{name} = %{version}
166 %endif
167
168 %package glib-devel
169 Summary: Murphy glib mainloop integration development files
170 Group: System/Libraries
171 Requires: %{name}-glib = %{version}
172 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
173 Requires: %{name}-core = %{version}
174 %else
175 Requires: %{name} = %{version}
176 %endif
177 %endif
178
179 %if %{?_with_qt:1}%{!?_with_qt:0}
180 %package qt
181 Summary: Murphy Qt mainloop integration
182 Group: System/Libraries
183 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
184 Requires: %{name}-core = %{version}
185 %else
186 Requires: %{name} = %{version}
187 %endif
188
189 %package qt-devel
190 Summary: Murphy Qt mainloop integration development files
191 Group: System/Libraries
192 Requires: %{name}-qt = %{version}
193 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
194 Requires: %{name}-core = %{version}
195 %else
196 Requires: %{name} = %{version}
197 %endif
198 %endif
199
200 %package tests
201 Summary: Various test binaries for Murphy
202 Group: System/Testing
203 Requires: %{name} = %{version}
204 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
205 Requires: %{name}-core = %{version}
206 %else
207 Requires: %{name} = %{version}
208 %endif
209
210 %package ivi-resource-manager
211 Summary: Murphy IVI resource manager plugin
212 Group: System/Service
213
214 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
215 %package system-controller
216 Summary: Murphy IVI System Controller plugin
217 Group: System/Service
218 %endif
219
220 %description
221 This package contains the basic daemon.
222
223 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
224 %description core
225 This package contains the core runtime libraries.
226
227 %description plugins-base
228 This package contains a basic set of plugins.
229 %endif
230
231 %description devel
232 This package contains header files and libraries necessary for development.
233
234 %description doc
235 This package contains documentation.
236
237 %if %{?_with_pulse:1}%{!?_with_pulse:0}
238 %description pulse
239 This package contains the Murphy PulseAudio mainloop integration runtime files.
240
241 %description pulse-devel
242 This package contains the Murphy PulseAudio mainloop integration development
243 files.
244 %endif
245
246 %if %{?_with_ecore:1}%{!?_with_ecore:0}
247 %description ecore
248 This package contains the Murphy EFL/ecore mainloop integration runtime files.
249
250 %description ecore-devel
251 This package contains the Murphy EFL/ecore mainloop integration development
252 files.
253 %endif
254
255 %if %{?_with_glib:1}%{!?_with_glib:0}
256 %description glib
257 This package contains the Murphy glib mainloop integration runtime files.
258
259 %description glib-devel
260 This package contains the Murphy glib mainloop integration development
261 files.
262 %endif
263
264 %if %{?_with_qt:1}%{!?_with_qt:0}
265 %description qt
266 This package contains the Murphy Qt mainloop integration runtime files.
267
268 %description qt-devel
269 This package contains the Murphy Qt mainloop integration development
270 files.
271 %endif
272
273 %description tests
274 This package contains various test binaries for Murphy.
275
276 %description ivi-resource-manager
277 This package contains the Murphy IVI resource manager plugin.
278
279 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
280 %description system-controller
281 This package contains the Murphy IVI resource manager plugin.
282 %endif
283
284 %prep
285 %setup -q
286
287 %build
288 %if %{?_with_debug:1}%{!?_with_debug:0}
289 export CFLAGS="-O0 -g3"
290 V="V=1"
291 %endif
292
293 CONFIG_OPTIONS=""
294 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
295
296 %if %{?_with_pulse:1}%{!?_with_pulse:0}
297 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
298 %else
299 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
300 %endif
301
302 %if %{?_with_ecore:1}%{!?_with_ecore:0}
303 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
304 %else
305 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
306 %endif
307
308 %if %{?_with_glib:1}%{!?_with_glib:0}
309 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
310 %else
311 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
312 %endif
313
314 %if %{?_with_qt:1}%{!?_with_qt:0}
315 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
316 %else
317 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
318 %endif
319
320 %if %{?_with_dbus:1}%{!?_with_dbus:0}
321 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
322 %else
323 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
324 %endif
325
326 %if %{?_with_telephony:1}%{!?_with_telephony:0}
327 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
328 %else
329 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
330 %endif
331
332 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
333 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
334 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
335 %else
336 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
337 %endif
338
339 %if %{?_with_websockets:1}%{!?_with_websockets:0}
340 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
341 %else
342 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
343 %endif
344
345 %if %{?_with_smack:1}%{!?_with_smack:0}
346 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
347 %else
348 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
349 %endif
350
351 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
352 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
353 %else
354 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
355 %endif
356
357 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
358 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
359 %else
360 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
361 %endif
362
363 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
364 grep '^processor *:' | wc -l`"
365 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
366
367 ./bootstrap && \
368 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
369 make clean && \
370 make -j$(($NUM_CPUS + 1)) $V
371
372 %install
373 rm -rf $RPM_BUILD_ROOT
374 %make_install
375
376 # Make sure we have a plugin dir even if all the basic plugins
377 # are configured to be built in.
378 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
379
380 # Get rid of any *.la files installed by libtool.
381 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
382
383 # Clean up also the murphy DB installation.
384 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
385
386 # Generate list of linkedin plugins (depends on the configuration).
387 outdir="`pwd`"
388 pushd $RPM_BUILD_ROOT >& /dev/null && \
389 find ./%{_libdir}/murphy/plugins -name libmurphy-plugin-*.so* | \
390 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
391 popd >& /dev/null
392
393 # Generate list of header files, filtering ones that go to subpackages.
394 outdir="`pwd`"
395 pushd $RPM_BUILD_ROOT >& /dev/null && \
396 find ./%{_includedir}/murphy | \
397 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
398 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
399 popd >& /dev/null
400
401 # Replace the default sample/test config files with the packaging ones.
402 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
403 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
404
405 # Copy plugin configuration files in place.
406 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
407 cp packaging.in/amb-config.lua \
408 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
409
410 # Copy tmpfiles.d config file in place
411 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
412 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
413
414 # Copy the systemd files in place.
415 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
416 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
417 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
418 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
419 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
420 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
421 %endif
422
423 %if %{?_with_dbus:1}%{!?_with_dbus:0}
424 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
425 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
426 %endif
427
428 # copy the manifest file
429 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
430 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
431 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
432 %if %{?_with_qt:1}%{!?_with_qt:0}
433 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
434 %endif
435 %if %{?_with_glib:1}%{!?_with_glib:0}
436 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
437 %endif
438 %if %{?_with_pulse:1}%{!?_with_pulse:0}
439 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
440 %endif
441 %if %{?_with_ecore:1}%{!?_with_ecore:0}
442 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
443 %endif
444 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
445 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
446 %endif
447
448 %clean
449 rm -rf $RPM_BUILD_ROOT
450
451 %post
452 /bin/systemctl enable murphyd.service
453
454 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
455 %post core
456 %endif
457 ldconfig
458
459 %postun
460 if [ "$1" = "0" ]; then
461 /bin/systemctl disable murphyd.service
462 fi
463
464 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
465 %postun core
466 %endif
467 ldconfig
468
469 %if %{?_with_glib:1}%{!?_with_glib:0}
470 %post glib
471 ldconfig
472
473 %postun glib
474 ldconfig
475 %endif
476
477 %if %{?_with_pulse:1}%{!?_with_pulse:0}
478 %post pulse
479 ldconfig
480
481 %postun pulse
482 ldconfig
483 %endif
484
485 %if %{?_with_ecore:1}%{!?_with_ecore:0}
486 %post ecore
487 ldconfig
488
489 %postun ecore
490 ldconfig
491 %endif
492
493 %if %{?_with_qt:1}%{!?_with_qt:0}
494 %post qt
495 lfconfig
496
497 %postun qt
498 ldconfig
499 %endif
500
501 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
502 %post system-controller
503 # prevent system controller from starting
504 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
505 # instead launch just ico-homescreen
506 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
507
508
509 %postun system-controller
510 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
511 ln -s %{systemddir}/user/ico-uxf-wait-launchpad-ready.path %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
512 %endif
513
514 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
515 %files -f filelist.plugins-base
516 %else
517 %files
518 %endif
519 %defattr(-,root,root,-)
520 %manifest %{_datadir}/murphy.manifest
521 %{_bindir}/murphyd
522 %config %{_sysconfdir}/murphy
523 %{systemddir}/system/murphyd.service
524 %{_tmpfilesdir}/murphyd.conf
525 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
526 %{_sbindir}/asm-bridge
527 %endif
528 %if %{?_with_dbus:1}%{!?_with_dbus:0}
529 %{_sysconfdir}/dbus-1/system.d
530 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
531 %endif
532 %if %{?_with_websockets:1}%{!?_with_websockets:0}
533 %{_datadir}/murphy
534 %endif
535
536 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
537 %files core
538 %defattr(-,root,root,-)
539 %endif
540 %{_libdir}/libmurphy-common.so.*
541 %{_libdir}/libmurphy-core.so.*
542 %{_libdir}/libmurphy-resolver.so.*
543 %{_libdir}/libmurphy-resource.so.*
544 %{_libdir}/libmurphy-resource-backend.so.*
545 %if %{?_with_lua:1}%{!?_with_lua:0}
546 %{_libdir}/libmurphy-lua-utils.so.*
547 %{_libdir}/libmurphy-lua-decision.so.*
548 %endif
549 %{_libdir}/libmurphy-domain-controller.so.*
550 %{_libdir}/murphy/*.so.*
551 %{_libdir}/libbreedline*.so.*
552 %if %{?_with_dbus:1}%{!?_with_dbus:0}
553 %{_libdir}/libmurphy-libdbus.so.*
554 %{_libdir}/libmurphy-dbus-libdbus.so.*
555 %endif
556
557 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
558 %files plugins-base -f filelist.plugins-base
559 %defattr(-,root,root,-)
560 %endif
561 %{_libdir}/murphy/plugins/plugin-domain-control.so
562 %{_libdir}/murphy/plugins/plugin-resource-asm.so
563 %{_libdir}/murphy/plugins/plugin-resource-native.so
564
565 %files devel -f filelist.devel-includes
566 %defattr(-,root,root,-)
567 # %{_includedir}/murphy/config.h
568 # %{_includedir}/murphy/common.h
569 # #%{_includedir}/murphy/core.h
570 # %{_includedir}/murphy/common
571 # %{_includedir}/murphy/core
572 # %{_includedir}/murphy/resolver
573 # %{_includedir}/murphy/resource
574 # # hmmm... should handle disabled plugins properly.
575 # %{_includedir}/murphy/domain-control
576 # %{_includedir}/murphy/plugins
577 %{_includedir}/murphy-db
578 %{_libdir}/libmurphy-common.so
579 %{_libdir}/libmurphy-core.so
580 %{_libdir}/libmurphy-resolver.so
581 %{_libdir}/libmurphy-resource.so
582 %{_libdir}/libmurphy-resource-backend.so
583 %if %{?_with_lua:1}%{!?_with_lua:0}
584 %{_libdir}/libmurphy-lua-utils.so
585 %{_libdir}/libmurphy-lua-decision.so
586 %endif
587 %{_libdir}/libmurphy-domain-controller.so
588 %{_libdir}/murphy/*.so
589 %{_libdir}/pkgconfig/murphy-common.pc
590 %{_libdir}/pkgconfig/murphy-core.pc
591 %{_libdir}/pkgconfig/murphy-resolver.pc
592 #%{_libdir}/pkgconfig/murphy-resource.pc
593 %if %{?_with_lua:1}%{!?_with_lua:0}
594 %{_libdir}/pkgconfig/murphy-lua-utils.pc
595 %{_libdir}/pkgconfig/murphy-lua-decision.pc
596 %endif
597 %{_libdir}/pkgconfig/murphy-domain-controller.pc
598 %{_libdir}/pkgconfig/murphy-db.pc
599 %{_libdir}/pkgconfig/murphy-resource.pc
600 %{_includedir}/breedline
601 %{_libdir}/libbreedline*.so
602 %{_libdir}/pkgconfig/breedline*.pc
603 %if %{?_with_dbus:1}%{!?_with_dbus:0}
604 #%{_includedir}/murphy/dbus
605 %{_libdir}/libmurphy-libdbus.so
606 %{_libdir}/libmurphy-dbus-libdbus.so
607 %{_libdir}/pkgconfig/murphy-libdbus.pc
608 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
609 %endif
610
611 %files doc
612 %defattr(-,root,root,-)
613 %doc %{_docdir}/../murphy/AUTHORS
614 %doc %{_docdir}/../murphy/CODING-STYLE
615 %license %{_docdir}/../murphy/COPYING
616 %doc %{_docdir}/../murphy/ChangeLog
617 %doc %{_docdir}/../murphy/INSTALL
618 %doc %{_docdir}/../murphy/NEWS
619 %doc %{_docdir}/../murphy/README
620
621 %if %{?_with_pulse:1}%{!?_with_pulse:0}
622 %files pulse
623 %defattr(-,root,root,-)
624 %{_libdir}/libmurphy-pulse.so.*
625 %manifest %{_datadir}/murphy-pulse.manifest
626
627 %files pulse-devel
628 %defattr(-,root,root,-)
629 %{_includedir}/murphy/common/pulse-glue.h
630 %{_libdir}/libmurphy-pulse.so
631 %{_libdir}/pkgconfig/murphy-pulse.pc
632 %endif
633
634 %if %{?_with_ecore:1}%{!?_with_ecore:0}
635 %files ecore
636 %defattr(-,root,root,-)
637 %{_libdir}/libmurphy-ecore.so.*
638 %manifest %{_datadir}/murphy-ecore.manifest
639
640 %files ecore-devel
641 %defattr(-,root,root,-)
642 %{_includedir}/murphy/common/ecore-glue.h
643 %{_libdir}/libmurphy-ecore.so
644 %{_libdir}/pkgconfig/murphy-ecore.pc
645 %endif
646
647 %if %{?_with_glib:1}%{!?_with_glib:0}
648 %files glib
649 %defattr(-,root,root,-)
650 %{_libdir}/libmurphy-glib.so.*
651 %manifest %{_datadir}/murphy-glib.manifest
652
653 %files glib-devel
654 %defattr(-,root,root,-)
655 %{_includedir}/murphy/common/glib-glue.h
656 %{_libdir}/libmurphy-glib.so
657 %{_libdir}/pkgconfig/murphy-glib.pc
658 %endif
659
660 %if %{?_with_qt:1}%{!?_with_qt:0}
661 %files qt
662 %defattr(-,root,root,-)
663 %{_libdir}/libmurphy-qt.so.*
664 %manifest %{_datadir}/murphy-qt.manifest
665
666 %files qt-devel
667 %defattr(-,root,root,-)
668 %{_includedir}/murphy/common/qt-glue.h
669 %{_libdir}/libmurphy-qt.so
670 %{_libdir}/pkgconfig/murphy-qt.pc
671 %endif
672
673 %files tests
674 %defattr(-,root,root,-)
675 %{_bindir}/resource-client
676 %{_bindir}/resource-api-test
677 %{_bindir}/resource-api-fuzz
678 %{_bindir}/test-domain-controller
679 %{_bindir}/murphy-console
680 %manifest %{_datadir}/murphy-tests.manifest
681
682 %files ivi-resource-manager
683 %defattr(-,root,root,-)
684 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
685 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
686
687 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
688 %files system-controller
689 %defattr(-,root,root,-)
690 %{_libdir}/murphy/plugins/plugin-system-controller.so
691 %{systemddir}/user/ico-homescreen.service
692 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
693 %manifest %{_datadir}/murphy-system-controller.manifest
694 %endif
695
696 %changelog
697 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
698 - Initial build for 2.0alpha.