packaging: added aul dependency when building system-controller.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _with_icosyscon 1}}
22 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
23 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
24
25 # TODO: take care of /lib vs /lib64...
26 %define systemddir /lib/systemd
27
28 Summary: Murphy policy framework
29 Name: murphy
30 Version: 0.0.46
31 Release: 1
32 License: BSD-3-Clause
33 Group: System/Service
34 URL: http://01.org/murphy/
35 Source0: %{name}-%{version}.tar.gz
36 Source1: murphy.manifest
37 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
38 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
39 Requires: %{name}-core = %{version}
40 %endif
41
42 Requires(post): /bin/systemctl
43 Requires(postun): /bin/systemctl
44
45 BuildRequires: flex
46 BuildRequires: bison
47 BuildRequires: pkgconfig(lua)
48 BuildRequires: pkgconfig(libsystemd-daemon)
49 BuildRequires: pkgconfig(libsystemd-journal)
50
51 %if %{?_with_pulse:1}%{!?_with_pulse:0}
52 BuildRequires: pkgconfig(libpulse)
53 %endif
54 %if %{?_with_ecore:1}%{!?_with_ecore:0}
55 BuildRequires: pkgconfig(ecore)
56 BuildRequires: mesa-libEGL
57 BuildRequires: mesa-libGLESv2
58 %endif
59 %if %{?_with_glib:1}%{!?_with_glib:0}
60 BuildRequires: pkgconfig(glib-2.0)
61 %endif
62 %if %{?_with_qt:1}%{!?_with_qt:0}
63 BuildRequires: pkgconfig(QtCore)
64 %endif
65 %if %{?_with_dbus:1}%{!?_with_dbus:0}
66 BuildRequires: pkgconfig(dbus-1)
67 %endif
68 %if %{?_with_telephony:1}%{!?_with_telephony:0}
69 BuildRequires: pkgconfig(ofono)
70 %endif
71 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
72 BuildRequires: pkgconfig(audio-session-mgr)
73 BuildRequires: pkgconfig(aul)
74 %endif
75 %if %{?_with_websockets:1}%{!?_with_websockets:0}
76 BuildRequires: libwebsockets-devel
77 %endif
78 BuildRequires: pkgconfig(json)
79
80 %if %{?_with_smack:1}%{!?_with_smack:0}
81 BuildRequires: pkgconfig(libsmack)
82 %endif
83
84 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
85 BuildRequires: ico-uxf-weston-plugin-devel
86 BuildRequires: pkgconfig(ail)
87 BuildRequires: pkgconfig(aul)
88 BuildRequires: libxml2-devel
89 %endif
90
91 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
92 %package core
93 Summary: Murphy core runtime libraries
94 Group: System/Libraries
95
96 %package plugins-base
97 Summary: The basic set of Murphy plugins
98 Group: System/Service
99 Requires: %{name} = %{version}
100 Requires: %{name}-core = %{version}
101 %endif
102
103 %package devel
104 Summary: The header files and libraries needed for Murphy development
105 Group: System/Libraries
106 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
107 Requires: %{name}-core = %{version}
108 %else
109 Requires: %{name} = %{version}
110 %endif
111 Requires: libjson-devel
112
113 %package doc
114 Summary: Documentation for Murphy
115 Group: SDK/Documentation
116
117 %if %{?_with_pulse:1}%{!?_with_pulse:0}
118 %package pulse
119 Summary: Murphy PulseAudio mainloop integration
120 Group: System/Libraries
121 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
122 Requires: %{name}-core = %{version}
123 %else
124 Requires: %{name} = %{version}
125 %endif
126
127 %package pulse-devel
128 Summary: Murphy PulseAudio mainloop integration development files
129 Group: System/Libraries
130 Requires: %{name}-pulse = %{version}
131 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
132 Requires: %{name}-core = %{version}
133 %else
134 Requires: %{name} = %{version}
135 %endif
136 %endif
137
138 %if %{?_with_ecore:1}%{!?_with_ecore:0}
139 %package ecore
140 Summary: Murphy EFL/ecore mainloop integration
141 Group: System/Libraries
142 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
143 Requires: %{name}-core = %{version}
144 %else
145 Requires: %{name} = %{version}
146 %endif
147
148 %package ecore-devel
149 Summary: Murphy EFL/ecore mainloop integration development files
150 Group: System/Libraries
151 Requires: %{name}-ecore = %{version}
152 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
153 Requires: %{name}-core = %{version}
154 %else
155 Requires: %{name} = %{version}
156 %endif
157 %endif
158
159 %if %{?_with_glib:1}%{!?_with_glib:0}
160 %package glib
161 Summary: Murphy glib mainloop integration
162 Group: System/Libraries
163 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
164 Requires: %{name}-core = %{version}
165 %else
166 Requires: %{name} = %{version}
167 %endif
168
169 %package glib-devel
170 Summary: Murphy glib mainloop integration development files
171 Group: System/Libraries
172 Requires: %{name}-glib = %{version}
173 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
174 Requires: %{name}-core = %{version}
175 %else
176 Requires: %{name} = %{version}
177 %endif
178 %endif
179
180 %if %{?_with_qt:1}%{!?_with_qt:0}
181 %package qt
182 Summary: Murphy Qt mainloop integration
183 Group: System/Libraries
184 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
185 Requires: %{name}-core = %{version}
186 %else
187 Requires: %{name} = %{version}
188 %endif
189
190 %package qt-devel
191 Summary: Murphy Qt mainloop integration development files
192 Group: System/Libraries
193 Requires: %{name}-qt = %{version}
194 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
195 Requires: %{name}-core = %{version}
196 %else
197 Requires: %{name} = %{version}
198 %endif
199 %endif
200
201 %package tests
202 Summary: Various test binaries for Murphy
203 Group: System/Testing
204 Requires: %{name} = %{version}
205 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
206 Requires: %{name}-core = %{version}
207 %else
208 Requires: %{name} = %{version}
209 %endif
210
211 %package ivi-resource-manager
212 Summary: Murphy IVI resource manager plugin
213 Group: System/Service
214
215 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
216 %package system-controller
217 Summary: Murphy IVI System Controller plugin
218 Group: System/Service
219 Conflicts: murphy-ivi-resource-manager
220 %endif
221
222 %description
223 This package contains the basic daemon.
224
225 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
226 %description core
227 This package contains the core runtime libraries.
228
229 %description plugins-base
230 This package contains a basic set of plugins.
231 %endif
232
233 %description devel
234 This package contains header files and libraries necessary for development.
235
236 %description doc
237 This package contains documentation.
238
239 %if %{?_with_pulse:1}%{!?_with_pulse:0}
240 %description pulse
241 This package contains the Murphy PulseAudio mainloop integration runtime files.
242
243 %description pulse-devel
244 This package contains the Murphy PulseAudio mainloop integration development
245 files.
246 %endif
247
248 %if %{?_with_ecore:1}%{!?_with_ecore:0}
249 %description ecore
250 This package contains the Murphy EFL/ecore mainloop integration runtime files.
251
252 %description ecore-devel
253 This package contains the Murphy EFL/ecore mainloop integration development
254 files.
255 %endif
256
257 %if %{?_with_glib:1}%{!?_with_glib:0}
258 %description glib
259 This package contains the Murphy glib mainloop integration runtime files.
260
261 %description glib-devel
262 This package contains the Murphy glib mainloop integration development
263 files.
264 %endif
265
266 %if %{?_with_qt:1}%{!?_with_qt:0}
267 %description qt
268 This package contains the Murphy Qt mainloop integration runtime files.
269
270 %description qt-devel
271 This package contains the Murphy Qt mainloop integration development
272 files.
273 %endif
274
275 %description tests
276 This package contains various test binaries for Murphy.
277
278 %description ivi-resource-manager
279 This package contains the Murphy IVI resource manager plugin.
280
281 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
282 %description system-controller
283 This package contains the Murphy IVI resource manager plugin.
284 %endif
285
286 %prep
287 %setup -q
288
289 %build
290 %if %{?_with_debug:1}%{!?_with_debug:0}
291 export CFLAGS="-O0 -g3"
292 V="V=1"
293 %endif
294
295 CONFIG_OPTIONS=""
296 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
297
298 %if %{?_with_pulse:1}%{!?_with_pulse:0}
299 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
300 %else
301 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
302 %endif
303
304 %if %{?_with_ecore:1}%{!?_with_ecore:0}
305 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
306 %else
307 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
308 %endif
309
310 %if %{?_with_glib:1}%{!?_with_glib:0}
311 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
312 %else
313 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
314 %endif
315
316 %if %{?_with_qt:1}%{!?_with_qt:0}
317 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
318 %else
319 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
320 %endif
321
322 %if %{?_with_dbus:1}%{!?_with_dbus:0}
323 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
324 %else
325 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
326 %endif
327
328 %if %{?_with_telephony:1}%{!?_with_telephony:0}
329 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
330 %else
331 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
332 %endif
333
334 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
335 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
336 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
337 %else
338 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
339 %endif
340
341 %if %{?_with_websockets:1}%{!?_with_websockets:0}
342 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
343 %else
344 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
345 %endif
346
347 %if %{?_with_smack:1}%{!?_with_smack:0}
348 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
349 %else
350 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
351 %endif
352
353 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
354 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
355 %else
356 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
357 %endif
358
359 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
360 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
361 %else
362 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
363 %endif
364
365 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
366 grep '^processor *:' | wc -l`"
367 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
368
369 ./bootstrap && \
370 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
371 make clean && \
372 make -j$(($NUM_CPUS + 1)) $V
373
374 %install
375 rm -rf $RPM_BUILD_ROOT
376 %make_install
377
378 # Make sure we have a plugin dir even if all the basic plugins
379 # are configured to be built in.
380 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
381
382 # Get rid of any *.la files installed by libtool.
383 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
384
385 # Clean up also the murphy DB installation.
386 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
387
388 # Generate list of linkedin plugins (depends on the configuration).
389 outdir="`pwd`"
390 pushd $RPM_BUILD_ROOT >& /dev/null && \
391 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
392 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
393 popd >& /dev/null
394 echo "Found the following linked-in plugin files:"
395 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
396
397 # Generate list of header files, filtering ones that go to subpackages.
398 outdir="`pwd`"
399 pushd $RPM_BUILD_ROOT >& /dev/null && \
400 find ./%{_includedir}/murphy | \
401 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
402 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
403 popd >& /dev/null
404
405 # Replace the default sample/test config files with the packaging ones.
406 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
407 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
408
409 # Copy plugin configuration files in place.
410 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
411 cp packaging.in/amb-config.lua \
412 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
413
414 # Copy tmpfiles.d config file in place
415 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
416 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
417
418 # Copy the systemd files in place.
419 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
420 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
421 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
422 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
423 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
424 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
425 %endif
426
427 %if %{?_with_dbus:1}%{!?_with_dbus:0}
428 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
429 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
430 %endif
431
432 # copy the manifest file
433 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
434 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
435 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
436 %if %{?_with_qt:1}%{!?_with_qt:0}
437 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
438 %endif
439 %if %{?_with_glib:1}%{!?_with_glib:0}
440 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
441 %endif
442 %if %{?_with_pulse:1}%{!?_with_pulse:0}
443 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
444 %endif
445 %if %{?_with_ecore:1}%{!?_with_ecore:0}
446 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
447 %endif
448 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
449 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
450 %endif
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %post
456 /bin/systemctl enable murphyd.service
457
458 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
459 %post core
460 %endif
461 ldconfig
462
463 %postun
464 if [ "$1" = "0" ]; then
465 /bin/systemctl disable murphyd.service
466 fi
467
468 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
469 %postun core
470 %endif
471 ldconfig
472
473 %if %{?_with_glib:1}%{!?_with_glib:0}
474 %post glib
475 ldconfig
476
477 %postun glib
478 ldconfig
479 %endif
480
481 %if %{?_with_pulse:1}%{!?_with_pulse:0}
482 %post pulse
483 ldconfig
484
485 %postun pulse
486 ldconfig
487 %endif
488
489 %if %{?_with_ecore:1}%{!?_with_ecore:0}
490 %post ecore
491 ldconfig
492
493 %postun ecore
494 ldconfig
495 %endif
496
497 %if %{?_with_qt:1}%{!?_with_qt:0}
498 %post qt
499 lfconfig
500
501 %postun qt
502 ldconfig
503 %endif
504
505 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
506 %post system-controller
507 # prevent system controller from starting
508 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
509 # instead launch just ico-homescreen
510 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
511
512
513 %postun system-controller
514 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
515 ln -s %{systemddir}/user/ico-uxf-wait-launchpad-ready.path %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
516 %endif
517
518 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
519 %files -f filelist.plugins-base
520 %else
521 %files
522 %endif
523 %defattr(-,root,root,-)
524 %manifest %{_datadir}/murphy.manifest
525 %{_bindir}/murphyd
526 %config %{_sysconfdir}/murphy
527 %{systemddir}/system/murphyd.service
528 %{_tmpfilesdir}/murphyd.conf
529 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
530 %{_sbindir}/asm-bridge
531 %endif
532 %if %{?_with_dbus:1}%{!?_with_dbus:0}
533 %{_sysconfdir}/dbus-1/system.d
534 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
535 %endif
536 %if %{?_with_websockets:1}%{!?_with_websockets:0}
537 %{_datadir}/murphy
538 %endif
539
540 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
541 %files core
542 %defattr(-,root,root,-)
543 %endif
544 %{_libdir}/libmurphy-common.so.*
545 %{_libdir}/libmurphy-core.so.*
546 %{_libdir}/libmurphy-resolver.so.*
547 %{_libdir}/libmurphy-resource.so.*
548 %{_libdir}/libmurphy-resource-backend.so.*
549 %if %{?_with_lua:1}%{!?_with_lua:0}
550 %{_libdir}/libmurphy-lua-utils.so.*
551 %{_libdir}/libmurphy-lua-decision.so.*
552 %endif
553 %{_libdir}/libmurphy-domain-controller.so.*
554 %{_libdir}/murphy/*.so.*
555 %{_libdir}/libbreedline*.so.*
556 %if %{?_with_dbus:1}%{!?_with_dbus:0}
557 %{_libdir}/libmurphy-libdbus.so.*
558 %{_libdir}/libmurphy-dbus-libdbus.so.*
559 %endif
560
561 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
562 %files plugins-base -f filelist.plugins-base
563 %defattr(-,root,root,-)
564 %endif
565 %{_libdir}/murphy/plugins/plugin-domain-control.so
566 %{_libdir}/murphy/plugins/plugin-resource-asm.so
567 %{_libdir}/murphy/plugins/plugin-resource-native.so
568
569 %files devel -f filelist.devel-includes
570 %defattr(-,root,root,-)
571 # %{_includedir}/murphy/config.h
572 # %{_includedir}/murphy/common.h
573 # #%{_includedir}/murphy/core.h
574 # %{_includedir}/murphy/common
575 # %{_includedir}/murphy/core
576 # %{_includedir}/murphy/resolver
577 # %{_includedir}/murphy/resource
578 # # hmmm... should handle disabled plugins properly.
579 # %{_includedir}/murphy/domain-control
580 # %{_includedir}/murphy/plugins
581 %{_includedir}/murphy-db
582 %{_libdir}/libmurphy-common.so
583 %{_libdir}/libmurphy-core.so
584 %{_libdir}/libmurphy-resolver.so
585 %{_libdir}/libmurphy-resource.so
586 %{_libdir}/libmurphy-resource-backend.so
587 %if %{?_with_lua:1}%{!?_with_lua:0}
588 %{_libdir}/libmurphy-lua-utils.so
589 %{_libdir}/libmurphy-lua-decision.so
590 %endif
591 %{_libdir}/libmurphy-domain-controller.so
592 %{_libdir}/murphy/*.so
593 %{_libdir}/pkgconfig/murphy-common.pc
594 %{_libdir}/pkgconfig/murphy-core.pc
595 %{_libdir}/pkgconfig/murphy-resolver.pc
596 #%{_libdir}/pkgconfig/murphy-resource.pc
597 %if %{?_with_lua:1}%{!?_with_lua:0}
598 %{_libdir}/pkgconfig/murphy-lua-utils.pc
599 %{_libdir}/pkgconfig/murphy-lua-decision.pc
600 %endif
601 %{_libdir}/pkgconfig/murphy-domain-controller.pc
602 %{_libdir}/pkgconfig/murphy-db.pc
603 %{_libdir}/pkgconfig/murphy-resource.pc
604 %{_includedir}/breedline
605 %{_libdir}/libbreedline*.so
606 %{_libdir}/pkgconfig/breedline*.pc
607 %if %{?_with_dbus:1}%{!?_with_dbus:0}
608 #%{_includedir}/murphy/dbus
609 %{_libdir}/libmurphy-libdbus.so
610 %{_libdir}/libmurphy-dbus-libdbus.so
611 %{_libdir}/pkgconfig/murphy-libdbus.pc
612 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
613 %endif
614
615 %files doc
616 %defattr(-,root,root,-)
617 %doc %{_docdir}/../murphy/AUTHORS
618 %doc %{_docdir}/../murphy/CODING-STYLE
619 %license %{_docdir}/../murphy/COPYING
620 %doc %{_docdir}/../murphy/ChangeLog
621 %doc %{_docdir}/../murphy/INSTALL
622 %doc %{_docdir}/../murphy/NEWS
623 %doc %{_docdir}/../murphy/README
624
625 %if %{?_with_pulse:1}%{!?_with_pulse:0}
626 %files pulse
627 %defattr(-,root,root,-)
628 %{_libdir}/libmurphy-pulse.so.*
629 %manifest %{_datadir}/murphy-pulse.manifest
630
631 %files pulse-devel
632 %defattr(-,root,root,-)
633 %{_includedir}/murphy/common/pulse-glue.h
634 %{_libdir}/libmurphy-pulse.so
635 %{_libdir}/pkgconfig/murphy-pulse.pc
636 %endif
637
638 %if %{?_with_ecore:1}%{!?_with_ecore:0}
639 %files ecore
640 %defattr(-,root,root,-)
641 %{_libdir}/libmurphy-ecore.so.*
642 %manifest %{_datadir}/murphy-ecore.manifest
643
644 %files ecore-devel
645 %defattr(-,root,root,-)
646 %{_includedir}/murphy/common/ecore-glue.h
647 %{_libdir}/libmurphy-ecore.so
648 %{_libdir}/pkgconfig/murphy-ecore.pc
649 %endif
650
651 %if %{?_with_glib:1}%{!?_with_glib:0}
652 %files glib
653 %defattr(-,root,root,-)
654 %{_libdir}/libmurphy-glib.so.*
655 %manifest %{_datadir}/murphy-glib.manifest
656
657 %files glib-devel
658 %defattr(-,root,root,-)
659 %{_includedir}/murphy/common/glib-glue.h
660 %{_libdir}/libmurphy-glib.so
661 %{_libdir}/pkgconfig/murphy-glib.pc
662 %endif
663
664 %if %{?_with_qt:1}%{!?_with_qt:0}
665 %files qt
666 %defattr(-,root,root,-)
667 %{_libdir}/libmurphy-qt.so.*
668 %manifest %{_datadir}/murphy-qt.manifest
669
670 %files qt-devel
671 %defattr(-,root,root,-)
672 %{_includedir}/murphy/common/qt-glue.h
673 %{_libdir}/libmurphy-qt.so
674 %{_libdir}/pkgconfig/murphy-qt.pc
675 %endif
676
677 %files tests
678 %defattr(-,root,root,-)
679 %{_bindir}/resource-client
680 %{_bindir}/resource-api-test
681 %{_bindir}/resource-api-fuzz
682 %{_bindir}/test-domain-controller
683 %{_bindir}/murphy-console
684 %manifest %{_datadir}/murphy-tests.manifest
685
686 %files ivi-resource-manager
687 %defattr(-,root,root,-)
688 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
689 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
690
691 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
692 %files system-controller
693 %defattr(-,root,root,-)
694 %{_libdir}/murphy/plugins/plugin-system-controller.so
695 %{systemddir}/user/ico-homescreen.service
696 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
697 %manifest %{_datadir}/murphy-system-controller.manifest
698 %endif
699
700 %changelog
701 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
702 - Initial build for 2.0alpha.