packaging: preliminary manifest work.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _with_icosyscon 1}}
22 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
23
24 # TODO: take care of /lib vs /lib64...
25 %define systemddir /lib/systemd
26
27 Summary: Murphy policy framework
28 Name: murphy
29 Version: 0.0.40
30 Release: 1
31 License: BSD-3-Clause
32 Group: System/Service
33 URL: http://01.org/murphy/
34 Source0: %{name}-%{version}.tar.gz
35 Source1: murphy.manifest
36 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
38 Requires: %{name}-core = %{version}
39 %endif
40
41 Requires(post): /bin/systemctl
42 Requires(postun): /bin/systemctl
43
44 BuildRequires: flex
45 BuildRequires: bison
46 BuildRequires: pkgconfig(lua)
47 BuildRequires: pkgconfig(libsystemd-daemon)
48 BuildRequires: pkgconfig(libsystemd-journal)
49
50 %if %{?_with_pulse:1}%{!?_with_pulse:0}
51 BuildRequires: pkgconfig(libpulse)
52 %endif
53 %if %{?_with_ecore:1}%{!?_with_ecore:0}
54 BuildRequires: pkgconfig(ecore)
55 BuildRequires: mesa-libEGL
56 BuildRequires: mesa-libGLESv2
57 %endif
58 %if %{?_with_glib:1}%{!?_with_glib:0}
59 BuildRequires: pkgconfig(glib-2.0)
60 %endif
61 %if %{?_with_qt:1}%{!?_with_qt:0}
62 BuildRequires: pkgconfig(QtCore)
63 %endif
64 %if %{?_with_dbus:1}%{!?_with_dbus:0}
65 BuildRequires: pkgconfig(dbus-1)
66 %endif
67 %if %{?_with_telephony:1}%{!?_with_telephony:0}
68 BuildRequires: pkgconfig(ofono)
69 %endif
70 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
71 BuildRequires: pkgconfig(audio-session-mgr)
72 BuildRequires: pkgconfig(aul)
73 %endif
74 %if %{?_with_websockets:1}%{!?_with_websockets:0}
75 BuildRequires: libwebsockets-devel
76 %endif
77 BuildRequires: pkgconfig(json)
78
79 %if %{?_with_smack:1}%{!?_with_smack:0}
80 BuildRequires: pkgconfig(libsmack)
81 %endif
82
83 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
84 BuildRequires: ico-uxf-weston-plugin-devel
85 BuildRequires: pkgconfig(ail)
86 %endif
87
88 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
89 %package core
90 Summary: Murphy core runtime libraries
91 Group: System/Libraries
92
93 %package plugins-base
94 Summary: The basic set of Murphy plugins
95 Group: System/Service
96 Requires: %{name} = %{version}
97 Requires: %{name}-core = %{version}
98 %endif
99
100 %package devel
101 Summary: The header files and libraries needed for Murphy development
102 Group: System/Libraries
103 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
104 Requires: %{name}-core = %{version}
105 %else
106 Requires: %{name} = %{version}
107 %endif
108 Requires: libjson-devel
109
110 %package doc
111 Summary: Documentation for Murphy
112 Group: SDK/Documentation
113
114 %if %{?_with_pulse:1}%{!?_with_pulse:0}
115 %package pulse
116 Summary: Murphy PulseAudio mainloop integration
117 Group: System/Libraries
118 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
119 Requires: %{name}-core = %{version}
120 %else
121 Requires: %{name} = %{version}
122 %endif
123
124 %package pulse-devel
125 Summary: Murphy PulseAudio mainloop integration development files
126 Group: System/Libraries
127 Requires: %{name}-pulse = %{version}
128 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
129 Requires: %{name}-core = %{version}
130 %else
131 Requires: %{name} = %{version}
132 %endif
133 %endif
134
135 %if %{?_with_ecore:1}%{!?_with_ecore:0}
136 %package ecore
137 Summary: Murphy EFL/ecore mainloop integration
138 Group: System/Libraries
139 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
140 Requires: %{name}-core = %{version}
141 %else
142 Requires: %{name} = %{version}
143 %endif
144
145 %package ecore-devel
146 Summary: Murphy EFL/ecore mainloop integration development files
147 Group: System/Libraries
148 Requires: %{name}-ecore = %{version}
149 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
150 Requires: %{name}-core = %{version}
151 %else
152 Requires: %{name} = %{version}
153 %endif
154 %endif
155
156 %if %{?_with_glib:1}%{!?_with_glib:0}
157 %package glib
158 Summary: Murphy glib mainloop integration
159 Group: System/Libraries
160 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
161 Requires: %{name}-core = %{version}
162 %else
163 Requires: %{name} = %{version}
164 %endif
165
166 %package glib-devel
167 Summary: Murphy glib mainloop integration development files
168 Group: System/Libraries
169 Requires: %{name}-glib = %{version}
170 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
171 Requires: %{name}-core = %{version}
172 %else
173 Requires: %{name} = %{version}
174 %endif
175 %endif
176
177 %if %{?_with_qt:1}%{!?_with_qt:0}
178 %package qt
179 Summary: Murphy Qt mainloop integration
180 Group: System/Libraries
181 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
182 Requires: %{name}-core = %{version}
183 %else
184 Requires: %{name} = %{version}
185 %endif
186
187 %package qt-devel
188 Summary: Murphy Qt mainloop integration development files
189 Group: System/Libraries
190 Requires: %{name}-qt = %{version}
191 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
192 Requires: %{name}-core = %{version}
193 %else
194 Requires: %{name} = %{version}
195 %endif
196 %endif
197
198 %package tests
199 Summary: Various test binaries for Murphy
200 Group: System/Testing
201 Requires: %{name} = %{version}
202 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
203 Requires: %{name}-core = %{version}
204 %else
205 Requires: %{name} = %{version}
206 %endif
207
208 %description
209 This package contains the basic daemon.
210
211 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
212 %description core
213 This package contains the core runtime libraries.
214
215 %description plugins-base
216 This package contains a basic set of plugins.
217 %endif
218
219 %description devel
220 This package contains header files and libraries necessary for development.
221
222 %description doc
223 This package contains documentation.
224
225 %if %{?_with_pulse:1}%{!?_with_pulse:0}
226 %description pulse
227 This package contains the Murphy PulseAudio mainloop integration runtime files.
228
229 %description pulse-devel
230 This package contains the Murphy PulseAudio mainloop integration development
231 files.
232 %endif
233
234 %if %{?_with_ecore:1}%{!?_with_ecore:0}
235 %description ecore
236 This package contains the Murphy EFL/ecore mainloop integration runtime files.
237
238 %description ecore-devel
239 This package contains the Murphy EFL/ecore mainloop integration development
240 files.
241 %endif
242
243 %if %{?_with_glib:1}%{!?_with_glib:0}
244 %description glib
245 This package contains the Murphy glib mainloop integration runtime files.
246
247 %description glib-devel
248 This package contains the Murphy glib mainloop integration development
249 files.
250 %endif
251
252 %if %{?_with_qt:1}%{!?_with_qt:0}
253 %description qt
254 This package contains the Murphy Qt mainloop integration runtime files.
255
256 %description qt-devel
257 This package contains the Murphy Qt mainloop integration development
258 files.
259 %endif
260
261 %description tests
262 This package contains various test binaries for Murphy.
263
264 %prep
265 %setup -q
266
267 %build
268 %if %{?_with_debug:1}%{!?_with_debug:0}
269 export CFLAGS="-O0 -g3"
270 V="V=1"
271 %endif
272
273 CONFIG_OPTIONS=""
274 DYNAMIC_PLUGINS="domain-control"
275
276 %if %{?_with_pulse:1}%{!?_with_pulse:0}
277 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
278 %else
279 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
280 %endif
281
282 %if %{?_with_ecore:1}%{!?_with_ecore:0}
283 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
284 %else
285 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
286 %endif
287
288 %if %{?_with_glib:1}%{!?_with_glib:0}
289 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
290 %else
291 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
292 %endif
293
294 %if %{?_with_qt:1}%{!?_with_qt:0}
295 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
296 %else
297 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
298 %endif
299
300 %if %{?_with_dbus:1}%{!?_with_dbus:0}
301 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-dbus"
302 %else
303 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-dbus"
304 %endif
305
306 %if %{?_with_telephony:1}%{!?_with_telephony:0}
307 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
308 %else
309 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
310 %endif
311
312 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
313 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
314 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
315 %else
316 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
317 %endif
318
319 %if %{?_with_websockets:1}%{!?_with_websockets:0}
320 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
321 %else
322 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
323 %endif
324
325 %if %{?_with_smack:1}%{!?_with_smack:0}
326 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
327 %else
328 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
329 %endif
330
331 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
332 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
333 %else
334 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
335 %endif
336
337 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
338 grep '^processor *:' | wc -l`"
339 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
340
341 ./bootstrap && \
342 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
343 make clean && \
344 make -j$(($NUM_CPUS + 1)) $V
345
346 %install
347 rm -rf $RPM_BUILD_ROOT
348 %make_install
349
350 # Make sure we have a plugin dir even if all the basic plugins
351 # are configured to be built in.
352 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
353
354 # Get rid of any *.la files installed by libtool.
355 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
356
357 # Clean up also the murphy DB installation.
358 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
359
360 # Generate list of linkedin plugins (depends on the configuration).
361 outdir="`pwd`"
362 pushd $RPM_BUILD_ROOT >& /dev/null && \
363 find ./%{_libdir}/murphy/plugins -name libmurphy-plugin-*.so* | \
364 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
365 popd >& /dev/null
366
367 # Generate list of header files, filtering ones that go to subpackages.
368 outdir="`pwd`"
369 pushd $RPM_BUILD_ROOT >& /dev/null && \
370 find ./%{_includedir}/murphy | \
371 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
372 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
373 popd >& /dev/null
374
375 # Replace the default sample/test config files with the packaging ones.
376 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
377 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
378
379 # Copy plugin configuration files in place.
380 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
381 cp packaging.in/amb-config.lua \
382 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
383
384 # Copy tmpfiles.d config file in place
385 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
386 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
387
388 # Copy the systemd service file in place.
389 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
390 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
391
392 %if %{?_with_dbus:1}%{!?_with_dbus:0}
393 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
394 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
395 %endif
396
397 # copy the manifest file
398 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
399 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
400 %if %{?_with_qt:1}%{!?_with_qt:0}
401 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
402 %endif
403 %if %{?_with_glib:1}%{!?_with_glib:0}
404 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
405 %endif
406 %if %{?_with_pulse:1}%{!?_with_pulse:0}
407 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
408 %endif
409 %if %{?_with_ecore:1}%{!?_with_ecore:0}
410 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
411 %endif
412
413 %clean
414 rm -rf $RPM_BUILD_ROOT
415
416 %post
417 /bin/systemctl enable murphyd.service
418
419 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
420 %post core
421 %endif
422 ldconfig
423
424 %postun
425 if [ "$1" = "0" ]; then
426 /bin/systemctl disable murphyd.service
427 fi
428
429 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
430 %postun core
431 %endif
432 ldconfig
433
434 %if %{?_with_glib:1}%{!?_with_glib:0}
435 %post glib
436 ldconfig
437
438 %postun glib
439 ldconfig
440 %endif
441
442 %if %{?_with_pulse:1}%{!?_with_pulse:0}
443 %post pulse
444 ldconfig
445
446 %postun pulse
447 ldconfig
448 %endif
449
450 %if %{?_with_ecore:1}%{!?_with_ecore:0}
451 %post ecore
452 ldconfig
453
454 %postun ecore
455 ldconfig
456 %endif
457
458 %if %{?_with_qt:1}%{!?_with_qt:0}
459 %post qt
460 lfconfig
461
462 %postun qt
463 ldconfig
464 %endif
465
466 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
467 %files -f filelist.plugins-base
468 %else
469 %files
470 %endif
471 %defattr(-,root,root,-)
472 %manifest %{_datadir}/murphy.manifest
473 %{_bindir}/murphyd
474 %config %{_sysconfdir}/murphy
475 %{systemddir}/system/murphyd.service
476 %{_tmpfilesdir}/murphyd.conf
477 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
478 %{_sbindir}/asm-bridge
479 %endif
480 %if %{?_with_dbus:1}%{!?_with_dbus:0}
481 %{_sysconfdir}/dbus-1/system.d
482 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
483 %endif
484 %if %{?_with_websockets:1}%{!?_with_websockets:0}
485 %{_datadir}/murphy
486 %endif
487
488 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
489 %files core
490 %defattr(-,root,root,-)
491 %endif
492 %{_libdir}/libmurphy-common.so.*
493 %{_libdir}/libmurphy-core.so.*
494 %{_libdir}/libmurphy-resolver.so.*
495 %{_libdir}/libmurphy-resource.so.*
496 %{_libdir}/libmurphy-resource-backend.so.*
497 %if %{?_with_lua:1}%{!?_with_lua:0}
498 %{_libdir}/libmurphy-lua-utils.so.*
499 %{_libdir}/libmurphy-lua-decision.so.*
500 %endif
501 %{_libdir}/libmurphy-domain-controller.so.*
502 %{_libdir}/murphy/*.so.*
503 %{_libdir}/libbreedline*.so.*
504 %if %{?_with_dbus:1}%{!?_with_dbus:0}
505 %{_libdir}/libmurphy-dbus.so.*
506 %endif
507
508 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
509 %files plugins-base -f filelist.plugins-base
510 %defattr(-,root,root,-)
511 %endif
512 %{_libdir}/murphy/plugins
513 %{_libdir}/libmurphy-plugin-system-controller.so*
514
515 %files devel -f filelist.devel-includes
516 %defattr(-,root,root,-)
517 # %{_includedir}/murphy/config.h
518 # %{_includedir}/murphy/common.h
519 # #%{_includedir}/murphy/core.h
520 # %{_includedir}/murphy/common
521 # %{_includedir}/murphy/core
522 # %{_includedir}/murphy/resolver
523 # %{_includedir}/murphy/resource
524 # # hmmm... should handle disabled plugins properly.
525 # %{_includedir}/murphy/domain-control
526 # %{_includedir}/murphy/plugins
527 %{_includedir}/murphy-db
528 %{_libdir}/libmurphy-common.so
529 %{_libdir}/libmurphy-core.so
530 %{_libdir}/libmurphy-resolver.so
531 %{_libdir}/libmurphy-resource.so
532 %{_libdir}/libmurphy-resource-backend.so
533 %if %{?_with_lua:1}%{!?_with_lua:0}
534 %{_libdir}/libmurphy-lua-utils.so
535 %{_libdir}/libmurphy-lua-decision.so
536 %endif
537 %{_libdir}/libmurphy-domain-controller.so
538 %{_libdir}/murphy/*.so
539 %{_libdir}/pkgconfig/murphy-common.pc
540 %{_libdir}/pkgconfig/murphy-core.pc
541 %{_libdir}/pkgconfig/murphy-resolver.pc
542 #%{_libdir}/pkgconfig/murphy-resource.pc
543 %if %{?_with_lua:1}%{!?_with_lua:0}
544 %{_libdir}/pkgconfig/murphy-lua-utils.pc
545 %{_libdir}/pkgconfig/murphy-lua-decision.pc
546 %endif
547 %{_libdir}/pkgconfig/murphy-domain-controller.pc
548 %{_libdir}/pkgconfig/murphy-db.pc
549 %{_libdir}/pkgconfig/murphy-resource.pc
550 %{_includedir}/breedline
551 %{_libdir}/libbreedline*.so
552 %{_libdir}/pkgconfig/breedline*.pc
553 %if %{?_with_dbus:1}%{!?_with_dbus:0}
554 #%{_includedir}/murphy/dbus
555 %{_libdir}/libmurphy-dbus.so
556 %{_libdir}/pkgconfig/murphy-dbus.pc
557 %endif
558
559 %files doc
560 %defattr(-,root,root,-)
561 %doc %{_docdir}/../murphy/AUTHORS
562 %doc %{_docdir}/../murphy/CODING-STYLE
563 %license %{_docdir}/../murphy/COPYING
564 %doc %{_docdir}/../murphy/ChangeLog
565 %doc %{_docdir}/../murphy/INSTALL
566 %doc %{_docdir}/../murphy/NEWS
567 %doc %{_docdir}/../murphy/README
568
569 %if %{?_with_pulse:1}%{!?_with_pulse:0}
570 %files pulse
571 %defattr(-,root,root,-)
572 %{_libdir}/libmurphy-pulse.so.*
573 %manifest %{_datadir}/murphy-pulse.manifest
574
575 %files pulse-devel
576 %defattr(-,root,root,-)
577 %{_includedir}/murphy/common/pulse-glue.h
578 %{_libdir}/libmurphy-pulse.so
579 %{_libdir}/pkgconfig/murphy-pulse.pc
580 %endif
581
582 %if %{?_with_ecore:1}%{!?_with_ecore:0}
583 %files ecore
584 %defattr(-,root,root,-)
585 %{_libdir}/libmurphy-ecore.so.*
586 %manifest %{_datadir}/murphy-ecore.manifest
587
588 %files ecore-devel
589 %defattr(-,root,root,-)
590 %{_includedir}/murphy/common/ecore-glue.h
591 %{_libdir}/libmurphy-ecore.so
592 %{_libdir}/pkgconfig/murphy-ecore.pc
593 %endif
594
595 %if %{?_with_glib:1}%{!?_with_glib:0}
596 %files glib
597 %defattr(-,root,root,-)
598 %{_libdir}/libmurphy-glib.so.*
599 %manifest %{_datadir}/murphy-glib.manifest
600
601 %files glib-devel
602 %defattr(-,root,root,-)
603 %{_includedir}/murphy/common/glib-glue.h
604 %{_libdir}/libmurphy-glib.so
605 %{_libdir}/pkgconfig/murphy-glib.pc
606 %endif
607
608 %if %{?_with_qt:1}%{!?_with_qt:0}
609 %files qt
610 %defattr(-,root,root,-)
611 %{_libdir}/libmurphy-qt.so.*
612 %manifest %{_datadir}/murphy-qt.manifest
613
614 %files qt-devel
615 %defattr(-,root,root,-)
616 %{_includedir}/murphy/common/qt-glue.h
617 %{_libdir}/libmurphy-qt.so
618 %{_libdir}/pkgconfig/murphy-qt.pc
619 %endif
620
621 %files tests
622 %defattr(-,root,root,-)
623 %{_bindir}/resource-client
624 %{_bindir}/resource-api-test
625 %{_bindir}/resource-api-fuzz
626 %{_bindir}/test-domain-controller
627 %{_bindir}/murphy-console
628 %manifest %{_datadir}/murphy-tests.manifest
629
630 %changelog
631 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
632 - Initial build for 2.0alpha.