packaging: system-controller needs to list an explicit conflict.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %define _with_icosyscon 1
11
12 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
13 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
14 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
15 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
16 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
17 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
18 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
19 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
20 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
21 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
22 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
23 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
24 %{!?_with_icoweston:%{!?_without_icoweston:%define _without_icoweston 1}}
25 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
26 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
27
28 # TODO: take care of /lib vs /lib64...
29 %define systemddir /lib/systemd
30
31 #
32 # Abnormalize _with_icosyscon to _enable_icosyscon
33 #
34 # Since some people seem to have a hard time understanding that
35 #
36 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
37 #    undefined as opposed to defining it to 0
38 #
39 # 2) if you decide to do it the wrong way at least you should be consistent
40 #    about it and not randomly change between the conventions
41 #
42 # we need to roll this butt-ugly hack to make sure that we always go with
43 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
44 # on how _with_icosyscon happens to be set (or unset).
45 #
46
47 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
48 %if %{_with_icosyscon}
49 %define _enable_icosyscon 1
50 %else
51 %define _enable_icosyscon 0
52 %endif
53 %else
54 %define _enable_icosyscon 0
55 %endif
56
57 Summary: Murphy policy framework
58 Name: murphy
59 Version: 0.0.54
60 Release: 1
61 License: BSD-3-Clause
62 Group: System/Service
63 URL: http://01.org/murphy/
64 Source0: %{name}-%{version}.tar.gz
65 Source1: murphy.manifest
66 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
67 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
68 Requires: %{name}-core = %{version}
69 %endif
70
71 Requires(post): /bin/systemctl
72 Requires(post): libcap-tools
73 Requires(postun): /bin/systemctl
74
75 BuildRequires: flex
76 BuildRequires: bison
77 BuildRequires: pkgconfig(lua)
78 BuildRequires: pkgconfig(libsystemd-daemon)
79 BuildRequires: pkgconfig(libsystemd-journal)
80 BuildRequires: pkgconfig(libcap)
81 BuildRequires: pkgconfig(libtzplatform-config)
82
83 %if %{?_with_pulse:1}%{!?_with_pulse:0}
84 BuildRequires: pkgconfig(libpulse)
85 %endif
86 %if %{?_with_ecore:1}%{!?_with_ecore:0}
87 BuildRequires: pkgconfig(ecore)
88 BuildRequires: mesa-libEGL
89 BuildRequires: mesa-libGLESv2
90 %endif
91 %if %{?_with_glib:1}%{!?_with_glib:0}
92 BuildRequires: pkgconfig(glib-2.0)
93 %endif
94 %if %{?_with_qt:1}%{!?_with_qt:0}
95 BuildRequires: pkgconfig(QtCore)
96 %endif
97 %if %{?_with_dbus:1}%{!?_with_dbus:0}
98 BuildRequires: pkgconfig(dbus-1)
99 %endif
100 %if %{?_with_telephony:1}%{!?_with_telephony:0}
101 BuildRequires: pkgconfig(ofono)
102 %endif
103 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
104 BuildRequires: pkgconfig(audio-session-mgr)
105 BuildRequires: pkgconfig(aul)
106 %endif
107 %if %{?_with_websockets:1}%{!?_with_websockets:0}
108 BuildRequires: libwebsockets-devel
109 %endif
110 BuildRequires: pkgconfig(json)
111
112 %if %{?_with_smack:1}%{!?_with_smack:0}
113 BuildRequires: pkgconfig(libsmack)
114 %endif
115
116 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
117 #%if %{_with_icosyscon} # gbs can't, so don't bother...
118 BuildRequires: ico-uxf-weston-plugin-devel
119 BuildRequires: weston-ivi-shell-devel
120 BuildRequires: genivi-shell-devel
121 BuildRequires: pkgconfig(ail)
122 BuildRequires: pkgconfig(aul)
123 BuildRequires: libxml2-devel
124 #%endif
125 %endif
126
127 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
128 %package core
129 Summary: Murphy core runtime libraries
130 Group: System/Libraries
131
132 %package plugins-base
133 Summary: The basic set of Murphy plugins
134 Group: System/Service
135 Requires: %{name} = %{version}
136 Requires: %{name}-core = %{version}
137 %endif
138
139 %package devel
140 Summary: The header files and libraries needed for Murphy development
141 Group: System/Libraries
142 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
143 Requires: %{name}-core = %{version}
144 %else
145 Requires: %{name} = %{version}
146 %endif
147 Requires: libjson-devel
148
149 %package doc
150 Summary: Documentation for Murphy
151 Group: SDK/Documentation
152
153 %if %{?_with_pulse:1}%{!?_with_pulse:0}
154 %package pulse
155 Summary: Murphy PulseAudio mainloop integration
156 Group: System/Libraries
157 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
158 Requires: %{name}-core = %{version}
159 %else
160 Requires: %{name} = %{version}
161 %endif
162
163 %package pulse-devel
164 Summary: Murphy PulseAudio mainloop integration development files
165 Group: System/Libraries
166 Requires: %{name}-pulse = %{version}
167 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
168 Requires: %{name}-core = %{version}
169 %else
170 Requires: %{name} = %{version}
171 %endif
172 %endif
173
174 %if %{?_with_ecore:1}%{!?_with_ecore:0}
175 %package ecore
176 Summary: Murphy EFL/ecore mainloop integration
177 Group: System/Libraries
178 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
179 Requires: %{name}-core = %{version}
180 %else
181 Requires: %{name} = %{version}
182 %endif
183
184 %package ecore-devel
185 Summary: Murphy EFL/ecore mainloop integration development files
186 Group: System/Libraries
187 Requires: %{name}-ecore = %{version}
188 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
189 Requires: %{name}-core = %{version}
190 %else
191 Requires: %{name} = %{version}
192 %endif
193 %endif
194
195 %if %{?_with_glib:1}%{!?_with_glib:0}
196 %package glib
197 Summary: Murphy glib mainloop integration
198 Group: System/Libraries
199 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
200 Requires: %{name}-core = %{version}
201 %else
202 Requires: %{name} = %{version}
203 %endif
204
205 %package glib-devel
206 Summary: Murphy glib mainloop integration development files
207 Group: System/Libraries
208 Requires: %{name}-glib = %{version}
209 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
210 Requires: %{name}-core = %{version}
211 %else
212 Requires: %{name} = %{version}
213 %endif
214 %endif
215
216 %if %{?_with_qt:1}%{!?_with_qt:0}
217 %package qt
218 Summary: Murphy Qt mainloop integration
219 Group: System/Libraries
220 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
221 Requires: %{name}-core = %{version}
222 %else
223 Requires: %{name} = %{version}
224 %endif
225
226 %package qt-devel
227 Summary: Murphy Qt mainloop integration development files
228 Group: System/Libraries
229 Requires: %{name}-qt = %{version}
230 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
231 Requires: %{name}-core = %{version}
232 %else
233 Requires: %{name} = %{version}
234 %endif
235 %endif
236
237 %package tests
238 Summary: Various test binaries for Murphy
239 Group: System/Testing
240 Requires: %{name} = %{version}
241 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
242 Requires: %{name}-core = %{version}
243 %else
244 Requires: %{name} = %{version}
245 %endif
246
247 %package ivi-resource-manager
248 Summary: Murphy IVI resource manager plugin
249 Group: System/Service
250
251 %if %{_enable_icosyscon}
252 %package system-controller
253 Summary: Murphy IVI System Controller plugin
254 Group: System/Service
255 Requires: ico-uxf-homescreen
256 Conflicts: murphy-ivi-resource-manager
257 Provides: system-controller
258 Conflicts: ico-uxf-homescreen-system-controller
259 %endif
260
261 %description
262 This package contains the basic daemon.
263
264 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
265 %description core
266 This package contains the core runtime libraries.
267
268 %description plugins-base
269 This package contains a basic set of plugins.
270 %endif
271
272 %description devel
273 This package contains header files and libraries necessary for development.
274
275 %description doc
276 This package contains documentation.
277
278 %if %{?_with_pulse:1}%{!?_with_pulse:0}
279 %description pulse
280 This package contains the Murphy PulseAudio mainloop integration runtime files.
281
282 %description pulse-devel
283 This package contains the Murphy PulseAudio mainloop integration development
284 files.
285 %endif
286
287 %if %{?_with_ecore:1}%{!?_with_ecore:0}
288 %description ecore
289 This package contains the Murphy EFL/ecore mainloop integration runtime files.
290
291 %description ecore-devel
292 This package contains the Murphy EFL/ecore mainloop integration development
293 files.
294 %endif
295
296 %if %{?_with_glib:1}%{!?_with_glib:0}
297 %description glib
298 This package contains the Murphy glib mainloop integration runtime files.
299
300 %description glib-devel
301 This package contains the Murphy glib mainloop integration development
302 files.
303 %endif
304
305 %if %{?_with_qt:1}%{!?_with_qt:0}
306 %description qt
307 This package contains the Murphy Qt mainloop integration runtime files.
308
309 %description qt-devel
310 This package contains the Murphy Qt mainloop integration development
311 files.
312 %endif
313
314 %description tests
315 This package contains various test binaries for Murphy.
316
317 %description ivi-resource-manager
318 This package contains the Murphy IVI resource manager plugin.
319
320 %if %{_enable_icosyscon}
321 %description system-controller
322 This package contains the Murphy IVI resource manager plugin.
323 %endif
324
325 %prep
326 %setup -q
327
328 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
329 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
330
331 %build
332 %if %{?_with_debug:1}%{!?_with_debug:0}
333 export CFLAGS="-O0 -g3"
334 V="V=1"
335 %endif
336
337 CONFIG_OPTIONS=""
338 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
339
340 %if %{?_with_pulse:1}%{!?_with_pulse:0}
341 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
342 %else
343 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
344 %endif
345
346 %if %{?_with_ecore:1}%{!?_with_ecore:0}
347 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
348 %else
349 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
350 %endif
351
352 %if %{?_with_glib:1}%{!?_with_glib:0}
353 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
354 %else
355 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
356 %endif
357
358 %if %{?_with_qt:1}%{!?_with_qt:0}
359 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
360 %else
361 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
362 %endif
363
364 %if %{?_with_dbus:1}%{!?_with_dbus:0}
365 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
366 %else
367 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
368 %endif
369
370 %if %{?_with_telephony:1}%{!?_with_telephony:0}
371 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
372 %else
373 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
374 %endif
375
376 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
377 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
378 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
379 %else
380 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
381 %endif
382
383 %if %{?_with_websockets:1}%{!?_with_websockets:0}
384 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
385 %else
386 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
387 %endif
388
389 %if %{?_with_smack:1}%{!?_with_smack:0}
390 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
391 %else
392 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
393 %endif
394
395 %if %{_enable_icosyscon}
396 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
397 %else
398 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
399 %endif
400
401 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
402 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
403 %else
404 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
405 %endif
406
407 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
408 grep '^processor *:' | wc -l`"
409 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
410
411 ./bootstrap && \
412 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
413 make clean && \
414 make -j$(($NUM_CPUS + 1)) $V
415
416 %install
417 rm -rf $RPM_BUILD_ROOT
418 %make_install
419
420 # Make sure we have a plugin dir even if all the basic plugins
421 # are configured to be built in.
422 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
423
424 # Get rid of any *.la files installed by libtool.
425 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
426
427 # Clean up also the murphy DB installation.
428 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
429
430 # Generate list of linkedin plugins (depends on the configuration).
431 outdir="`pwd`"
432 pushd $RPM_BUILD_ROOT >& /dev/null && \
433 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
434 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
435 popd >& /dev/null
436 echo "Found the following linked-in plugin files:"
437 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
438
439 # Generate list of header files, filtering ones that go to subpackages.
440 outdir="`pwd`"
441 pushd $RPM_BUILD_ROOT >& /dev/null && \
442 find ./%{_includedir}/murphy | \
443 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
444 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
445 popd >& /dev/null
446
447 # Replace the default sample/test config files with the packaging ones.
448 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/murphy/*
449 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
450 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
451
452 # Copy plugin configuration files in place.
453 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
454 cp packaging.in/amb-config.lua \
455 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
456
457 # Copy tmpfiles.d config file in place
458 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
459 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
460
461 # Copy the systemd files in place.
462 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
463 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
464 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
465 %if %{_enable_icosyscon}
466 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
467 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
468 %endif
469
470 %if %{?_with_dbus:1}%{!?_with_dbus:0}
471 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
472 sed "s/@TZ_SYS_USER_GROUP@/%{TZ_SYS_USER_GROUP}/g" packaging.in/org.Murphy.conf.in > packaging.in/org.Murphy.conf
473 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
474 %endif
475
476 # copy the manifest file
477 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
478 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
479 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
480 %if %{?_with_qt:1}%{!?_with_qt:0}
481 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
482 %endif
483 %if %{?_with_glib:1}%{!?_with_glib:0}
484 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
485 %endif
486 %if %{?_with_pulse:1}%{!?_with_pulse:0}
487 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
488 %endif
489 %if %{?_with_ecore:1}%{!?_with_ecore:0}
490 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
491 %endif
492 %if %{_enable_icosyscon}
493 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
494 %endif
495
496 %clean
497 rm -rf $RPM_BUILD_ROOT
498
499 %post
500 /bin/systemctl enable murphyd.service
501 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
502
503 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
504 %post core
505 %endif
506 ldconfig
507
508 %postun
509 if [ "$1" = "0" ]; then
510 /bin/systemctl disable murphyd.service
511 fi
512
513 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
514 %postun core
515 %endif
516 ldconfig
517
518 %if %{?_with_glib:1}%{!?_with_glib:0}
519 %post glib
520 ldconfig
521
522 %postun glib
523 ldconfig
524 %endif
525
526 %if %{?_with_pulse:1}%{!?_with_pulse:0}
527 %post pulse
528 ldconfig
529
530 %postun pulse
531 ldconfig
532 %endif
533
534 %if %{?_with_ecore:1}%{!?_with_ecore:0}
535 %post ecore
536 ldconfig
537
538 %postun ecore
539 ldconfig
540 %endif
541
542 %if %{?_with_qt:1}%{!?_with_qt:0}
543 %post qt
544 lfconfig
545
546 %postun qt
547 ldconfig
548 %endif
549
550 %if %{_enable_icosyscon}
551 %post system-controller
552 # prevent system controller from starting
553 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
554 # instead launch just ico-homescreen
555 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
556 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path \
557     %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
558
559 %postun system-controller
560 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
561 if [ -f %{systemddir}/user/ico-uxf-wait-launchpad-ready.path ]; then
562     ln -sf %{systemddir}/user/ico-uxf-wait-launchpad-ready.path \
563         %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
564 fi
565 %endif
566
567 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
568 %files -f filelist.plugins-base
569 %else
570 %files
571 %endif
572 %defattr(-,root,root,-)
573 %manifest %{_datadir}/murphy.manifest
574 %{_bindir}/murphyd
575 %config %{_sysconfdir}/murphy
576 %{systemddir}/system/murphyd.service
577 %{_tmpfilesdir}/murphyd.conf
578 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
579 %{_sbindir}/asm-bridge
580 %endif
581 %if %{?_with_dbus:1}%{!?_with_dbus:0}
582 %{_sysconfdir}/dbus-1/system.d
583 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
584 %endif
585 %if %{?_with_websockets:1}%{!?_with_websockets:0}
586 %{_datadir}/murphy
587 %endif
588
589 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
590 %files core
591 %defattr(-,root,root,-)
592 %endif
593 %{_libdir}/libmurphy-common.so.*
594 %{_libdir}/libmurphy-core.so.*
595 %{_libdir}/libmurphy-resolver.so.*
596 %{_libdir}/libmurphy-resource.so.*
597 %{_libdir}/libmurphy-resource-backend.so.*
598 %if %{?_with_lua:1}%{!?_with_lua:0}
599 %{_libdir}/libmurphy-lua-utils.so.*
600 %{_libdir}/libmurphy-lua-decision.so.*
601 %endif
602 %{_libdir}/libmurphy-domain-controller.so.*
603 %{_libdir}/murphy/*.so.*
604 %{_libdir}/libbreedline*.so.*
605 %if %{?_with_dbus:1}%{!?_with_dbus:0}
606 %{_libdir}/libmurphy-libdbus.so.*
607 %{_libdir}/libmurphy-dbus-libdbus.so.*
608 %endif
609
610 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
611 %files plugins-base -f filelist.plugins-base
612 %defattr(-,root,root,-)
613 %endif
614 %{_libdir}/murphy/plugins/plugin-domain-control.so
615 %{_libdir}/murphy/plugins/plugin-resource-asm.so
616 %{_libdir}/murphy/plugins/plugin-resource-native.so
617
618 %files devel -f filelist.devel-includes
619 %defattr(-,root,root,-)
620 # %{_includedir}/murphy/config.h
621 # %{_includedir}/murphy/common.h
622 # #%{_includedir}/murphy/core.h
623 # %{_includedir}/murphy/common
624 # %{_includedir}/murphy/core
625 # %{_includedir}/murphy/resolver
626 # %{_includedir}/murphy/resource
627 # # hmmm... should handle disabled plugins properly.
628 # %{_includedir}/murphy/domain-control
629 # %{_includedir}/murphy/plugins
630 %{_includedir}/murphy-db
631 %{_libdir}/libmurphy-common.so
632 %{_libdir}/libmurphy-core.so
633 %{_libdir}/libmurphy-resolver.so
634 %{_libdir}/libmurphy-resource.so
635 %{_libdir}/libmurphy-resource-backend.so
636 %if %{?_with_lua:1}%{!?_with_lua:0}
637 %{_libdir}/libmurphy-lua-utils.so
638 %{_libdir}/libmurphy-lua-decision.so
639 %endif
640 %{_libdir}/libmurphy-domain-controller.so
641 %{_libdir}/murphy/*.so
642 %{_libdir}/pkgconfig/murphy-common.pc
643 %{_libdir}/pkgconfig/murphy-core.pc
644 %{_libdir}/pkgconfig/murphy-resolver.pc
645 #%{_libdir}/pkgconfig/murphy-resource.pc
646 %if %{?_with_lua:1}%{!?_with_lua:0}
647 %{_libdir}/pkgconfig/murphy-lua-utils.pc
648 %{_libdir}/pkgconfig/murphy-lua-decision.pc
649 %endif
650 %{_libdir}/pkgconfig/murphy-domain-controller.pc
651 %{_libdir}/pkgconfig/murphy-db.pc
652 %{_libdir}/pkgconfig/murphy-resource.pc
653 %{_includedir}/breedline
654 %{_libdir}/libbreedline*.so
655 %{_libdir}/pkgconfig/breedline*.pc
656 %if %{?_with_dbus:1}%{!?_with_dbus:0}
657 #%{_includedir}/murphy/dbus
658 %{_libdir}/libmurphy-libdbus.so
659 %{_libdir}/libmurphy-dbus-libdbus.so
660 %{_libdir}/pkgconfig/murphy-libdbus.pc
661 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
662 %endif
663
664 %files doc
665 %defattr(-,root,root,-)
666 %doc %{_docdir}/../murphy/AUTHORS
667 %doc %{_docdir}/../murphy/CODING-STYLE
668 %doc %{_docdir}/../murphy/ChangeLog
669 %doc %{_docdir}/../murphy/NEWS
670 %doc %{_docdir}/../murphy/README
671 %license COPYING LICENSE-BSD
672
673 %if %{?_with_pulse:1}%{!?_with_pulse:0}
674 %files pulse
675 %defattr(-,root,root,-)
676 %{_libdir}/libmurphy-pulse.so.*
677 %manifest %{_datadir}/murphy-pulse.manifest
678
679 %files pulse-devel
680 %defattr(-,root,root,-)
681 %{_includedir}/murphy/common/pulse-glue.h
682 %{_libdir}/libmurphy-pulse.so
683 %{_libdir}/pkgconfig/murphy-pulse.pc
684 %endif
685
686 %if %{?_with_ecore:1}%{!?_with_ecore:0}
687 %files ecore
688 %defattr(-,root,root,-)
689 %{_libdir}/libmurphy-ecore.so.*
690 %manifest %{_datadir}/murphy-ecore.manifest
691
692 %files ecore-devel
693 %defattr(-,root,root,-)
694 %{_includedir}/murphy/common/ecore-glue.h
695 %{_libdir}/libmurphy-ecore.so
696 %{_libdir}/pkgconfig/murphy-ecore.pc
697 %endif
698
699 %if %{?_with_glib:1}%{!?_with_glib:0}
700 %files glib
701 %defattr(-,root,root,-)
702 %{_libdir}/libmurphy-glib.so.*
703 %manifest %{_datadir}/murphy-glib.manifest
704
705 %files glib-devel
706 %defattr(-,root,root,-)
707 %{_includedir}/murphy/common/glib-glue.h
708 %{_libdir}/libmurphy-glib.so
709 %{_libdir}/pkgconfig/murphy-glib.pc
710 %endif
711
712 %if %{?_with_qt:1}%{!?_with_qt:0}
713 %files qt
714 %defattr(-,root,root,-)
715 %{_libdir}/libmurphy-qt.so.*
716 %manifest %{_datadir}/murphy-qt.manifest
717
718 %files qt-devel
719 %defattr(-,root,root,-)
720 %{_includedir}/murphy/common/qt-glue.h
721 %{_libdir}/libmurphy-qt.so
722 %{_libdir}/pkgconfig/murphy-qt.pc
723 %endif
724
725 %files tests
726 %defattr(-,root,root,-)
727 %{_bindir}/resource-client
728 %{_bindir}/resource-api-test
729 %{_bindir}/resource-api-fuzz
730 %{_bindir}/test-domain-controller
731 %{_bindir}/murphy-console
732 %manifest %{_datadir}/murphy-tests.manifest
733
734 %files ivi-resource-manager
735 %defattr(-,root,root,-)
736 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
737 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
738
739 %if %{_enable_icosyscon}
740 %files system-controller
741 %defattr(-,root,root,-)
742 %{_libdir}/murphy/plugins/plugin-system-controller.so
743 %{systemddir}/user/ico-homescreen.service
744 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
745 %manifest %{_datadir}/murphy-system-controller.manifest
746 %endif
747
748 %changelog
749 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
750 - Initial build for 2.0alpha.