packaging: disable ICO system controller.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
22 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
23 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
24
25 # TODO: take care of /lib vs /lib64...
26 %define systemddir /lib/systemd
27
28 Summary: Murphy policy framework
29 Name: murphy
30 Version: 0.0.52
31 Release: 1
32 License: BSD-3-Clause
33 Group: System/Service
34 URL: http://01.org/murphy/
35 Source0: %{name}-%{version}.tar.gz
36 Source1: murphy.manifest
37 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
38 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
39 Requires: %{name}-core = %{version}
40 %endif
41
42 Requires(post): /bin/systemctl
43 Requires(post): libcap-tools
44 Requires(postun): /bin/systemctl
45
46 BuildRequires: flex
47 BuildRequires: bison
48 BuildRequires: pkgconfig(lua)
49 BuildRequires: pkgconfig(libsystemd-daemon)
50 BuildRequires: pkgconfig(libsystemd-journal)
51 BuildRequires: pkgconfig(libcap)
52
53 %if %{?_with_pulse:1}%{!?_with_pulse:0}
54 BuildRequires: pkgconfig(libpulse)
55 %endif
56 %if %{?_with_ecore:1}%{!?_with_ecore:0}
57 BuildRequires: pkgconfig(ecore)
58 BuildRequires: mesa-libEGL
59 BuildRequires: mesa-libGLESv2
60 %endif
61 %if %{?_with_glib:1}%{!?_with_glib:0}
62 BuildRequires: pkgconfig(glib-2.0)
63 %endif
64 %if %{?_with_qt:1}%{!?_with_qt:0}
65 BuildRequires: pkgconfig(QtCore)
66 %endif
67 %if %{?_with_dbus:1}%{!?_with_dbus:0}
68 BuildRequires: pkgconfig(dbus-1)
69 %endif
70 %if %{?_with_telephony:1}%{!?_with_telephony:0}
71 BuildRequires: pkgconfig(ofono)
72 %endif
73 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
74 BuildRequires: pkgconfig(audio-session-mgr)
75 BuildRequires: pkgconfig(aul)
76 %endif
77 %if %{?_with_websockets:1}%{!?_with_websockets:0}
78 BuildRequires: libwebsockets-devel
79 %endif
80 BuildRequires: pkgconfig(json)
81
82 %if %{?_with_smack:1}%{!?_with_smack:0}
83 BuildRequires: pkgconfig(libsmack)
84 %endif
85
86 %if %{_with_icosyscon}
87 BuildRequires: ico-uxf-weston-plugin-devel
88 BuildRequires: pkgconfig(ail)
89 BuildRequires: pkgconfig(aul)
90 BuildRequires: libxml2-devel
91 %endif
92
93 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
94 %package core
95 Summary: Murphy core runtime libraries
96 Group: System/Libraries
97
98 %package plugins-base
99 Summary: The basic set of Murphy plugins
100 Group: System/Service
101 Requires: %{name} = %{version}
102 Requires: %{name}-core = %{version}
103 %endif
104
105 %package devel
106 Summary: The header files and libraries needed for Murphy development
107 Group: System/Libraries
108 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
109 Requires: %{name}-core = %{version}
110 %else
111 Requires: %{name} = %{version}
112 %endif
113 Requires: libjson-devel
114
115 %package doc
116 Summary: Documentation for Murphy
117 Group: SDK/Documentation
118
119 %if %{?_with_pulse:1}%{!?_with_pulse:0}
120 %package pulse
121 Summary: Murphy PulseAudio mainloop integration
122 Group: System/Libraries
123 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
124 Requires: %{name}-core = %{version}
125 %else
126 Requires: %{name} = %{version}
127 %endif
128
129 %package pulse-devel
130 Summary: Murphy PulseAudio mainloop integration development files
131 Group: System/Libraries
132 Requires: %{name}-pulse = %{version}
133 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
134 Requires: %{name}-core = %{version}
135 %else
136 Requires: %{name} = %{version}
137 %endif
138 %endif
139
140 %if %{?_with_ecore:1}%{!?_with_ecore:0}
141 %package ecore
142 Summary: Murphy EFL/ecore mainloop integration
143 Group: System/Libraries
144 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
145 Requires: %{name}-core = %{version}
146 %else
147 Requires: %{name} = %{version}
148 %endif
149
150 %package ecore-devel
151 Summary: Murphy EFL/ecore mainloop integration development files
152 Group: System/Libraries
153 Requires: %{name}-ecore = %{version}
154 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
155 Requires: %{name}-core = %{version}
156 %else
157 Requires: %{name} = %{version}
158 %endif
159 %endif
160
161 %if %{?_with_glib:1}%{!?_with_glib:0}
162 %package glib
163 Summary: Murphy glib mainloop integration
164 Group: System/Libraries
165 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
166 Requires: %{name}-core = %{version}
167 %else
168 Requires: %{name} = %{version}
169 %endif
170
171 %package glib-devel
172 Summary: Murphy glib mainloop integration development files
173 Group: System/Libraries
174 Requires: %{name}-glib = %{version}
175 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
176 Requires: %{name}-core = %{version}
177 %else
178 Requires: %{name} = %{version}
179 %endif
180 %endif
181
182 %if %{?_with_qt:1}%{!?_with_qt:0}
183 %package qt
184 Summary: Murphy Qt mainloop integration
185 Group: System/Libraries
186 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
187 Requires: %{name}-core = %{version}
188 %else
189 Requires: %{name} = %{version}
190 %endif
191
192 %package qt-devel
193 Summary: Murphy Qt mainloop integration development files
194 Group: System/Libraries
195 Requires: %{name}-qt = %{version}
196 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
197 Requires: %{name}-core = %{version}
198 %else
199 Requires: %{name} = %{version}
200 %endif
201 %endif
202
203 %package tests
204 Summary: Various test binaries for Murphy
205 Group: System/Testing
206 Requires: %{name} = %{version}
207 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
208 Requires: %{name}-core = %{version}
209 %else
210 Requires: %{name} = %{version}
211 %endif
212
213 %package ivi-resource-manager
214 Summary: Murphy IVI resource manager plugin
215 Group: System/Service
216
217 %if %{_with_icosyscon}
218 %package system-controller
219 Summary: Murphy IVI System Controller plugin
220 Group: System/Service
221 Requires: ico-uxf-homescreen
222 Conflicts: murphy-ivi-resource-manager
223 %endif
224
225 %description
226 This package contains the basic daemon.
227
228 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
229 %description core
230 This package contains the core runtime libraries.
231
232 %description plugins-base
233 This package contains a basic set of plugins.
234 %endif
235
236 %description devel
237 This package contains header files and libraries necessary for development.
238
239 %description doc
240 This package contains documentation.
241
242 %if %{?_with_pulse:1}%{!?_with_pulse:0}
243 %description pulse
244 This package contains the Murphy PulseAudio mainloop integration runtime files.
245
246 %description pulse-devel
247 This package contains the Murphy PulseAudio mainloop integration development
248 files.
249 %endif
250
251 %if %{?_with_ecore:1}%{!?_with_ecore:0}
252 %description ecore
253 This package contains the Murphy EFL/ecore mainloop integration runtime files.
254
255 %description ecore-devel
256 This package contains the Murphy EFL/ecore mainloop integration development
257 files.
258 %endif
259
260 %if %{?_with_glib:1}%{!?_with_glib:0}
261 %description glib
262 This package contains the Murphy glib mainloop integration runtime files.
263
264 %description glib-devel
265 This package contains the Murphy glib mainloop integration development
266 files.
267 %endif
268
269 %if %{?_with_qt:1}%{!?_with_qt:0}
270 %description qt
271 This package contains the Murphy Qt mainloop integration runtime files.
272
273 %description qt-devel
274 This package contains the Murphy Qt mainloop integration development
275 files.
276 %endif
277
278 %description tests
279 This package contains various test binaries for Murphy.
280
281 %description ivi-resource-manager
282 This package contains the Murphy IVI resource manager plugin.
283
284 %if %{_with_icosyscon}
285 %description system-controller
286 This package contains the Murphy IVI resource manager plugin.
287 %endif
288
289 %prep
290 %setup -q
291
292 %build
293 %if %{?_with_debug:1}%{!?_with_debug:0}
294 export CFLAGS="-O0 -g3"
295 V="V=1"
296 %endif
297
298 CONFIG_OPTIONS=""
299 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
300
301 %if %{?_with_pulse:1}%{!?_with_pulse:0}
302 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
303 %else
304 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
305 %endif
306
307 %if %{?_with_ecore:1}%{!?_with_ecore:0}
308 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
309 %else
310 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
311 %endif
312
313 %if %{?_with_glib:1}%{!?_with_glib:0}
314 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
315 %else
316 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
317 %endif
318
319 %if %{?_with_qt:1}%{!?_with_qt:0}
320 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
321 %else
322 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
323 %endif
324
325 %if %{?_with_dbus:1}%{!?_with_dbus:0}
326 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
327 %else
328 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
329 %endif
330
331 %if %{?_with_telephony:1}%{!?_with_telephony:0}
332 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
333 %else
334 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
335 %endif
336
337 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
338 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
339 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
340 %else
341 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
342 %endif
343
344 %if %{?_with_websockets:1}%{!?_with_websockets:0}
345 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
346 %else
347 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
348 %endif
349
350 %if %{?_with_smack:1}%{!?_with_smack:0}
351 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
352 %else
353 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
354 %endif
355
356 %if %{_with_icosyscon}
357 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
358 %else
359 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
360 %endif
361
362 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
363 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
364 %else
365 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
366 %endif
367
368 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
369 grep '^processor *:' | wc -l`"
370 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
371
372 ./bootstrap && \
373 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
374 make clean && \
375 make -j$(($NUM_CPUS + 1)) $V
376
377 %install
378 rm -rf $RPM_BUILD_ROOT
379 %make_install
380
381 # Make sure we have a plugin dir even if all the basic plugins
382 # are configured to be built in.
383 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
384
385 # Get rid of any *.la files installed by libtool.
386 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
387
388 # Clean up also the murphy DB installation.
389 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
390
391 # Generate list of linkedin plugins (depends on the configuration).
392 outdir="`pwd`"
393 pushd $RPM_BUILD_ROOT >& /dev/null && \
394 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
395 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
396 popd >& /dev/null
397 echo "Found the following linked-in plugin files:"
398 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
399
400 # Generate list of header files, filtering ones that go to subpackages.
401 outdir="`pwd`"
402 pushd $RPM_BUILD_ROOT >& /dev/null && \
403 find ./%{_includedir}/murphy | \
404 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
405 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
406 popd >& /dev/null
407
408 # Replace the default sample/test config files with the packaging ones.
409 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/murphy/*
410 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
411 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
412
413 # Copy plugin configuration files in place.
414 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
415 cp packaging.in/amb-config.lua \
416 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
417
418 # Copy tmpfiles.d config file in place
419 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
420 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
421
422 # Copy the systemd files in place.
423 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
424 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
425 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
426 %if %{_with_icosyscon}
427 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
428 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
429 %endif
430
431 %if %{?_with_dbus:1}%{!?_with_dbus:0}
432 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
433 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
434 %endif
435
436 # copy the manifest file
437 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
438 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
439 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
440 %if %{?_with_qt:1}%{!?_with_qt:0}
441 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
442 %endif
443 %if %{?_with_glib:1}%{!?_with_glib:0}
444 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
445 %endif
446 %if %{?_with_pulse:1}%{!?_with_pulse:0}
447 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
448 %endif
449 %if %{?_with_ecore:1}%{!?_with_ecore:0}
450 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
451 %endif
452 %if %{_with_icosyscon}
453 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
454 %endif
455
456 %clean
457 rm -rf $RPM_BUILD_ROOT
458
459 %post
460 /bin/systemctl enable murphyd.service
461 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
462
463 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
464 %post core
465 %endif
466 ldconfig
467
468 %postun
469 if [ "$1" = "0" ]; then
470 /bin/systemctl disable murphyd.service
471 fi
472
473 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
474 %postun core
475 %endif
476 ldconfig
477
478 %if %{?_with_glib:1}%{!?_with_glib:0}
479 %post glib
480 ldconfig
481
482 %postun glib
483 ldconfig
484 %endif
485
486 %if %{?_with_pulse:1}%{!?_with_pulse:0}
487 %post pulse
488 ldconfig
489
490 %postun pulse
491 ldconfig
492 %endif
493
494 %if %{?_with_ecore:1}%{!?_with_ecore:0}
495 %post ecore
496 ldconfig
497
498 %postun ecore
499 ldconfig
500 %endif
501
502 %if %{?_with_qt:1}%{!?_with_qt:0}
503 %post qt
504 lfconfig
505
506 %postun qt
507 ldconfig
508 %endif
509
510 %if %{_with_icosyscon}
511 %post system-controller
512 # prevent system controller from starting
513 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
514 # instead launch just ico-homescreen
515 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
516 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path \
517     %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
518
519 %postun system-controller
520 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
521 if [ -f %{systemddir}/user/ico-uxf-wait-launchpad-ready.path ]; then
522     ln -sf %{systemddir}/user/ico-uxf-wait-launchpad-ready.path \
523         %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
524 fi
525 %endif
526
527 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
528 %files -f filelist.plugins-base
529 %else
530 %files
531 %endif
532 %defattr(-,root,root,-)
533 %manifest %{_datadir}/murphy.manifest
534 %{_bindir}/murphyd
535 %config %{_sysconfdir}/murphy
536 %{systemddir}/system/murphyd.service
537 %{_tmpfilesdir}/murphyd.conf
538 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
539 %{_sbindir}/asm-bridge
540 %endif
541 %if %{?_with_dbus:1}%{!?_with_dbus:0}
542 %{_sysconfdir}/dbus-1/system.d
543 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
544 %endif
545 %if %{?_with_websockets:1}%{!?_with_websockets:0}
546 %{_datadir}/murphy
547 %endif
548
549 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
550 %files core
551 %defattr(-,root,root,-)
552 %endif
553 %{_libdir}/libmurphy-common.so.*
554 %{_libdir}/libmurphy-core.so.*
555 %{_libdir}/libmurphy-resolver.so.*
556 %{_libdir}/libmurphy-resource.so.*
557 %{_libdir}/libmurphy-resource-backend.so.*
558 %if %{?_with_lua:1}%{!?_with_lua:0}
559 %{_libdir}/libmurphy-lua-utils.so.*
560 %{_libdir}/libmurphy-lua-decision.so.*
561 %endif
562 %{_libdir}/libmurphy-domain-controller.so.*
563 %{_libdir}/murphy/*.so.*
564 %{_libdir}/libbreedline*.so.*
565 %if %{?_with_dbus:1}%{!?_with_dbus:0}
566 %{_libdir}/libmurphy-libdbus.so.*
567 %{_libdir}/libmurphy-dbus-libdbus.so.*
568 %endif
569
570 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
571 %files plugins-base -f filelist.plugins-base
572 %defattr(-,root,root,-)
573 %endif
574 %{_libdir}/murphy/plugins/plugin-domain-control.so
575 %{_libdir}/murphy/plugins/plugin-resource-asm.so
576 %{_libdir}/murphy/plugins/plugin-resource-native.so
577
578 %files devel -f filelist.devel-includes
579 %defattr(-,root,root,-)
580 # %{_includedir}/murphy/config.h
581 # %{_includedir}/murphy/common.h
582 # #%{_includedir}/murphy/core.h
583 # %{_includedir}/murphy/common
584 # %{_includedir}/murphy/core
585 # %{_includedir}/murphy/resolver
586 # %{_includedir}/murphy/resource
587 # # hmmm... should handle disabled plugins properly.
588 # %{_includedir}/murphy/domain-control
589 # %{_includedir}/murphy/plugins
590 %{_includedir}/murphy-db
591 %{_libdir}/libmurphy-common.so
592 %{_libdir}/libmurphy-core.so
593 %{_libdir}/libmurphy-resolver.so
594 %{_libdir}/libmurphy-resource.so
595 %{_libdir}/libmurphy-resource-backend.so
596 %if %{?_with_lua:1}%{!?_with_lua:0}
597 %{_libdir}/libmurphy-lua-utils.so
598 %{_libdir}/libmurphy-lua-decision.so
599 %endif
600 %{_libdir}/libmurphy-domain-controller.so
601 %{_libdir}/murphy/*.so
602 %{_libdir}/pkgconfig/murphy-common.pc
603 %{_libdir}/pkgconfig/murphy-core.pc
604 %{_libdir}/pkgconfig/murphy-resolver.pc
605 #%{_libdir}/pkgconfig/murphy-resource.pc
606 %if %{?_with_lua:1}%{!?_with_lua:0}
607 %{_libdir}/pkgconfig/murphy-lua-utils.pc
608 %{_libdir}/pkgconfig/murphy-lua-decision.pc
609 %endif
610 %{_libdir}/pkgconfig/murphy-domain-controller.pc
611 %{_libdir}/pkgconfig/murphy-db.pc
612 %{_libdir}/pkgconfig/murphy-resource.pc
613 %{_includedir}/breedline
614 %{_libdir}/libbreedline*.so
615 %{_libdir}/pkgconfig/breedline*.pc
616 %if %{?_with_dbus:1}%{!?_with_dbus:0}
617 #%{_includedir}/murphy/dbus
618 %{_libdir}/libmurphy-libdbus.so
619 %{_libdir}/libmurphy-dbus-libdbus.so
620 %{_libdir}/pkgconfig/murphy-libdbus.pc
621 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
622 %endif
623
624 %files doc
625 %defattr(-,root,root,-)
626 %doc %{_docdir}/../murphy/AUTHORS
627 %doc %{_docdir}/../murphy/CODING-STYLE
628 %license %{_docdir}/../murphy/COPYING
629 %doc %{_docdir}/../murphy/ChangeLog
630 %doc %{_docdir}/../murphy/INSTALL
631 %doc %{_docdir}/../murphy/NEWS
632 %doc %{_docdir}/../murphy/README
633
634 %if %{?_with_pulse:1}%{!?_with_pulse:0}
635 %files pulse
636 %defattr(-,root,root,-)
637 %{_libdir}/libmurphy-pulse.so.*
638 %manifest %{_datadir}/murphy-pulse.manifest
639
640 %files pulse-devel
641 %defattr(-,root,root,-)
642 %{_includedir}/murphy/common/pulse-glue.h
643 %{_libdir}/libmurphy-pulse.so
644 %{_libdir}/pkgconfig/murphy-pulse.pc
645 %endif
646
647 %if %{?_with_ecore:1}%{!?_with_ecore:0}
648 %files ecore
649 %defattr(-,root,root,-)
650 %{_libdir}/libmurphy-ecore.so.*
651 %manifest %{_datadir}/murphy-ecore.manifest
652
653 %files ecore-devel
654 %defattr(-,root,root,-)
655 %{_includedir}/murphy/common/ecore-glue.h
656 %{_libdir}/libmurphy-ecore.so
657 %{_libdir}/pkgconfig/murphy-ecore.pc
658 %endif
659
660 %if %{?_with_glib:1}%{!?_with_glib:0}
661 %files glib
662 %defattr(-,root,root,-)
663 %{_libdir}/libmurphy-glib.so.*
664 %manifest %{_datadir}/murphy-glib.manifest
665
666 %files glib-devel
667 %defattr(-,root,root,-)
668 %{_includedir}/murphy/common/glib-glue.h
669 %{_libdir}/libmurphy-glib.so
670 %{_libdir}/pkgconfig/murphy-glib.pc
671 %endif
672
673 %if %{?_with_qt:1}%{!?_with_qt:0}
674 %files qt
675 %defattr(-,root,root,-)
676 %{_libdir}/libmurphy-qt.so.*
677 %manifest %{_datadir}/murphy-qt.manifest
678
679 %files qt-devel
680 %defattr(-,root,root,-)
681 %{_includedir}/murphy/common/qt-glue.h
682 %{_libdir}/libmurphy-qt.so
683 %{_libdir}/pkgconfig/murphy-qt.pc
684 %endif
685
686 %files tests
687 %defattr(-,root,root,-)
688 %{_bindir}/resource-client
689 %{_bindir}/resource-api-test
690 %{_bindir}/resource-api-fuzz
691 %{_bindir}/test-domain-controller
692 %{_bindir}/murphy-console
693 %manifest %{_datadir}/murphy-tests.manifest
694
695 %files ivi-resource-manager
696 %defattr(-,root,root,-)
697 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
698 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
699
700 %if %{_with_icosyscon}
701 %files system-controller
702 %defattr(-,root,root,-)
703 %{_libdir}/murphy/plugins/plugin-system-controller.so
704 %{systemddir}/user/ico-homescreen.service
705 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
706 %manifest %{_datadir}/murphy-system-controller.manifest
707 %endif
708
709 %changelog
710 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
711 - Initial build for 2.0alpha.