packaging: pumped version, updated changelog.
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %define _with_icosyscon 1
11
12 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
13 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
14 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
15 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
16 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
17 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
18 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
19 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
20 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
21 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
22 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
23 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
24 %{!?_with_icoweston:%{!?_without_icoweston:%define _without_icoweston 1}}
25 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
26 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
27
28 #
29 # Abnormalize _with_icosyscon to _enable_icosyscon
30 #
31 # Since some people seem to have a hard time understanding that
32 #
33 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
34 #    undefined as opposed to defining it to 0
35 #
36 # 2) if you decide to do it the wrong way at least you should be consistent
37 #    about it and not randomly change between the conventions
38 #
39 # we need to roll this butt-ugly hack to make sure that we always go with
40 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
41 # on how _with_icosyscon happens to be set (or unset).
42 #
43
44 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
45 %if %{_with_icosyscon}
46 %define _enable_icosyscon 1
47 %else
48 %define _enable_icosyscon 0
49 %endif
50 %else
51 %define _enable_icosyscon 0
52 %endif
53
54 Summary: Resource policy framework
55 Name: murphy
56 Version: 0.0.57
57 Release: 1
58 License: BSD-3-Clause
59 Group: System/Service
60 URL: http://01.org/murphy/
61 Source0: %{name}-%{version}.tar.gz
62 Source1001: %{name}.manifest
63 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
64 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
65 Requires: %{name}-core = %{version}
66 %endif
67
68 Requires(post): /bin/systemctl
69 Requires(post): libcap-tools
70 Requires(postun): /bin/systemctl
71
72 BuildRequires: flex
73 BuildRequires: bison
74 BuildRequires: pkgconfig(lua)
75 BuildRequires: pkgconfig(libsystemd-daemon)
76 BuildRequires: pkgconfig(libsystemd-journal)
77 BuildRequires: pkgconfig(libcap)
78 BuildRequires: pkgconfig(libtzplatform-config)
79
80 %if %{?_with_pulse:1}%{!?_with_pulse:0}
81 BuildRequires: pkgconfig(libpulse)
82 %endif
83 %if %{?_with_ecore:1}%{!?_with_ecore:0}
84 BuildRequires: pkgconfig(ecore)
85 BuildRequires: mesa-libEGL
86 BuildRequires: mesa-libGLESv2
87 %endif
88 %if %{?_with_glib:1}%{!?_with_glib:0}
89 BuildRequires: pkgconfig(glib-2.0)
90 %endif
91 %if %{?_with_qt:1}%{!?_with_qt:0}
92 BuildRequires: pkgconfig(QtCore)
93 %endif
94 %if %{?_with_dbus:1}%{!?_with_dbus:0}
95 BuildRequires: pkgconfig(dbus-1)
96 %endif
97 %if %{?_with_telephony:1}%{!?_with_telephony:0}
98 BuildRequires: pkgconfig(ofono)
99 %endif
100 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
101 BuildRequires: pkgconfig(audio-session-mgr)
102 BuildRequires: pkgconfig(aul)
103 %endif
104 %if %{?_with_websockets:1}%{!?_with_websockets:0}
105 BuildRequires: libwebsockets-devel
106 %endif
107 BuildRequires: pkgconfig(json)
108
109 %if %{?_with_smack:1}%{!?_with_smack:0}
110 BuildRequires: pkgconfig(libsmack)
111 %endif
112
113 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
114 # %%if %%{_with_icosyscon} # gbs can't, so don't bother...
115 BuildRequires: ico-uxf-weston-plugin-devel
116 BuildRequires: weston-ivi-shell-devel
117 BuildRequires: genivi-shell-devel
118 BuildRequires: pkgconfig(ail)
119 BuildRequires: pkgconfig(aul)
120 BuildRequires: libxml2-devel
121 # %%endif
122 %endif
123
124 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
125 %package core
126 Summary: Murphy core runtime libraries
127 Group: System/Libraries
128
129 %package plugins-base
130 Summary: The basic set of Murphy plugins
131 Group: System/Service
132 Requires: %{name} = %{version}
133 Requires: %{name}-core = %{version}
134 %endif
135
136 %package devel
137 Summary: The header files and libraries needed for Murphy development
138 Group: System/Libraries
139 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
140 Requires: %{name}-core = %{version}
141 %else
142 Requires: %{name} = %{version}
143 %endif
144 Requires: libjson-devel
145
146 %package doc
147 Summary: Documentation for Murphy
148 Group: SDK/Documentation
149
150 %if %{?_with_pulse:1}%{!?_with_pulse:0}
151 %package pulse
152 Summary: Murphy PulseAudio mainloop integration
153 Group: System/Libraries
154 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
155 Requires: %{name}-core = %{version}
156 %else
157 Requires: %{name} = %{version}
158 %endif
159
160 %package pulse-devel
161 Summary: Murphy PulseAudio mainloop integration development files
162 Group: System/Libraries
163 Requires: %{name}-pulse = %{version}
164 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
165 Requires: %{name}-core = %{version}
166 %else
167 Requires: %{name} = %{version}
168 %endif
169 %endif
170
171 %if %{?_with_ecore:1}%{!?_with_ecore:0}
172 %package ecore
173 Summary: Murphy EFL/ecore mainloop integration
174 Group: System/Libraries
175 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
176 Requires: %{name}-core = %{version}
177 %else
178 Requires: %{name} = %{version}
179 %endif
180
181 %package ecore-devel
182 Summary: Murphy EFL/ecore mainloop integration development files
183 Group: System/Libraries
184 Requires: %{name}-ecore = %{version}
185 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
186 Requires: %{name}-core = %{version}
187 %else
188 Requires: %{name} = %{version}
189 %endif
190 %endif
191
192 %if %{?_with_glib:1}%{!?_with_glib:0}
193 %package glib
194 Summary: Murphy glib mainloop integration
195 Group: System/Libraries
196 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
197 Requires: %{name}-core = %{version}
198 %else
199 Requires: %{name} = %{version}
200 %endif
201
202 %package glib-devel
203 Summary: Murphy glib mainloop integration development files
204 Group: System/Libraries
205 Requires: %{name}-glib = %{version}
206 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
207 Requires: %{name}-core = %{version}
208 %else
209 Requires: %{name} = %{version}
210 %endif
211 %endif
212
213 %if %{?_with_qt:1}%{!?_with_qt:0}
214 %package qt
215 Summary: Murphy Qt mainloop integration
216 Group: System/Libraries
217 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
218 Requires: %{name}-core = %{version}
219 %else
220 Requires: %{name} = %{version}
221 %endif
222
223 %package qt-devel
224 Summary: Murphy Qt mainloop integration development files
225 Group: System/Libraries
226 Requires: %{name}-qt = %{version}
227 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
228 Requires: %{name}-core = %{version}
229 %else
230 Requires: %{name} = %{version}
231 %endif
232 %endif
233
234 %package gam
235 Summary: Murphy support for Genivi Audio Manager
236 Group: System/Libraries
237 Requires: %{name} = %{version}
238
239 %package gam-devel
240 Summary: Murphy support for Genivi Audio Manager development files
241 Group: System/Libraries
242 Requires: %{name}-gam = %{version}
243
244 %package tests
245 Summary: Various test binaries for Murphy
246 Group: System/Testing
247 Requires: %{name} = %{version}
248 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
249 Requires: %{name}-core = %{version}
250 %else
251 Requires: %{name} = %{version}
252 %endif
253
254 %package ivi-resource-manager
255 Summary: Murphy IVI resource manager plugin
256 Group: System/Service
257
258 %if %{_enable_icosyscon}
259 %package system-controller
260 Summary: Murphy IVI System Controller plugin
261 Group: System/Service
262 Requires: ico-uxf-homescreen
263 Conflicts: murphy-ivi-resource-manager
264 Provides: system-controller
265 Conflicts: ico-uxf-homescreen-system-controller
266 %endif
267
268 %description
269 This package contains the basic Murphy daemon.
270
271 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
272 %description core
273 This package contains the core runtime libraries.
274
275 %description plugins-base
276 This package contains a basic set of plugins.
277 %endif
278
279 %description devel
280 This package contains header files and libraries necessary for development.
281
282 %description doc
283 This package contains documentation.
284
285 %if %{?_with_pulse:1}%{!?_with_pulse:0}
286 %description pulse
287 This package contains the Murphy PulseAudio mainloop integration runtime files.
288
289 %description pulse-devel
290 This package contains the Murphy PulseAudio mainloop integration development
291 files.
292 %endif
293
294 %if %{?_with_ecore:1}%{!?_with_ecore:0}
295 %description ecore
296 This package contains the Murphy EFL/ecore mainloop integration runtime files.
297
298 %description ecore-devel
299 This package contains the Murphy EFL/ecore mainloop integration development
300 files.
301 %endif
302
303 %if %{?_with_glib:1}%{!?_with_glib:0}
304 %description glib
305 This package contains the Murphy glib mainloop integration runtime files.
306
307 %description glib-devel
308 This package contains the Murphy glib mainloop integration development
309 files.
310 %endif
311
312 %if %{?_with_qt:1}%{!?_with_qt:0}
313 %description qt
314 This package contains the Murphy Qt mainloop integration runtime files.
315
316 %description qt-devel
317 This package contains the Murphy Qt mainloop integration development
318 files.
319 %endif
320
321 %description tests
322 This package contains various test binaries for Murphy.
323
324 %description ivi-resource-manager
325 This package contains the Murphy IVI resource manager plugin.
326
327 %if %{_enable_icosyscon}
328 %description system-controller
329 This package contains the Murphy IVI resource manager plugin.
330 %endif
331
332 %description gam
333 This package contains the Murphy plugins for necessary for supporting
334 Genivi Audio Manager.
335
336 %description gam-devel
337 This package contains development files for Murphy Genivi Audio Manager
338 plugins.
339
340 %prep
341 %setup -q
342 cp %{SOURCE1001} .
343
344 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
345 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
346
347 %build
348 %if %{?_with_debug:1}%{!?_with_debug:0}
349 export CFLAGS="-O0 -g3"
350 V="V=1"
351 %endif
352
353 CONFIG_OPTIONS=""
354 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
355
356 %if %{?_with_pulse:1}%{!?_with_pulse:0}
357 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
358 %else
359 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
360 %endif
361
362 %if %{?_with_ecore:1}%{!?_with_ecore:0}
363 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
364 %else
365 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
366 %endif
367
368 %if %{?_with_glib:1}%{!?_with_glib:0}
369 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
370 %else
371 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
372 %endif
373
374 %if %{?_with_qt:1}%{!?_with_qt:0}
375 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
376 %else
377 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
378 %endif
379
380 %if %{?_with_dbus:1}%{!?_with_dbus:0}
381 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
382 %else
383 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
384 %endif
385
386 %if %{?_with_telephony:1}%{!?_with_telephony:0}
387 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
388 %else
389 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
390 %endif
391
392 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
393 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
394 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
395 %else
396 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
397 %endif
398
399 %if %{?_with_websockets:1}%{!?_with_websockets:0}
400 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
401 %else
402 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
403 %endif
404
405 %if %{?_with_smack:1}%{!?_with_smack:0}
406 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
407 %else
408 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
409 %endif
410
411 %if %{_enable_icosyscon}
412 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
413 %else
414 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
415 %endif
416
417 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
418 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
419 %else
420 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
421 %endif
422
423 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
424 grep '^processor *:' | wc -l`"
425 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
426
427 ./bootstrap && \
428 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
429 %__make clean && \
430 %__make -j$(($NUM_CPUS + 1)) $V
431
432 %install
433 rm -rf %{buildroot}
434 %make_install
435
436 # Make sure we have a plugin dir even if all the basic plugins
437 # are configured to be built in.
438 mkdir -p %{buildroot}%{_libdir}/murphy/plugins
439
440 # Get rid of any *.la files installed by libtool.
441 rm -f %{buildroot}%{_libdir}/*.la
442
443 # Clean up also the murphy DB installation.
444 rm -f %{buildroot}%{_libdir}/murphy/*.la
445
446 # Generate list of linkedin plugins (depends on the configuration).
447 outdir="`pwd`"
448 pushd %{buildroot} >& /dev/null && \
449 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
450 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
451 popd >& /dev/null
452 echo "Found the following linked-in plugin files:"
453 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
454
455 # Generate list of header files, filtering ones that go to subpackages.
456 outdir="`pwd`"
457 pushd %{buildroot} >& /dev/null && \
458 find ./%{_includedir}/murphy | \
459 grep -E -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
460 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
461 popd >& /dev/null
462
463 # Replace the default sample/test config files with the packaging ones.
464 rm -f %{buildroot}%{_sysconfdir}/murphy/*
465 cp packaging.in/murphy-lua.conf %{buildroot}%{_sysconfdir}/murphy/murphy.conf
466 cp packaging.in/murphy.lua      %{buildroot}%{_sysconfdir}/murphy/murphy.lua
467
468 # Copy plugin configuration files in place.
469 mkdir -p %{buildroot}%{_sysconfdir}/murphy/plugins/amb
470 cp packaging.in/amb-config.lua \
471 %{buildroot}%{_sysconfdir}/murphy/plugins/amb/config.lua
472
473 # Copy tmpfiles.d config file in place
474 mkdir -p %{buildroot}%{_tmpfilesdir}
475 cp packaging.in/murphyd.conf %{buildroot}%{_tmpfilesdir}
476
477 # Copy the systemd files in place.
478 mkdir -p %{buildroot}%{_unitdir}
479 mkdir -p %{buildroot}%{_unitdir_user}
480 cp packaging.in/murphyd.service %{buildroot}%{_unitdir}
481 %if %{_enable_icosyscon}
482 cp packaging.in/ico-homescreen.service %{buildroot}%{_unitdir_user}
483 cp packaging.in/murphy-wait-for-launchpad-ready.path \
484     %{buildroot}%{_unitdir_user}
485 %endif
486
487 %if %{?_with_dbus:1}%{!?_with_dbus:0}
488 mkdir -p %{buildroot}%{_sysconfdir}/dbus-1/system.d
489 sed "s/@TZ_SYS_USER_GROUP@/%{TZ_SYS_USER_GROUP}/g" \
490     packaging.in/org.Murphy.conf.in > packaging.in/org.Murphy.conf
491 cp packaging.in/org.Murphy.conf \
492     %{buildroot}%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
493 %endif
494
495 # copy (experimental) GAM resource backend configuration files
496 mkdir -p %{buildroot}%{_sysconfdir}/murphy/gam
497 cp packaging.in/gam-*.names packaging.in/gam-*.tree \
498     %{buildroot}%{_sysconfdir}/murphy/gam
499
500 %clean
501 rm -rf %{buildroot}
502
503 %post
504 /bin/systemctl enable murphyd.service
505 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
506
507 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
508 %post core
509 %endif
510 ldconfig
511
512 %postun
513 if [ "$1" = "0" ]; then
514 /bin/systemctl disable murphyd.service
515 fi
516
517 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
518 %postun core
519 %endif
520 ldconfig
521
522 %if %{?_with_glib:1}%{!?_with_glib:0}
523 %post glib
524 ldconfig
525
526 %postun glib
527 ldconfig
528 %endif
529
530 %if %{?_with_pulse:1}%{!?_with_pulse:0}
531 %post pulse
532 ldconfig
533
534 %postun pulse
535 ldconfig
536 %endif
537
538 %if %{?_with_ecore:1}%{!?_with_ecore:0}
539 %post ecore
540 ldconfig
541
542 %postun ecore
543 ldconfig
544 %endif
545
546 %if %{?_with_qt:1}%{!?_with_qt:0}
547 %post qt
548 ldconfig
549
550 %postun qt
551 ldconfig
552 %endif
553
554 %if %{_enable_icosyscon}
555 %post system-controller
556 # prevent system controller from starting
557 rm -f %{_unitdir_user}/weston.target.wants/ico-uxf-wait-launchpad-ready.path
558 # instead launch just ico-homescreen
559 rm -f %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
560 ln -s %{_unitdir_user}/murphy-wait-for-launchpad-ready.path \
561     %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
562
563 %postun system-controller
564 if [ "$1" = "0" ]; then
565 rm -f %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
566 if [ -f %{_unitdir_user}/ico-uxf-wait-launchpad-ready.path ]; then
567     ln -sf %{_unitdir_user}/ico-uxf-wait-launchpad-ready.path \
568         %{_unitdir_user}/weston.target.wants/ico-uxf-wait-launchpad-ready.path
569 fi
570 fi
571 %endif
572
573 %post gam
574 ldconfig
575
576 %postun gam
577 ldconfig
578
579 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
580 %files -f filelist.plugins-base
581 %else
582 %files
583 %endif
584 %defattr(-,root,root,-)
585 %manifest murphy.manifest
586 %{_bindir}/murphyd
587 %config %{_sysconfdir}/murphy
588 %{_unitdir}/murphyd.service
589 %{_tmpfilesdir}/murphyd.conf
590 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
591 %{_sbindir}/asm-bridge
592 %endif
593 %if %{?_with_dbus:1}%{!?_with_dbus:0}
594 %{_sysconfdir}/dbus-1/system.d
595 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
596 %endif
597 %if %{?_with_websockets:1}%{!?_with_websockets:0}
598 %{_datadir}/murphy
599 %endif
600
601 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
602 %files core
603 %defattr(-,root,root,-)
604 %endif
605 %{_libdir}/libmurphy-common.so.*
606 %{_libdir}/libmurphy-core.so.*
607 %{_libdir}/libmurphy-resolver.so.*
608 %{_libdir}/libmurphy-resource.so.*
609 %{_libdir}/libmurphy-resource-backend.so.*
610 %if %{?_with_lua:1}%{!?_with_lua:0}
611 %{_libdir}/libmurphy-lua-utils.so.*
612 %{_libdir}/libmurphy-lua-decision.so.*
613 %endif
614 %{_libdir}/libmurphy-domain-controller.so.*
615 %{_libdir}/murphy/*.so.*
616 %{_libdir}/libbreedline*.so.*
617 %if %{?_with_dbus:1}%{!?_with_dbus:0}
618 %{_libdir}/libmurphy-libdbus.so.*
619 %{_libdir}/libmurphy-dbus-libdbus.so.*
620 %endif
621
622 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
623 %files plugins-base -f filelist.plugins-base
624 %defattr(-,root,root,-)
625 %endif
626 %{_libdir}/murphy/plugins/plugin-domain-control.so
627 %{_libdir}/murphy/plugins/plugin-resource-asm.so
628 %{_libdir}/murphy/plugins/plugin-resource-native.so
629
630 %files devel -f filelist.devel-includes
631 %defattr(-,root,root,-)
632 # %%{_includedir}/murphy/config.h
633 # %%{_includedir}/murphy/common.h
634 # %%{_includedir}/murphy/core.h
635 # %%{_includedir}/murphy/common
636 # %%{_includedir}/murphy/core
637 # %%{_includedir}/murphy/resolver
638 # %%{_includedir}/murphy/resource
639 # # hmmm... should handle disabled plugins properly.
640 # %%{_includedir}/murphy/domain-control
641 # %%{_includedir}/murphy/plugins
642 %{_includedir}/murphy-db
643 %{_libdir}/libmurphy-common.so
644 %{_libdir}/libmurphy-core.so
645 %{_libdir}/libmurphy-resolver.so
646 %{_libdir}/libmurphy-resource.so
647 %{_libdir}/libmurphy-resource-backend.so
648 %if %{?_with_lua:1}%{!?_with_lua:0}
649 %{_libdir}/libmurphy-lua-utils.so
650 %{_libdir}/libmurphy-lua-decision.so
651 %endif
652 %{_libdir}/libmurphy-domain-controller.so
653 %{_libdir}/murphy/*.so
654 %{_libdir}/pkgconfig/murphy-common.pc
655 %{_libdir}/pkgconfig/murphy-core.pc
656 %{_libdir}/pkgconfig/murphy-resolver.pc
657 # %%{_libdir}/pkgconfig/murphy-resource.pc
658 %if %{?_with_lua:1}%{!?_with_lua:0}
659 %{_libdir}/pkgconfig/murphy-lua-utils.pc
660 %{_libdir}/pkgconfig/murphy-lua-decision.pc
661 %endif
662 %{_libdir}/pkgconfig/murphy-domain-controller.pc
663 %{_libdir}/pkgconfig/murphy-db.pc
664 %{_libdir}/pkgconfig/murphy-resource.pc
665 %{_includedir}/breedline
666 %{_libdir}/libbreedline*.so
667 %{_libdir}/pkgconfig/breedline*.pc
668 %if %{?_with_dbus:1}%{!?_with_dbus:0}
669 # %%{_includedir}/murphy/dbus
670 %{_libdir}/libmurphy-libdbus.so
671 %{_libdir}/libmurphy-dbus-libdbus.so
672 %{_libdir}/pkgconfig/murphy-libdbus.pc
673 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
674 %endif
675
676 %files doc
677 %defattr(-,root,root,-)
678 %doc %{_docdir}/../murphy/AUTHORS
679 %doc %{_docdir}/../murphy/CODING-STYLE
680 %doc %{_docdir}/../murphy/ChangeLog
681 %doc %{_docdir}/../murphy/NEWS
682 %doc %{_docdir}/../murphy/README
683 %license COPYING LICENSE-BSD
684
685 %if %{?_with_pulse:1}%{!?_with_pulse:0}
686 %files pulse
687 %defattr(-,root,root,-)
688 %{_libdir}/libmurphy-pulse.so.*
689 %manifest murphy.manifest
690
691 %files pulse-devel
692 %defattr(-,root,root,-)
693 %{_includedir}/murphy/common/pulse-glue.h
694 %{_libdir}/libmurphy-pulse.so
695 %{_libdir}/pkgconfig/murphy-pulse.pc
696 %endif
697
698 %if %{?_with_ecore:1}%{!?_with_ecore:0}
699 %files ecore
700 %defattr(-,root,root,-)
701 %{_libdir}/libmurphy-ecore.so.*
702 %manifest murphy.manifest
703
704 %files ecore-devel
705 %defattr(-,root,root,-)
706 %{_includedir}/murphy/common/ecore-glue.h
707 %{_libdir}/libmurphy-ecore.so
708 %{_libdir}/pkgconfig/murphy-ecore.pc
709 %endif
710
711 %if %{?_with_glib:1}%{!?_with_glib:0}
712 %files glib
713 %defattr(-,root,root,-)
714 %{_libdir}/libmurphy-glib.so.*
715 %manifest murphy.manifest
716
717 %files glib-devel
718 %defattr(-,root,root,-)
719 %{_includedir}/murphy/common/glib-glue.h
720 %{_libdir}/libmurphy-glib.so
721 %{_libdir}/pkgconfig/murphy-glib.pc
722 %endif
723
724 %if %{?_with_qt:1}%{!?_with_qt:0}
725 %files qt
726 %defattr(-,root,root,-)
727 %{_libdir}/libmurphy-qt.so.*
728 %manifest murphy.manifest
729
730 %files qt-devel
731 %defattr(-,root,root,-)
732 %{_includedir}/murphy/common/qt-glue.h
733 %{_libdir}/libmurphy-qt.so
734 %{_libdir}/pkgconfig/murphy-qt.pc
735 %endif
736
737 %files gam
738 %defattr(-,root,root,-)
739 %{_libdir}/libmurphy-decision-tree.so.*
740 %{_libdir}/libmurphy-decision-tree.so.0.0.0
741 %{_libdir}/murphy/plugins/plugin-gam-resource-manager.so
742
743 %files gam-devel
744 %defattr(-,root,root,-)
745 %{_bindir}/decision-test
746 %{_bindir}/pattern-generator
747 %{_libdir}/libmurphy-decision-tree.so
748
749 %files tests
750 %defattr(-,root,root,-)
751 %{_bindir}/resource-client
752 %{_bindir}/resource-api-test
753 %{_bindir}/resource-api-fuzz
754 %{_bindir}/test-domain-controller
755 %{_bindir}/murphy-console
756 %manifest murphy.manifest
757
758 %files ivi-resource-manager
759 %defattr(-,root,root,-)
760 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
761 %manifest murphy.manifest
762
763 %if %{_enable_icosyscon}
764 %files system-controller
765 %defattr(-,root,root,-)
766 %{_libdir}/murphy/plugins/plugin-system-controller.so
767 %{_unitdir_user}/ico-homescreen.service
768 %{_unitdir_user}/murphy-wait-for-launchpad-ready.path
769 %manifest murphy.manifest
770 %endif
771
772 %changelog
773 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
774 - Initial build for 2.0alpha.