packaging: Properly separate license packaging, add LICENSE-BSD
[profile/ivi/murphy.git] / packaging / murphy.spec
1 # By default we build with distro-default compilation flags which
2 # enables optimizations. If you want to build with full debugging
3 # ie. with optimization turned off and full debug info (-O0 -g3)
4 # pass '--with debug' to rpmbuild on the command line. Similary
5 # you can chose to compile with/without pulse, ecore, glib, qt,
6 # dbus, and telephony support. --without squashpkg will prevent
7 # squashing the -core and -plugins-base packages into the base
8 # murphy package.
9
10 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
11 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
12 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
13 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
14 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
15 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
16 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
17 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
18 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
19 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
20 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
21 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
22 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
23 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
24
25 # TODO: take care of /lib vs /lib64...
26 %define systemddir /lib/systemd
27
28 #
29 # Abnormalize _with_icosyscon to _enable_icosyscon
30 #
31 # Since some people seem to have a hard time understanding that
32 #
33 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
34 #    undefined as opposed to defining it to 0
35 #
36 # 2) if you decide to do it the wrong way at least you should be consistent
37 #    about it and not randomly change between the conventions
38 #
39 # we need to roll this butt-ugly hack to make sure that we always go with
40 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
41 # on how _with_icosyscon happens to be set (or unset).
42 #
43
44 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
45 %if %{_with_icosyscon}
46 %define _enable_icosyscon 1
47 %else
48 %define _enable_icosyscon 0
49 %endif
50 %else
51 %define _enable_icosyscon 0
52 %endif
53
54 Summary: Murphy policy framework
55 Name: murphy
56 Version: 0.0.54
57 Release: 1
58 License: BSD-3-Clause
59 Group: System/Service
60 URL: http://01.org/murphy/
61 Source0: %{name}-%{version}.tar.gz
62 Source1: murphy.manifest
63 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
64 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
65 Requires: %{name}-core = %{version}
66 %endif
67
68 Requires(post): /bin/systemctl
69 Requires(post): libcap-tools
70 Requires(postun): /bin/systemctl
71
72 BuildRequires: flex
73 BuildRequires: bison
74 BuildRequires: pkgconfig(lua)
75 BuildRequires: pkgconfig(libsystemd-daemon)
76 BuildRequires: pkgconfig(libsystemd-journal)
77 BuildRequires: pkgconfig(libcap)
78 BuildRequires: pkgconfig(libtzplatform-config)
79
80 %if %{?_with_pulse:1}%{!?_with_pulse:0}
81 BuildRequires: pkgconfig(libpulse)
82 %endif
83 %if %{?_with_ecore:1}%{!?_with_ecore:0}
84 BuildRequires: pkgconfig(ecore)
85 BuildRequires: mesa-libEGL
86 BuildRequires: mesa-libGLESv2
87 %endif
88 %if %{?_with_glib:1}%{!?_with_glib:0}
89 BuildRequires: pkgconfig(glib-2.0)
90 %endif
91 %if %{?_with_qt:1}%{!?_with_qt:0}
92 BuildRequires: pkgconfig(QtCore)
93 %endif
94 %if %{?_with_dbus:1}%{!?_with_dbus:0}
95 BuildRequires: pkgconfig(dbus-1)
96 %endif
97 %if %{?_with_telephony:1}%{!?_with_telephony:0}
98 BuildRequires: pkgconfig(ofono)
99 %endif
100 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
101 BuildRequires: pkgconfig(audio-session-mgr)
102 BuildRequires: pkgconfig(aul)
103 %endif
104 %if %{?_with_websockets:1}%{!?_with_websockets:0}
105 BuildRequires: libwebsockets-devel
106 %endif
107 BuildRequires: pkgconfig(json)
108
109 %if %{?_with_smack:1}%{!?_with_smack:0}
110 BuildRequires: pkgconfig(libsmack)
111 %endif
112
113 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
114 #%if %{_with_icosyscon} # gbs can't, so don't bother...
115 BuildRequires: ico-uxf-weston-plugin-devel
116 BuildRequires: pkgconfig(ail)
117 BuildRequires: pkgconfig(aul)
118 BuildRequires: libxml2-devel
119 #%endif
120 %endif
121
122 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
123 %package core
124 Summary: Murphy core runtime libraries
125 Group: System/Libraries
126
127 %package plugins-base
128 Summary: The basic set of Murphy plugins
129 Group: System/Service
130 Requires: %{name} = %{version}
131 Requires: %{name}-core = %{version}
132 %endif
133
134 %package devel
135 Summary: The header files and libraries needed for Murphy development
136 Group: System/Libraries
137 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
138 Requires: %{name}-core = %{version}
139 %else
140 Requires: %{name} = %{version}
141 %endif
142 Requires: libjson-devel
143
144 %package doc
145 Summary: Documentation for Murphy
146 Group: SDK/Documentation
147
148 %if %{?_with_pulse:1}%{!?_with_pulse:0}
149 %package pulse
150 Summary: Murphy PulseAudio mainloop integration
151 Group: System/Libraries
152 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
153 Requires: %{name}-core = %{version}
154 %else
155 Requires: %{name} = %{version}
156 %endif
157
158 %package pulse-devel
159 Summary: Murphy PulseAudio mainloop integration development files
160 Group: System/Libraries
161 Requires: %{name}-pulse = %{version}
162 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
163 Requires: %{name}-core = %{version}
164 %else
165 Requires: %{name} = %{version}
166 %endif
167 %endif
168
169 %if %{?_with_ecore:1}%{!?_with_ecore:0}
170 %package ecore
171 Summary: Murphy EFL/ecore mainloop integration
172 Group: System/Libraries
173 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
174 Requires: %{name}-core = %{version}
175 %else
176 Requires: %{name} = %{version}
177 %endif
178
179 %package ecore-devel
180 Summary: Murphy EFL/ecore mainloop integration development files
181 Group: System/Libraries
182 Requires: %{name}-ecore = %{version}
183 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
184 Requires: %{name}-core = %{version}
185 %else
186 Requires: %{name} = %{version}
187 %endif
188 %endif
189
190 %if %{?_with_glib:1}%{!?_with_glib:0}
191 %package glib
192 Summary: Murphy glib mainloop integration
193 Group: System/Libraries
194 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
195 Requires: %{name}-core = %{version}
196 %else
197 Requires: %{name} = %{version}
198 %endif
199
200 %package glib-devel
201 Summary: Murphy glib mainloop integration development files
202 Group: System/Libraries
203 Requires: %{name}-glib = %{version}
204 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
205 Requires: %{name}-core = %{version}
206 %else
207 Requires: %{name} = %{version}
208 %endif
209 %endif
210
211 %if %{?_with_qt:1}%{!?_with_qt:0}
212 %package qt
213 Summary: Murphy Qt mainloop integration
214 Group: System/Libraries
215 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
216 Requires: %{name}-core = %{version}
217 %else
218 Requires: %{name} = %{version}
219 %endif
220
221 %package qt-devel
222 Summary: Murphy Qt mainloop integration development files
223 Group: System/Libraries
224 Requires: %{name}-qt = %{version}
225 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
226 Requires: %{name}-core = %{version}
227 %else
228 Requires: %{name} = %{version}
229 %endif
230 %endif
231
232 %package tests
233 Summary: Various test binaries for Murphy
234 Group: System/Testing
235 Requires: %{name} = %{version}
236 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
237 Requires: %{name}-core = %{version}
238 %else
239 Requires: %{name} = %{version}
240 %endif
241
242 %package ivi-resource-manager
243 Summary: Murphy IVI resource manager plugin
244 Group: System/Service
245
246 %if %{_enable_icosyscon}
247 %package system-controller
248 Summary: Murphy IVI System Controller plugin
249 Group: System/Service
250 Requires: ico-uxf-homescreen
251 Conflicts: murphy-ivi-resource-manager
252 %endif
253
254 %description
255 This package contains the basic daemon.
256
257 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
258 %description core
259 This package contains the core runtime libraries.
260
261 %description plugins-base
262 This package contains a basic set of plugins.
263 %endif
264
265 %description devel
266 This package contains header files and libraries necessary for development.
267
268 %description doc
269 This package contains documentation.
270
271 %if %{?_with_pulse:1}%{!?_with_pulse:0}
272 %description pulse
273 This package contains the Murphy PulseAudio mainloop integration runtime files.
274
275 %description pulse-devel
276 This package contains the Murphy PulseAudio mainloop integration development
277 files.
278 %endif
279
280 %if %{?_with_ecore:1}%{!?_with_ecore:0}
281 %description ecore
282 This package contains the Murphy EFL/ecore mainloop integration runtime files.
283
284 %description ecore-devel
285 This package contains the Murphy EFL/ecore mainloop integration development
286 files.
287 %endif
288
289 %if %{?_with_glib:1}%{!?_with_glib:0}
290 %description glib
291 This package contains the Murphy glib mainloop integration runtime files.
292
293 %description glib-devel
294 This package contains the Murphy glib mainloop integration development
295 files.
296 %endif
297
298 %if %{?_with_qt:1}%{!?_with_qt:0}
299 %description qt
300 This package contains the Murphy Qt mainloop integration runtime files.
301
302 %description qt-devel
303 This package contains the Murphy Qt mainloop integration development
304 files.
305 %endif
306
307 %description tests
308 This package contains various test binaries for Murphy.
309
310 %description ivi-resource-manager
311 This package contains the Murphy IVI resource manager plugin.
312
313 %if %{_enable_icosyscon}
314 %description system-controller
315 This package contains the Murphy IVI resource manager plugin.
316 %endif
317
318 %prep
319 %setup -q
320
321 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
322 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
323
324 %build
325 %if %{?_with_debug:1}%{!?_with_debug:0}
326 export CFLAGS="-O0 -g3"
327 V="V=1"
328 %endif
329
330 CONFIG_OPTIONS=""
331 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
332
333 %if %{?_with_pulse:1}%{!?_with_pulse:0}
334 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
335 %else
336 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
337 %endif
338
339 %if %{?_with_ecore:1}%{!?_with_ecore:0}
340 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
341 %else
342 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
343 %endif
344
345 %if %{?_with_glib:1}%{!?_with_glib:0}
346 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
347 %else
348 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
349 %endif
350
351 %if %{?_with_qt:1}%{!?_with_qt:0}
352 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
353 %else
354 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
355 %endif
356
357 %if %{?_with_dbus:1}%{!?_with_dbus:0}
358 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
359 %else
360 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
361 %endif
362
363 %if %{?_with_telephony:1}%{!?_with_telephony:0}
364 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
365 %else
366 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
367 %endif
368
369 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
370 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
371 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
372 %else
373 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
374 %endif
375
376 %if %{?_with_websockets:1}%{!?_with_websockets:0}
377 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
378 %else
379 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
380 %endif
381
382 %if %{?_with_smack:1}%{!?_with_smack:0}
383 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
384 %else
385 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
386 %endif
387
388 %if %{_enable_icosyscon}
389 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
390 %else
391 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
392 %endif
393
394 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
395 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
396 %else
397 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
398 %endif
399
400 NUM_CPUS="`cat /proc/cpuinfo | tr -s '\t' ' ' | \
401 grep '^processor *:' | wc -l`"
402 [ -z "$NUM_CPUS" ] && NUM_CPUS=1
403
404 ./bootstrap && \
405 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS && \
406 make clean && \
407 make -j$(($NUM_CPUS + 1)) $V
408
409 %install
410 rm -rf $RPM_BUILD_ROOT
411 %make_install
412
413 # Make sure we have a plugin dir even if all the basic plugins
414 # are configured to be built in.
415 mkdir -p $RPM_BUILD_ROOT%{_libdir}/murphy/plugins
416
417 # Get rid of any *.la files installed by libtool.
418 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
419
420 # Clean up also the murphy DB installation.
421 rm -f $RPM_BUILD_ROOT%{_libdir}/murphy/*.la
422
423 # Generate list of linkedin plugins (depends on the configuration).
424 outdir="`pwd`"
425 pushd $RPM_BUILD_ROOT >& /dev/null && \
426 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
427 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
428 popd >& /dev/null
429 echo "Found the following linked-in plugin files:"
430 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
431
432 # Generate list of header files, filtering ones that go to subpackages.
433 outdir="`pwd`"
434 pushd $RPM_BUILD_ROOT >& /dev/null && \
435 find ./%{_includedir}/murphy | \
436 egrep -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
437 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
438 popd >& /dev/null
439
440 # Replace the default sample/test config files with the packaging ones.
441 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/murphy/*
442 cp packaging.in/murphy-lua.conf $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.conf
443 cp packaging.in/murphy.lua      $RPM_BUILD_ROOT%{_sysconfdir}/murphy/murphy.lua
444
445 # Copy plugin configuration files in place.
446 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb
447 cp packaging.in/amb-config.lua \
448 $RPM_BUILD_ROOT%{_sysconfdir}/murphy/plugins/amb/config.lua
449
450 # Copy tmpfiles.d config file in place
451 mkdir -p $RPM_BUILD_ROOT%{_tmpfilesdir}
452 cp packaging.in/murphyd.conf $RPM_BUILD_ROOT%{_tmpfilesdir}
453
454 # Copy the systemd files in place.
455 mkdir -p $RPM_BUILD_ROOT%{systemddir}/system
456 mkdir -p $RPM_BUILD_ROOT%{systemddir}/user
457 cp packaging.in/murphyd.service $RPM_BUILD_ROOT%{systemddir}/system
458 %if %{_enable_icosyscon}
459 cp packaging.in/ico-homescreen.service $RPM_BUILD_ROOT%{systemddir}/user
460 cp packaging.in/murphy-wait-for-launchpad-ready.path $RPM_BUILD_ROOT%{systemddir}/user
461 %endif
462
463 %if %{?_with_dbus:1}%{!?_with_dbus:0}
464 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
465 sed "s/@TZ_SYS_USER_GROUP@/%{TZ_SYS_USER_GROUP}/g" packaging.in/org.Murphy.conf.in > packaging.in/org.Murphy.conf
466 cp packaging.in/org.Murphy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
467 %endif
468
469 # copy the manifest file
470 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy.manifest
471 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-tests.manifest
472 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ivi-resource-manager.manifest
473 %if %{?_with_qt:1}%{!?_with_qt:0}
474 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-qt.manifest
475 %endif
476 %if %{?_with_glib:1}%{!?_with_glib:0}
477 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-glib.manifest
478 %endif
479 %if %{?_with_pulse:1}%{!?_with_pulse:0}
480 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-pulse.manifest
481 %endif
482 %if %{?_with_ecore:1}%{!?_with_ecore:0}
483 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-ecore.manifest
484 %endif
485 %if %{_enable_icosyscon}
486 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/murphy-system-controller.manifest
487 %endif
488
489 %clean
490 rm -rf $RPM_BUILD_ROOT
491
492 %post
493 /bin/systemctl enable murphyd.service
494 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
495
496 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
497 %post core
498 %endif
499 ldconfig
500
501 %postun
502 if [ "$1" = "0" ]; then
503 /bin/systemctl disable murphyd.service
504 fi
505
506 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
507 %postun core
508 %endif
509 ldconfig
510
511 %if %{?_with_glib:1}%{!?_with_glib:0}
512 %post glib
513 ldconfig
514
515 %postun glib
516 ldconfig
517 %endif
518
519 %if %{?_with_pulse:1}%{!?_with_pulse:0}
520 %post pulse
521 ldconfig
522
523 %postun pulse
524 ldconfig
525 %endif
526
527 %if %{?_with_ecore:1}%{!?_with_ecore:0}
528 %post ecore
529 ldconfig
530
531 %postun ecore
532 ldconfig
533 %endif
534
535 %if %{?_with_qt:1}%{!?_with_qt:0}
536 %post qt
537 lfconfig
538
539 %postun qt
540 ldconfig
541 %endif
542
543 %if %{_enable_icosyscon}
544 %post system-controller
545 # prevent system controller from starting
546 rm -f %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
547 # instead launch just ico-homescreen
548 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
549 ln -s %{systemddir}/user/murphy-wait-for-launchpad-ready.path \
550     %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
551
552 %postun system-controller
553 rm -f %{systemddir}/user/weston.target.wants/murphy-wait-for-launchpad-ready.path
554 if [ -f %{systemddir}/user/ico-uxf-wait-launchpad-ready.path ]; then
555     ln -sf %{systemddir}/user/ico-uxf-wait-launchpad-ready.path \
556         %{systemddir}/user/weston.target.wants/ico-uxf-wait-launchpad-ready.path
557 fi
558 %endif
559
560 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
561 %files -f filelist.plugins-base
562 %else
563 %files
564 %endif
565 %defattr(-,root,root,-)
566 %manifest %{_datadir}/murphy.manifest
567 %{_bindir}/murphyd
568 %config %{_sysconfdir}/murphy
569 %{systemddir}/system/murphyd.service
570 %{_tmpfilesdir}/murphyd.conf
571 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
572 %{_sbindir}/asm-bridge
573 %endif
574 %if %{?_with_dbus:1}%{!?_with_dbus:0}
575 %{_sysconfdir}/dbus-1/system.d
576 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
577 %endif
578 %if %{?_with_websockets:1}%{!?_with_websockets:0}
579 %{_datadir}/murphy
580 %endif
581
582 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
583 %files core
584 %defattr(-,root,root,-)
585 %endif
586 %{_libdir}/libmurphy-common.so.*
587 %{_libdir}/libmurphy-core.so.*
588 %{_libdir}/libmurphy-resolver.so.*
589 %{_libdir}/libmurphy-resource.so.*
590 %{_libdir}/libmurphy-resource-backend.so.*
591 %if %{?_with_lua:1}%{!?_with_lua:0}
592 %{_libdir}/libmurphy-lua-utils.so.*
593 %{_libdir}/libmurphy-lua-decision.so.*
594 %endif
595 %{_libdir}/libmurphy-domain-controller.so.*
596 %{_libdir}/murphy/*.so.*
597 %{_libdir}/libbreedline*.so.*
598 %if %{?_with_dbus:1}%{!?_with_dbus:0}
599 %{_libdir}/libmurphy-libdbus.so.*
600 %{_libdir}/libmurphy-dbus-libdbus.so.*
601 %endif
602
603 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
604 %files plugins-base -f filelist.plugins-base
605 %defattr(-,root,root,-)
606 %endif
607 %{_libdir}/murphy/plugins/plugin-domain-control.so
608 %{_libdir}/murphy/plugins/plugin-resource-asm.so
609 %{_libdir}/murphy/plugins/plugin-resource-native.so
610
611 %files devel -f filelist.devel-includes
612 %defattr(-,root,root,-)
613 # %{_includedir}/murphy/config.h
614 # %{_includedir}/murphy/common.h
615 # #%{_includedir}/murphy/core.h
616 # %{_includedir}/murphy/common
617 # %{_includedir}/murphy/core
618 # %{_includedir}/murphy/resolver
619 # %{_includedir}/murphy/resource
620 # # hmmm... should handle disabled plugins properly.
621 # %{_includedir}/murphy/domain-control
622 # %{_includedir}/murphy/plugins
623 %{_includedir}/murphy-db
624 %{_libdir}/libmurphy-common.so
625 %{_libdir}/libmurphy-core.so
626 %{_libdir}/libmurphy-resolver.so
627 %{_libdir}/libmurphy-resource.so
628 %{_libdir}/libmurphy-resource-backend.so
629 %if %{?_with_lua:1}%{!?_with_lua:0}
630 %{_libdir}/libmurphy-lua-utils.so
631 %{_libdir}/libmurphy-lua-decision.so
632 %endif
633 %{_libdir}/libmurphy-domain-controller.so
634 %{_libdir}/murphy/*.so
635 %{_libdir}/pkgconfig/murphy-common.pc
636 %{_libdir}/pkgconfig/murphy-core.pc
637 %{_libdir}/pkgconfig/murphy-resolver.pc
638 #%{_libdir}/pkgconfig/murphy-resource.pc
639 %if %{?_with_lua:1}%{!?_with_lua:0}
640 %{_libdir}/pkgconfig/murphy-lua-utils.pc
641 %{_libdir}/pkgconfig/murphy-lua-decision.pc
642 %endif
643 %{_libdir}/pkgconfig/murphy-domain-controller.pc
644 %{_libdir}/pkgconfig/murphy-db.pc
645 %{_libdir}/pkgconfig/murphy-resource.pc
646 %{_includedir}/breedline
647 %{_libdir}/libbreedline*.so
648 %{_libdir}/pkgconfig/breedline*.pc
649 %if %{?_with_dbus:1}%{!?_with_dbus:0}
650 #%{_includedir}/murphy/dbus
651 %{_libdir}/libmurphy-libdbus.so
652 %{_libdir}/libmurphy-dbus-libdbus.so
653 %{_libdir}/pkgconfig/murphy-libdbus.pc
654 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
655 %endif
656
657 %files doc
658 %defattr(-,root,root,-)
659 %doc %{_docdir}/../murphy/AUTHORS
660 %doc %{_docdir}/../murphy/CODING-STYLE
661 %doc %{_docdir}/../murphy/ChangeLog
662 %doc %{_docdir}/../murphy/NEWS
663 %doc %{_docdir}/../murphy/README
664 %license COPYING LICENSE-BSD
665
666 %if %{?_with_pulse:1}%{!?_with_pulse:0}
667 %files pulse
668 %defattr(-,root,root,-)
669 %{_libdir}/libmurphy-pulse.so.*
670 %manifest %{_datadir}/murphy-pulse.manifest
671
672 %files pulse-devel
673 %defattr(-,root,root,-)
674 %{_includedir}/murphy/common/pulse-glue.h
675 %{_libdir}/libmurphy-pulse.so
676 %{_libdir}/pkgconfig/murphy-pulse.pc
677 %endif
678
679 %if %{?_with_ecore:1}%{!?_with_ecore:0}
680 %files ecore
681 %defattr(-,root,root,-)
682 %{_libdir}/libmurphy-ecore.so.*
683 %manifest %{_datadir}/murphy-ecore.manifest
684
685 %files ecore-devel
686 %defattr(-,root,root,-)
687 %{_includedir}/murphy/common/ecore-glue.h
688 %{_libdir}/libmurphy-ecore.so
689 %{_libdir}/pkgconfig/murphy-ecore.pc
690 %endif
691
692 %if %{?_with_glib:1}%{!?_with_glib:0}
693 %files glib
694 %defattr(-,root,root,-)
695 %{_libdir}/libmurphy-glib.so.*
696 %manifest %{_datadir}/murphy-glib.manifest
697
698 %files glib-devel
699 %defattr(-,root,root,-)
700 %{_includedir}/murphy/common/glib-glue.h
701 %{_libdir}/libmurphy-glib.so
702 %{_libdir}/pkgconfig/murphy-glib.pc
703 %endif
704
705 %if %{?_with_qt:1}%{!?_with_qt:0}
706 %files qt
707 %defattr(-,root,root,-)
708 %{_libdir}/libmurphy-qt.so.*
709 %manifest %{_datadir}/murphy-qt.manifest
710
711 %files qt-devel
712 %defattr(-,root,root,-)
713 %{_includedir}/murphy/common/qt-glue.h
714 %{_libdir}/libmurphy-qt.so
715 %{_libdir}/pkgconfig/murphy-qt.pc
716 %endif
717
718 %files tests
719 %defattr(-,root,root,-)
720 %{_bindir}/resource-client
721 %{_bindir}/resource-api-test
722 %{_bindir}/resource-api-fuzz
723 %{_bindir}/test-domain-controller
724 %{_bindir}/murphy-console
725 %manifest %{_datadir}/murphy-tests.manifest
726
727 %files ivi-resource-manager
728 %defattr(-,root,root,-)
729 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
730 %manifest %{_datadir}/murphy-ivi-resource-manager.manifest
731
732 %if %{_enable_icosyscon}
733 %files system-controller
734 %defattr(-,root,root,-)
735 %{_libdir}/murphy/plugins/plugin-system-controller.so
736 %{systemddir}/user/ico-homescreen.service
737 %{systemddir}/user/murphy-wait-for-launchpad-ready.path
738 %manifest %{_datadir}/murphy-system-controller.manifest
739 %endif
740
741 %changelog
742 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
743 - Initial build for 2.0alpha.