da5e9940bd9eb8bd354aed5222ebb5b73853602b
[profile/ivi/murphy.git] / packaging / murphy.spec
1 %bcond_with icosyscon
2
3 # By default we build with distro-default compilation flags which
4 # enables optimizations. If you want to build with full debugging
5 # ie. with optimization turned off and full debug info (-O0 -g3)
6 # pass '--with debug' to rpmbuild on the command line. Similary
7 # you can chose to compile with/without pulse, ecore, glib, qt,
8 # dbus, and telephony support. --without squashpkg will prevent
9 # squashing the -core and -plugins-base packages into the base
10 # murphy package.
11
12
13 %{!?_with_debug:%{!?_without_debug:%define _without_debug 0}}
14 %{!?_with_lua:%{!?_without_lua:%define _with_lua 1}}
15 %{!?_with_pulse:%{!?_without_pulse:%define _with_pulse 1}}
16 %{!?_with_ecore:%{!?_without_ecore:%define _with_ecore 1}}
17 %{!?_with_glib:%{!?_without_glib:%define _with_glib 1}}
18 %{!?_with_qt:%{!?_without_qt:%define _without_qt 1}}
19 %{!?_with_dbus:%{!?_without_dbus:%define _with_dbus 1}}
20 %{!?_with_telephony:%{!?_without_telephony:%define _with_telephony 1}}
21 %{!?_with_audiosession:%{!?_without_audiosession:%define _with_audiosession 1}}
22 %{!?_with_websockets:%{!?_without_websockets:%define _with_websockets 1}}
23 %{!?_with_smack:%{!?_without_smack:%define _with_smack 1}}
24 %{!?_with_icosyscon:%{!?_without_icosyscon:%define _without_icosyscon 1}}
25 %{!?_with_icoweston:%{!?_without_icoweston:%define _without_icoweston 1}}
26 %{!?_with_sysmon:%{!?_without_sysmon:%define _with_sysmon 1}}
27 %{!?_with_squashpkg:%{!?_without_squashpkg:%define _with_squashpkg 1}}
28
29 #
30 # Abnormalize _with_icosyscon to _enable_icosyscon
31 #
32 # Since some people seem to have a hard time understanding that
33 #
34 # 1) the right way to disable a conditional _with_* rpm macro is to leave it
35 #    undefined as opposed to defining it to 0
36 #
37 # 2) if you decide to do it the wrong way at least you should be consistent
38 #    about it and not randomly change between the conventions
39 #
40 # we need to roll this butt-ugly hack to make sure that we always go with
41 # the wrong convention. We always set up _enable_icosyscon to 1 or 0 depending
42 # on how _with_icosyscon happens to be set (or unset).
43 #
44
45 %if %{!?_with_icosyscon:0}%{?_with_icosyscon:1}
46 %if %{_with_icosyscon}
47 %define _enable_icosyscon 1
48 %else
49 %define _enable_icosyscon 0
50 %endif
51 %else
52 %define _enable_icosyscon 0
53 %endif
54
55 Summary: Resource policy framework
56 Name: murphy
57 Version: 0.0.64
58 Release: 1
59 License: BSD-3-Clause
60 Group: System/Service
61 URL: http://01.org/murphy/
62 Source0: %{name}-%{version}.tar.gz
63 Source1001: %{name}.manifest
64 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
65 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
66 Requires: %{name}-core = %{version}
67 %endif
68
69 Requires(post): /bin/systemctl
70 Requires(post): libcap-tools
71 Requires(postun): /bin/systemctl
72
73 BuildRequires: flex
74 BuildRequires: bison
75 BuildRequires: pkgconfig(lua)
76 BuildRequires: pkgconfig(libsystemd-daemon)
77 BuildRequires: pkgconfig(libsystemd-journal)
78 BuildRequires: pkgconfig(libcap)
79 BuildRequires: pkgconfig(libtzplatform-config)
80
81 %if %{?_with_pulse:1}%{!?_with_pulse:0}
82 BuildRequires: pkgconfig(libpulse)
83 %endif
84 %if %{?_with_ecore:1}%{!?_with_ecore:0}
85 BuildRequires: pkgconfig(ecore)
86 BuildRequires: mesa-libEGL
87 BuildRequires: mesa-libGLESv2
88 %endif
89 %if %{?_with_glib:1}%{!?_with_glib:0}
90 BuildRequires: pkgconfig(glib-2.0)
91 %endif
92 %if %{?_with_qt:1}%{!?_with_qt:0}
93 BuildRequires: pkgconfig(QtCore)
94 %endif
95 %if %{?_with_dbus:1}%{!?_with_dbus:0}
96 BuildRequires: pkgconfig(dbus-1)
97 %endif
98 %if %{?_with_telephony:1}%{!?_with_telephony:0}
99 BuildRequires: pkgconfig(ofono)
100 %endif
101 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
102 BuildRequires: pkgconfig(audio-session-mgr)
103 BuildRequires: pkgconfig(aul)
104 %endif
105 %if %{?_with_websockets:1}%{!?_with_websockets:0}
106 BuildRequires: libwebsockets-devel
107 %endif
108 BuildRequires: pkgconfig(json)
109
110 %if %{?_with_smack:1}%{!?_with_smack:0}
111 BuildRequires: pkgconfig(libsmack)
112 %endif
113
114 %if %{?_with_icosyscon:1}%{!?_with_icosyscon:0}
115 # %%if %%{_with_icosyscon} # gbs can't, so don't bother...
116 BuildRequires: ico-uxf-weston-plugin-devel
117 BuildRequires: weston-ivi-shell-devel
118 BuildRequires: genivi-shell-devel
119 BuildRequires: pkgconfig(ail)
120 BuildRequires: pkgconfig(aul)
121 BuildRequires: libxml2-devel
122 # %%endif
123 %endif
124
125 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
126 %package core
127 Summary: Murphy core runtime libraries
128 Group: System/Libraries
129
130 %package plugins-base
131 Summary: The basic set of Murphy plugins
132 Group: System/Service
133 Requires: %{name} = %{version}
134 Requires: %{name}-core = %{version}
135 %endif
136
137 %package devel
138 Summary: The header files and libraries needed for Murphy development
139 Group: System/Libraries
140 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
141 Requires: %{name}-core = %{version}
142 %else
143 Requires: %{name} = %{version}
144 %endif
145 Requires: libjson-devel
146
147 %package doc
148 Summary: Documentation for Murphy
149 Group: SDK/Documentation
150
151 %if %{?_with_pulse:1}%{!?_with_pulse:0}
152 %package pulse
153 Summary: Murphy PulseAudio mainloop integration
154 Group: System/Libraries
155 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
156 Requires: %{name}-core = %{version}
157 %else
158 Requires: %{name} = %{version}
159 %endif
160
161 %package pulse-devel
162 Summary: Murphy PulseAudio mainloop integration development files
163 Group: System/Libraries
164 Requires: %{name}-pulse = %{version}
165 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
166 Requires: %{name}-core = %{version}
167 %else
168 Requires: %{name} = %{version}
169 %endif
170 %endif
171
172 %if %{?_with_ecore:1}%{!?_with_ecore:0}
173 %package ecore
174 Summary: Murphy EFL/ecore mainloop integration
175 Group: System/Libraries
176 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
177 Requires: %{name}-core = %{version}
178 %else
179 Requires: %{name} = %{version}
180 %endif
181
182 %package ecore-devel
183 Summary: Murphy EFL/ecore mainloop integration development files
184 Group: System/Libraries
185 Requires: %{name}-ecore = %{version}
186 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
187 Requires: %{name}-core = %{version}
188 %else
189 Requires: %{name} = %{version}
190 %endif
191 %endif
192
193 %if %{?_with_glib:1}%{!?_with_glib:0}
194 %package glib
195 Summary: Murphy glib mainloop integration
196 Group: System/Libraries
197 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
198 Requires: %{name}-core = %{version}
199 %else
200 Requires: %{name} = %{version}
201 %endif
202
203 %package glib-devel
204 Summary: Murphy glib mainloop integration development files
205 Group: System/Libraries
206 Requires: %{name}-glib = %{version}
207 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
208 Requires: %{name}-core = %{version}
209 %else
210 Requires: %{name} = %{version}
211 %endif
212 %endif
213
214 %if %{?_with_qt:1}%{!?_with_qt:0}
215 %package qt
216 Summary: Murphy Qt mainloop integration
217 Group: System/Libraries
218 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
219 Requires: %{name}-core = %{version}
220 %else
221 Requires: %{name} = %{version}
222 %endif
223
224 %package qt-devel
225 Summary: Murphy Qt mainloop integration development files
226 Group: System/Libraries
227 Requires: %{name}-qt = %{version}
228 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
229 Requires: %{name}-core = %{version}
230 %else
231 Requires: %{name} = %{version}
232 %endif
233 %endif
234
235 %package gam
236 Summary: Murphy support for Genivi Audio Manager
237 Group: System/Libraries
238 Requires: %{name} = %{version}
239
240 %package gam-devel
241 Summary: Murphy support for Genivi Audio Manager development files
242 Group: System/Libraries
243 Requires: %{name}-gam = %{version}
244
245 %package tests
246 Summary: Various test binaries for Murphy
247 Group: System/Testing
248 Requires: %{name} = %{version}
249 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
250 Requires: %{name}-core = %{version}
251 %else
252 Requires: %{name} = %{version}
253 %endif
254
255 %package ivi-resource-manager
256 Summary: Murphy IVI resource manager plugin
257 Group: System/Service
258
259 %if %{_enable_icosyscon}
260 %package system-controller
261 Summary: Murphy IVI System Controller plugin
262 Group: System/Service
263 Requires: ico-uxf-homescreen
264 Conflicts: murphy-ivi-resource-manager
265 Provides: system-controller
266 Conflicts: ico-uxf-homescreen-system-controller
267 %endif
268
269 %description
270 This package contains the basic Murphy daemon.
271
272 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
273 %description core
274 This package contains the core runtime libraries.
275
276 %description plugins-base
277 This package contains a basic set of plugins.
278 %endif
279
280 %description devel
281 This package contains header files and libraries necessary for development.
282
283 %description doc
284 This package contains documentation.
285
286 %if %{?_with_pulse:1}%{!?_with_pulse:0}
287 %description pulse
288 This package contains the Murphy PulseAudio mainloop integration runtime files.
289
290 %description pulse-devel
291 This package contains the Murphy PulseAudio mainloop integration development
292 files.
293 %endif
294
295 %if %{?_with_ecore:1}%{!?_with_ecore:0}
296 %description ecore
297 This package contains the Murphy EFL/ecore mainloop integration runtime files.
298
299 %description ecore-devel
300 This package contains the Murphy EFL/ecore mainloop integration development
301 files.
302 %endif
303
304 %if %{?_with_glib:1}%{!?_with_glib:0}
305 %description glib
306 This package contains the Murphy glib mainloop integration runtime files.
307
308 %description glib-devel
309 This package contains the Murphy glib mainloop integration development
310 files.
311 %endif
312
313 %if %{?_with_qt:1}%{!?_with_qt:0}
314 %description qt
315 This package contains the Murphy Qt mainloop integration runtime files.
316
317 %description qt-devel
318 This package contains the Murphy Qt mainloop integration development
319 files.
320 %endif
321
322 %description tests
323 This package contains various test binaries for Murphy.
324
325 %description ivi-resource-manager
326 This package contains the Murphy IVI resource manager plugin.
327
328 %if %{_enable_icosyscon}
329 %description system-controller
330 This package contains the Murphy IVI resource manager plugin.
331 %endif
332
333 %description gam
334 This package contains the Murphy plugins for necessary for supporting
335 Genivi Audio Manager.
336
337 %description gam-devel
338 This package contains development files for Murphy Genivi Audio Manager
339 plugins.
340
341 %prep
342 %setup -q
343 cp %{SOURCE1001} .
344
345 echo "_with_icosyscon:   \"%{_with_icosyscon}\""
346 echo "_enable_icosyscon: \"%{_enable_icosyscon}\""
347
348 %build
349 %if %{?_with_debug:1}%{!?_with_debug:0}
350 export CFLAGS="-O0 -g3"
351 V="V=1"
352 %endif
353
354 CONFIG_OPTIONS=""
355 DYNAMIC_PLUGINS="domain-control,system-controller,ivi-resource-manager"
356
357 %if %{?_with_pulse:1}%{!?_with_pulse:0}
358 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-pulse"
359 %else
360 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-pulse"
361 %endif
362
363 %if %{?_with_ecore:1}%{!?_with_ecore:0}
364 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-ecore"
365 %else
366 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-ecore"
367 %endif
368
369 %if %{?_with_glib:1}%{!?_with_glib:0}
370 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-glib"
371 %else
372 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-glib"
373 %endif
374
375 %if %{?_with_qt:1}%{!?_with_qt:0}
376 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-qt"
377 %else
378 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-qt"
379 %endif
380
381 %if %{?_with_dbus:1}%{!?_with_dbus:0}
382 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-libdbus"
383 %else
384 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-libdbus"
385 %endif
386
387 %if %{?_with_telephony:1}%{!?_with_telephony:0}
388 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-gpl --enable-telephony"
389 %else
390 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-telephony"
391 %endif
392
393 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
394 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-resource-asm"
395 DYNAMIC_PLUGINS="$DYNAMIC_PLUGINS,resource-asm"
396 %else
397 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-resource-asm"
398 %endif
399
400 %if %{?_with_websockets:1}%{!?_with_websockets:0}
401 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-websockets"
402 %else
403 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-websockets"
404 %endif
405
406 %if %{?_with_smack:1}%{!?_with_smack:0}
407 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-smack"
408 %else
409 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-smack"
410 %endif
411
412 %if %{_enable_icosyscon}
413 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-controller"
414 %else
415 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-controller"
416 %endif
417
418 %if %{?_with_sysmon:1}%{!?_with_sysmon:0}
419 CONFIG_OPTIONS="$CONFIG_OPTIONS --enable-system-monitor"
420 %else
421 CONFIG_OPTIONS="$CONFIG_OPTIONS --disable-system-monitor"
422 %endif
423
424 ./bootstrap
425 %configure $CONFIG_OPTIONS --with-dynamic-plugins=$DYNAMIC_PLUGINS
426 %__make clean
427 %__make %{?_smp_mflags} $V
428
429 %install
430 rm -rf %{buildroot}
431 %make_install
432
433 # Make sure we have a plugin dir even if all the basic plugins
434 # are configured to be built in.
435 mkdir -p %{buildroot}%{_libdir}/murphy/plugins
436
437 # Get rid of any *.la files installed by libtool.
438 rm -f %{buildroot}%{_libdir}/*.la
439
440 # Clean up also the murphy DB installation.
441 rm -f %{buildroot}%{_libdir}/murphy/*.la
442
443 # Generate list of linkedin plugins (depends on the configuration).
444 outdir="`pwd`"
445 pushd %{buildroot} >& /dev/null && \
446 find ./%{_libdir} -name libmurphy-plugin-*.so* | \
447 sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
448 popd >& /dev/null
449 echo "Found the following linked-in plugin files:"
450 cat $outdir/filelist.plugins-base | sed 's/^/    /g'
451
452 # Generate list of header files, filtering ones that go to subpackages.
453 outdir="`pwd`"
454 pushd %{buildroot} >& /dev/null && \
455 find ./%{_includedir}/murphy | \
456 grep -E -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
457 sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
458 popd >& /dev/null
459
460 # Replace the default sample/test config files with the packaging ones.
461 rm -f %{buildroot}%{_sysconfdir}/murphy/*
462 cp packaging.in/murphy-lua.conf %{buildroot}%{_sysconfdir}/murphy/murphy.conf
463 cp packaging.in/murphy.lua      %{buildroot}%{_sysconfdir}/murphy/murphy.lua
464
465 # Copy plugin configuration files in place.
466 mkdir -p %{buildroot}%{_sysconfdir}/murphy/plugins/amb
467 cp packaging.in/amb-config.lua \
468 %{buildroot}%{_sysconfdir}/murphy/plugins/amb/config.lua
469
470 # Copy tmpfiles.d config file in place
471 mkdir -p %{buildroot}%{_tmpfilesdir}
472 cp packaging.in/murphyd.conf %{buildroot}%{_tmpfilesdir}
473
474 # Copy the systemd files in place.
475 mkdir -p %{buildroot}%{_unitdir}
476 mkdir -p %{buildroot}%{_unitdir_user}
477 cp packaging.in/murphyd.service %{buildroot}%{_unitdir_user}
478
479 %if %{?_with_dbus:1}%{!?_with_dbus:0}
480 mkdir -p %{buildroot}%{_sysconfdir}/dbus-1/system.d
481 sed "s/@TZ_SYS_USER_GROUP@/%{TZ_SYS_USER_GROUP}/g" \
482     packaging.in/org.Murphy.conf.in > packaging.in/org.Murphy.conf
483 cp packaging.in/org.Murphy.conf \
484     %{buildroot}%{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
485 %endif
486
487 # copy (experimental) GAM resource backend configuration files
488 mkdir -p %{buildroot}%{_sysconfdir}/murphy/gam
489 cp packaging.in/gam-*.names packaging.in/gam-*.tree \
490     %{buildroot}%{_sysconfdir}/murphy/gam
491
492 %clean
493 rm -rf %{buildroot}
494
495 %post
496 /bin/systemctl --user enable --global murphyd.service
497 setcap 'cap_net_admin=+ep' %{_bindir}/murphyd
498
499 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
500 %post core
501 %endif
502 ldconfig
503
504 %postun
505 if [ "$1" = "0" ]; then
506 /bin/systemctl --user disable --global murphyd.service
507 fi
508
509 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
510 %postun core
511 %endif
512 ldconfig
513
514 %if %{?_with_glib:1}%{!?_with_glib:0}
515 %post glib
516 ldconfig
517
518 %postun glib
519 ldconfig
520 %endif
521
522 %if %{?_with_pulse:1}%{!?_with_pulse:0}
523 %post pulse
524 ldconfig
525
526 %postun pulse
527 ldconfig
528 %endif
529
530 %if %{?_with_ecore:1}%{!?_with_ecore:0}
531 %post ecore
532 ldconfig
533
534 %postun ecore
535 ldconfig
536 %endif
537
538 %if %{?_with_qt:1}%{!?_with_qt:0}
539 %post qt
540 ldconfig
541
542 %postun qt
543 ldconfig
544 %endif
545
546 %post gam
547 ldconfig
548
549 %postun gam
550 ldconfig
551
552 %if %{?_with_squashpkg:1}%{!?_with_squashpkg:0}
553 %files -f filelist.plugins-base
554 %else
555 %files
556 %endif
557 %defattr(-,root,root,-)
558 %manifest murphy.manifest
559 %{_bindir}/murphyd
560 %config %{_sysconfdir}/murphy
561 %{_unitdir_user}/murphyd.service
562 %{_tmpfilesdir}/murphyd.conf
563 %if %{?_with_audiosession:1}%{!?_with_audiosession:0}
564 %{_sbindir}/asm-bridge
565 %endif
566 %if %{?_with_dbus:1}%{!?_with_dbus:0}
567 %{_sysconfdir}/dbus-1/system.d
568 %config %{_sysconfdir}/dbus-1/system.d/org.Murphy.conf
569 %endif
570 %if %{?_with_websockets:1}%{!?_with_websockets:0}
571 %{_datadir}/murphy
572 %endif
573
574 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
575 %files core
576 %defattr(-,root,root,-)
577 %endif
578 %{_libdir}/libmurphy-common.so.*
579 %{_libdir}/libmurphy-core.so.*
580 %{_libdir}/libmurphy-resolver.so.*
581 %{_libdir}/libmurphy-resource.so.*
582 %{_libdir}/libmurphy-resource-backend.so.*
583 %if %{?_with_lua:1}%{!?_with_lua:0}
584 %{_libdir}/libmurphy-lua-utils.so.*
585 %{_libdir}/libmurphy-lua-decision.so.*
586 %endif
587 %{_libdir}/libmurphy-domain-controller.so.*
588 %{_libdir}/murphy/*.so.*
589 %{_libdir}/libbreedline*.so.*
590 %if %{?_with_dbus:1}%{!?_with_dbus:0}
591 %{_libdir}/libmurphy-libdbus.so.*
592 %{_libdir}/libmurphy-dbus-libdbus.so.*
593 %endif
594
595 %if %{?_with_squashpkg:0}%{!?_with_squashpkg:1}
596 %files plugins-base -f filelist.plugins-base
597 %defattr(-,root,root,-)
598 %endif
599 %{_libdir}/murphy/plugins/plugin-domain-control.so
600 %{_libdir}/murphy/plugins/plugin-resource-asm.so
601 %{_libdir}/murphy/plugins/plugin-resource-native.so
602
603 %files devel -f filelist.devel-includes
604 %defattr(-,root,root,-)
605 # %%{_includedir}/murphy/config.h
606 # %%{_includedir}/murphy/common.h
607 # %%{_includedir}/murphy/core.h
608 # %%{_includedir}/murphy/common
609 # %%{_includedir}/murphy/core
610 # %%{_includedir}/murphy/resolver
611 # %%{_includedir}/murphy/resource
612 # # hmmm... should handle disabled plugins properly.
613 # %%{_includedir}/murphy/domain-control
614 # %%{_includedir}/murphy/plugins
615 %{_includedir}/murphy-db
616 %{_libdir}/libmurphy-common.so
617 %{_libdir}/libmurphy-core.so
618 %{_libdir}/libmurphy-resolver.so
619 %{_libdir}/libmurphy-resource.so
620 %{_libdir}/libmurphy-resource-backend.so
621 %if %{?_with_lua:1}%{!?_with_lua:0}
622 %{_libdir}/libmurphy-lua-utils.so
623 %{_libdir}/libmurphy-lua-decision.so
624 %endif
625 %{_libdir}/libmurphy-domain-controller.so
626 %{_libdir}/murphy/*.so
627 %{_libdir}/pkgconfig/murphy-common.pc
628 %{_libdir}/pkgconfig/murphy-core.pc
629 %{_libdir}/pkgconfig/murphy-resolver.pc
630 # %%{_libdir}/pkgconfig/murphy-resource.pc
631 %if %{?_with_lua:1}%{!?_with_lua:0}
632 %{_libdir}/pkgconfig/murphy-lua-utils.pc
633 %{_libdir}/pkgconfig/murphy-lua-decision.pc
634 %endif
635 %{_libdir}/pkgconfig/murphy-domain-controller.pc
636 %{_libdir}/pkgconfig/murphy-db.pc
637 %{_libdir}/pkgconfig/murphy-resource.pc
638 %{_includedir}/breedline
639 %{_libdir}/libbreedline*.so
640 %{_libdir}/pkgconfig/breedline*.pc
641 %if %{?_with_dbus:1}%{!?_with_dbus:0}
642 # %%{_includedir}/murphy/dbus
643 %{_libdir}/libmurphy-libdbus.so
644 %{_libdir}/libmurphy-dbus-libdbus.so
645 %{_libdir}/pkgconfig/murphy-libdbus.pc
646 %{_libdir}/pkgconfig/murphy-dbus-libdbus.pc
647 %endif
648
649 %files doc
650 %defattr(-,root,root,-)
651 %doc %{_docdir}/../murphy/AUTHORS
652 %doc %{_docdir}/../murphy/CODING-STYLE
653 %doc %{_docdir}/../murphy/ChangeLog
654 %doc %{_docdir}/../murphy/NEWS
655 %doc %{_docdir}/../murphy/README
656 %license COPYING LICENSE-BSD
657
658 %if %{?_with_pulse:1}%{!?_with_pulse:0}
659 %files pulse
660 %defattr(-,root,root,-)
661 %{_libdir}/libmurphy-pulse.so.*
662 %manifest murphy.manifest
663
664 %files pulse-devel
665 %defattr(-,root,root,-)
666 %{_includedir}/murphy/common/pulse-glue.h
667 %{_libdir}/libmurphy-pulse.so
668 %{_libdir}/pkgconfig/murphy-pulse.pc
669 %endif
670
671 %if %{?_with_ecore:1}%{!?_with_ecore:0}
672 %files ecore
673 %defattr(-,root,root,-)
674 %{_libdir}/libmurphy-ecore.so.*
675 %manifest murphy.manifest
676
677 %files ecore-devel
678 %defattr(-,root,root,-)
679 %{_includedir}/murphy/common/ecore-glue.h
680 %{_libdir}/libmurphy-ecore.so
681 %{_libdir}/pkgconfig/murphy-ecore.pc
682 %endif
683
684 %if %{?_with_glib:1}%{!?_with_glib:0}
685 %files glib
686 %defattr(-,root,root,-)
687 %{_libdir}/libmurphy-glib.so.*
688 %manifest murphy.manifest
689
690 %files glib-devel
691 %defattr(-,root,root,-)
692 %{_includedir}/murphy/common/glib-glue.h
693 %{_libdir}/libmurphy-glib.so
694 %{_libdir}/pkgconfig/murphy-glib.pc
695 %endif
696
697 %if %{?_with_qt:1}%{!?_with_qt:0}
698 %files qt
699 %defattr(-,root,root,-)
700 %{_libdir}/libmurphy-qt.so.*
701 %manifest murphy.manifest
702
703 %files qt-devel
704 %defattr(-,root,root,-)
705 %{_includedir}/murphy/common/qt-glue.h
706 %{_libdir}/libmurphy-qt.so
707 %{_libdir}/pkgconfig/murphy-qt.pc
708 %endif
709
710 %files gam
711 %defattr(-,root,root,-)
712 %{_libdir}/libmurphy-decision-tree.so.*
713 %{_libdir}/libmurphy-decision-tree.so.0.0.0
714 %{_libdir}/murphy/plugins/plugin-gam-resource-manager.so
715
716 %files gam-devel
717 %defattr(-,root,root,-)
718 %{_bindir}/decision-test
719 %{_bindir}/pattern-generator
720 %{_libdir}/libmurphy-decision-tree.so
721
722 %files tests
723 %defattr(-,root,root,-)
724 %{_bindir}/resource-client
725 %{_bindir}/resource-api-test
726 %{_bindir}/resource-api-fuzz
727 %{_bindir}/resource-context-create
728 %{_bindir}/test-domain-controller
729 %{_bindir}/murphy-console
730 %manifest murphy.manifest
731
732 %files ivi-resource-manager
733 %defattr(-,root,root,-)
734 %{_libdir}/murphy/plugins/plugin-ivi-resource-manager.so
735 %manifest murphy.manifest
736
737 %if %{_enable_icosyscon}
738 %files system-controller
739 %defattr(-,root,root,-)
740 %{_libdir}/murphy/plugins/plugin-system-controller.so
741 %manifest murphy.manifest
742 %endif
743
744 %changelog
745 * Tue Nov 27 2012 Krisztian Litkey <krisztian.litkey@intel.com> -
746 - Initial build for 2.0alpha.