Apply manifest guide.
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.2
3 Release:        1
4 License:        Samsung
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8
9 Requires(post): /usr/bin/sqlite3
10 Requires(post): /usr/bin/vconftool
11 Requires(post): /sbin/ldconfig
12 Requires(postun): /sbin/ldconfig
13 Requires(post): systemd
14 Requires(postun): systemd
15 BuildRequires: cmake
16 BuildRequires: pkgconfig(alarm-service)
17 BuildRequires: pkgconfig(aul)
18 BuildRequires: pkgconfig(capi-appfw-application)
19 BuildRequires: pkgconfig(contacts-service)
20 BuildRequires: pkgconfig(db-util)
21 BuildRequires: pkgconfig(devman_haptic)
22 BuildRequires: pkgconfig(dlog)
23 BuildRequires: pkgconfig(drm-client)
24 BuildRequires: pkgconfig(glib-2.0)
25 BuildRequires: pkgconfig(libcurl)
26 BuildRequires: pkgconfig(libsystemd-daemon)
27 BuildRequires: pkgconfig(libxml-2.0)
28 BuildRequires: pkgconfig(libwbxml2)
29 BuildRequires: pkgconfig(media-thumbnail)
30 BuildRequires: pkgconfig(mm-fileinfo)
31 BuildRequires: pkgconfig(mm-player)
32 BuildRequires: pkgconfig(mm-session)
33 BuildRequires: pkgconfig(network)
34 BuildRequires: pkgconfig(notification)
35 BuildRequires: pkgconfig(pmapi)
36 BuildRequires: pkgconfig(mmutil-imgp)
37 BuildRequires: pkgconfig(mmutil-jpeg)
38 BuildRequires: pkgconfig(security-server)
39 BuildRequires: pkgconfig(sensor)
40 BuildRequires: pkgconfig(svi)
41 BuildRequires: pkgconfig(tapi)
42 BuildRequires: pkgconfig(vconf)
43
44 %description
45 Description: Messaging Framework Library
46
47
48 %package devel
49 License:        Flora License v1.0
50 Summary:        Messaging Framework Library (development)
51 Requires:       %{name} = %{version}-%{release}
52 Group:          Development/Libraries
53
54 %description devel
55 Description: Messaging Framework Library (development)
56
57
58 %package tools
59 License:        Flora License v1.0
60 Summary:        Messaging server application
61 Requires:       %{name} = %{version}-%{release}
62 Group:          TO_BU / FILL_IN
63 Requires(post): /usr/bin/sqlite3
64 Requires(post): /usr/bin/vconftool
65 Requires(post): /sbin/ldconfig
66 Requires(postun): /sbin/ldconfig
67
68 %description tools
69 Description:  Messaging server application
70
71
72 %package -n sms-plugin
73 License:        Flora License v1.0
74 Summary:        SMS plugin library
75 Requires:       %{name} = %{version}-%{release}
76 Group:          System/Libraries
77 Requires(post): /sbin/ldconfig
78 Requires(postun): /sbin/ldconfig
79
80 %description -n sms-plugin
81 Description: SMS plugin library
82
83 %package -n mms-plugin
84 License:        Flora License v1.0
85 Summary:        MMS plugin library
86 Requires:       %{name} = %{version}-%{release}
87 Group:          System/Libraries
88 Requires(post): /sbin/ldconfig
89 Requires(postun): /sbin/ldconfig
90
91 %description -n mms-plugin
92 Description: MMS plugin library
93
94 %prep
95 %setup -q
96
97
98 %build
99 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
100 make %{?jobs:-j%jobs}
101
102 %install
103 rm -rf %{buildroot}
104 mkdir -p %{buildroot}/usr/share/license
105
106 %make_install
107
108 mkdir -p %{buildroot}%{_libdir}/systemd/user/tizen-middleware.target.wants
109 ln -s %{_libdir}/systemd/user/msg-service.service %{buildroot}%{_libdir}/systemd/user/tizen-middleware.target.wants/msg-service.service
110
111 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
112 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
113 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
114 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
115
116 mkdir -p %{buildroot}/opt/usr/data/msg-service
117
118 %post tools -p /sbin/ldconfig
119 %post -n sms-plugin -p /sbin/ldconfig
120 %post -n mms-plugin -p /sbin/ldconfig
121
122 %post
123 /sbin/ldconfig
124
125 if [ ! -f /opt/usr/dbspace/.msg_service.db ]
126 then
127     mkdir -p %{buildroot}/opt/usr/dbspace/
128     sqlite3 /opt/usr/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
129
130     CREATE TABLE MSG_CONVERSATION_TABLE ( CONV_ID INTEGER NOT NULL , UNREAD_CNT INTEGER DEFAULT 0 , SMS_CNT INTEGER DEFAULT 0 , MMS_CNT INTEGER DEFAULT 0 , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , MSG_DIRECTION INTEGER NOT NULL , DISPLAY_TIME INTEGER , DISPLAY_NAME TEXT , MSG_TEXT TEXT );
131     CREATE TABLE MSG_ADDRESS_TABLE ( ADDRESS_ID INTEGER PRIMARY KEY , CONV_ID INTEGER  NOT NULL , ADDRESS_TYPE INTEGER , RECIPIENT_TYPE INTEGER , ADDRESS_VAL TEXT , CONTACT_ID INTEGER , DISPLAY_NAME TEXT , FIRST_NAME TEXT , LAST_NAME TEXT , IMAGE_PATH TEXT , SYNC_TIME DATETIME , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
132     CREATE TABLE MSG_FOLDER_TABLE ( FOLDER_ID INTEGER PRIMARY KEY , FOLDER_NAME TEXT NOT NULL , FOLDER_TYPE INTEGER DEFAULT 0 );
133     CREATE TABLE MSG_MESSAGE_TABLE ( MSG_ID INTEGER PRIMARY KEY , CONV_ID INTEGER NOT NULL , FOLDER_ID INTEGER NOT NULL , STORAGE_ID INTEGER NOT NULL , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , DISPLAY_TIME DATETIME , DATA_SIZE INTEGER DEFAULT 0 , NETWORK_STATUS INTEGER DEFAULT 0 , READ_STATUS INTEGER DEFAULT 0 , PROTECTED INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , MSG_DIRECTION INTEGER NOT NULL , SCHEDULED_TIME DATETIME , BACKUP INTEGER DEFAULT 0 , SUBJECT TEXT , MSG_DATA TEXT , THUMB_PATH TEXT , MSG_TEXT TEXT , ATTACHMENT_COUNT INTEGER DEFAULT 0 , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) , FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
134     CREATE TABLE MSG_SIM_TABLE ( MSG_ID INTEGER , SIM_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
135     CREATE TABLE MSG_PUSH_TABLE ( MSG_ID INTEGER , ACTION INTEGER , CREATED INTEGER , EXPIRES INTEGER , ID TEXT , HREF TEXT , CONTENT TEXT , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
136     CREATE TABLE MSG_CBMSG_TABLE ( MSG_ID INTEGER , CB_MSG_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
137     CREATE TABLE MSG_SYNCML_TABLE ( MSG_ID INTEGER , EXT_ID INTEGER NOT NULL , PINCODE INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
138     CREATE TABLE MSG_SMS_SENDOPT_TABLE ( MSG_ID INTEGER , DELREP_REQ INTEGER NOT NULL , KEEP_COPY INTEGER NOT NULL , REPLY_PATH INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
139     CREATE TABLE MSG_FILTER_TABLE ( FILTER_ID INTEGER PRIMARY KEY , FILTER_TYPE INTEGER NOT NULL , FILTER_VALUE TEXT NOT NULL , FILTER_ACTIVE INTEGER DEFAULT 0);
140     CREATE TABLE MSG_MMS_MESSAGE_TABLE ( MSG_ID INTEGER , TRANSACTION_ID TEXT , MESSAGE_ID TEXT , FWD_MESSAGE_ID TEXT , CONTENTS_LOCATION TEXT , FILE_PATH TEXT , VERSION INTEGER NOT NULL , DATA_TYPE INTEGER DEFAULT -1 , DATE DATETIME , HIDE_ADDRESS INTEGER DEFAULT 0 , ASK_DELIVERY_REPORT INTEGER DEFAULT 0 , REPORT_ALLOWED INTEGER DEFAULT 0 , READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 , ASK_READ_REPLY INTEGER DEFAULT 0 , READ INTEGER DEFAULT 0 , READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 , READ_REPORT_SENT INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , KEEP_COPY INTEGER DEFAULT 0 , MSG_SIZE INTEGER NOT NULL , MSG_CLASS INTEGER DEFAULT -1 , EXPIRY_TIME DATETIME , CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 , DELIVERY_TIME DATETIME , MSG_STATUS INTEGER DEFAULT -1 , FOREIGN KEY (MSG_ID) REFERENCES MSG_MESSAGE_TABLE (MSG_ID) );
141     CREATE TABLE MSG_MMS_PREVIEW_INFO_TABLE ( MSG_ID INTEGER, TYPE INTEGER, VALUE TEXT, COUNT INTEGER, PRIMARY KEY (MSG_ID, TYPE)  ON CONFLICT REPLACE FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) ON DELETE CASCADE);
142     CREATE TABLE MSG_REPORT_TABLE ( MSG_ID INTEGER , ADDRESS_VAL TEXT , STATUS_TYPE INTEGER , STATUS INTEGER DEFAULT 0 , TIME DATETIME);
143     CREATE TABLE MSG_PUSHCFG_TABLE ( PUSH_ID INTEGER , CONTENT_TYPE TEXT, APP_ID TEXT, PKG_NAME TEXT, LAUNCH INTEGER, APPCODE INTEGER, SECURE INTEGER);
144
145     CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
146     CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
147     CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
148
149     INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
150     INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
151     INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
152     INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
153     INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
154     INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
155     INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
156     INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);
157
158     INSERT INTO MSG_PUSHCFG_TABLE VALUES (1, 'text/vnd.wap.si', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 1, 0);
159     INSERT INTO MSG_PUSHCFG_TABLE VALUES (2, 'application/vnd.wap.sic', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 2, 0);
160     INSERT INTO MSG_PUSHCFG_TABLE VALUES (3, 'text/vnd.wap.sl', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 3, 0);
161         INSERT INTO MSG_PUSHCFG_TABLE VALUES (4, 'application/vnd.wap.slc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 4, 0);
162     INSERT INTO MSG_PUSHCFG_TABLE VALUES (5, 'text/vnd.wap.co', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 5, 0);
163
164     INSERT INTO MSG_PUSHCFG_TABLE VALUES (6, 'application/vnd.wap.coc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 6, 0);
165     INSERT INTO MSG_PUSHCFG_TABLE VALUES (7, 'application/vnd.wap.mms-message', 'X-Wap-Application-Id: x-wap-application:mms.ua', '', 0, 7, 0);
166     INSERT INTO MSG_PUSHCFG_TABLE VALUES (8, 'application/vnd.wap.sia', 'X-Wap-Application-Id: x-wap-application:push.sia', '', 0, 8, 0);
167     INSERT INTO MSG_PUSHCFG_TABLE VALUES (9, 'application/vnd.syncml.dm+wbxml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 9, 0);
168     INSERT INTO MSG_PUSHCFG_TABLE VALUES (10, 'application/vnd.syncml.dm+xml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 10, 0);
169
170     INSERT INTO MSG_PUSHCFG_TABLE VALUES (11, 'application/vnd.syncml.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 11, 0);
171     INSERT INTO MSG_PUSHCFG_TABLE VALUES (12, 'application/vnd.syncml.ds.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.ds', '', 0, 12, 0);
172     INSERT INTO MSG_PUSHCFG_TABLE VALUES (13, 'application/vnd.syncml+wbxml', 'X-Wap-Application-Id:x-wap-application:push.syncml', '', 0, 13, 0);
173     INSERT INTO MSG_PUSHCFG_TABLE VALUES (14, 'application/vnd.wap.locc+wbxml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 14, 0);
174     INSERT INTO MSG_PUSHCFG_TABLE VALUES (15, 'application/vnd.wap.loc+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 15, 0);
175
176     INSERT INTO MSG_PUSHCFG_TABLE VALUES (16, 'application/vnd.oma.dd+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 16, 0);
177     INSERT INTO MSG_PUSHCFG_TABLE VALUES (17, 'application/vnd.oma.drm.message', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 17, 0);
178     INSERT INTO MSG_PUSHCFG_TABLE VALUES (18, 'application/vnd.oma.drm.content', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 18, 0);
179     INSERT INTO MSG_PUSHCFG_TABLE VALUES (19, 'application/vnd.oma.drm.rights+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 19, 0);
180     INSERT INTO MSG_PUSHCFG_TABLE VALUES (20, 'application/vnd.oma.drm.rights+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 20, 0);
181
182     INSERT INTO MSG_PUSHCFG_TABLE VALUES (21, 'application/vnd.oma.drm.ro+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 21, 0);
183     INSERT INTO MSG_PUSHCFG_TABLE VALUES (22, 'application/vnd.oma.drm.roap-pdu+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 22, 0);
184     INSERT INTO MSG_PUSHCFG_TABLE VALUES (23, 'application/vnd.oma.drm.roap-trigger+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 23, 0);
185     INSERT INTO MSG_PUSHCFG_TABLE VALUES (24, 'application/vnd.oma.drm.roap-trigger+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 24, 0);
186         INSERT INTO MSG_PUSHCFG_TABLE VALUES (25, 'text/vnd.wap.connectivity-xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 26, 0);
187
188         INSERT INTO MSG_PUSHCFG_TABLE VALUES (26, 'application/vnd.wap.connectivity-wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 27, 0);
189         INSERT INTO MSG_PUSHCFG_TABLE VALUES (27, 'application/x-wap-prov.browser-settings', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 28, 0);
190         INSERT INTO MSG_PUSHCFG_TABLE VALUES (28, 'application/x-wap-prov.browser-bookmarks', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 29, 0);
191         INSERT INTO MSG_PUSHCFG_TABLE VALUES (29, 'application/x-wap-prov.syncset+xml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 30, 0);
192         INSERT INTO MSG_PUSHCFG_TABLE VALUES (30, 'application/x-wap-prov.syncset+wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 31, 0);
193
194         INSERT INTO MSG_PUSHCFG_TABLE VALUES (31, 'text/vnd.wap.emn+xml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 32, 0);
195         INSERT INTO MSG_PUSHCFG_TABLE VALUES (32, 'application/vnd.wap.emn+wbxml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 33, 0);
196         INSERT INTO MSG_PUSHCFG_TABLE VALUES (33, 'application/vnd.wv.csp.cir', 'X-Wap-Application-Id: x-wap-application:wv.ua', '', 0, 34, 0);
197         INSERT INTO MSG_PUSHCFG_TABLE VALUES (34, 'application/vnd.omaloc-supl-init', 'X-Wap-Application-Id: x-oma-application:ulp.ua', '', 0, 44, 0);
198         INSERT INTO MSG_PUSHCFG_TABLE VALUES (35, 'application/vnd.wap.emn+wbxml', 'X-oma-docomo:xmd.mail.ua', '', 0, 45, 1);"
199 fi
200
201 chown :6011 /opt/usr/dbspace/.msg_service.db
202 chown :6011 /opt/usr/dbspace/.msg_service.db-journal
203 chmod 660 /opt/usr/dbspace/.msg_service.db
204 chmod 660 /opt/usr/dbspace/.msg_service.db-journal
205 mkdir -p /opt/usr/data/msg-service
206 chgrp db_msg_service /opt/usr/data/msg-service
207 chsmack -a 'msg-service::db' /opt/usr/dbspace/.msg_service.db*
208
209 ########## Setting Config Value (Internal keys) ##########
210 # Message Server Status
211 vconftool set -t bool memory/msg/ready 0 -i -g 5000
212
213 # SMS Send Options
214 vconftool set -t int db/msg/network_mode 2
215
216 # New Message Count
217 vconftool set -t int db/msg/recv_sms 0
218 vconftool set -t int db/msg/recv_mms 0
219
220 ########## Setting Config Value (Private keys) ##########
221 # General Options
222 vconftool set -t bool db/private/msg-service/general/keep_copy 1
223 vconftool set -t bool db/private/msg-service/general/auto_erase 0
224 vconftool set -t bool db/private/msg-service/general/block_msg 1
225 vconftool set -t int db/private/msg-service/general/contact_sync_time 0
226
227 # SMS Send Options
228 vconftool set -t int db/private/msg-service/sms_send/dcs 3
229 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0
230 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0
231 vconftool set -t int db/private/msg-service/sms_send/save_storage 1
232
233 # SMSC
234 vconftool set -t int db/private/msg-service/smsc/total_count 1
235 vconftool set -t int db/private/msg-service/smsc/selected 0
236
237 vconftool set -t int db/private/msg-service/smsc/pid/0 1
238 vconftool set -t int db/private/msg-service/smsc/val_period/0 255
239 vconftool set -t string db/private/msg-service/smsc/name/0 ""
240 vconftool set -t int db/private/msg-service/smsc/ton/0 1
241 vconftool set -t int db/private/msg-service/smsc/npi/0 1
242 vconftool set -t string db/private/msg-service/smsc/address/0 ""
243
244 vconftool set -t int db/private/msg-service/smsc/pid/1 0
245 vconftool set -t int db/private/msg-service/smsc/val_period/1 0
246 vconftool set -t string db/private/msg-service/smsc/name/1 ""
247 vconftool set -t int db/private/msg-service/smsc/ton/1 0
248 vconftool set -t int db/private/msg-service/smsc/npi/1 0
249 vconftool set -t string db/private/msg-service/smsc/address/1 ""
250
251 vconftool set -t int db/private/msg-service/smsc/pid/2 0
252 vconftool set -t int db/private/msg-service/smsc/val_period/2 0
253 vconftool set -t string db/private/msg-service/smsc/name/2 ""
254 vconftool set -t int db/private/msg-service/smsc/ton/2 0
255 vconftool set -t int db/private/msg-service/smsc/npi/2 0
256 vconftool set -t string db/private/msg-service/smsc/address/2 ""
257
258 # MMS Send Options
259 vconftool set -t int db/private/msg-service/mms_send/msg_class 0
260 vconftool set -t int db/private/msg-service/mms_send/priority 1
261 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0
262 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0
263 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0
264 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1
265 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1
266 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0
267 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0
268 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0
269 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1
270 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0
271 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0
272 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0
273 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0
274 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2
275
276 # MMS Receive Options
277 vconftool set -t int db/private/msg-service/mms_recv/home_network 0
278 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0
279 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1
280 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1
281 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0
282 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0
283
284 # MMS Receive Options
285 vconftool set -t int db/private/msg-service/mms_style/font_size 30
286 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0
287 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0
288 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0
289 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255
290 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255
291 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255
292 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255
293 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0
294 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0
295 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0
296 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255
297 vconftool set -t int db/private/msg-service/mms_style/page_dur 2
298 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0
299 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0
300
301 # Push Msg Options
302 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1
303 vconftool set -t int db/private/msg-service/push_msg/service_load 1
304
305 # CB Msg Options
306 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f
307 vconftool set -t bool db/private/msg-service/cb_msg/save 1 -f
308 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0
309 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0
310 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f
311 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0
312 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0
313 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0
314 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0
315 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0
316 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0
317 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0
318 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0
319 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0
320
321 # Voice Mail Options
322 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number "5500" -f
323 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count 0
324
325 # MMS Size Options
326 vconftool set -t int db/private/msg-service/size_opt/msg_size 300
327
328 # SIM message count
329 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0
330 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0
331
332 # SIM information
333 vconftool set -t int memory/private/msg-service/sim_changed 0 -i
334 vconftool set -t string memory/private/msg-service/sim_imsi "" -i
335 vconftool set -t bool memory/private/msg-service/national_sim 0 -i
336
337 /sbin/ldconfig
338 /bin/systemctl daemon-reload
339 if [ "$1" = "1" ]; then
340     systemctl stop msg-service.service
341 fi
342
343 %postun -p /sbin/ldconfig
344
345 %postun tools -p /sbin/ldconfig
346 %postun -n sms-plugin -p /sbin/ldconfig
347 %postun -n mms-plugin -p /sbin/ldconfig
348
349 %files
350 %manifest msg-service.manifest
351 %defattr(-,root,root,-)
352 %dir %attr(775,root,db_msg_service) /opt/usr/data/msg-service
353 %{_libdir}/libmsg_plugin_manager.so
354 %{_libdir}/libmsg_mapi.so.*
355 %{_libdir}/libmsg_framework_handler.so
356 %{_libdir}/libmsg_transaction_manager.so
357 %{_libdir}/libmsg_utils.so
358 %{_libdir}/libmsg_transaction_proxy.so
359 /usr/share/license/msg-service/LICENSE
360
361 %files devel
362 %defattr(-,root,root,-)
363 %{_libdir}/libmsg_mapi.so
364 %{_libdir}/pkgconfig/msg-service.pc
365 %{_includedir}/msg-service/*
366
367 %files tools
368 %manifest msg-service-tools.manifest
369 %defattr(-,root,root,-)
370 %{_bindir}/msg-helper
371 %{_bindir}/msg-server
372 %{_datadir}/media/Sherbet.wav
373 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
374 %{_sysconfdir}/rc.d/init.d/msg-server
375 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
376 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
377 %{_libdir}/systemd/user/msg-service.service
378 %{_libdir}/systemd/user/tizen-middleware.target.wants/msg-service.service
379 /usr/share/license/msg-service/LICENSE
380
381 %files -n sms-plugin
382 %manifest sms-plugin.manifest
383 %defattr(-,root,root,-)
384 %{_libdir}/libmsg_sms_plugin.so
385 /usr/share/license/msg-service/LICENSE
386
387 %files -n mms-plugin
388 %manifest mms-plugin.manifest
389 %defattr(-,root,root,-)
390 %{_libdir}/libmsg_mms_plugin.so
391 %{_libdir}/libmsg_mms_language_pack.so
392 /usr/share/license/msg-service/LICENSE
393
394 %changelog
395 * Wed Oct 25 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
396 - New release version
397
398 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
399 - Apply New TAPI.
400 - Modify transaction data size of sos recipient list.
401
402 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
403 - Fix contact sync defect.
404 - New MessageFW API.
405
406 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
407 - Change devman_haptic.h to devman_managed.h.
408 - Modify to set MSG_SERVER_READY before sim status check.
409 - Fix bug in sim message save related operations.
410 - Limit sim related APIs not to work on sim not available status.
411 - Modify indicator icon image path & related.
412
413 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
414 - Modify MAX_SEGMENT_NUM to 15.
415 - Modify MMplayer related to support interrupted event.
416 - Fix bug in storage change callback which could cause on submit request.
417
418 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
419 - Modify vconf key path for sos sending option.
420
421 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
422 - Storage change callback for scheduled message
423 - code chage to support glib2-2.32
424 - Apply Backup && Restore of Mms Type
425
426 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
427 - Update display time for scheduled message when it is sent.
428
429 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
430 - Comment the test app in CMakefile.
431 - Modify MMS BG color of vconf value.
432 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
433 - Add '-i' option for vconf keys of memory type
434 - Add smsc vconf keys(default value).
435 - To avoid msg incoming sound and notification on SOS
436
437 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
438 - Add '-i' option for vconf keys of memory type.
439 - Add smsc vconf keys(default value).
440 - To avoid msg incoming sound and notification on SOS state.
441 - Change BGcolor to black && font colore to white.
442
443 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
444 - Apply Mdm policy.
445 - SOS message.
446 - Fix horizontality development problem.
447 - Remove vconf key for new message count. (db/badge/com.samsung.message)
448 - Change vconf key path of "mms_send/msg_class" to private.
449
450 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
451 - Add new MAPI.
452
453 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
454 - Modify to support new DRM service.
455 - Rename private vconf keys.
456 - Modify .postinst and .spec file to pre-install used vconf keys.
457 - Remove compile warnings.
458 - Fix bug in manual retrieve operation.
459
460 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
461 - Fix DB conflict which cause db lock.
462 - Fix bug in Find My Mobile function.
463 - Add '*' and '#' symbol as valid number.
464
465 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
466 - Change mobile tracker related vconf key define values.
467 - Apply MDM policy for allowing text messaging.
468 - Fix bug for getting thumbnail path.
469 - Enable functionality of scheduled message.
470 - Change alarm setting of scheduled message from volatile type to non-volatile.
471 - Fix error in search query.
472
473 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
474 - Change some thread list related APIs to support DB change.
475 - DB change to support multiple recipient.
476
477 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
478 - Modify to manage contact sync time by vconf.
479 - Use g_idle_add() routine for updating unread message count(vconf values).
480 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
481 - Fix bug for allocated size of replacing string.
482 - Resolve search problem for special characters.
483 - add xmlFree.
484
485 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
486 - Remove unused vconf keys.
487 - Initialize SMSC selected_index.
488 - Remove systemd related.
489
490 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
491 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
492 - Fix S1-2397/2417/2418/2419.
493 - Remove sent status callback check during submit request.
494 - Modify offset and limit operation on search.
495 - Remove invalid folder and file.
496 - Change browser launching API from aul to service-capi.
497 - Remove unused file.
498 - Invalid type checking is fixed.
499
500 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
501 - Add #include <sys/stat.h> to support chmod related defines.
502 - Fix DRM content issue(unregistered mo content)
503
504 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
505 - Modify plugin configuration file location for FOTA.
506 - Remove the db query which create sample data.
507
508 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
509 - Update msg-service.spec for OBS.
510 - Fix TC execute failure.
511 - Fix S1-1419(Removed mms raw file issue after rebooting)