Create vconf keys owned by the "app" user.
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.0
3 Release:        1
4 License:        Samsung
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source101:      msg-service.service
9
10 Requires(post): /usr/bin/sqlite3
11 Requires(post): /usr/bin/vconftool
12 Requires(post): /sbin/ldconfig
13 Requires(postun): /sbin/ldconfig
14 Requires(post): systemd
15 Requires(postun): systemd
16 BuildRequires: cmake
17 BuildRequires: pkgconfig(alarm-service)
18 BuildRequires: pkgconfig(aul)
19 BuildRequires: pkgconfig(capi-appfw-application)
20 BuildRequires: pkgconfig(contacts-service)
21 BuildRequires: pkgconfig(db-util)
22 BuildRequires: pkgconfig(devman_haptic)
23 BuildRequires: pkgconfig(dlog)
24 BuildRequires: pkgconfig(drm-client)
25 BuildRequires: pkgconfig(glib-2.0)
26 BuildRequires: pkgconfig(libcurl)
27 BuildRequires: pkgconfig(libsystemd-daemon)
28 BuildRequires: pkgconfig(libxml-2.0)
29 BuildRequires: pkgconfig(libwbxml2)
30 BuildRequires: pkgconfig(media-thumbnail)
31 BuildRequires: pkgconfig(mm-fileinfo)
32 BuildRequires: pkgconfig(mm-player)
33 BuildRequires: pkgconfig(mm-session)
34 BuildRequires: pkgconfig(network)
35 BuildRequires: pkgconfig(notification)
36 BuildRequires: pkgconfig(pmapi)
37 BuildRequires: pkgconfig(mmutil-imgp)
38 BuildRequires: pkgconfig(mmutil-jpeg)
39 BuildRequires: pkgconfig(security-server)
40 BuildRequires: pkgconfig(sensor)
41 BuildRequires: pkgconfig(svi)
42 BuildRequires: pkgconfig(tapi)
43 BuildRequires: pkgconfig(vconf)
44
45 %description
46 Description: Messaging Framework Library
47
48
49 %package devel
50 License:        Apache License v2.0
51 Summary:        Messaging Framework Library (development)
52 Requires:       %{name} = %{version}-%{release}
53 Group:          Development/Libraries
54
55 %description devel
56 Description: Messaging Framework Library (development)
57
58
59 %package tools
60 License:        Apache License v2.0
61 Summary:        Messaging server application
62 Requires:       %{name} = %{version}-%{release}
63 Group:          TO_BU / FILL_IN
64 Requires(post): /usr/bin/sqlite3
65 Requires(post): /usr/bin/vconftool
66 Requires(post): /sbin/ldconfig
67 Requires(postun): /sbin/ldconfig
68
69 %description tools
70 Description:  Messaging server application
71
72
73 %package -n sms-plugin
74 License:        Apache License v2.0
75 Summary:        SMS plugin library
76 Requires:       %{name} = %{version}-%{release}
77 Group:          System/Libraries
78 Requires(post): /sbin/ldconfig
79 Requires(postun): /sbin/ldconfig
80
81 %description -n sms-plugin
82 Description: SMS plugin library
83
84 %package -n mms-plugin
85 License:        Apache License v2.0
86 Summary:        MMS plugin library
87 Requires:       %{name} = %{version}-%{release}
88 Group:          System/Libraries
89 Requires(post): /sbin/ldconfig
90 Requires(postun): /sbin/ldconfig
91
92 %description -n mms-plugin
93 Description: MMS plugin library
94
95 %prep
96 %setup -q
97
98
99 %build
100 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
101 make %{?jobs:-j%jobs}
102
103 %install
104
105 rm -rf %{buildroot}
106 %make_install
107
108 mkdir -p %{buildroot}%{_libdir}/systemd/user/tizen-middleware.target.wants
109 install -m 0644 %SOURCE101 %{buildroot}%{_libdir}/systemd/user/
110 ln -s ../msg-service.service %{buildroot}%{_libdir}/systemd/user/tizen-middleware.target.wants/msg-service.service
111
112 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
113 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
114 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
115 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
116
117 mkdir -p %{buildroot}/opt/data/msg-service
118
119 %post tools -p /sbin/ldconfig
120 %post -n sms-plugin -p /sbin/ldconfig
121 %post -n mms-plugin -p /sbin/ldconfig
122
123 %post
124 /sbin/ldconfig
125
126 if [ ! -f /opt/dbspace/.msg_service.db ]
127 then
128     mkdir -p %{buildroot}/opt/dbspace/
129     sqlite3 /opt/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
130
131     CREATE TABLE MSG_CONVERSATION_TABLE ( CONV_ID INTEGER NOT NULL , UNREAD_CNT INTEGER DEFAULT 0 , SMS_CNT INTEGER DEFAULT 0 , MMS_CNT INTEGER DEFAULT 0 , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , MSG_DIRECTION INTEGER NOT NULL , DISPLAY_TIME INTEGER , DISPLAY_NAME TEXT , MSG_TEXT TEXT );
132     CREATE TABLE MSG_ADDRESS_TABLE ( ADDRESS_ID INTEGER PRIMARY KEY , CONV_ID INTEGER  NOT NULL , ADDRESS_TYPE INTEGER , RECIPIENT_TYPE INTEGER , ADDRESS_VAL TEXT , CONTACT_ID INTEGER , DISPLAY_NAME TEXT , FIRST_NAME TEXT , LAST_NAME TEXT , IMAGE_PATH TEXT , SYNC_TIME DATETIME , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
133     CREATE TABLE MSG_FOLDER_TABLE ( FOLDER_ID INTEGER PRIMARY KEY , FOLDER_NAME TEXT NOT NULL , FOLDER_TYPE INTEGER DEFAULT 0 );
134     CREATE TABLE MSG_MESSAGE_TABLE ( MSG_ID INTEGER PRIMARY KEY , CONV_ID INTEGER NOT NULL , FOLDER_ID INTEGER NOT NULL , STORAGE_ID INTEGER NOT NULL , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , DISPLAY_TIME DATETIME , DATA_SIZE INTEGER DEFAULT 0 , NETWORK_STATUS INTEGER DEFAULT 0 , READ_STATUS INTEGER DEFAULT 0 , PROTECTED INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , MSG_DIRECTION INTEGER NOT NULL , SCHEDULED_TIME DATETIME , BACKUP INTEGER DEFAULT 0 , SUBJECT TEXT , MSG_DATA TEXT , THUMB_PATH TEXT , MSG_TEXT TEXT , DELIVERY_REPORT_STATUS INTEGER DEFAULT 0 , DELIVERY_REPORT_TIME DATETIME , READ_REPORT_STATUS INTEGER DEFAULT 0 , READ_REPORT_TIME DATETIME , ATTACHMENT_COUNT INTEGER DEFAULT 0 , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) , FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
135     CREATE TABLE MSG_SIM_TABLE ( MSG_ID INTEGER , SIM_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
136     CREATE TABLE MSG_PUSH_TABLE ( MSG_ID INTEGER , ACTION INTEGER , CREATED INTEGER , EXPIRES INTEGER , ID TEXT , HREF TEXT , CONTENT TEXT , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
137     CREATE TABLE MSG_CBMSG_TABLE ( MSG_ID INTEGER , CB_MSG_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
138     CREATE TABLE MSG_SYNCML_TABLE ( MSG_ID INTEGER , EXT_ID INTEGER NOT NULL , PINCODE INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
139     CREATE TABLE MSG_SMS_SENDOPT_TABLE ( MSG_ID INTEGER , DELREP_REQ INTEGER NOT NULL , KEEP_COPY INTEGER NOT NULL , REPLY_PATH INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
140     CREATE TABLE MSG_FILTER_TABLE ( FILTER_ID INTEGER PRIMARY KEY , FILTER_TYPE INTEGER NOT NULL , FILTER_VALUE TEXT NOT NULL );
141     CREATE TABLE MSG_MMS_MESSAGE_TABLE ( MSG_ID INTEGER , TRANSACTION_ID TEXT , MESSAGE_ID TEXT , FWD_MESSAGE_ID TEXT , CONTENTS_LOCATION TEXT , FILE_PATH TEXT , VERSION INTEGER NOT NULL , DATA_TYPE INTEGER DEFAULT -1 , DATE DATETIME , HIDE_ADDRESS INTEGER DEFAULT 0 , ASK_DELIVERY_REPORT INTEGER DEFAULT 0 , REPORT_ALLOWED INTEGER DEFAULT 0 , READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 , ASK_READ_REPLY INTEGER DEFAULT 0 , READ INTEGER DEFAULT 0 , READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 , READ_REPORT_SENT INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , KEEP_COPY INTEGER DEFAULT 0 , MSG_SIZE INTEGER NOT NULL , MSG_CLASS INTEGER DEFAULT -1 , EXPIRY_TIME DATETIME , CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 , DELIVERY_TIME DATETIME , MSG_STATUS INTEGER DEFAULT -1 , FOREIGN KEY (MSG_ID) REFERENCES MSG_MESSAGE_TABLE (MSG_ID) );
142
143     CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
144     CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
145     CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
146
147     INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
148     INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
149     INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
150     INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
151     INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
152     INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
153     INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
154     INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);"
155 fi
156
157 chown :6011 /opt/dbspace/.msg_service.db
158 chown :6011 /opt/dbspace/.msg_service.db-journal
159
160 chmod 660 /opt/dbspace/.msg_service.db
161 chmod 660 /opt/dbspace/.msg_service.db-journal
162 mkdir -p /opt/data/msg-service
163 chgrp db_msg_service /opt/data/msg-service
164
165 ########## Setting Config Value (Internal keys) ##########
166 vcuid=5000
167 # Message Server Status
168 vconftool set -t bool memory/msg/ready 0 -i -g 5000 -u $vcuid
169
170 # SMS Send Options
171 vconftool set -t int db/msg/network_mode 2 -u $vcuid
172
173 # New Message Count
174 vconftool set -t int db/msg/recv_sms 0 -u $vcuid
175 vconftool set -t int db/msg/recv_mms 0 -u $vcuid
176
177 ########## Setting Config Value (Private keys) ##########
178 # General Options
179 vconftool set -t bool db/private/msg-service/general/keep_copy 1 -u $vcuid
180 vconftool set -t bool db/private/msg-service/general/auto_erase 0 -u $vcuid
181 vconftool set -t bool db/private/msg-service/general/block_msg 0 -u $vcuid
182 vconftool set -t int db/private/msg-service/general/contact_sync_time 0 -u $vcuid
183
184 # SMS Send Options
185 vconftool set -t int db/private/msg-service/sms_send/dcs 3 -u $vcuid
186 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0 -u $vcuid
187 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0 -u $vcuid
188 vconftool set -t int db/private/msg-service/sms_send/save_storage 1 -u $vcuid
189
190 # SMSC
191 vconftool set -t int db/private/msg-service/smsc/total_count 1 -u $vcuid
192 vconftool set -t int db/private/msg-service/smsc/selected 0 -u $vcuid
193
194 vconftool set -t int db/private/msg-service/smsc/pid/0 1 -u $vcuid
195 vconftool set -t int db/private/msg-service/smsc/val_period/0 255 -u $vcuid
196 vconftool set -t string db/private/msg-service/smsc/name/0 "" -u $vcuid
197 vconftool set -t int db/private/msg-service/smsc/ton/0 1 -u $vcuid
198 vconftool set -t int db/private/msg-service/smsc/npi/0 1 -u $vcuid
199 vconftool set -t string db/private/msg-service/smsc/address/0 "" -u $vcuid
200
201 vconftool set -t int db/private/msg-service/smsc/pid/1 0 -u $vcuid
202 vconftool set -t int db/private/msg-service/smsc/val_period/1 0 -u $vcuid
203 vconftool set -t string db/private/msg-service/smsc/name/1 "" -u $vcuid
204 vconftool set -t int db/private/msg-service/smsc/ton/1 0 -u $vcuid
205 vconftool set -t int db/private/msg-service/smsc/npi/1 0 -u $vcuid
206 vconftool set -t string db/private/msg-service/smsc/address/1 "" -u $vcuid
207
208 vconftool set -t int db/private/msg-service/smsc/pid/2 0 -u $vcuid
209 vconftool set -t int db/private/msg-service/smsc/val_period/2 0 -u $vcuid
210 vconftool set -t string db/private/msg-service/smsc/name/2 "" -u $vcuid
211 vconftool set -t int db/private/msg-service/smsc/ton/2 0 -u $vcuid
212 vconftool set -t int db/private/msg-service/smsc/npi/2 0 -u $vcuid
213 vconftool set -t string db/private/msg-service/smsc/address/2 "" -u $vcuid
214
215 # MMS Send Options
216 vconftool set -t int db/private/msg-service/mms_send/msg_class 0 -u $vcuid
217 vconftool set -t int db/private/msg-service/mms_send/priority 1 -u $vcuid
218 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0 -u $vcuid
219 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0 -u $vcuid
220 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0 -u $vcuid
221 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1 -u $vcuid
222 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1 -u $vcuid
223 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0 -u $vcuid
224 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0 -u $vcuid
225 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0 -u $vcuid
226 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1 -u $vcuid
227 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0 -u $vcuid
228 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0 -u $vcuid
229 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0 -u $vcuid
230 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0 -u $vcuid
231 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2 -u $vcuid
232
233 # MMS Receive Options
234 vconftool set -t int db/private/msg-service/mms_recv/home_network 0 -u $vcuid
235 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0 -u $vcuid
236 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1 -u $vcuid
237 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1 -u $vcuid
238 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0 -u $vcuid
239 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0 -u $vcuid
240
241 # MMS Receive Options
242 vconftool set -t int db/private/msg-service/mms_style/font_size 30 -u $vcuid
243 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0 -u $vcuid
244 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0 -u $vcuid
245 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0 -u $vcuid
246 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255 -u $vcuid
247 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255 -u $vcuid
248 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255 -u $vcuid
249 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255 -u $vcuid
250 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0 -u $vcuid
251 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0 -u $vcuid
252 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0 -u $vcuid
253 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255 -u $vcuid
254 vconftool set -t int db/private/msg-service/mms_style/page_dur 2 -u $vcuid
255 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0 -u $vcuid
256 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0 -u $vcuid
257
258 # Push Msg Options
259 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1 -u $vcuid
260 vconftool set -t int db/private/msg-service/push_msg/service_load 1 -u $vcuid
261
262 # CB Msg Options
263 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f -u $vcuid
264 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0 -u $vcuid
265 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0 -u $vcuid
266 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f -u $vcuid
267 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0 -u $vcuid
268 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0 -u $vcuid
269 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0 -u $vcuid
270 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0 -u $vcuid
271 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0 -u $vcuid
272 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0 -u $vcuid
273 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0 -u $vcuid
274 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0 -u $vcuid
275 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0 -u $vcuid
276
277 # Voice Mail Options
278 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number "" -u $vcuid
279
280 # MMS Size Options
281 vconftool set -t int db/private/msg-service/size_opt/msg_size 300 -u $vcuid
282
283 # SIM message count
284 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0 -u $vcuid
285 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0 -u $vcuid
286
287 # SIM information
288 vconftool set -t int memory/private/msg-service/sim_changed 0 -i -u $vcuid
289 vconftool set -t string memory/private/msg-service/sim_imsi "" -i -u $vcuid
290 vconftool set -t bool memory/private/msg-service/national_sim 0 -i -u $vcuid
291
292 /sbin/ldconfig
293 /bin/systemctl daemon-reload
294 if [ "$1" = "1" ]; then
295     systemctl stop msg-service.service
296 fi
297
298 %postun -p /sbin/ldconfig
299
300 %postun tools -p /sbin/ldconfig
301 %postun -n sms-plugin -p /sbin/ldconfig
302 %postun -n mms-plugin -p /sbin/ldconfig
303
304 %files
305 %defattr(-,root,root,-)
306 %dir %attr(775,root,db_msg_service) /opt/data/msg-service
307 %{_libdir}/libmsg_plugin_manager.so
308 %{_libdir}/libmsg_mapi.so.*
309 %{_libdir}/libmsg_framework_handler.so
310 %{_libdir}/libmsg_transaction_manager.so
311 %{_libdir}/libmsg_utils.so
312 %{_libdir}/libmsg_transaction_proxy.so
313 %{_sysconfdir}/rc.d/init.d/msg-server
314 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
315 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
316
317 %files devel
318 %defattr(-,root,root,-)
319 %{_libdir}/libmsg_mapi.so
320 %{_libdir}/pkgconfig/msg-service.pc
321 %{_includedir}/msg-service/*
322
323 %files tools
324 %defattr(-,root,root,-)
325 %{_bindir}/msg-helper
326 %{_bindir}/msg-server
327 %{_datadir}/media/Sherbet.wav
328 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
329 %{_libdir}/systemd/user/msg-service.service
330 %{_libdir}/systemd/user/tizen-middleware.target.wants/msg-service.service
331
332 %files -n sms-plugin
333 %defattr(-,root,root,-)
334 %{_libdir}/libmsg_sms_plugin.so
335
336 %files -n mms-plugin
337 %defattr(-,root,root,-)
338 %{_libdir}/libmsg_mms_plugin.so
339 %{_libdir}/libmsg_mms_language_pack.so
340
341 %changelog
342 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
343 - Apply New TAPI.
344 - Modify transaction data size of sos recipient list.
345
346 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
347 - Fix contact sync defect.
348 - New MessageFW API.
349
350 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
351 - Change devman_haptic.h to devman_managed.h.
352 - Modify to set MSG_SERVER_READY before sim status check.
353 - Fix bug in sim message save related operations.
354 - Limit sim related APIs not to work on sim not available status.
355 - Modify indicator icon image path & related.
356
357 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
358 - Modify MAX_SEGMENT_NUM to 15.
359 - Modify MMplayer related to support interrupted event.
360 - Fix bug in storage change callback which could cause on submit request.
361
362 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
363 - Modify vconf key path for sos sending option.
364
365 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
366 - Storage change callback for scheduled message
367 - code chage to support glib2-2.32
368 - Apply Backup && Restore of Mms Type
369
370 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
371 - Update display time for scheduled message when it is sent.
372
373 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
374 - Comment the test app in CMakefile.
375 - Modify MMS BG color of vconf value.
376 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
377 - Add '-i' option for vconf keys of memory type
378 - Add smsc vconf keys(default value).
379 - To avoid msg incoming sound and notification on SOS
380
381 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
382 - Add '-i' option for vconf keys of memory type.
383 - Add smsc vconf keys(default value).
384 - To avoid msg incoming sound and notification on SOS state.
385 - Change BGcolor to black && font colore to white.
386
387 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
388 - Apply Mdm policy.
389 - SOS message.
390 - Fix horizontality development problem.
391 - Remove vconf key for new message count. (db/badge/com.samsung.message)
392 - Change vconf key path of "mms_send/msg_class" to private.
393
394 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
395 - Add new MAPI.
396
397 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
398 - Modify to support new DRM service.
399 - Rename private vconf keys.
400 - Modify .postinst and .spec file to pre-install used vconf keys.
401 - Remove compile warnings.
402 - Fix bug in manual retrieve operation.
403
404 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
405 - Fix DB conflict which cause db lock.
406 - Fix bug in Find My Mobile function.
407 - Add '*' and '#' symbol as valid number.
408
409 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
410 - Change mobile tracker related vconf key define values.
411 - Apply MDM policy for allowing text messaging.
412 - Fix bug for getting thumbnail path.
413 - Enable functionality of scheduled message.
414 - Change alarm setting of scheduled message from volatile type to non-volatile.
415 - Fix error in search query.
416
417 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
418 - Change some thread list related APIs to support DB change.
419 - DB change to support multiple recipient.
420
421 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
422 - Modify to manage contact sync time by vconf.
423 - Use g_idle_add() routine for updating unread message count(vconf values).
424 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
425 - Fix bug for allocated size of replacing string.
426 - Resolve search problem for special characters.
427 - add xmlFree.
428
429 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
430 - Remove unused vconf keys.
431 - Initialize SMSC selected_index.
432 - Remove systemd related.
433
434 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
435 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
436 - Fix S1-2397/2417/2418/2419.
437 - Remove sent status callback check during submit request.
438 - Modify offset and limit operation on search.
439 - Remove invalid folder and file.
440 - Change browser launching API from aul to service-capi.
441 - Remove unused file.
442 - Invalid type checking is fixed.
443
444 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
445 - Add #include <sys/stat.h> to support chmod related defines.
446 - Fix DRM content issue(unregistered mo content)
447
448 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
449 - Modify plugin configuration file location for FOTA.
450 - Remove the db query which create sample data.
451
452 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
453 - Update msg-service.spec for OBS.
454 - Fix TC execute failure.
455 - Fix S1-1419(Removed mms raw file issue after rebooting)