Merge "apply push/cb function"
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.0
3 Release:        1
4 License:        Samsung
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8
9 Requires(post): /usr/bin/sqlite3
10 Requires(post): /usr/bin/vconftool
11 Requires(post): /sbin/ldconfig
12 Requires(postun): /sbin/ldconfig
13 BuildRequires: cmake
14 BuildRequires: pkgconfig(alarm-service)
15 BuildRequires: pkgconfig(aul)
16 BuildRequires: pkgconfig(capi-appfw-application)
17 BuildRequires: pkgconfig(contacts-service)
18 BuildRequires: pkgconfig(db-util)
19 BuildRequires: pkgconfig(devman_haptic)
20 BuildRequires: pkgconfig(dlog)
21 BuildRequires: pkgconfig(drm-client)
22 BuildRequires: pkgconfig(glib-2.0)
23 BuildRequires: pkgconfig(libcurl)
24 BuildRequires: pkgconfig(libsystemd-daemon)
25 BuildRequires: pkgconfig(libxml-2.0)
26 BuildRequires: pkgconfig(libwbxml2)
27 BuildRequires: pkgconfig(media-thumbnail)
28 BuildRequires: pkgconfig(mm-fileinfo)
29 BuildRequires: pkgconfig(mm-player)
30 BuildRequires: pkgconfig(mm-session)
31 BuildRequires: pkgconfig(network)
32 BuildRequires: pkgconfig(notification)
33 BuildRequires: pkgconfig(pmapi)
34 BuildRequires: pkgconfig(mmutil-imgp)
35 BuildRequires: pkgconfig(mmutil-jpeg)
36 BuildRequires: pkgconfig(security-server)
37 BuildRequires: pkgconfig(sensor)
38 BuildRequires: pkgconfig(svi)
39 BuildRequires: pkgconfig(tapi)
40 BuildRequires: pkgconfig(vconf)
41
42 %description
43 Description: Messaging Framework Library
44
45
46 %package devel
47 License:        Apache License v2.0
48 Summary:        Messaging Framework Library (development)
49 Requires:       %{name} = %{version}-%{release}
50 Group:          Development/Libraries
51
52 %description devel
53 Description: Messaging Framework Library (development)
54
55
56 %package tools
57 License:        Apache License v2.0
58 Summary:        Messaging server application
59 Requires:       %{name} = %{version}-%{release}
60 Group:          TO_BU / FILL_IN
61 Requires(post): /usr/bin/sqlite3
62 Requires(post): /usr/bin/vconftool
63 Requires(post): /sbin/ldconfig
64 Requires(postun): /sbin/ldconfig
65
66 %description tools
67 Description:  Messaging server application
68
69
70 %package -n sms-plugin
71 License:        Apache License v2.0
72 Summary:        SMS plugin library
73 Requires:       %{name} = %{version}-%{release}
74 Group:          System/Libraries
75 Requires(post): /sbin/ldconfig
76 Requires(postun): /sbin/ldconfig
77
78 %description -n sms-plugin
79 Description: SMS plugin library
80
81 %package -n mms-plugin
82 License:        Apache License v2.0
83 Summary:        MMS plugin library
84 Requires:       %{name} = %{version}-%{release}
85 Group:          System/Libraries
86 Requires(post): /sbin/ldconfig
87 Requires(postun): /sbin/ldconfig
88
89 %description -n mms-plugin
90 Description: MMS plugin library
91
92 %prep
93 %setup -q
94
95
96 %build
97 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
98 make %{?jobs:-j%jobs}
99
100 %install
101
102 rm -rf %{buildroot}
103 %make_install
104
105 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
106 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
107 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
108 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
109
110
111
112 mkdir -p %{buildroot}/opt/data/msg-service
113
114 %post tools -p /sbin/ldconfig
115 %post -n sms-plugin -p /sbin/ldconfig
116 %post -n mms-plugin -p /sbin/ldconfig
117
118 %post
119 /sbin/ldconfig
120
121 if [ ! -f /opt/dbspace/.msg_service.db ]
122 then
123     sqlite3 /opt/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
124
125     CREATE TABLE MSG_CONVERSATION_TABLE ( CONV_ID INTEGER NOT NULL , UNREAD_CNT INTEGER DEFAULT 0 , SMS_CNT INTEGER DEFAULT 0 , MMS_CNT INTEGER DEFAULT 0 , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , MSG_DIRECTION INTEGER NOT NULL , DISPLAY_TIME INTEGER , DISPLAY_NAME TEXT , MSG_TEXT TEXT );
126     CREATE TABLE MSG_ADDRESS_TABLE ( ADDRESS_ID INTEGER PRIMARY KEY , CONV_ID INTEGER  NOT NULL , ADDRESS_TYPE INTEGER , RECIPIENT_TYPE INTEGER , ADDRESS_VAL TEXT , CONTACT_ID INTEGER , DISPLAY_NAME TEXT , FIRST_NAME TEXT , LAST_NAME TEXT , IMAGE_PATH TEXT , SYNC_TIME DATETIME , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
127     CREATE TABLE MSG_FOLDER_TABLE ( FOLDER_ID INTEGER PRIMARY KEY , FOLDER_NAME TEXT NOT NULL , FOLDER_TYPE INTEGER DEFAULT 0 );
128     CREATE TABLE MSG_MESSAGE_TABLE ( MSG_ID INTEGER PRIMARY KEY , CONV_ID INTEGER NOT NULL , FOLDER_ID INTEGER NOT NULL , STORAGE_ID INTEGER NOT NULL , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , DISPLAY_TIME DATETIME , DATA_SIZE INTEGER DEFAULT 0 , NETWORK_STATUS INTEGER DEFAULT 0 , READ_STATUS INTEGER DEFAULT 0 , PROTECTED INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , MSG_DIRECTION INTEGER NOT NULL , SCHEDULED_TIME DATETIME , BACKUP INTEGER DEFAULT 0 , SUBJECT TEXT , MSG_DATA TEXT , THUMB_PATH TEXT , MSG_TEXT TEXT , DELIVERY_REPORT_STATUS INTEGER DEFAULT 0 , DELIVERY_REPORT_TIME DATETIME , READ_REPORT_STATUS INTEGER DEFAULT 0 , READ_REPORT_TIME DATETIME , ATTACHMENT_COUNT INTEGER DEFAULT 0 , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) , FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
129     CREATE TABLE MSG_SIM_TABLE ( MSG_ID INTEGER , SIM_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
130     CREATE TABLE MSG_PUSH_TABLE ( MSG_ID INTEGER , ACTION INTEGER , CREATED INTEGER , EXPIRES INTEGER , ID TEXT , HREF TEXT , CONTENT TEXT , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
131     CREATE TABLE MSG_CBMSG_TABLE ( MSG_ID INTEGER , CB_MSG_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
132     CREATE TABLE MSG_SYNCML_TABLE ( MSG_ID INTEGER , EXT_ID INTEGER NOT NULL , PINCODE INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
133     CREATE TABLE MSG_SMS_SENDOPT_TABLE ( MSG_ID INTEGER , DELREP_REQ INTEGER NOT NULL , KEEP_COPY INTEGER NOT NULL , REPLY_PATH INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
134     CREATE TABLE MSG_FILTER_TABLE ( FILTER_ID INTEGER PRIMARY KEY , FILTER_TYPE INTEGER NOT NULL , FILTER_VALUE TEXT NOT NULL );
135     CREATE TABLE MSG_MMS_MESSAGE_TABLE ( MSG_ID INTEGER , TRANSACTION_ID TEXT , MESSAGE_ID TEXT , FWD_MESSAGE_ID TEXT , CONTENTS_LOCATION TEXT , FILE_PATH TEXT , VERSION INTEGER NOT NULL , DATA_TYPE INTEGER DEFAULT -1 , DATE DATETIME , HIDE_ADDRESS INTEGER DEFAULT 0 , ASK_DELIVERY_REPORT INTEGER DEFAULT 0 , REPORT_ALLOWED INTEGER DEFAULT 0 , READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 , ASK_READ_REPLY INTEGER DEFAULT 0 , READ INTEGER DEFAULT 0 , READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 , READ_REPORT_SENT INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , KEEP_COPY INTEGER DEFAULT 0 , MSG_SIZE INTEGER NOT NULL , MSG_CLASS INTEGER DEFAULT -1 , EXPIRY_TIME DATETIME , CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 , DELIVERY_TIME DATETIME , MSG_STATUS INTEGER DEFAULT -1 , FOREIGN KEY (MSG_ID) REFERENCES MSG_MESSAGE_TABLE (MSG_ID) );
136     CREATE TABLE MSG_PUSHCFG_TABLE ( PUSH_ID INTEGER , CONTENT_TYPE TEXT, APP_ID TEXT, PKG_NAME TEXT, LAUNCH INTEGER, APPCODE INTEGER, SECURE INTEGER);
137
138     CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
139     CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
140     CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
141
142     INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
143     INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
144     INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
145     INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
146     INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
147     INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
148     INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
149     INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);
150
151     INSERT INTO MSG_PUSHCFG_TABLE VALUES (1, 'text/vnd.wap.si', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 1, 0);
152     INSERT INTO MSG_PUSHCFG_TABLE VALUES (2, 'application/vnd.wap.sic', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 2, 0);
153     INSERT INTO MSG_PUSHCFG_TABLE VALUES (3, 'text/vnd.wap.sl', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 3, 0);
154         INSERT INTO MSG_PUSHCFG_TABLE VALUES (4, 'application/vnd.wap.slc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 4, 0);
155     INSERT INTO MSG_PUSHCFG_TABLE VALUES (5, 'text/vnd.wap.co', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 5, 0);
156
157     INSERT INTO MSG_PUSHCFG_TABLE VALUES (6, 'application/vnd.wap.coc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 6, 0);
158     INSERT INTO MSG_PUSHCFG_TABLE VALUES (7, 'application/vnd.wap.mms-message', 'X-Wap-Application-Id: x-wap-application:mms.ua', '', 0, 7, 0);
159     INSERT INTO MSG_PUSHCFG_TABLE VALUES (8, 'application/vnd.wap.sia', 'X-Wap-Application-Id: x-wap-application:push.sia', '', 0, 8, 0);
160     INSERT INTO MSG_PUSHCFG_TABLE VALUES (9, 'application/vnd.syncml.dm+wbxml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 9, 0);
161     INSERT INTO MSG_PUSHCFG_TABLE VALUES (10, 'application/vnd.syncml.dm+xml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 10, 0);
162
163     INSERT INTO MSG_PUSHCFG_TABLE VALUES (11, 'application/vnd.syncml.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 11, 0);
164     INSERT INTO MSG_PUSHCFG_TABLE VALUES (12, 'application/vnd.syncml.ds.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.ds', '', 0, 12, 0);
165     INSERT INTO MSG_PUSHCFG_TABLE VALUES (13, 'application/vnd.syncml+wbxml', 'X-Wap-Application-Id:x-wap-application:push.syncml', '', 0, 13, 0);
166     INSERT INTO MSG_PUSHCFG_TABLE VALUES (14, 'application/vnd.wap.locc+wbxml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 14, 0);
167     INSERT INTO MSG_PUSHCFG_TABLE VALUES (15, 'application/vnd.wap.loc+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 15, 0);
168
169     INSERT INTO MSG_PUSHCFG_TABLE VALUES (16, 'application/vnd.oma.dd+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 16, 0);
170     INSERT INTO MSG_PUSHCFG_TABLE VALUES (17, 'application/vnd.oma.drm.message', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 17, 0);
171     INSERT INTO MSG_PUSHCFG_TABLE VALUES (18, 'application/vnd.oma.drm.content', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 18, 0);
172     INSERT INTO MSG_PUSHCFG_TABLE VALUES (19, 'application/vnd.oma.drm.rights+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 19, 0);
173     INSERT INTO MSG_PUSHCFG_TABLE VALUES (20, 'application/vnd.oma.drm.rights+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 20, 0);
174
175     INSERT INTO MSG_PUSHCFG_TABLE VALUES (21, 'application/vnd.oma.drm.ro+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 21, 0);
176     INSERT INTO MSG_PUSHCFG_TABLE VALUES (22, 'application/vnd.oma.drm.roap-pdu+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 22, 0);
177     INSERT INTO MSG_PUSHCFG_TABLE VALUES (23, 'application/vnd.oma.drm.roap-trigger+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 23, 0);
178     INSERT INTO MSG_PUSHCFG_TABLE VALUES (24, 'application/vnd.oma.drm.roap-trigger+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 24, 0);
179         INSERT INTO MSG_PUSHCFG_TABLE VALUES (25, 'text/vnd.wap.connectivity-xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 26, 0);
180
181         INSERT INTO MSG_PUSHCFG_TABLE VALUES (26, 'application/vnd.wap.connectivity-wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 27, 0);
182         INSERT INTO MSG_PUSHCFG_TABLE VALUES (27, 'application/x-wap-prov.browser-settings', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 28, 0);
183         INSERT INTO MSG_PUSHCFG_TABLE VALUES (28, 'application/x-wap-prov.browser-bookmarks', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 29, 0);
184         INSERT INTO MSG_PUSHCFG_TABLE VALUES (29, 'application/x-wap-prov.syncset+xml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 30, 0);
185         INSERT INTO MSG_PUSHCFG_TABLE VALUES (30, 'application/x-wap-prov.syncset+wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 31, 0);
186
187         INSERT INTO MSG_PUSHCFG_TABLE VALUES (31, 'text/vnd.wap.emn+xml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 32, 0);
188         INSERT INTO MSG_PUSHCFG_TABLE VALUES (32, 'application/vnd.wap.emn+wbxml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 33, 0);
189         INSERT INTO MSG_PUSHCFG_TABLE VALUES (33, 'application/vnd.wv.csp.cir', 'X-Wap-Application-Id: x-wap-application:wv.ua', '', 0, 34, 0);
190         INSERT INTO MSG_PUSHCFG_TABLE VALUES (34, 'application/vnd.omaloc-supl-init', 'X-Wap-Application-Id: x-oma-application:ulp.ua', '', 0, 44, 0);
191         INSERT INTO MSG_PUSHCFG_TABLE VALUES (35, 'application/vnd.wap.emn+wbxml', 'X-oma-docomo:xmd.mail.ua', '', 0, 45, 1);"
192 fi
193
194 chown :6011 /opt/dbspace/.msg_service.db
195 chown :6011 /opt/dbspace/.msg_service.db-journal
196
197
198 chmod 660 /opt/dbspace/.msg_service.db
199 chmod 660 /opt/dbspace/.msg_service.db-journal
200
201
202 ########## Setting Config Value (Internal keys) ##########
203 # Message Server Status
204 vconftool set -t bool memory/msg/ready 0 -i
205
206 # SMS Send Options
207 vconftool set -t int db/msg/network_mode 2
208
209 # New Message Count
210 vconftool set -t int db/msg/recv_sms 0
211 vconftool set -t int db/msg/recv_mms 0
212
213 ########## Setting Config Value (Private keys) ##########
214 # General Options
215 vconftool set -t bool db/private/msg-service/general/keep_copy 1
216 vconftool set -t bool db/private/msg-service/general/auto_erase 0
217 vconftool set -t bool db/private/msg-service/general/block_msg 0
218 vconftool set -t int db/private/msg-service/general/contact_sync_time 0
219
220 # SMS Send Options
221 vconftool set -t int db/private/msg-service/sms_send/dcs 3
222 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0
223 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0
224 vconftool set -t int db/private/msg-service/sms_send/save_storage 1
225
226 # SMSC
227 vconftool set -t int db/private/msg-service/smsc/total_count 1
228 vconftool set -t int db/private/msg-service/smsc/selected 0
229
230 vconftool set -t int db/private/msg-service/smsc/pid/0 1
231 vconftool set -t int db/private/msg-service/smsc/val_period/0 255
232 vconftool set -t string db/private/msg-service/smsc/name/0 ""
233 vconftool set -t int db/private/msg-service/smsc/ton/0 1
234 vconftool set -t int db/private/msg-service/smsc/npi/0 1
235 vconftool set -t string db/private/msg-service/smsc/address/0 ""
236
237 vconftool set -t int db/private/msg-service/smsc/pid/1 0
238 vconftool set -t int db/private/msg-service/smsc/val_period/1 0
239 vconftool set -t string db/private/msg-service/smsc/name/1 ""
240 vconftool set -t int db/private/msg-service/smsc/ton/1 0
241 vconftool set -t int db/private/msg-service/smsc/npi/1 0
242 vconftool set -t string db/private/msg-service/smsc/address/1 ""
243
244 vconftool set -t int db/private/msg-service/smsc/pid/2 0
245 vconftool set -t int db/private/msg-service/smsc/val_period/2 0
246 vconftool set -t string db/private/msg-service/smsc/name/2 ""
247 vconftool set -t int db/private/msg-service/smsc/ton/2 0
248 vconftool set -t int db/private/msg-service/smsc/npi/2 0
249 vconftool set -t string db/private/msg-service/smsc/address/2 ""
250
251 # MMS Send Options
252 vconftool set -t int db/private/msg-service/mms_send/msg_class 0
253 vconftool set -t int db/private/msg-service/mms_send/priority 1
254 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0
255 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0
256 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0
257 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1
258 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1
259 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0
260 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0
261 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0
262 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1
263 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0
264 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0
265 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0
266 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0
267 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2
268
269 # MMS Receive Options
270 vconftool set -t int db/private/msg-service/mms_recv/home_network 0
271 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0
272 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1
273 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1
274 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0
275 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0
276
277 # MMS Receive Options
278 vconftool set -t int db/private/msg-service/mms_style/font_size 30
279 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0
280 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0
281 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0
282 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255
283 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255
284 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255
285 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255
286 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0
287 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0
288 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0
289 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255
290 vconftool set -t int db/private/msg-service/mms_style/page_dur 2
291 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0
292 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0
293
294 # Push Msg Options
295 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1
296 vconftool set -t int db/private/msg-service/push_msg/service_load 1
297
298 # CB Msg Options
299 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f
300 vconftool set -t bool db/private/msg-service/cb_msg/save 1 -f
301 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0
302 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0
303 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f
304 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0
305 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0
306 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0
307 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0
308 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0
309 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0
310 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0
311 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0
312 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0
313
314 # Voice Mail Options
315 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number ""
316
317 # MMS Size Options
318 vconftool set -t int db/private/msg-service/size_opt/msg_size 300
319
320 # SIM message count
321 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0
322 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0
323
324 # SIM information
325 vconftool set -t int memory/private/msg-service/sim_changed 0 -i
326 vconftool set -t string memory/private/msg-service/sim_imsi "" -i
327 vconftool set -t bool memory/private/msg-service/national_sim 0 -i
328
329 %postun -p /sbin/ldconfig
330
331 %postun tools -p /sbin/ldconfig
332 %postun -n sms-plugin -p /sbin/ldconfig
333 %postun -n mms-plugin -p /sbin/ldconfig
334
335 %files
336 %defattr(-,root,root,-)
337 %dir /opt/data/msg-service
338 %{_libdir}/libmsg_plugin_manager.so
339 %{_libdir}/libmsg_mapi.so.*
340 %{_libdir}/libmsg_framework_handler.so
341 %{_libdir}/libmsg_transaction_manager.so
342 %{_libdir}/libmsg_utils.so
343 %{_libdir}/libmsg_transaction_proxy.so
344 %{_sysconfdir}/rc.d/init.d/msg-server
345 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
346 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
347
348 %files devel
349 %defattr(-,root,root,-)
350 %{_libdir}/libmsg_mapi.so
351 %{_libdir}/pkgconfig/msg-service.pc
352 %{_includedir}/msg-service/*
353
354 %files tools
355 %defattr(-,root,root,-)
356 %{_bindir}/msg-helper
357 %{_bindir}/msg-server
358 %{_datadir}/media/Sherbet.wav
359 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
360
361 %files -n sms-plugin
362 %defattr(-,root,root,-)
363 %{_libdir}/libmsg_sms_plugin.so
364
365 %files -n mms-plugin
366 %defattr(-,root,root,-)
367 %{_libdir}/libmsg_mms_plugin.so
368 %{_libdir}/libmsg_mms_language_pack.so
369
370 %changelog
371 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
372 - Apply New TAPI.
373 - Modify transaction data size of sos recipient list.
374
375 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
376 - Fix contact sync defect.
377 - New MessageFW API.
378
379 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
380 - Change devman_haptic.h to devman_managed.h.
381 - Modify to set MSG_SERVER_READY before sim status check.
382 - Fix bug in sim message save related operations.
383 - Limit sim related APIs not to work on sim not available status.
384 - Modify indicator icon image path & related.
385
386 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
387 - Modify MAX_SEGMENT_NUM to 15.
388 - Modify MMplayer related to support interrupted event.
389 - Fix bug in storage change callback which could cause on submit request.
390
391 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
392 - Modify vconf key path for sos sending option.
393
394 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
395 - Storage change callback for scheduled message
396 - code chage to support glib2-2.32
397 - Apply Backup && Restore of Mms Type
398
399 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
400 - Update display time for scheduled message when it is sent.
401
402 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
403 - Comment the test app in CMakefile.
404 - Modify MMS BG color of vconf value.
405 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
406 - Add '-i' option for vconf keys of memory type
407 - Add smsc vconf keys(default value).
408 - To avoid msg incoming sound and notification on SOS
409
410 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
411 - Add '-i' option for vconf keys of memory type.
412 - Add smsc vconf keys(default value).
413 - To avoid msg incoming sound and notification on SOS state.
414 - Change BGcolor to black && font colore to white.
415
416 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
417 - Apply Mdm policy.
418 - SOS message.
419 - Fix horizontality development problem.
420 - Remove vconf key for new message count. (db/badge/com.samsung.message)
421 - Change vconf key path of "mms_send/msg_class" to private.
422
423 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
424 - Add new MAPI.
425
426 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
427 - Modify to support new DRM service.
428 - Rename private vconf keys.
429 - Modify .postinst and .spec file to pre-install used vconf keys.
430 - Remove compile warnings.
431 - Fix bug in manual retrieve operation.
432
433 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
434 - Fix DB conflict which cause db lock.
435 - Fix bug in Find My Mobile function.
436 - Add '*' and '#' symbol as valid number.
437
438 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
439 - Change mobile tracker related vconf key define values.
440 - Apply MDM policy for allowing text messaging.
441 - Fix bug for getting thumbnail path.
442 - Enable functionality of scheduled message.
443 - Change alarm setting of scheduled message from volatile type to non-volatile.
444 - Fix error in search query.
445
446 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
447 - Change some thread list related APIs to support DB change.
448 - DB change to support multiple recipient.
449
450 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
451 - Modify to manage contact sync time by vconf.
452 - Use g_idle_add() routine for updating unread message count(vconf values).
453 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
454 - Fix bug for allocated size of replacing string.
455 - Resolve search problem for special characters.
456 - add xmlFree.
457
458 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
459 - Remove unused vconf keys.
460 - Initialize SMSC selected_index.
461 - Remove systemd related.
462
463 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
464 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
465 - Fix S1-2397/2417/2418/2419.
466 - Remove sent status callback check during submit request.
467 - Modify offset and limit operation on search.
468 - Remove invalid folder and file.
469 - Change browser launching API from aul to service-capi.
470 - Remove unused file.
471 - Invalid type checking is fixed.
472
473 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
474 - Add #include <sys/stat.h> to support chmod related defines.
475 - Fix DRM content issue(unregistered mo content)
476
477 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
478 - Modify plugin configuration file location for FOTA.
479 - Remove the db query which create sample data.
480
481 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
482 - Update msg-service.spec for OBS.
483 - Fix TC execute failure.
484 - Fix S1-1419(Removed mms raw file issue after rebooting)