Apply SMACK rule file in RSA.
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.2
3 Release:        3
4 License:        Samsung
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source101:      msg-service.service
9
10 Requires(post): /usr/bin/sqlite3
11 Requires(post): /usr/bin/vconftool
12 Requires(post): /sbin/ldconfig
13 Requires(postun): /sbin/ldconfig
14 Requires(post): systemd
15 Requires(postun): systemd
16 BuildRequires: cmake
17 BuildRequires: pkgconfig(alarm-service)
18 BuildRequires: pkgconfig(aul)
19 BuildRequires: pkgconfig(capi-appfw-application)
20 BuildRequires: pkgconfig(contacts-service2)
21 BuildRequires: pkgconfig(db-util)
22 BuildRequires: pkgconfig(dlog)
23 BuildRequires: pkgconfig(drm-client)
24 BuildRequires: pkgconfig(glib-2.0)
25 BuildRequires: pkgconfig(libcurl)
26 BuildRequires: pkgconfig(libsystemd-daemon)
27 BuildRequires: pkgconfig(libxml-2.0)
28 BuildRequires: pkgconfig(libwbxml2)
29 BuildRequires: pkgconfig(media-thumbnail)
30 BuildRequires: pkgconfig(mm-fileinfo)
31 BuildRequires: pkgconfig(mm-player)
32 BuildRequires: pkgconfig(mm-session)
33 BuildRequires: pkgconfig(mm-sound)
34 BuildRequires: pkgconfig(network)
35 BuildRequires: pkgconfig(notification)
36 BuildRequires: pkgconfig(pmapi)
37 BuildRequires: pkgconfig(mmutil-imgp)
38 BuildRequires: pkgconfig(mmutil-jpeg)
39 BuildRequires: pkgconfig(security-server)
40 BuildRequires: pkgconfig(sensor)
41 BuildRequires: pkgconfig(svi)
42 BuildRequires: pkgconfig(tapi)
43 BuildRequires: pkgconfig(vconf)
44 BuildRequires: pkgconfig(feedback)
45
46 %description
47 Description: Messaging Framework Library
48
49
50 %package devel
51 License:        Flora License v1.0
52 Summary:        Messaging Framework Library (development)
53 Requires:       %{name} = %{version}-%{release}
54 Group:          Development/Libraries
55
56 %description devel
57 Description: Messaging Framework Library (development)
58
59
60 %package tools
61 License:        Flora License v1.0
62 Summary:        Messaging server application
63 Requires:       %{name} = %{version}-%{release}
64 Group:          TO_BU / FILL_IN
65 Requires(post): /usr/bin/sqlite3
66 Requires(post): /usr/bin/vconftool
67 Requires(post): /sbin/ldconfig
68 Requires(postun): /sbin/ldconfig
69
70 %description tools
71 Description:  Messaging server application
72
73
74 %package -n sms-plugin
75 License:        Flora License v1.0
76 Summary:        SMS plugin library
77 Requires:       %{name} = %{version}-%{release}
78 Group:          System/Libraries
79 Requires(post): /sbin/ldconfig
80 Requires(postun): /sbin/ldconfig
81
82 %description -n sms-plugin
83 Description: SMS plugin library
84
85 %package -n mms-plugin
86 License:        Flora License v1.0
87 Summary:        MMS plugin library
88 Requires:       %{name} = %{version}-%{release}
89 Group:          System/Libraries
90 Requires(post): /sbin/ldconfig
91 Requires(postun): /sbin/ldconfig
92
93 %description -n mms-plugin
94 Description: MMS plugin library
95
96 %prep
97 %setup -q
98
99
100 %build
101 %cmake .
102 make %{?jobs:-j%jobs}
103
104 %install
105 rm -rf %{buildroot}
106 mkdir -p %{buildroot}/usr/share/license
107 mkdir -p %{buildroot}/etc/config
108
109 mkdir -p %{buildroot}/var/log/msgfw
110
111 %make_install
112
113 mkdir -p %{buildroot}/usr/lib/systemd/user/tizen-middleware.target.wants
114 #install -m 0644 %SOURCE101 %{buildroot}/usr/lib/systemd/user/
115 ln -s ../msg-service.service %{buildroot}/usr/lib/systemd/user/tizen-middleware.target.wants/msg-service.service
116 ln -s ../msg-service-log.service %{buildroot}/usr/lib/systemd/user/tizen-middleware.target.wants/msg-service-log.service
117
118 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
119 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
120 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
121 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
122
123 mkdir -p %{buildroot}/opt/usr/data/msg-service
124
125 %if 0%{?simulator}
126 rm %{buildroot}/etc/config/sysinfo-message.xml
127 mv %{buildroot}/etc/config/sysinfo-message.emul.xml %{buildroot}/etc/config/sysinfo-message.xml
128 %else
129 rm %{buildroot}/etc/config/sysinfo-message.emul.xml
130 %endif
131
132
133 %post tools -p /sbin/ldconfig
134 %post -n sms-plugin -p /sbin/ldconfig
135 %post -n mms-plugin -p /sbin/ldconfig
136
137 %post
138 /sbin/ldconfig
139
140 if [ ! -f /opt/usr/dbspace/.msg_service.db ]
141 then
142     mkdir -p /opt/usr/dbspace/
143     sqlite3 /opt/usr/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
144
145     CREATE TABLE MSG_CONVERSATION_TABLE (
146         CONV_ID INTEGER PRIMARY KEY ,
147         UNREAD_CNT INTEGER DEFAULT 0 ,
148         SMS_CNT INTEGER DEFAULT 0 ,
149         MMS_CNT INTEGER DEFAULT 0 ,
150         MAIN_TYPE INTEGER DEFAULT 0 ,
151         SUB_TYPE INTEGER DEFAULT 0 ,
152         MSG_DIRECTION INTEGER DEFAULT 0 ,
153         DISPLAY_TIME DATETIME ,
154         DISPLAY_NAME TEXT ,
155         MSG_TEXT TEXT );
156
157     CREATE TABLE MSG_ADDRESS_TABLE (
158         ADDRESS_ID INTEGER PRIMARY KEY ,
159         CONV_ID INTEGER  NOT NULL ,
160         ADDRESS_TYPE INTEGER ,
161         RECIPIENT_TYPE INTEGER ,
162         ADDRESS_VAL TEXT ,
163         CONTACT_ID INTEGER ,
164         DISPLAY_NAME TEXT ,
165         FIRST_NAME TEXT ,
166         LAST_NAME TEXT ,
167         IMAGE_PATH TEXT ,
168         SYNC_TIME DATETIME ,
169         FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
170
171     CREATE TABLE MSG_FOLDER_TABLE (
172         FOLDER_ID INTEGER PRIMARY KEY ,
173         FOLDER_NAME TEXT NOT NULL ,
174         FOLDER_TYPE INTEGER DEFAULT 0 );
175
176     CREATE TABLE MSG_MESSAGE_TABLE (
177         MSG_ID INTEGER PRIMARY KEY ,
178         CONV_ID INTEGER NOT NULL ,
179         FOLDER_ID INTEGER NOT NULL ,
180         STORAGE_ID INTEGER NOT NULL ,
181         MAIN_TYPE INTEGER NOT NULL ,
182         SUB_TYPE INTEGER NOT NULL ,
183         DISPLAY_TIME DATETIME ,
184         DATA_SIZE INTEGER DEFAULT 0 ,
185         NETWORK_STATUS INTEGER DEFAULT 0 ,
186         READ_STATUS INTEGER DEFAULT 0 ,
187         PROTECTED INTEGER DEFAULT 0 ,
188         PRIORITY INTEGER DEFAULT 0 ,
189         MSG_DIRECTION INTEGER NOT NULL ,
190         SCHEDULED_TIME DATETIME ,
191         BACKUP INTEGER DEFAULT 0 ,
192         SUBJECT TEXT ,
193         MSG_DATA TEXT ,
194         THUMB_PATH TEXT ,
195         MSG_TEXT TEXT ,
196         ATTACHMENT_COUNT INTEGER DEFAULT 0 ,
197         FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) ,
198         FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
199
200     CREATE TABLE MSG_SIM_TABLE (
201         MSG_ID INTEGER PRIMARY KEY ,
202         SIM_ID INTEGER NOT NULL ,
203         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
204
205     CREATE TABLE MSG_PUSH_TABLE (
206         MSG_ID INTEGER PRIMARY KEY ,
207         ACTION INTEGER ,
208         CREATED INTEGER ,
209         EXPIRES INTEGER ,
210         ID TEXT ,
211         HREF TEXT ,
212         CONTENT TEXT ,
213         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
214
215     CREATE TABLE MSG_CBMSG_TABLE (
216         MSG_ID INTEGER PRIMARY KEY ,
217         CB_MSG_ID INTEGER NOT NULL ,
218         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
219
220     CREATE TABLE MSG_SYNCML_TABLE (
221         MSG_ID INTEGER PRIMARY KEY ,
222         EXT_ID INTEGER NOT NULL ,
223         PINCODE INTEGER NOT NULL ,
224         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
225
226     CREATE TABLE MSG_SCHEDULED_TABLE (
227         MSG_ID INTEGER PRIMARY KEY ,
228         ALARM_ID INTEGER NOT NULL ,
229         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
230
231     CREATE TABLE MSG_SMS_SENDOPT_TABLE (
232         MSG_ID INTEGER PRIMARY KEY ,
233         DELREP_REQ INTEGER NOT NULL ,
234         KEEP_COPY INTEGER NOT NULL ,
235         REPLY_PATH INTEGER NOT NULL ,
236         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
237
238     CREATE TABLE MSG_FILTER_TABLE (
239         FILTER_ID INTEGER PRIMARY KEY ,
240         FILTER_TYPE INTEGER NOT NULL ,
241         FILTER_VALUE TEXT NOT NULL ,
242         FILTER_ACTIVE INTEGER DEFAULT 0 );
243
244     CREATE TABLE MSG_MMS_MESSAGE_TABLE (
245         MSG_ID INTEGER PRIMARY KEY ,
246         TRANSACTION_ID TEXT ,
247         MESSAGE_ID TEXT ,
248         FWD_MESSAGE_ID TEXT ,
249         CONTENTS_LOCATION TEXT ,
250         FILE_PATH TEXT ,
251         VERSION INTEGER NOT NULL ,
252         DATA_TYPE INTEGER DEFAULT -1 ,
253         DATE DATETIME ,
254         HIDE_ADDRESS INTEGER DEFAULT 0 ,
255         ASK_DELIVERY_REPORT INTEGER DEFAULT 0 ,
256         REPORT_ALLOWED INTEGER DEFAULT 0 ,
257         READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 ,
258         ASK_READ_REPLY INTEGER DEFAULT 0 ,
259         READ INTEGER DEFAULT 0 ,
260         READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 ,
261         READ_REPORT_SENT INTEGER DEFAULT 0 ,
262         PRIORITY INTEGER DEFAULT 0 ,
263         KEEP_COPY INTEGER DEFAULT 0 ,
264         MSG_SIZE INTEGER NOT NULL ,
265         MSG_CLASS INTEGER DEFAULT -1 ,
266         EXPIRY_TIME DATETIME ,
267         CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 ,
268         DELIVERY_TIME DATETIME ,
269         MSG_STATUS INTEGER DEFAULT -1 ,
270         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
271
272     CREATE TABLE MSG_MMS_PREVIEW_INFO_TABLE (
273         MSG_ID INTEGER NOT NULL ,
274         TYPE INTEGER,
275         VALUE TEXT,
276         COUNT INTEGER,
277         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
278
279     CREATE TABLE MSG_REPORT_TABLE (
280         MSG_ID INTEGER NOT NULL ,
281         ADDRESS_VAL TEXT ,
282         STATUS_TYPE INTEGER ,
283         STATUS INTEGER DEFAULT 0 ,
284         TIME DATETIME );
285
286     CREATE TABLE MSG_PUSHCFG_TABLE (
287         PUSH_ID INTEGER PRIMARY KEY ,
288         CONTENT_TYPE TEXT,
289         APP_ID TEXT,
290         PKG_NAME TEXT,
291         LAUNCH INTEGER,
292         APPCODE INTEGER,
293         SECURE INTEGER );
294
295     CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
296     CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
297     CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
298
299     INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
300     INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
301     INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
302     INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
303     INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
304     INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
305     INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
306     INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);
307
308     INSERT INTO MSG_PUSHCFG_TABLE VALUES (1, 'text/vnd.wap.si', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 1, 0);
309     INSERT INTO MSG_PUSHCFG_TABLE VALUES (2, 'application/vnd.wap.sic', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 2, 0);
310     INSERT INTO MSG_PUSHCFG_TABLE VALUES (3, 'text/vnd.wap.sl', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 3, 0);
311         INSERT INTO MSG_PUSHCFG_TABLE VALUES (4, 'application/vnd.wap.slc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 4, 0);
312     INSERT INTO MSG_PUSHCFG_TABLE VALUES (5, 'text/vnd.wap.co', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 5, 0);
313
314     INSERT INTO MSG_PUSHCFG_TABLE VALUES (6, 'application/vnd.wap.coc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 6, 0);
315     INSERT INTO MSG_PUSHCFG_TABLE VALUES (7, 'application/vnd.wap.mms-message', 'X-Wap-Application-Id: x-wap-application:mms.ua', '', 0, 7, 0);
316     INSERT INTO MSG_PUSHCFG_TABLE VALUES (8, 'application/vnd.wap.sia', 'X-Wap-Application-Id: x-wap-application:push.sia', '', 0, 8, 0);
317     INSERT INTO MSG_PUSHCFG_TABLE VALUES (9, 'application/vnd.syncml.dm+wbxml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 9, 0);
318     INSERT INTO MSG_PUSHCFG_TABLE VALUES (10, 'application/vnd.syncml.dm+xml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 10, 0);
319
320     INSERT INTO MSG_PUSHCFG_TABLE VALUES (11, 'application/vnd.syncml.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 11, 0);
321     INSERT INTO MSG_PUSHCFG_TABLE VALUES (12, 'application/vnd.syncml.ds.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.ds', '', 0, 12, 0);
322     INSERT INTO MSG_PUSHCFG_TABLE VALUES (13, 'application/vnd.syncml+wbxml', 'X-Wap-Application-Id:x-wap-application:push.syncml', '', 0, 13, 0);
323     INSERT INTO MSG_PUSHCFG_TABLE VALUES (14, 'application/vnd.wap.locc+wbxml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 14, 0);
324     INSERT INTO MSG_PUSHCFG_TABLE VALUES (15, 'application/vnd.wap.loc+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 15, 0);
325
326     INSERT INTO MSG_PUSHCFG_TABLE VALUES (16, 'application/vnd.oma.dd+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 16, 0);
327     INSERT INTO MSG_PUSHCFG_TABLE VALUES (17, 'application/vnd.oma.drm.message', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 17, 0);
328     INSERT INTO MSG_PUSHCFG_TABLE VALUES (18, 'application/vnd.oma.drm.content', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 18, 0);
329     INSERT INTO MSG_PUSHCFG_TABLE VALUES (19, 'application/vnd.oma.drm.rights+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 19, 0);
330     INSERT INTO MSG_PUSHCFG_TABLE VALUES (20, 'application/vnd.oma.drm.rights+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 20, 0);
331
332     INSERT INTO MSG_PUSHCFG_TABLE VALUES (21, 'application/vnd.oma.drm.ro+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 21, 0);
333     INSERT INTO MSG_PUSHCFG_TABLE VALUES (22, 'application/vnd.oma.drm.roap-pdu+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 22, 0);
334     INSERT INTO MSG_PUSHCFG_TABLE VALUES (23, 'application/vnd.oma.drm.roap-trigger+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 23, 0);
335     INSERT INTO MSG_PUSHCFG_TABLE VALUES (24, 'application/vnd.oma.drm.roap-trigger+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 24, 0);
336         INSERT INTO MSG_PUSHCFG_TABLE VALUES (25, 'text/vnd.wap.connectivity-xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 26, 0);
337
338         INSERT INTO MSG_PUSHCFG_TABLE VALUES (26, 'application/vnd.wap.connectivity-wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 27, 0);
339         INSERT INTO MSG_PUSHCFG_TABLE VALUES (27, 'application/x-wap-prov.browser-settings', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 28, 0);
340         INSERT INTO MSG_PUSHCFG_TABLE VALUES (28, 'application/x-wap-prov.browser-bookmarks', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 29, 0);
341         INSERT INTO MSG_PUSHCFG_TABLE VALUES (29, 'application/x-wap-prov.syncset+xml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 30, 0);
342         INSERT INTO MSG_PUSHCFG_TABLE VALUES (30, 'application/x-wap-prov.syncset+wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 31, 0);
343
344         INSERT INTO MSG_PUSHCFG_TABLE VALUES (31, 'text/vnd.wap.emn+xml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 32, 0);
345         INSERT INTO MSG_PUSHCFG_TABLE VALUES (32, 'application/vnd.wap.emn+wbxml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 33, 0);
346         INSERT INTO MSG_PUSHCFG_TABLE VALUES (33, 'application/vnd.wv.csp.cir', 'X-Wap-Application-Id: x-wap-application:wv.ua', '', 0, 34, 0);
347         INSERT INTO MSG_PUSHCFG_TABLE VALUES (34, 'application/vnd.omaloc-supl-init', 'X-Wap-Application-Id: x-oma-application:ulp.ua', '', 0, 44, 0);
348         INSERT INTO MSG_PUSHCFG_TABLE VALUES (35, 'application/vnd.wap.emn+wbxml', 'X-oma-docomo:xmd.mail.ua', '', 0, 45, 1);"
349 fi
350
351 chown :6011 /opt/usr/dbspace/.msg_service.db
352 chown :6011 /opt/usr/dbspace/.msg_service.db-journal
353 chmod 660 /opt/usr/dbspace/.msg_service.db
354 chmod 660 /opt/usr/dbspace/.msg_service.db-journal
355 mkdir -p /opt/usr/data/msg-service
356 chgrp db_msg_service /opt/usr/data/msg-service
357
358 if [ -f /usr/lib/rpm-plugins/msm.so ]
359 then
360         chsmack -a 'msg-service::db' /opt/usr/dbspace/.msg_service.db*
361         chsmack -a "_" -e "_" /etc/rc.d/init.d/msg-server
362         chsmack -a "_" -e "_" /etc/rc.d/rc3.d/S70msg-server
363         chsmack -a "_" -e "_" /etc/rc.d/rc5.d/S70msg-server
364 fi
365
366 ########## Setting Config Value (Internal keys) ##########
367 vcuid=5000
368 # Message Server Status
369 vconftool set -t bool memory/msg/ready 0 -i -g 5000 -u $vcuid
370
371 # SMS Send Options
372 vconftool set -t int db/msg/network_mode 2 -u $vcuid
373
374 # New Message Count
375 vconftool set -t int db/msg/recv_sms 0 -u $vcuid
376 vconftool set -t int db/msg/recv_mms 0 -u $vcuid
377
378 ########## Setting Config Value (Private keys) ##########
379 # General Options
380 vconftool set -t bool db/private/msg-service/general/keep_copy 1 -u $vcuid
381 vconftool set -t bool db/private/msg-service/general/auto_erase 0 -u $vcuid
382 vconftool set -t bool db/private/msg-service/general/block_msg 0 -u $vcuid
383 vconftool set -t int db/private/msg-service/general/contact_sync_time 0 -u $vcuid
384
385 # SMS Send Options
386 vconftool set -t int db/private/msg-service/sms_send/dcs 3 -u $vcuid
387 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0 -u $vcuid
388 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0 -u $vcuid
389 vconftool set -t int db/private/msg-service/sms_send/save_storage 1 -u $vcuid
390
391 # SMSC
392 vconftool set -t int db/private/msg-service/smsc/total_count 1 -u $vcuid
393 vconftool set -t int db/private/msg-service/smsc/selected 0 -u $vcuid
394
395 vconftool set -t int db/private/msg-service/smsc/pid/0 1 -u $vcuid
396 vconftool set -t int db/private/msg-service/smsc/val_period/0 255 -u $vcuid
397 vconftool set -t string db/private/msg-service/smsc/name/0 "" -u $vcuid
398 vconftool set -t int db/private/msg-service/smsc/ton/0 1 -u $vcuid
399 vconftool set -t int db/private/msg-service/smsc/npi/0 1 -u $vcuid
400 vconftool set -t string db/private/msg-service/smsc/address/0 "" -u $vcuid
401
402 vconftool set -t int db/private/msg-service/smsc/pid/1 0 -u $vcuid
403 vconftool set -t int db/private/msg-service/smsc/val_period/1 0 -u $vcuid
404 vconftool set -t string db/private/msg-service/smsc/name/1 "" -u $vcuid
405 vconftool set -t int db/private/msg-service/smsc/ton/1 0 -u $vcuid
406 vconftool set -t int db/private/msg-service/smsc/npi/1 0 -u $vcuid
407 vconftool set -t string db/private/msg-service/smsc/address/1 "" -u $vcuid
408
409 vconftool set -t int db/private/msg-service/smsc/pid/2 0 -u $vcuid
410 vconftool set -t int db/private/msg-service/smsc/val_period/2 0 -u $vcuid
411 vconftool set -t string db/private/msg-service/smsc/name/2 "" -u $vcuid
412 vconftool set -t int db/private/msg-service/smsc/ton/2 0 -u $vcuid
413 vconftool set -t int db/private/msg-service/smsc/npi/2 0 -u $vcuid
414 vconftool set -t string db/private/msg-service/smsc/address/2 "" -u $vcuid
415
416 # MMS Send Options
417 vconftool set -t int db/private/msg-service/mms_send/msg_class 0 -u $vcuid
418 vconftool set -t int db/private/msg-service/mms_send/priority 1 -u $vcuid
419 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0 -u $vcuid
420 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0 -u $vcuid
421 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0 -u $vcuid
422 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1 -u $vcuid
423 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1 -u $vcuid
424 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0 -u $vcuid
425 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0 -u $vcuid
426 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0 -u $vcuid
427 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1 -u $vcuid
428 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0 -u $vcuid
429 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0 -u $vcuid
430 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0 -u $vcuid
431 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0 -u $vcuid
432 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2 -u $vcuid
433
434 # MMS Receive Options
435 vconftool set -t int db/private/msg-service/mms_recv/home_network 0 -u $vcuid
436 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0 -u $vcuid
437 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1 -u $vcuid
438 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1 -u $vcuid
439 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0 -u $vcuid
440 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0 -u $vcuid
441
442 # MMS Receive Options
443 vconftool set -t int db/private/msg-service/mms_style/font_size 30 -u $vcuid
444 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0 -u $vcuid
445 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0 -u $vcuid
446 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0 -u $vcuid
447 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255 -u $vcuid
448 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255 -u $vcuid
449 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255 -u $vcuid
450 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255 -u $vcuid
451 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0 -u $vcuid
452 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0 -u $vcuid
453 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0 -u $vcuid
454 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255 -u $vcuid
455 vconftool set -t int db/private/msg-service/mms_style/page_dur 2 -u $vcuid
456 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0 -u $vcuid
457 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0 -u $vcuid
458
459 # Push Msg Options
460 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1 -u $vcuid
461 vconftool set -t int db/private/msg-service/push_msg/service_load 1 -u $vcuid
462
463 # CB Msg Options
464 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f -u $vcuid
465 vconftool set -t bool db/private/msg-service/cb_msg/save 1 -f -u $vcuid
466 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0 -u $vcuid
467 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0 -u $vcuid
468 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f -u $vcuid
469 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0 -u $vcuid
470 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0 -u $vcuid
471 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0 -u $vcuid
472 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0 -u $vcuid
473 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0 -u $vcuid
474 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0 -u $vcuid
475 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0 -u $vcuid
476 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0 -u $vcuid
477 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0 -u $vcuid
478
479 # Voice Mail Options
480 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number "5500" -f -u $vcuid
481 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count 0 -u $vcuid
482
483 # MMS Size Options
484 vconftool set -t int db/private/msg-service/size_opt/msg_size 300 -u $vcuid
485
486 # SIM message count
487 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0 -u $vcuid
488 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0 -u $vcuid
489
490 # SIM information
491 vconftool set -t int memory/private/msg-service/sim_changed 0 -i -u $vcuid
492 vconftool set -t string memory/private/msg-service/sim_imsi "" -i -u $vcuid
493 vconftool set -t bool memory/private/msg-service/national_sim 0 -i -u $vcuid
494 vconftool set -t string memory/private/msg-service/msisdn "" -i -u $vcuid
495
496 vconftool set -t int db/private/msg-service/notification_priv_id 0 -u $vcuid
497
498 /sbin/ldconfig
499 /bin/systemctl daemon-reload
500 if [ "$1" = "1" ]; then
501     systemctl stop msg-service.service
502 fi
503
504 %postun -p /sbin/ldconfig
505
506 %postun tools -p /sbin/ldconfig
507 %postun -n sms-plugin -p /sbin/ldconfig
508 %postun -n mms-plugin -p /sbin/ldconfig
509
510 %files
511 %manifest msg-service.manifest
512 %defattr(-,root,root,-)
513 %dir %attr(775,root,db_msg_service) /opt/usr/data/msg-service
514 %{_libdir}/libmsg_plugin_manager.so
515 %{_libdir}/libmsg_mapi.so.*
516 %{_libdir}/libmsg_framework_handler.so
517 %{_libdir}/libmsg_transaction_manager.so
518 %{_libdir}/libmsg_utils.so
519 %{_libdir}/libmsg_transaction_proxy.so
520 %{_libdir}/libmsg_vobject.so
521 /usr/share/license/msg-service/LICENSE.Flora
522
523 %files devel
524 %defattr(-,root,root,-)
525 %{_libdir}/libmsg_mapi.so
526 %{_libdir}/pkgconfig/msg-service.pc
527 %{_includedir}/msg-service/*
528
529 %files tools
530 %manifest msg-service-tools.manifest
531 %defattr(-,root,root,-)
532 %{_bindir}/msg-helper
533 %{_bindir}/msg-server
534 %{_datadir}/media/Sherbet.wav
535 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
536 %{_sysconfdir}/rc.d/init.d/msg-server
537 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
538 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
539 /usr/lib/systemd/user/msg-service.service
540 /usr/lib/systemd/user/msg-service-log.service
541 /usr/lib/systemd/user/tizen-middleware.target.wants/msg-service.service
542 /usr/lib/systemd/user/tizen-middleware.target.wants/msg-service-log.service
543 /usr/share/license/msg-service/LICENSE.Flora
544 /opt/etc/smack/accesses.d/msg-service.rule
545 /etc/config/sysinfo-message.xml
546
547 %attr(0755,app,app)/var/log/msgfw
548
549
550 %files -n sms-plugin
551 %manifest sms-plugin.manifest
552 %defattr(-,root,root,-)
553 %{_libdir}/libmsg_sms_plugin.so
554 /usr/share/license/msg-service/LICENSE.Flora
555
556 %files -n mms-plugin
557 %manifest mms-plugin.manifest
558 %defattr(-,root,root,-)
559 %{_libdir}/libmsg_mms_plugin.so
560 /usr/share/license/msg-service/LICENSE.Flora
561
562 %changelog
563 * Wed Oct 25 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
564 - New release version
565
566 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
567 - Apply New TAPI.
568 - Modify transaction data size of sos recipient list.
569
570 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
571 - Fix contact sync defect.
572 - New MessageFW API.
573
574 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
575 - Change devman_haptic.h to devman_managed.h.
576 - Modify to set MSG_SERVER_READY before sim status check.
577 - Fix bug in sim message save related operations.
578 - Limit sim related APIs not to work on sim not available status.
579 - Modify indicator icon image path & related.
580
581 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
582 - Modify MAX_SEGMENT_NUM to 15.
583 - Modify MMplayer related to support interrupted event.
584 - Fix bug in storage change callback which could cause on submit request.
585
586 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
587 - Modify vconf key path for sos sending option.
588
589 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
590 - Storage change callback for scheduled message
591 - code chage to support glib2-2.32
592 - Apply Backup && Restore of Mms Type
593
594 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
595 - Update display time for scheduled message when it is sent.
596
597 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
598 - Comment the test app in CMakefile.
599 - Modify MMS BG color of vconf value.
600 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
601 - Add '-i' option for vconf keys of memory type
602 - Add smsc vconf keys(default value).
603 - To avoid msg incoming sound and notification on SOS
604
605 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
606 - Add '-i' option for vconf keys of memory type.
607 - Add smsc vconf keys(default value).
608 - To avoid msg incoming sound and notification on SOS state.
609 - Change BGcolor to black && font colore to white.
610
611 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
612 - Apply Mdm policy.
613 - SOS message.
614 - Fix horizontality development problem.
615 - Remove vconf key for new message count. (db/badge/com.samsung.message)
616 - Change vconf key path of "mms_send/msg_class" to private.
617
618 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
619 - Add new MAPI.
620
621 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
622 - Modify to support new DRM service.
623 - Rename private vconf keys.
624 - Modify .postinst and .spec file to pre-install used vconf keys.
625 - Remove compile warnings.
626 - Fix bug in manual retrieve operation.
627
628 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
629 - Fix DB conflict which cause db lock.
630 - Fix bug in Find My Mobile function.
631 - Add '*' and '#' symbol as valid number.
632
633 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
634 - Change mobile tracker related vconf key define values.
635 - Apply MDM policy for allowing text messaging.
636 - Fix bug for getting thumbnail path.
637 - Enable functionality of scheduled message.
638 - Change alarm setting of scheduled message from volatile type to non-volatile.
639 - Fix error in search query.
640
641 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
642 - Change some thread list related APIs to support DB change.
643 - DB change to support multiple recipient.
644
645 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
646 - Modify to manage contact sync time by vconf.
647 - Use g_idle_add() routine for updating unread message count(vconf values).
648 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
649 - Fix bug for allocated size of replacing string.
650 - Resolve search problem for special characters.
651 - add xmlFree.
652
653 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
654 - Remove unused vconf keys.
655 - Initialize SMSC selected_index.
656 - Remove systemd related.
657
658 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
659 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
660 - Fix S1-2397/2417/2418/2419.
661 - Remove sent status callback check during submit request.
662 - Modify offset and limit operation on search.
663 - Remove invalid folder and file.
664 - Change browser launching API from aul to service-capi.
665 - Remove unused file.
666 - Invalid type checking is fixed.
667
668 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
669 - Add #include <sys/stat.h> to support chmod related defines.
670 - Fix DRM content issue(unregistered mo content)
671
672 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
673 - Modify plugin configuration file location for FOTA.
674 - Remove the db query which create sample data.
675
676 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
677 - Update msg-service.spec for OBS.
678 - Fix TC execute failure.
679 - Fix S1-1419(Removed mms raw file issue after rebooting)