Remove hardcoded path for multiuser support
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.3
3 Release:        1
4 License:        Flora-1.1
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source101:      msg-service.service
9 Source1001:     %{name}.manifest
10 Source1002:     %{name}-devel.manifest
11 Source1003:     %{name}-tools.manifest
12 Source1004:     sms-plugin.manifest
13 Source1005:     mms-plugin.manifest
14
15 Requires(post): /usr/bin/sqlite3
16 Requires(post): /usr/bin/vconftool
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19 Requires(post): systemd
20 Requires(postun): systemd
21 BuildRequires: cmake
22 BuildRequires: pkgconfig(alarm-service)
23 BuildRequires: pkgconfig(appsvc)
24 BuildRequires: pkgconfig(aul)
25 BuildRequires: pkgconfig(capi-appfw-application)
26 BuildRequires: pkgconfig(contacts-service2)
27 BuildRequires: pkgconfig(db-util)
28 BuildRequires: pkgconfig(dlog)
29 BuildRequires: pkgconfig(drm-client)
30 BuildRequires: pkgconfig(glib-2.0)
31 BuildRequires: pkgconfig(libcurl)
32 BuildRequires: pkgconfig(libsystemd-daemon)
33 BuildRequires: pkgconfig(libxml-2.0)
34 BuildRequires: pkgconfig(libwbxml2)
35 BuildRequires: pkgconfig(media-thumbnail)
36 BuildRequires: pkgconfig(mm-fileinfo)
37 BuildRequires: pkgconfig(mm-player)
38 BuildRequires: pkgconfig(mm-session)
39 BuildRequires: pkgconfig(mm-sound)
40 BuildRequires: pkgconfig(network)
41 BuildRequires: pkgconfig(notification)
42 BuildRequires: pkgconfig(pmapi)
43 BuildRequires: pkgconfig(mmutil-imgp)
44 BuildRequires: pkgconfig(mmutil-jpeg)
45 BuildRequires: pkgconfig(security-server)
46 BuildRequires: pkgconfig(sensor)
47 BuildRequires: pkgconfig(svi)
48 BuildRequires: pkgconfig(tapi)
49 BuildRequires: pkgconfig(vconf)
50 BuildRequires: pkgconfig(feedback)
51 BuildRequires: pkgconfig(capi-network-connection)
52 BuildRequires: pkgconfig(libtzplatform-config)
53
54 %description
55 Description: Messaging Framework Library
56
57
58 %package devel
59 License:        Flora License v1.1
60 Summary:        Messaging Framework Library (development)
61 Requires:       %{name} = %{version}-%{release}
62 Group:          Development/Libraries
63
64 %description devel
65 Description: Messaging Framework Library (development)
66
67
68 %package tools
69 License:        Flora License v1.1
70 Summary:        Messaging server application
71 Requires:       %{name} = %{version}-%{release}
72 Group:          TO_BU / FILL_IN
73 Requires(post): /usr/bin/sqlite3
74 Requires(post): /usr/bin/vconftool
75 Requires(post): /sbin/ldconfig
76 Requires(postun): /sbin/ldconfig
77
78 %description tools
79 Description:  Messaging server application
80
81
82 %package -n sms-plugin
83 License:        Flora License v1.1
84 Summary:        SMS plugin library
85 Requires:       %{name} = %{version}-%{release}
86 Group:          System/Libraries
87 Requires(post): /sbin/ldconfig
88 Requires(postun): /sbin/ldconfig
89
90 %description -n sms-plugin
91 Description: SMS plugin library
92
93 %package -n mms-plugin
94 License:        Flora License v1.1
95 Summary:        MMS plugin library
96 Requires:       %{name} = %{version}-%{release}
97 Group:          System/Libraries
98 Requires(post): /sbin/ldconfig
99 Requires(postun): /sbin/ldconfig
100
101 %description -n mms-plugin
102 Description: MMS plugin library
103
104 %prep
105 %setup -q
106 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} %{SOURCE1005} .
107
108
109 %build
110 %cmake . \
111         -DTZ_SYS_SHARE=%TZ_SYS_SHARE \
112         -DUNITDIR_USER=%{_unitdir_user} \
113         -DTZ_SYS_SMACK=%TZ_SYS_SMACK
114
115 make %{?jobs:-j%jobs}
116
117 %install
118 rm -rf %{buildroot}
119 mkdir -p %{buildroot}/etc/config
120
121 mkdir -p %{buildroot}/var/log/msgfw
122
123 %make_install
124
125 mkdir -p %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants
126 #install -m 0644 %SOURCE101 %{buildroot}%{_unitdir_user}/
127 ln -s ../msg-service.service %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/msg-service.service
128 ln -s ../msg-service-log.service %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/msg-service-log.service
129
130 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
131 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
132 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
133 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
134
135 mkdir -p %{buildroot}/opt/usr/data/msg-service
136
137 %if 0%{?simulator}
138 rm %{buildroot}/etc/config/sysinfo-message.xml
139 mv %{buildroot}/etc/config/sysinfo-message.emul.xml %{buildroot}/etc/config/sysinfo-message.xml
140 %else
141 rm %{buildroot}/etc/config/sysinfo-message.emul.xml
142 %endif
143
144
145 %post tools -p /sbin/ldconfig
146 %post -n sms-plugin -p /sbin/ldconfig
147 %post -n mms-plugin -p /sbin/ldconfig
148
149 %post
150 /sbin/ldconfig
151
152 /bin/systemctl daemon-reload
153 if [ "$1" = "1" ]; then
154     systemctl stop msg-service.service
155 fi
156
157 %postun -p /sbin/ldconfig
158
159 %postun tools -p /sbin/ldconfig
160 %postun -n sms-plugin -p /sbin/ldconfig
161 %postun -n mms-plugin -p /sbin/ldconfig
162
163 %files
164 %manifest %{name}.manifest
165 %license LICENSE.Flora
166 %defattr(-,root,root,-)
167 %{_libdir}/libmsg_plugin_manager.so
168 %{_libdir}/libmsg_mapi.so.*
169 %{_libdir}/libmsg_framework_handler.so
170 %{_libdir}/libmsg_transaction_manager.so
171 %{_libdir}/libmsg_utils.so
172 %{_libdir}/libmsg_transaction_proxy.so
173 %{_libdir}/libmsg_vobject.so
174 %TZ_SYS_SHARE/%{name}/msg_service-init-DB.sh
175
176 %files devel
177 %manifest %{name}-devel.manifest
178 %defattr(-,root,root,-)
179 %{_libdir}/libmsg_mapi.so
180 %{_libdir}/pkgconfig/msg-service.pc
181 %{_includedir}/msg-service/*
182
183 %files tools
184 %manifest %{name}-tools.manifest
185 %license LICENSE.Flora
186 %defattr(-,root,root,-)
187 %{_bindir}/msg-helper
188 %{_bindir}/msg-server
189 %{_datadir}/media/Sherbet.wav
190 %attr(0644,root,root)%{_datadir}/msg-service/plugin.cfg
191 %{_sysconfdir}/rc.d/init.d/msg-server
192 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
193 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
194 %{_unitdir_user}/msg-service.service
195 %{_unitdir_user}/msg-service-log.service
196 %{_unitdir_user}/tizen-middleware.target.wants/msg-service.service
197 %{_unitdir_user}/tizen-middleware.target.wants/msg-service-log.service
198 %{_sysconfdir}/config/sysinfo-message.xml
199 %attr(0755,root,%TZ_SYS_USER_GROUP) /var/log/msgfw
200
201 %files -n sms-plugin
202 %manifest sms-plugin.manifest
203 %license LICENSE.Flora
204 %defattr(-,root,root,-)
205 %{_libdir}/libmsg_sms_plugin.so
206
207 %files -n mms-plugin
208 %manifest mms-plugin.manifest
209 %license LICENSE.Flora
210 %defattr(-,root,root,-)
211 %{_libdir}/libmsg_mms_plugin.so
212
213 %changelog
214 * Wed Oct 25 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
215 - New release version
216
217 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
218 - Apply New TAPI.
219 - Modify transaction data size of sos recipient list.
220
221 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
222 - Fix contact sync defect.
223 - New MessageFW API.
224
225 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
226 - Change devman_haptic.h to devman_managed.h.
227 - Modify to set MSG_SERVER_READY before sim status check.
228 - Fix bug in sim message save related operations.
229 - Limit sim related APIs not to work on sim not available status.
230 - Modify indicator icon image path & related.
231
232 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
233 - Modify MAX_SEGMENT_NUM to 15.
234 - Modify MMplayer related to support interrupted event.
235 - Fix bug in storage change callback which could cause on submit request.
236
237 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
238 - Modify vconf key path for sos sending option.
239
240 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
241 - Storage change callback for scheduled message
242 - code chage to support glib2-2.32
243 - Apply Backup && Restore of Mms Type
244
245 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
246 - Update display time for scheduled message when it is sent.
247
248 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
249 - Comment the test app in CMakefile.
250 - Modify MMS BG color of vconf value.
251 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
252 - Add '-i' option for vconf keys of memory type
253 - Add smsc vconf keys(default value).
254 - To avoid msg incoming sound and notification on SOS
255
256 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
257 - Add '-i' option for vconf keys of memory type.
258 - Add smsc vconf keys(default value).
259 - To avoid msg incoming sound and notification on SOS state.
260 - Change BGcolor to black && font colore to white.
261
262 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
263 - Apply Mdm policy.
264 - SOS message.
265 - Fix horizontality development problem.
266 - Remove vconf key for new message count. (db/badge/com.samsung.message)
267 - Change vconf key path of "mms_send/msg_class" to private.
268
269 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
270 - Add new MAPI.
271
272 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
273 - Modify to support new DRM service.
274 - Rename private vconf keys.
275 - Modify .postinst and .spec file to pre-install used vconf keys.
276 - Remove compile warnings.
277 - Fix bug in manual retrieve operation.
278
279 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
280 - Fix DB conflict which cause db lock.
281 - Fix bug in Find My Mobile function.
282 - Add '*' and '#' symbol as valid number.
283
284 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
285 - Change mobile tracker related vconf key define values.
286 - Apply MDM policy for allowing text messaging.
287 - Fix bug for getting thumbnail path.
288 - Enable functionality of scheduled message.
289 - Change alarm setting of scheduled message from volatile type to non-volatile.
290 - Fix error in search query.
291
292 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
293 - Change some thread list related APIs to support DB change.
294 - DB change to support multiple recipient.
295
296 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
297 - Modify to manage contact sync time by vconf.
298 - Use g_idle_add() routine for updating unread message count(vconf values).
299 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
300 - Fix bug for allocated size of replacing string.
301 - Resolve search problem for special characters.
302 - add xmlFree.
303
304 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
305 - Remove unused vconf keys.
306 - Initialize SMSC selected_index.
307 - Remove systemd related.
308
309 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
310 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
311 - Fix S1-2397/2417/2418/2419.
312 - Remove sent status callback check during submit request.
313 - Modify offset and limit operation on search.
314 - Remove invalid folder and file.
315 - Change browser launching API from aul to service-capi.
316 - Remove unused file.
317 - Invalid type checking is fixed.
318
319 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
320 - Add #include <sys/stat.h> to support chmod related defines.
321 - Fix DRM content issue(unregistered mo content)
322
323 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
324 - Modify plugin configuration file location for FOTA.
325 - Remove the db query which create sample data.
326
327 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
328 - Update msg-service.spec for OBS.
329 - Fix TC execute failure.
330 - Fix S1-1419(Removed mms raw file issue after rebooting)