Fix manifests
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.2
3 Release:        3
4 License:        Samsung
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source101:      msg-service.service
9 Source1001:     %{name}.manifest
10 Source1002:     %{name}-devel.manifest
11 Source1003:     %{name}-tools.manifest
12 Source1004:     sms-plugin.manifest
13 Source1005:     mms-plugin.manifest
14
15 Requires(post): /usr/bin/sqlite3
16 Requires(post): /usr/bin/vconftool
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19 Requires(post): systemd
20 Requires(postun): systemd
21 BuildRequires: cmake
22 BuildRequires: pkgconfig(alarm-service)
23 BuildRequires: pkgconfig(aul)
24 BuildRequires: pkgconfig(capi-appfw-application)
25 BuildRequires: pkgconfig(contacts-service2)
26 BuildRequires: pkgconfig(db-util)
27 BuildRequires: pkgconfig(dlog)
28 BuildRequires: pkgconfig(drm-client)
29 BuildRequires: pkgconfig(glib-2.0)
30 BuildRequires: pkgconfig(libcurl)
31 BuildRequires: pkgconfig(libsystemd-daemon)
32 BuildRequires: pkgconfig(libxml-2.0)
33 BuildRequires: pkgconfig(libwbxml2)
34 BuildRequires: pkgconfig(media-thumbnail)
35 BuildRequires: pkgconfig(mm-fileinfo)
36 BuildRequires: pkgconfig(mm-player)
37 BuildRequires: pkgconfig(mm-session)
38 BuildRequires: pkgconfig(mm-sound)
39 BuildRequires: pkgconfig(network)
40 BuildRequires: pkgconfig(notification)
41 BuildRequires: pkgconfig(pmapi)
42 BuildRequires: pkgconfig(mmutil-imgp)
43 BuildRequires: pkgconfig(mmutil-jpeg)
44 BuildRequires: pkgconfig(security-server)
45 BuildRequires: pkgconfig(sensor)
46 BuildRequires: pkgconfig(svi)
47 BuildRequires: pkgconfig(tapi)
48 BuildRequires: pkgconfig(vconf)
49 BuildRequires: pkgconfig(feedback)
50
51 %description
52 Description: Messaging Framework Library
53
54
55 %package devel
56 License:        Flora License v1.0
57 Summary:        Messaging Framework Library (development)
58 Requires:       %{name} = %{version}-%{release}
59 Group:          Development/Libraries
60
61 %description devel
62 Description: Messaging Framework Library (development)
63
64
65 %package tools
66 License:        Flora License v1.0
67 Summary:        Messaging server application
68 Requires:       %{name} = %{version}-%{release}
69 Group:          TO_BU / FILL_IN
70 Requires(post): /usr/bin/sqlite3
71 Requires(post): /usr/bin/vconftool
72 Requires(post): /sbin/ldconfig
73 Requires(postun): /sbin/ldconfig
74
75 %description tools
76 Description:  Messaging server application
77
78
79 %package -n sms-plugin
80 License:        Flora License v1.0
81 Summary:        SMS plugin library
82 Requires:       %{name} = %{version}-%{release}
83 Group:          System/Libraries
84 Requires(post): /sbin/ldconfig
85 Requires(postun): /sbin/ldconfig
86
87 %description -n sms-plugin
88 Description: SMS plugin library
89
90 %package -n mms-plugin
91 License:        Flora License v1.0
92 Summary:        MMS plugin library
93 Requires:       %{name} = %{version}-%{release}
94 Group:          System/Libraries
95 Requires(post): /sbin/ldconfig
96 Requires(postun): /sbin/ldconfig
97
98 %description -n mms-plugin
99 Description: MMS plugin library
100
101 %prep
102 %setup -q
103 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} %{SOURCE1005} .
104
105
106 %build
107 %cmake .
108 make %{?jobs:-j%jobs}
109
110 %install
111 rm -rf %{buildroot}
112 mkdir -p %{buildroot}/usr/share/license
113 mkdir -p %{buildroot}/etc/config
114
115 mkdir -p %{buildroot}/var/log/msgfw
116
117 %make_install
118
119 mkdir -p %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants
120 #install -m 0644 %SOURCE101 %{buildroot}%{_unitdir_user}/
121 ln -s ../msg-service.service %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/msg-service.service
122 ln -s ../msg-service-log.service %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/msg-service-log.service
123
124 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
125 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
126 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
127 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
128
129 mkdir -p %{buildroot}/opt/usr/data/msg-service
130
131 %if 0%{?simulator}
132 rm %{buildroot}/etc/config/sysinfo-message.xml
133 mv %{buildroot}/etc/config/sysinfo-message.emul.xml %{buildroot}/etc/config/sysinfo-message.xml
134 %else
135 rm %{buildroot}/etc/config/sysinfo-message.emul.xml
136 %endif
137
138
139 %post tools -p /sbin/ldconfig
140 %post -n sms-plugin -p /sbin/ldconfig
141 %post -n mms-plugin -p /sbin/ldconfig
142
143 %post
144 /sbin/ldconfig
145
146 if [ ! -f /opt/usr/dbspace/.msg_service.db ]
147 then
148     mkdir -p /opt/usr/dbspace/
149     sqlite3 /opt/usr/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
150
151     CREATE TABLE MSG_CONVERSATION_TABLE (
152         CONV_ID INTEGER PRIMARY KEY ,
153         UNREAD_CNT INTEGER DEFAULT 0 ,
154         SMS_CNT INTEGER DEFAULT 0 ,
155         MMS_CNT INTEGER DEFAULT 0 ,
156         MAIN_TYPE INTEGER DEFAULT 0 ,
157         SUB_TYPE INTEGER DEFAULT 0 ,
158         MSG_DIRECTION INTEGER DEFAULT 0 ,
159         DISPLAY_TIME DATETIME ,
160         DISPLAY_NAME TEXT ,
161         MSG_TEXT TEXT );
162
163     CREATE TABLE MSG_ADDRESS_TABLE (
164         ADDRESS_ID INTEGER PRIMARY KEY ,
165         CONV_ID INTEGER  NOT NULL ,
166         ADDRESS_TYPE INTEGER ,
167         RECIPIENT_TYPE INTEGER ,
168         ADDRESS_VAL TEXT ,
169         CONTACT_ID INTEGER ,
170         DISPLAY_NAME TEXT ,
171         FIRST_NAME TEXT ,
172         LAST_NAME TEXT ,
173         IMAGE_PATH TEXT ,
174         SYNC_TIME DATETIME ,
175         FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
176
177     CREATE TABLE MSG_FOLDER_TABLE (
178         FOLDER_ID INTEGER PRIMARY KEY ,
179         FOLDER_NAME TEXT NOT NULL ,
180         FOLDER_TYPE INTEGER DEFAULT 0 );
181
182     CREATE TABLE MSG_MESSAGE_TABLE (
183         MSG_ID INTEGER PRIMARY KEY ,
184         CONV_ID INTEGER NOT NULL ,
185         FOLDER_ID INTEGER NOT NULL ,
186         STORAGE_ID INTEGER NOT NULL ,
187         MAIN_TYPE INTEGER NOT NULL ,
188         SUB_TYPE INTEGER NOT NULL ,
189         DISPLAY_TIME DATETIME ,
190         DATA_SIZE INTEGER DEFAULT 0 ,
191         NETWORK_STATUS INTEGER DEFAULT 0 ,
192         READ_STATUS INTEGER DEFAULT 0 ,
193         PROTECTED INTEGER DEFAULT 0 ,
194         PRIORITY INTEGER DEFAULT 0 ,
195         MSG_DIRECTION INTEGER NOT NULL ,
196         SCHEDULED_TIME DATETIME ,
197         BACKUP INTEGER DEFAULT 0 ,
198         SUBJECT TEXT ,
199         MSG_DATA TEXT ,
200         THUMB_PATH TEXT ,
201         MSG_TEXT TEXT ,
202         ATTACHMENT_COUNT INTEGER DEFAULT 0 ,
203         FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) ,
204         FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
205
206     CREATE TABLE MSG_SIM_TABLE (
207         MSG_ID INTEGER PRIMARY KEY ,
208         SIM_ID INTEGER NOT NULL ,
209         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
210
211     CREATE TABLE MSG_PUSH_TABLE (
212         MSG_ID INTEGER PRIMARY KEY ,
213         ACTION INTEGER ,
214         CREATED INTEGER ,
215         EXPIRES INTEGER ,
216         ID TEXT ,
217         HREF TEXT ,
218         CONTENT TEXT ,
219         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
220
221     CREATE TABLE MSG_CBMSG_TABLE (
222         MSG_ID INTEGER PRIMARY KEY ,
223         CB_MSG_ID INTEGER NOT NULL ,
224         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
225
226     CREATE TABLE MSG_SYNCML_TABLE (
227         MSG_ID INTEGER PRIMARY KEY ,
228         EXT_ID INTEGER NOT NULL ,
229         PINCODE INTEGER NOT NULL ,
230         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
231
232     CREATE TABLE MSG_SCHEDULED_TABLE (
233         MSG_ID INTEGER PRIMARY KEY ,
234         ALARM_ID INTEGER NOT NULL ,
235         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
236
237     CREATE TABLE MSG_SMS_SENDOPT_TABLE (
238         MSG_ID INTEGER PRIMARY KEY ,
239         DELREP_REQ INTEGER NOT NULL ,
240         KEEP_COPY INTEGER NOT NULL ,
241         REPLY_PATH INTEGER NOT NULL ,
242         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
243
244     CREATE TABLE MSG_FILTER_TABLE (
245         FILTER_ID INTEGER PRIMARY KEY ,
246         FILTER_TYPE INTEGER NOT NULL ,
247         FILTER_VALUE TEXT NOT NULL ,
248         FILTER_ACTIVE INTEGER DEFAULT 0 );
249
250     CREATE TABLE MSG_MMS_MESSAGE_TABLE (
251         MSG_ID INTEGER PRIMARY KEY ,
252         TRANSACTION_ID TEXT ,
253         MESSAGE_ID TEXT ,
254         FWD_MESSAGE_ID TEXT ,
255         CONTENTS_LOCATION TEXT ,
256         FILE_PATH TEXT ,
257         VERSION INTEGER NOT NULL ,
258         DATA_TYPE INTEGER DEFAULT -1 ,
259         DATE DATETIME ,
260         HIDE_ADDRESS INTEGER DEFAULT 0 ,
261         ASK_DELIVERY_REPORT INTEGER DEFAULT 0 ,
262         REPORT_ALLOWED INTEGER DEFAULT 0 ,
263         READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 ,
264         ASK_READ_REPLY INTEGER DEFAULT 0 ,
265         READ INTEGER DEFAULT 0 ,
266         READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 ,
267         READ_REPORT_SENT INTEGER DEFAULT 0 ,
268         PRIORITY INTEGER DEFAULT 0 ,
269         KEEP_COPY INTEGER DEFAULT 0 ,
270         MSG_SIZE INTEGER NOT NULL ,
271         MSG_CLASS INTEGER DEFAULT -1 ,
272         EXPIRY_TIME DATETIME ,
273         CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 ,
274         DELIVERY_TIME DATETIME ,
275         MSG_STATUS INTEGER DEFAULT -1 ,
276         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
277
278     CREATE TABLE MSG_MMS_PREVIEW_INFO_TABLE (
279         MSG_ID INTEGER NOT NULL ,
280         TYPE INTEGER,
281         VALUE TEXT,
282         COUNT INTEGER,
283         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
284
285     CREATE TABLE MSG_REPORT_TABLE (
286         MSG_ID INTEGER NOT NULL ,
287         ADDRESS_VAL TEXT ,
288         STATUS_TYPE INTEGER ,
289         STATUS INTEGER DEFAULT 0 ,
290         TIME DATETIME );
291
292     CREATE TABLE MSG_PUSHCFG_TABLE (
293         PUSH_ID INTEGER PRIMARY KEY ,
294         CONTENT_TYPE TEXT,
295         APP_ID TEXT,
296         PKG_NAME TEXT,
297         LAUNCH INTEGER,
298         APPCODE INTEGER,
299         SECURE INTEGER );
300
301     CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
302     CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
303     CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
304
305     INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
306     INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
307     INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
308     INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
309     INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
310     INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
311     INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
312     INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);
313
314     INSERT INTO MSG_PUSHCFG_TABLE VALUES (1, 'text/vnd.wap.si', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 1, 0);
315     INSERT INTO MSG_PUSHCFG_TABLE VALUES (2, 'application/vnd.wap.sic', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 2, 0);
316     INSERT INTO MSG_PUSHCFG_TABLE VALUES (3, 'text/vnd.wap.sl', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 3, 0);
317         INSERT INTO MSG_PUSHCFG_TABLE VALUES (4, 'application/vnd.wap.slc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 4, 0);
318     INSERT INTO MSG_PUSHCFG_TABLE VALUES (5, 'text/vnd.wap.co', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 5, 0);
319
320     INSERT INTO MSG_PUSHCFG_TABLE VALUES (6, 'application/vnd.wap.coc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 6, 0);
321     INSERT INTO MSG_PUSHCFG_TABLE VALUES (7, 'application/vnd.wap.mms-message', 'X-Wap-Application-Id: x-wap-application:mms.ua', '', 0, 7, 0);
322     INSERT INTO MSG_PUSHCFG_TABLE VALUES (8, 'application/vnd.wap.sia', 'X-Wap-Application-Id: x-wap-application:push.sia', '', 0, 8, 0);
323     INSERT INTO MSG_PUSHCFG_TABLE VALUES (9, 'application/vnd.syncml.dm+wbxml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 9, 0);
324     INSERT INTO MSG_PUSHCFG_TABLE VALUES (10, 'application/vnd.syncml.dm+xml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 10, 0);
325
326     INSERT INTO MSG_PUSHCFG_TABLE VALUES (11, 'application/vnd.syncml.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 11, 0);
327     INSERT INTO MSG_PUSHCFG_TABLE VALUES (12, 'application/vnd.syncml.ds.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.ds', '', 0, 12, 0);
328     INSERT INTO MSG_PUSHCFG_TABLE VALUES (13, 'application/vnd.syncml+wbxml', 'X-Wap-Application-Id:x-wap-application:push.syncml', '', 0, 13, 0);
329     INSERT INTO MSG_PUSHCFG_TABLE VALUES (14, 'application/vnd.wap.locc+wbxml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 14, 0);
330     INSERT INTO MSG_PUSHCFG_TABLE VALUES (15, 'application/vnd.wap.loc+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 15, 0);
331
332     INSERT INTO MSG_PUSHCFG_TABLE VALUES (16, 'application/vnd.oma.dd+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 16, 0);
333     INSERT INTO MSG_PUSHCFG_TABLE VALUES (17, 'application/vnd.oma.drm.message', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 17, 0);
334     INSERT INTO MSG_PUSHCFG_TABLE VALUES (18, 'application/vnd.oma.drm.content', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 18, 0);
335     INSERT INTO MSG_PUSHCFG_TABLE VALUES (19, 'application/vnd.oma.drm.rights+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 19, 0);
336     INSERT INTO MSG_PUSHCFG_TABLE VALUES (20, 'application/vnd.oma.drm.rights+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 20, 0);
337
338     INSERT INTO MSG_PUSHCFG_TABLE VALUES (21, 'application/vnd.oma.drm.ro+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 21, 0);
339     INSERT INTO MSG_PUSHCFG_TABLE VALUES (22, 'application/vnd.oma.drm.roap-pdu+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 22, 0);
340     INSERT INTO MSG_PUSHCFG_TABLE VALUES (23, 'application/vnd.oma.drm.roap-trigger+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 23, 0);
341     INSERT INTO MSG_PUSHCFG_TABLE VALUES (24, 'application/vnd.oma.drm.roap-trigger+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 24, 0);
342         INSERT INTO MSG_PUSHCFG_TABLE VALUES (25, 'text/vnd.wap.connectivity-xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 26, 0);
343
344         INSERT INTO MSG_PUSHCFG_TABLE VALUES (26, 'application/vnd.wap.connectivity-wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 27, 0);
345         INSERT INTO MSG_PUSHCFG_TABLE VALUES (27, 'application/x-wap-prov.browser-settings', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 28, 0);
346         INSERT INTO MSG_PUSHCFG_TABLE VALUES (28, 'application/x-wap-prov.browser-bookmarks', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 29, 0);
347         INSERT INTO MSG_PUSHCFG_TABLE VALUES (29, 'application/x-wap-prov.syncset+xml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 30, 0);
348         INSERT INTO MSG_PUSHCFG_TABLE VALUES (30, 'application/x-wap-prov.syncset+wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 31, 0);
349
350         INSERT INTO MSG_PUSHCFG_TABLE VALUES (31, 'text/vnd.wap.emn+xml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 32, 0);
351         INSERT INTO MSG_PUSHCFG_TABLE VALUES (32, 'application/vnd.wap.emn+wbxml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 33, 0);
352         INSERT INTO MSG_PUSHCFG_TABLE VALUES (33, 'application/vnd.wv.csp.cir', 'X-Wap-Application-Id: x-wap-application:wv.ua', '', 0, 34, 0);
353         INSERT INTO MSG_PUSHCFG_TABLE VALUES (34, 'application/vnd.omaloc-supl-init', 'X-Wap-Application-Id: x-oma-application:ulp.ua', '', 0, 44, 0);
354         INSERT INTO MSG_PUSHCFG_TABLE VALUES (35, 'application/vnd.wap.emn+wbxml', 'X-oma-docomo:xmd.mail.ua', '', 0, 45, 1);"
355 fi
356
357 chown :6011 /opt/usr/dbspace/.msg_service.db
358 chown :6011 /opt/usr/dbspace/.msg_service.db-journal
359 chmod 660 /opt/usr/dbspace/.msg_service.db
360 chmod 660 /opt/usr/dbspace/.msg_service.db-journal
361 mkdir -p /opt/usr/data/msg-service
362 chgrp db_msg_service /opt/usr/data/msg-service
363
364 ########## Setting Config Value (Internal keys) ##########
365 vcuid=5000
366 # Message Server Status
367 vconftool set -t bool memory/msg/ready 0 -i -g 5000 -u $vcuid
368
369 # SMS Send Options
370 vconftool set -t int db/msg/network_mode 2 -u $vcuid
371
372 # New Message Count
373 vconftool set -t int db/msg/recv_sms 0 -u $vcuid
374 vconftool set -t int db/msg/recv_mms 0 -u $vcuid
375
376 ########## Setting Config Value (Private keys) ##########
377 # General Options
378 vconftool set -t bool db/private/msg-service/general/keep_copy 1 -u $vcuid
379 vconftool set -t bool db/private/msg-service/general/auto_erase 0 -u $vcuid
380 vconftool set -t bool db/private/msg-service/general/block_msg 0 -u $vcuid
381 vconftool set -t int db/private/msg-service/general/contact_sync_time 0 -u $vcuid
382
383 # SMS Send Options
384 vconftool set -t int db/private/msg-service/sms_send/dcs 3 -u $vcuid
385 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0 -u $vcuid
386 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0 -u $vcuid
387 vconftool set -t int db/private/msg-service/sms_send/save_storage 1 -u $vcuid
388
389 # SMSC
390 vconftool set -t int db/private/msg-service/smsc/total_count 1 -u $vcuid
391 vconftool set -t int db/private/msg-service/smsc/selected 0 -u $vcuid
392
393 vconftool set -t int db/private/msg-service/smsc/pid/0 1 -u $vcuid
394 vconftool set -t int db/private/msg-service/smsc/val_period/0 255 -u $vcuid
395 vconftool set -t string db/private/msg-service/smsc/name/0 "" -u $vcuid
396 vconftool set -t int db/private/msg-service/smsc/ton/0 1 -u $vcuid
397 vconftool set -t int db/private/msg-service/smsc/npi/0 1 -u $vcuid
398 vconftool set -t string db/private/msg-service/smsc/address/0 "" -u $vcuid
399
400 vconftool set -t int db/private/msg-service/smsc/pid/1 0 -u $vcuid
401 vconftool set -t int db/private/msg-service/smsc/val_period/1 0 -u $vcuid
402 vconftool set -t string db/private/msg-service/smsc/name/1 "" -u $vcuid
403 vconftool set -t int db/private/msg-service/smsc/ton/1 0 -u $vcuid
404 vconftool set -t int db/private/msg-service/smsc/npi/1 0 -u $vcuid
405 vconftool set -t string db/private/msg-service/smsc/address/1 "" -u $vcuid
406
407 vconftool set -t int db/private/msg-service/smsc/pid/2 0 -u $vcuid
408 vconftool set -t int db/private/msg-service/smsc/val_period/2 0 -u $vcuid
409 vconftool set -t string db/private/msg-service/smsc/name/2 "" -u $vcuid
410 vconftool set -t int db/private/msg-service/smsc/ton/2 0 -u $vcuid
411 vconftool set -t int db/private/msg-service/smsc/npi/2 0 -u $vcuid
412 vconftool set -t string db/private/msg-service/smsc/address/2 "" -u $vcuid
413
414 # MMS Send Options
415 vconftool set -t int db/private/msg-service/mms_send/msg_class 0 -u $vcuid
416 vconftool set -t int db/private/msg-service/mms_send/priority 1 -u $vcuid
417 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0 -u $vcuid
418 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0 -u $vcuid
419 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0 -u $vcuid
420 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1 -u $vcuid
421 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1 -u $vcuid
422 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0 -u $vcuid
423 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0 -u $vcuid
424 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0 -u $vcuid
425 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1 -u $vcuid
426 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0 -u $vcuid
427 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0 -u $vcuid
428 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0 -u $vcuid
429 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0 -u $vcuid
430 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2 -u $vcuid
431
432 # MMS Receive Options
433 vconftool set -t int db/private/msg-service/mms_recv/home_network 0 -u $vcuid
434 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0 -u $vcuid
435 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1 -u $vcuid
436 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1 -u $vcuid
437 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0 -u $vcuid
438 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0 -u $vcuid
439
440 # MMS Receive Options
441 vconftool set -t int db/private/msg-service/mms_style/font_size 30 -u $vcuid
442 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0 -u $vcuid
443 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0 -u $vcuid
444 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0 -u $vcuid
445 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255 -u $vcuid
446 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255 -u $vcuid
447 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255 -u $vcuid
448 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255 -u $vcuid
449 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0 -u $vcuid
450 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0 -u $vcuid
451 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0 -u $vcuid
452 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255 -u $vcuid
453 vconftool set -t int db/private/msg-service/mms_style/page_dur 2 -u $vcuid
454 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0 -u $vcuid
455 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0 -u $vcuid
456
457 # Push Msg Options
458 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1 -u $vcuid
459 vconftool set -t int db/private/msg-service/push_msg/service_load 1 -u $vcuid
460
461 # CB Msg Options
462 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f -u $vcuid
463 vconftool set -t bool db/private/msg-service/cb_msg/save 1 -f -u $vcuid
464 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0 -u $vcuid
465 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0 -u $vcuid
466 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f -u $vcuid
467 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0 -u $vcuid
468 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0 -u $vcuid
469 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0 -u $vcuid
470 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0 -u $vcuid
471 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0 -u $vcuid
472 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0 -u $vcuid
473 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0 -u $vcuid
474 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0 -u $vcuid
475 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0 -u $vcuid
476
477 # Voice Mail Options
478 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number "5500" -f -u $vcuid
479 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count 0 -u $vcuid
480
481 # MMS Size Options
482 vconftool set -t int db/private/msg-service/size_opt/msg_size 300 -u $vcuid
483
484 # SIM message count
485 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0 -u $vcuid
486 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0 -u $vcuid
487
488 # SIM information
489 vconftool set -t int memory/private/msg-service/sim_changed 0 -i -u $vcuid
490 vconftool set -t string memory/private/msg-service/sim_imsi "" -i -u $vcuid
491 vconftool set -t bool memory/private/msg-service/national_sim 0 -i -u $vcuid
492 vconftool set -t string memory/private/msg-service/msisdn "" -i -u $vcuid
493
494 vconftool set -t int db/private/msg-service/notification_priv_id 0 -u $vcuid
495
496 /sbin/ldconfig
497 /bin/systemctl daemon-reload
498 if [ "$1" = "1" ]; then
499     systemctl stop msg-service.service
500 fi
501
502 %postun -p /sbin/ldconfig
503
504 %postun tools -p /sbin/ldconfig
505 %postun -n sms-plugin -p /sbin/ldconfig
506 %postun -n mms-plugin -p /sbin/ldconfig
507
508 %files
509 %manifest %{name}.manifest
510 %defattr(-,root,root,-)
511 %dir %attr(775,root,db_msg_service) /opt/usr/data/msg-service
512 %{_libdir}/libmsg_plugin_manager.so
513 %{_libdir}/libmsg_mapi.so.*
514 %{_libdir}/libmsg_framework_handler.so
515 %{_libdir}/libmsg_transaction_manager.so
516 %{_libdir}/libmsg_utils.so
517 %{_libdir}/libmsg_transaction_proxy.so
518 %{_libdir}/libmsg_vobject.so
519 /usr/share/license/msg-service/LICENSE.Flora
520
521 %files devel
522 %manifest %{name}-devel.manifest
523 %defattr(-,root,root,-)
524 %{_libdir}/libmsg_mapi.so
525 %{_libdir}/pkgconfig/msg-service.pc
526 %{_includedir}/msg-service/*
527
528 %files tools
529 %manifest %{name}-tools.manifest
530 %defattr(-,root,root,-)
531 %{_bindir}/msg-helper
532 %{_bindir}/msg-server
533 %{_datadir}/media/Sherbet.wav
534 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
535 %{_sysconfdir}/rc.d/init.d/msg-server
536 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
537 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
538 %{_unitdir_user}/msg-service.service
539 %{_unitdir_user}/msg-service-log.service
540 %{_unitdir_user}/tizen-middleware.target.wants/msg-service.service
541 %{_unitdir_user}/tizen-middleware.target.wants/msg-service-log.service
542 /usr/share/license/msg-service/LICENSE.Flora
543 /opt/etc/smack/accesses.d/msg-service.rule
544 /etc/config/sysinfo-message.xml
545
546 %attr(0755,app,app)/var/log/msgfw
547
548
549 %files -n sms-plugin
550 %manifest sms-plugin.manifest
551 %defattr(-,root,root,-)
552 %{_libdir}/libmsg_sms_plugin.so
553 /usr/share/license/msg-service/LICENSE.Flora
554
555 %files -n mms-plugin
556 %manifest mms-plugin.manifest
557 %defattr(-,root,root,-)
558 %{_libdir}/libmsg_mms_plugin.so
559 /usr/share/license/msg-service/LICENSE.Flora
560
561 %changelog
562 * Wed Oct 25 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
563 - New release version
564
565 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
566 - Apply New TAPI.
567 - Modify transaction data size of sos recipient list.
568
569 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
570 - Fix contact sync defect.
571 - New MessageFW API.
572
573 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
574 - Change devman_haptic.h to devman_managed.h.
575 - Modify to set MSG_SERVER_READY before sim status check.
576 - Fix bug in sim message save related operations.
577 - Limit sim related APIs not to work on sim not available status.
578 - Modify indicator icon image path & related.
579
580 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
581 - Modify MAX_SEGMENT_NUM to 15.
582 - Modify MMplayer related to support interrupted event.
583 - Fix bug in storage change callback which could cause on submit request.
584
585 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
586 - Modify vconf key path for sos sending option.
587
588 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
589 - Storage change callback for scheduled message
590 - code chage to support glib2-2.32
591 - Apply Backup && Restore of Mms Type
592
593 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
594 - Update display time for scheduled message when it is sent.
595
596 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
597 - Comment the test app in CMakefile.
598 - Modify MMS BG color of vconf value.
599 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
600 - Add '-i' option for vconf keys of memory type
601 - Add smsc vconf keys(default value).
602 - To avoid msg incoming sound and notification on SOS
603
604 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
605 - Add '-i' option for vconf keys of memory type.
606 - Add smsc vconf keys(default value).
607 - To avoid msg incoming sound and notification on SOS state.
608 - Change BGcolor to black && font colore to white.
609
610 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
611 - Apply Mdm policy.
612 - SOS message.
613 - Fix horizontality development problem.
614 - Remove vconf key for new message count. (db/badge/com.samsung.message)
615 - Change vconf key path of "mms_send/msg_class" to private.
616
617 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
618 - Add new MAPI.
619
620 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
621 - Modify to support new DRM service.
622 - Rename private vconf keys.
623 - Modify .postinst and .spec file to pre-install used vconf keys.
624 - Remove compile warnings.
625 - Fix bug in manual retrieve operation.
626
627 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
628 - Fix DB conflict which cause db lock.
629 - Fix bug in Find My Mobile function.
630 - Add '*' and '#' symbol as valid number.
631
632 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
633 - Change mobile tracker related vconf key define values.
634 - Apply MDM policy for allowing text messaging.
635 - Fix bug for getting thumbnail path.
636 - Enable functionality of scheduled message.
637 - Change alarm setting of scheduled message from volatile type to non-volatile.
638 - Fix error in search query.
639
640 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
641 - Change some thread list related APIs to support DB change.
642 - DB change to support multiple recipient.
643
644 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
645 - Modify to manage contact sync time by vconf.
646 - Use g_idle_add() routine for updating unread message count(vconf values).
647 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
648 - Fix bug for allocated size of replacing string.
649 - Resolve search problem for special characters.
650 - add xmlFree.
651
652 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
653 - Remove unused vconf keys.
654 - Initialize SMSC selected_index.
655 - Remove systemd related.
656
657 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
658 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
659 - Fix S1-2397/2417/2418/2419.
660 - Remove sent status callback check during submit request.
661 - Modify offset and limit operation on search.
662 - Remove invalid folder and file.
663 - Change browser launching API from aul to service-capi.
664 - Remove unused file.
665 - Invalid type checking is fixed.
666
667 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
668 - Add #include <sys/stat.h> to support chmod related defines.
669 - Fix DRM content issue(unregistered mo content)
670
671 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
672 - Modify plugin configuration file location for FOTA.
673 - Remove the db query which create sample data.
674
675 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
676 - Update msg-service.spec for OBS.
677 - Fix TC execute failure.
678 - Fix S1-1419(Removed mms raw file issue after rebooting)