Merge "AArch64 support" into tizen
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.3
3 Release:        1
4 License:        Flora-1.1
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source101:      msg-service.service
9 Source1001:     %{name}.manifest
10 Source1002:     %{name}-devel.manifest
11 Source1003:     %{name}-tools.manifest
12 Source1004:     sms-plugin.manifest
13 Source1005:     mms-plugin.manifest
14
15 Requires(post): /usr/bin/sqlite3
16 Requires(post): /usr/bin/vconftool
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19 Requires(post): systemd
20 Requires(postun): systemd
21 BuildRequires: cmake
22 BuildRequires: pkgconfig(alarm-service)
23 BuildRequires: pkgconfig(appsvc)
24 BuildRequires: pkgconfig(aul)
25 BuildRequires: pkgconfig(capi-appfw-application)
26 BuildRequires: pkgconfig(contacts-service2)
27 BuildRequires: pkgconfig(db-util)
28 BuildRequires: pkgconfig(dlog)
29 BuildRequires: pkgconfig(drm-client)
30 BuildRequires: pkgconfig(glib-2.0)
31 BuildRequires: pkgconfig(libcurl)
32 BuildRequires: pkgconfig(libsystemd-daemon)
33 BuildRequires: pkgconfig(libxml-2.0)
34 BuildRequires: pkgconfig(libwbxml2)
35 BuildRequires: pkgconfig(media-thumbnail)
36 BuildRequires: pkgconfig(mm-fileinfo)
37 BuildRequires: pkgconfig(mm-player)
38 BuildRequires: pkgconfig(mm-session)
39 BuildRequires: pkgconfig(mm-sound)
40 BuildRequires: pkgconfig(network)
41 BuildRequires: pkgconfig(notification)
42 BuildRequires: pkgconfig(pmapi)
43 BuildRequires: pkgconfig(mmutil-imgp)
44 BuildRequires: pkgconfig(mmutil-jpeg)
45 BuildRequires: pkgconfig(security-server)
46 BuildRequires: pkgconfig(sensor)
47 BuildRequires: pkgconfig(svi)
48 BuildRequires: pkgconfig(tapi)
49 BuildRequires: pkgconfig(vconf)
50 BuildRequires: pkgconfig(feedback)
51 BuildRequires: pkgconfig(capi-network-connection)
52 BuildRequires: pkgconfig(libtzplatform-config)
53
54 %description
55 Description: Messaging Framework Library
56
57
58 %package devel
59 License:        Flora License v1.1
60 Summary:        Messaging Framework Library (development)
61 Requires:       %{name} = %{version}-%{release}
62 Group:          Development/Libraries
63
64 %description devel
65 Description: Messaging Framework Library (development)
66
67
68 %package tools
69 License:        Flora License v1.1
70 Summary:        Messaging server application
71 Requires:       %{name} = %{version}-%{release}
72 Group:          TO_BU / FILL_IN
73 Requires(post): /usr/bin/sqlite3
74 Requires(post): /usr/bin/vconftool
75 Requires(post): /sbin/ldconfig
76 Requires(postun): /sbin/ldconfig
77
78 %description tools
79 Description:  Messaging server application
80
81
82 %package -n sms-plugin
83 License:        Flora License v1.1
84 Summary:        SMS plugin library
85 Requires:       %{name} = %{version}-%{release}
86 Group:          System/Libraries
87 Requires(post): /sbin/ldconfig
88 Requires(postun): /sbin/ldconfig
89
90 %description -n sms-plugin
91 Description: SMS plugin library
92
93 %package -n mms-plugin
94 License:        Flora License v1.1
95 Summary:        MMS plugin library
96 Requires:       %{name} = %{version}-%{release}
97 Group:          System/Libraries
98 Requires(post): /sbin/ldconfig
99 Requires(postun): /sbin/ldconfig
100
101 %description -n mms-plugin
102 Description: MMS plugin library
103
104 %prep
105 %setup -q
106 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} %{SOURCE1005} .
107
108
109 %build
110 %cmake . \
111         -DTZ_SYS_SHARE=%TZ_SYS_SHARE \
112         -DUNITDIR_USER=%{_unitdir_user} \
113         -DTZ_SYS_SMACK=%TZ_SYS_SMACK
114
115 make %{?jobs:-j%jobs}
116
117 %install
118 rm -rf %{buildroot}
119 mkdir -p %{buildroot}/etc/config
120
121 mkdir -p %{buildroot}/var/log/msgfw
122
123 %make_install
124
125 mkdir -p %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants
126 #install -m 0644 %SOURCE101 %{buildroot}%{_unitdir_user}/
127 ln -s ../msg-service.service %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/msg-service.service
128 ln -s ../msg-service-log.service %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/msg-service-log.service
129
130 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
131 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
132 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
133 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
134
135 %if 0%{?simulator}
136 rm %{buildroot}/etc/config/sysinfo-message.xml
137 mv %{buildroot}/etc/config/sysinfo-message.emul.xml %{buildroot}/etc/config/sysinfo-message.xml
138 %else
139 rm %{buildroot}/etc/config/sysinfo-message.emul.xml
140 %endif
141
142
143 %post tools -p /sbin/ldconfig
144 %post -n sms-plugin -p /sbin/ldconfig
145 %post -n mms-plugin -p /sbin/ldconfig
146
147 %post
148 /sbin/ldconfig
149
150 /bin/systemctl daemon-reload
151 if [ "$1" = "1" ]; then
152     systemctl stop msg-service.service
153 fi
154
155 %postun -p /sbin/ldconfig
156
157 %postun tools -p /sbin/ldconfig
158 %postun -n sms-plugin -p /sbin/ldconfig
159 %postun -n mms-plugin -p /sbin/ldconfig
160
161 %files
162 %manifest %{name}.manifest
163 %license LICENSE.Flora
164 %defattr(-,root,root,-)
165 %{_libdir}/libmsg_plugin_manager.so
166 %{_libdir}/libmsg_mapi.so.*
167 %{_libdir}/libmsg_framework_handler.so
168 %{_libdir}/libmsg_transaction_manager.so
169 %{_libdir}/libmsg_utils.so
170 %{_libdir}/libmsg_transaction_proxy.so
171 %{_libdir}/libmsg_vobject.so
172 %TZ_SYS_SHARE/%{name}/msg_service-init-DB.sh
173
174 %files devel
175 %manifest %{name}-devel.manifest
176 %defattr(-,root,root,-)
177 %{_libdir}/libmsg_mapi.so
178 %{_libdir}/pkgconfig/msg-service.pc
179 %{_includedir}/msg-service/*
180
181 %files tools
182 %manifest %{name}-tools.manifest
183 %license LICENSE.Flora
184 %defattr(-,root,root,-)
185 %{_bindir}/msg-helper
186 %{_bindir}/msg-server
187 %{_datadir}/media/Sherbet.wav
188 %attr(0644,root,root)%{_datadir}/msg-service/plugin.cfg
189 %{_sysconfdir}/rc.d/init.d/msg-server
190 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
191 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
192 %{_unitdir_user}/msg-service.service
193 %{_unitdir_user}/msg-service-log.service
194 %{_unitdir_user}/tizen-middleware.target.wants/msg-service.service
195 %{_unitdir_user}/tizen-middleware.target.wants/msg-service-log.service
196 %{_sysconfdir}/config/sysinfo-message.xml
197 %attr(0755,root,%TZ_SYS_USER_GROUP) /var/log/msgfw
198
199 %files -n sms-plugin
200 %manifest sms-plugin.manifest
201 %license LICENSE.Flora
202 %defattr(-,root,root,-)
203 %{_libdir}/libmsg_sms_plugin.so
204
205 %files -n mms-plugin
206 %manifest mms-plugin.manifest
207 %license LICENSE.Flora
208 %defattr(-,root,root,-)
209 %{_libdir}/libmsg_mms_plugin.so
210
211 %changelog
212 * Wed Oct 25 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
213 - New release version
214
215 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
216 - Apply New TAPI.
217 - Modify transaction data size of sos recipient list.
218
219 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
220 - Fix contact sync defect.
221 - New MessageFW API.
222
223 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
224 - Change devman_haptic.h to devman_managed.h.
225 - Modify to set MSG_SERVER_READY before sim status check.
226 - Fix bug in sim message save related operations.
227 - Limit sim related APIs not to work on sim not available status.
228 - Modify indicator icon image path & related.
229
230 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
231 - Modify MAX_SEGMENT_NUM to 15.
232 - Modify MMplayer related to support interrupted event.
233 - Fix bug in storage change callback which could cause on submit request.
234
235 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
236 - Modify vconf key path for sos sending option.
237
238 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
239 - Storage change callback for scheduled message
240 - code chage to support glib2-2.32
241 - Apply Backup && Restore of Mms Type
242
243 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
244 - Update display time for scheduled message when it is sent.
245
246 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
247 - Comment the test app in CMakefile.
248 - Modify MMS BG color of vconf value.
249 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
250 - Add '-i' option for vconf keys of memory type
251 - Add smsc vconf keys(default value).
252 - To avoid msg incoming sound and notification on SOS
253
254 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
255 - Add '-i' option for vconf keys of memory type.
256 - Add smsc vconf keys(default value).
257 - To avoid msg incoming sound and notification on SOS state.
258 - Change BGcolor to black && font colore to white.
259
260 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
261 - Apply Mdm policy.
262 - SOS message.
263 - Fix horizontality development problem.
264 - Remove vconf key for new message count. (db/badge/com.samsung.message)
265 - Change vconf key path of "mms_send/msg_class" to private.
266
267 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
268 - Add new MAPI.
269
270 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
271 - Modify to support new DRM service.
272 - Rename private vconf keys.
273 - Modify .postinst and .spec file to pre-install used vconf keys.
274 - Remove compile warnings.
275 - Fix bug in manual retrieve operation.
276
277 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
278 - Fix DB conflict which cause db lock.
279 - Fix bug in Find My Mobile function.
280 - Add '*' and '#' symbol as valid number.
281
282 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
283 - Change mobile tracker related vconf key define values.
284 - Apply MDM policy for allowing text messaging.
285 - Fix bug for getting thumbnail path.
286 - Enable functionality of scheduled message.
287 - Change alarm setting of scheduled message from volatile type to non-volatile.
288 - Fix error in search query.
289
290 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
291 - Change some thread list related APIs to support DB change.
292 - DB change to support multiple recipient.
293
294 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
295 - Modify to manage contact sync time by vconf.
296 - Use g_idle_add() routine for updating unread message count(vconf values).
297 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
298 - Fix bug for allocated size of replacing string.
299 - Resolve search problem for special characters.
300 - add xmlFree.
301
302 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
303 - Remove unused vconf keys.
304 - Initialize SMSC selected_index.
305 - Remove systemd related.
306
307 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
308 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
309 - Fix S1-2397/2417/2418/2419.
310 - Remove sent status callback check during submit request.
311 - Modify offset and limit operation on search.
312 - Remove invalid folder and file.
313 - Change browser launching API from aul to service-capi.
314 - Remove unused file.
315 - Invalid type checking is fixed.
316
317 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
318 - Add #include <sys/stat.h> to support chmod related defines.
319 - Fix DRM content issue(unregistered mo content)
320
321 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
322 - Modify plugin configuration file location for FOTA.
323 - Remove the db query which create sample data.
324
325 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
326 - Update msg-service.spec for OBS.
327 - Fix TC execute failure.
328 - Fix S1-1419(Removed mms raw file issue after rebooting)