Sync with tizen 2.4
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        1.0.1
3 Release:        1
4 License:        Apache-2.0
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source1:        msg-server.service
9 Source2:        msg-server.socket
10
11 #%if "%{?tizen_profile_name}" == "wearable"
12 #ExcludeArch: %{arm} %ix86 x86_64
13 #%endif
14
15 Requires(post): /usr/bin/sqlite3
16 Requires(post): /usr/bin/vconftool
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19 Requires(post): systemd
20 Requires(postun): systemd
21 BuildRequires: cmake
22 BuildRequires: pkgconfig(alarm-service)
23 BuildRequires: pkgconfig(aul)
24 BuildRequires: pkgconfig(badge)
25 BuildRequires: pkgconfig(capi-appfw-application)
26 BuildRequires: pkgconfig(capi-network-connection)
27 BuildRequires: pkgconfig(capi-system-info)
28 #BuildRequires: pkgconfig(capi-telephony)
29 BuildRequires: pkgconfig(contacts-service2)
30 BuildRequires: pkgconfig(db-util)
31 BuildRequires: pkgconfig(dbus-glib-1)
32 BuildRequires: pkgconfig(deviced)
33 BuildRequires: pkgconfig(dlog)
34 BuildRequires: pkgconfig(feedback)
35 BuildRequires: pkgconfig(gio-2.0)
36 BuildRequires: pkgconfig(gobject-2.0)
37 BuildRequires: pkgconfig(iniparser)
38 BuildRequires: pkgconfig(json-glib-1.0)
39 BuildRequires: pkgconfig(lbs-dbus)
40 BuildRequires: pkgconfig(libcurl)
41 BuildRequires: pkgconfig(libsystemd-daemon)
42 BuildRequires: pkgconfig(libxml-2.0)
43 BuildRequires: pkgconfig(libwbxml2)
44 BuildRequires: pkgconfig(media-thumbnail)
45 BuildRequires: pkgconfig(mm-fileinfo)
46 BuildRequires: pkgconfig(mm-player)
47 BuildRequires: pkgconfig(mm-session)
48 BuildRequires: pkgconfig(mm-sound)
49 BuildRequires: pkgconfig(mmutil-imgp)
50 BuildRequires: pkgconfig(mmutil-jpeg)
51 BuildRequires: pkgconfig(notification)
52 BuildRequires: pkgconfig(privacy-manager-client)
53 BuildRequires: pkgconfig(secure-storage)
54 BuildRequires: pkgconfig(security-server)
55 BuildRequires: pkgconfig(sensor)
56 BuildRequires: pkgconfig(storage)
57 BuildRequires: pkgconfig(tapi)
58 BuildRequires: pkgconfig(vconf)
59
60 %description
61 Description: Messaging Framework Library
62
63
64 %package devel
65 License:        Apache-2.0
66 Summary:        Messaging Framework Library (development)
67 Requires:       %{name} = %{version}-%{release}
68 Group:          Development/Libraries
69
70 %description devel
71 Description: Messaging Framework Library (development)
72
73
74 %package tools
75 License:        Apache-2.0
76 Summary:        Messaging server application
77 Requires:       %{name} = %{version}-%{release}
78 Group:          TO_BU / FILL_IN
79 Requires(post): /usr/bin/sqlite3
80 Requires(post): /usr/bin/vconftool
81 Requires(post): /sbin/ldconfig
82 Requires(postun): /sbin/ldconfig
83
84 %description tools
85 Description:  Messaging server application
86
87
88 %package -n sms-plugin
89 License:        Apache-2.0
90 Summary:        SMS plugin library
91 Requires:       %{name} = %{version}-%{release}
92 Group:          System/Libraries
93 Requires(post): /sbin/ldconfig
94 Requires(postun): /sbin/ldconfig
95
96 %description -n sms-plugin
97 Description: SMS plugin library
98
99 %package -n mms-plugin
100 License:        Apache-2.0
101 Summary:        MMS plugin library
102 Requires:       %{name} = %{version}-%{release}
103 Group:          System/Libraries
104 Requires(post): /sbin/ldconfig
105 Requires(postun): /sbin/ldconfig
106
107 %description -n mms-plugin
108 Description: MMS plugin library
109
110 %prep
111 %setup -q
112
113 %build
114 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
115 %ifarch i586
116 -D_TIZEN_I586_ENABLED:BOOL=ON \
117 %else
118 -D_TIZEN_I586_ENABLED:BOOL=OFF \
119 %endif
120 %if 0%{?sec_product_feature_container_enable} == 1
121 -D_FEATURE_CONTAINER_ENABLE:BOOL=ON \
122 %endif
123 %if "%{?tizen_profile_name}" == "wearable"
124 -D_MSG_WEARABLE_PROFILE:BOOL=ON
125 %else
126 -D_MSG_WEARABLE_PROFILE:BOOL=OFF
127 %endif
128
129 make %{?jobs:-j%jobs}
130
131 %install
132 rm -rf %{buildroot}
133 mkdir -p %{buildroot}/usr/share/license
134 mkdir -p %{buildroot}/etc/config
135
136 %make_install
137
138 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
139 install -m 0644 %SOURCE1 %{buildroot}%{_libdir}/systemd/system/msg-server.service
140 ln -s ../msg-server.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/msg-server.service
141
142 mkdir -p %{buildroot}%{_libdir}/systemd/system/sockets.target.wants
143 install -m 0644 %SOURCE2 %{buildroot}%{_libdir}/systemd/system/msg-server.socket
144 ln -s ../msg-server.socket %{buildroot}%{_libdir}/systemd/system/sockets.target.wants/msg-server.socket
145
146 mkdir -p %{buildroot}/opt/usr/dbspace
147 sqlite3 %{buildroot}/opt/usr/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;"
148 sqlite3 %{buildroot}/opt/usr/dbspace/.msg_service.db < %{buildroot}/usr/share/msg-service/msg-service-db.sql
149
150 rm %{buildroot}/usr/share/msg-service/msg-service-db.sql
151
152 %post tools
153 /sbin/ldconfig
154
155 chown 200:5000 /opt/usr/dbspace/.msg_service.db
156 chown 200:5000 /opt/usr/dbspace/.msg_service.db-journal
157 chown 200:200 %{_libdir}/systemd/system/msg-server.socket
158
159 chmod 660 /opt/usr/dbspace/.msg_service.db
160 chmod 660 /opt/usr/dbspace/.msg_service.db-journal
161
162 if [ -f /usr/lib/rpm-plugins/msm.so ]
163 then
164         chsmack -a 'msg-service::db' /opt/usr/dbspace/.msg_service.db*
165 fi
166
167 %post -n sms-plugin -p /sbin/ldconfig
168 %post -n mms-plugin -p /sbin/ldconfig
169
170 %post
171 /sbin/ldconfig
172
173 mkdir -p /opt/usr/data/msg-service
174 chgrp db_msg_service /opt/usr/data/msg-service
175
176
177 ########## Setting Config Value (Internal keys) ##########
178 # Message Server Status
179 vconftool set -t bool memory/msg/ready 0 -i -u 200 -g 5000 -s system::vconf_inhouse
180
181 # SMS Send Options
182 vconftool set -t int db/msg/network_mode 2 -u 200 -g 5000 -s system::vconf_inhouse
183
184 # New Message Count
185 vconftool set -t int db/msg/recv_sms 0 -u 200 -g 5000 -s system::vconf_inhouse
186 vconftool set -t int db/msg/recv_mms 0 -u 200 -g 5000 -s system::vconf_inhouse
187
188 ########## Setting Config Value (Private keys) ##########
189 # General Options
190 vconftool set -t bool db/private/msg-service/general/keep_copy 1 -s msg-service::vconf -u 200 -g 5000
191 vconftool set -t bool db/private/msg-service/general/auto_erase 0 -s msg-service::vconf -u 200 -g 5000
192 vconftool set -t bool db/private/msg-service/general/block_msg 1 -s msg-service::vconf -u 200 -g 5000
193 vconftool set -t int db/private/msg-service/general/contact_sync_time 0 -s msg-service::vconf -u 200 -g 5000
194 vconftool set -t int db/private/msg-service/general/alert_rep_type 0 -s msg-service::vconf -u 200 -g 5000
195 vconftool set -t int db/private/msg-service/general/search_tags 31 -s msg-service::vconf -u 200 -g 5000
196
197 vconftool set -t int db/private/msg-service/general/page_limit 0 -s msg-service::vconf -u 200 -g 5000
198 vconftool set -t int db/private/msg-service/general/sms_mms_threshold 0 -s msg-service::vconf -u 200 -g 5000
199 vconftool set -t int db/private/msg-service/general/max_recipient 0 -s msg-service::vconf -u 200 -g 5000
200 vconftool set -t int db/private/msg-service/general/sms_storage 0 -s msg-service::vconf -u 200 -g 5000
201
202 vconftool set -t bool db/private/msg-service/general/block_unknown_msg 0 -s msg-service::vconf -u 200 -g 5000
203 vconftool set -t int db/private/msg-service/general/sms_limit 1000 -s msg-service::vconf -u 200 -g 5000
204 vconftool set -t int db/private/msg-service/general/mms_limit 100 -s msg-service::vconf -u 200 -g 5000
205 vconftool set -t bool db/private/msg-service/general/notification 1 -s msg-service::vconf -u 200 -g 5000
206 vconftool set -t bool db/private/msg-service/general/vibration 1 -s msg-service::vconf -u 200 -g 5000
207 vconftool set -t bool db/private/msg-service/general/preview 1 -s msg-service::vconf -u 200 -g 5000
208 vconftool set -t int db/private/msg-service/general/ringtone_type 0 -s msg-service::vconf -u 200 -g 5000
209 vconftool set -t string db/private/msg-service/general/ringtone_path "" -s msg-service::vconf -u 200 -g 5000
210
211 vconftool set -t string db/private/msg-service/general/ua_profile "" -s msg-service::vconf -u 200 -g 5000
212
213 vconftool set -t int db/private/msg-service/general/msg_id_counter 0 -s msg-service::vconf -u 200 -g 5000
214
215 # SMS Send Options
216 vconftool set -t int db/private/msg-service/sms_send/dcs 3 -s msg-service::vconf -u 200 -g 5000
217 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0 -s msg-service::vconf -u 200 -g 5000
218 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0 -s msg-service::vconf -u 200 -g 5000
219 vconftool set -t int db/private/msg-service/sms_send/save_storage 1 -s msg-service::vconf -u 200 -g 5000
220
221 # MMS Send Options
222 vconftool set -t int db/private/msg-service/mms_send/msg_class 0 -s msg-service::vconf -u 200 -g 5000
223 vconftool set -t int db/private/msg-service/mms_send/priority 1 -s msg-service::vconf -u 200 -g 5000
224 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0 -s msg-service::vconf -u 200 -g 5000
225 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0 -s msg-service::vconf -u 200 -g 5000
226 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0 -s msg-service::vconf -u 200 -g 5000
227 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 0 -s msg-service::vconf -u 200 -g 5000
228 vconftool set -t bool db/private/msg-service/mms_send/read_reply 0 -s msg-service::vconf -u 200 -g 5000
229 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0 -s msg-service::vconf -u 200 -g 5000
230 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0 -s msg-service::vconf -u 200 -g 5000
231 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0 -s msg-service::vconf -u 200 -g 5000
232 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1 -s msg-service::vconf -u 200 -g 5000
233 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0 -s msg-service::vconf -u 200 -g 5000
234 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0 -s msg-service::vconf -u 200 -g 5000
235 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0 -s msg-service::vconf -u 200 -g 5000
236 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0 -s msg-service::vconf -u 200 -g 5000
237 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2 -s msg-service::vconf -u 200 -g 5000
238
239 # MMS Receive Options
240 vconftool set -t int db/private/msg-service/mms_recv/home_network 0 -s msg-service::vconf -u 200 -g 5000
241 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 1 -s msg-service::vconf -u 200 -g 5000
242 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1 -s msg-service::vconf -u 200 -g 5000
243 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1 -s msg-service::vconf -u 200 -g 5000
244 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0 -s msg-service::vconf -u 200 -g 5000
245 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0 -s msg-service::vconf -u 200 -g 5000
246
247 # MMS Style Options
248 vconftool set -t int db/private/msg-service/mms_style/font_size 30 -s msg-service::vconf -u 200 -g 5000
249 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0 -s msg-service::vconf -u 200 -g 5000
250 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0 -s msg-service::vconf -u 200 -g 5000
251 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0 -s msg-service::vconf -u 200 -g 5000
252 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255 -s msg-service::vconf -u 200 -g 5000
253 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255 -s msg-service::vconf -u 200 -g 5000
254 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255 -s msg-service::vconf -u 200 -g 5000
255 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255 -s msg-service::vconf -u 200 -g 5000
256 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0 -s msg-service::vconf -u 200 -g 5000
257 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0 -s msg-service::vconf -u 200 -g 5000
258 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0 -s msg-service::vconf -u 200 -g 5000
259 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255 -s msg-service::vconf -u 200 -g 5000
260 vconftool set -t int db/private/msg-service/mms_style/page_dur 2 -s msg-service::vconf -u 200 -g 5000
261 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0 -s msg-service::vconf -u 200 -g 5000
262 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0 -s msg-service::vconf -u 200 -g 5000
263
264 # Push Msg Options
265 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1 -s msg-service::vconf -u 200 -g 5000
266 vconftool set -t int db/private/msg-service/push_msg/service_load 1 -s msg-service::vconf -u 200 -g 5000
267
268 # CB Msg Options
269 vconftool set -t bool db/private/msg-service/cb_msg/receive/1 0 -f -s msg-service::vconf -u 200 -g 5000
270 vconftool set -t bool db/private/msg-service/cb_msg/receive/2 0 -f -s msg-service::vconf -u 200 -g 5000
271 vconftool set -t bool db/private/msg-service/cb_msg/save 0 -f -s msg-service::vconf -u 200 -g 5000
272 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count/1 0 -f -s msg-service::vconf -u 200 -g 5000
273 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count/2 0 -f -s msg-service::vconf -u 200 -g 5000
274 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count/3 0 -f -s msg-service::vconf -u 200 -g 5000
275 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f -s msg-service::vconf -u 200 -g 5000
276 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0 -s msg-service::vconf -u 200 -g 5000
277 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0 -s msg-service::vconf -u 200 -g 5000
278 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0 -s msg-service::vconf -u 200 -g 5000
279 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0 -s msg-service::vconf -u 200 -g 5000
280 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0 -s msg-service::vconf -u 200 -g 5000
281 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0 -s msg-service::vconf -u 200 -g 5000
282 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0 -s msg-service::vconf -u 200 -g 5000
283 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0 -s msg-service::vconf -u 200 -g 5000
284 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0 -s msg-service::vconf -u 200 -g 5000
285
286 # Voice Mail Options
287 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number/1 "" -f -s msg-service::vconf -u 200 -g 5000
288 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count/1 0 -f -s msg-service::vconf -u 200 -g 5000
289 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_alphaid/1 "" -f -s msg-service::vconf -u 200 -g 5000
290
291 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number/2 "" -f -s msg-service::vconf -u 200 -g 5000
292 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count/2 0 -f -s msg-service::vconf -u 200 -g 5000
293 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_alphaid/2 "" -f -s msg-service::vconf -u 200 -g 5000
294
295 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number/3 "" -f -s msg-service::vconf -u 200 -g 5000
296 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count/3 0 -f -s msg-service::vconf -u 200 -g 5000
297 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_alphaid/3 "" -f -s msg-service::vconf -u 200 -g 5000
298
299 # MMS Size Options
300 vconftool set -t int db/private/msg-service/size_opt/msg_size 300 -s msg-service::vconf -u 200 -g 5000
301
302 # SIM message count
303 vconftool set -t int db/private/msg-service/sim_count/used_cnt/1 0 -f -s msg-service::vconf -u 200 -g 5000
304 vconftool set -t int db/private/msg-service/sim_count/total_cnt/1 0 -f -s msg-service::vconf -u 200 -g 5000
305 vconftool set -t int db/private/msg-service/sim_count/used_cnt/2 0 -f -s msg-service::vconf -u 200 -g 5000
306 vconftool set -t int db/private/msg-service/sim_count/total_cnt/2 0 -f -s msg-service::vconf -u 200 -g 5000
307 vconftool set -t int db/private/msg-service/sim_count/used_cnt/3 0 -f -s msg-service::vconf -u 200 -g 5000
308 vconftool set -t int db/private/msg-service/sim_count/total_cnt/3 0 -f -s msg-service::vconf -u 200 -g 5000
309
310 # SIM information
311 vconftool set -t int memory/private/msg-service/sim_changed/1 0 -i -f -s msg-service::vconf -u 200 -g 5000
312 vconftool set -t string memory/private/msg-service/sim_subs_id/1 "" -i -f -s msg-service::vconf -u 200 -g 5000
313 vconftool set -t bool memory/private/msg-service/national_sim/1 0 -i -f -s msg-service::vconf -u 200 -g 5000
314 vconftool set -t string memory/private/msg-service/msisdn/1 "" -i -f -s msg-service::vconf -u 200 -g 5000
315 vconftool set -t string memory/private/msg-service/iccid/1 "" -i -f -s msg-service::vconf -u 200 -g 5000
316
317 vconftool set -t int memory/private/msg-service/sim_changed/2 0 -i -f -s msg-service::vconf -u 200 -g 5000
318 vconftool set -t string memory/private/msg-service/sim_subs_id/2 "" -i -f -s msg-service::vconf -u 200 -g 5000
319 vconftool set -t bool memory/private/msg-service/national_sim/2 0 -i -f -s msg-service::vconf -u 200 -g 5000
320 vconftool set -t string memory/private/msg-service/msisdn/2 "" -i -f -s msg-service::vconf -u 200 -g 5000
321 vconftool set -t string memory/private/msg-service/iccid/2 "" -i -f -s msg-service::vconf -u 200 -g 5000
322
323 vconftool set -t int memory/private/msg-service/sim_changed/3 0 -i -f -s msg-service::vconf -u 200 -g 5000
324 vconftool set -t string memory/private/msg-service/sim_subs_id/3 "" -i -f -s msg-service::vconf -u 200 -g 5000
325 vconftool set -t bool memory/private/msg-service/national_sim/3 0 -i -f -s msg-service::vconf -u 200 -g 5000
326 vconftool set -t string memory/private/msg-service/msisdn/3 "" -i -f -s msg-service::vconf -u 200 -g 5000
327 vconftool set -t string memory/private/msg-service/iccid/3 "" -i -f -s msg-service::vconf -u 200 -g 5000
328 vconftool set -t int  memory/private/msg-service/default_network_sim 0 -i -f -s msg-service::vconf -u 200 -g 5000
329
330 # SST information
331 vconftool set -t bool memory/private/msg-service/sim_st/1 1 -i -f -s msg-service::vconf -u 200 -g 5000
332 vconftool set -t bool memory/private/msg-service/sim_mo_ctrl/1 0 -i -f -s msg-service::vconf -u 200 -g 5000
333
334 vconftool set -t bool memory/private/msg-service/sim_st/2 1 -i -f -s msg-service::vconf -u 200 -g 5000
335 vconftool set -t bool memory/private/msg-service/sim_mo_ctrl/2 0 -i -f -s msg-service::vconf -u 200 -g 5000
336
337 vconftool set -t bool memory/private/msg-service/sim_st/3 1 -i -f -s msg-service::vconf -u 200 -g 5000
338 vconftool set -t bool memory/private/msg-service/sim_mo_ctrl/3 0 -i -f -s msg-service::vconf -u 200 -g 5000
339
340 # Notification
341 vconftool set -t int db/private/msg-service/notification_priv_id 0 -s msg-service::vconf -u 200 -g 5000
342 vconftool set -t int db/private/msg-service/voice_noti_id1 0 -s msg-service::vconf -u 200 -g 5000
343 vconftool set -t int db/private/msg-service/voice_noti_id2 0 -s msg-service::vconf -u 200 -g 5000
344 vconftool set -t int db/private/msg-service/cb_noti_priv_id 0 -s msg-service::vconf -u 200 -g 5000
345 vconftool set -t int db/private/msg-service/sim_msg_noti_priv_id 0 -s msg-service::vconf -u 200 -g 5000
346 vconftool set -t int db/private/msg-service/emergency_noti_id 0 -s msg-service::vconf -u 200 -g 5000
347 vconftool set -t int db/private/msg-service/sentfail_noti_id 0 -s msg-service::vconf -u 200 -g 5000
348 vconftool set -t int db/private/msg-service/sim_full_noti_id 0 -s msg-service::vconf -u 200 -g 5000
349
350
351 %postun -p /sbin/ldconfig
352
353 %postun tools -p /sbin/ldconfig
354 %postun -n sms-plugin -p /sbin/ldconfig
355 %postun -n mms-plugin -p /sbin/ldconfig
356
357 %files
358 %manifest msg-service.manifest
359 %defattr(-,system,system,-)
360 %{_libdir}/libmsg_plugin_manager.so
361 %{_libdir}/libmsg_mapi.so.*
362 %{_libdir}/libmsg_framework_handler.so
363 %{_libdir}/libmsg_transaction_manager.so
364 %{_libdir}/libmsg_utils.so
365 %{_libdir}/libmsg_externals.so
366 %{_libdir}/libmsg_transaction_proxy.so
367 %{_libdir}/libmsg_vobject.so
368 /usr/share/license/msg-service/LICENSE.APLv2
369
370 %files devel
371 %defattr(-,system,system,-)
372 %{_libdir}/libmsg_mapi.so
373 %{_libdir}/pkgconfig/msg-service.pc
374 %{_includedir}/msg-service/*
375
376 %files tools
377 %manifest msg-service-tools.manifest
378 %defattr(-,system,system,-)
379 %{_bindir}/msg-server
380 %config(noreplace) /opt/usr/dbspace/.msg_service.db*
381 %{_libdir}/systemd/system/msg-server.service
382 %{_libdir}/systemd/system/multi-user.target.wants/msg-server.service
383 %{_libdir}/systemd/system/sockets.target.wants/msg-server.socket
384 %{_libdir}/systemd/system/msg-server.socket
385 /usr/share/license/msg-service/LICENSE.APLv2
386 /etc/smack/accesses.d/msg-service.rule
387 /etc/config/*
388
389 %files -n sms-plugin
390 %manifest sms-plugin.manifest
391 %defattr(-,system,system,-)
392 %{_libdir}/libmsg_sms_plugin.so
393 /usr/share/license/msg-service/LICENSE.APLv2
394
395 %files -n mms-plugin
396 %manifest mms-plugin.manifest
397 %defattr(-,system,system,-)
398 %{_libdir}/libmsg_mms_plugin.so
399 /usr/share/license/msg-service/LICENSE.APLv2
400
401 %changelog