5 Summary: Messaging Framework Library
6 Group: System/Libraries
7 Source0: %{name}-%{version}.tar.gz
8 Source101: msg-service.service
10 Requires(post): /usr/bin/sqlite3
11 Requires(post): /usr/bin/vconftool
12 Requires(post): /sbin/ldconfig
13 Requires(postun): /sbin/ldconfig
14 Requires(post): systemd
15 Requires(postun): systemd
17 BuildRequires: pkgconfig(alarm-service)
18 BuildRequires: pkgconfig(aul)
19 BuildRequires: pkgconfig(capi-appfw-application)
20 BuildRequires: pkgconfig(contacts-service)
21 BuildRequires: pkgconfig(db-util)
22 BuildRequires: pkgconfig(devman_haptic)
23 BuildRequires: pkgconfig(dlog)
24 BuildRequires: pkgconfig(drm-client)
25 BuildRequires: pkgconfig(glib-2.0)
26 BuildRequires: pkgconfig(libcurl)
27 BuildRequires: pkgconfig(libsystemd-daemon)
28 BuildRequires: pkgconfig(libxml-2.0)
29 BuildRequires: pkgconfig(libwbxml2)
30 BuildRequires: pkgconfig(media-thumbnail)
31 BuildRequires: pkgconfig(mm-fileinfo)
32 BuildRequires: pkgconfig(mm-player)
33 BuildRequires: pkgconfig(mm-session)
34 BuildRequires: pkgconfig(network)
35 BuildRequires: pkgconfig(notification)
36 BuildRequires: pkgconfig(pmapi)
37 BuildRequires: pkgconfig(mmutil-imgp)
38 BuildRequires: pkgconfig(mmutil-jpeg)
39 BuildRequires: pkgconfig(security-server)
40 BuildRequires: pkgconfig(sensor)
41 BuildRequires: pkgconfig(svi)
42 BuildRequires: pkgconfig(tapi)
43 BuildRequires: pkgconfig(vconf)
46 Description: Messaging Framework Library
50 License: Flora License v1.0
51 Summary: Messaging Framework Library (development)
52 Requires: %{name} = %{version}-%{release}
53 Group: Development/Libraries
56 Description: Messaging Framework Library (development)
60 License: Flora License v1.0
61 Summary: Messaging server application
62 Requires: %{name} = %{version}-%{release}
63 Group: TO_BU / FILL_IN
64 Requires(post): /usr/bin/sqlite3
65 Requires(post): /usr/bin/vconftool
66 Requires(post): /sbin/ldconfig
67 Requires(postun): /sbin/ldconfig
70 Description: Messaging server application
73 %package -n sms-plugin
74 License: Flora License v1.0
75 Summary: SMS plugin library
76 Requires: %{name} = %{version}-%{release}
77 Group: System/Libraries
78 Requires(post): /sbin/ldconfig
79 Requires(postun): /sbin/ldconfig
81 %description -n sms-plugin
82 Description: SMS plugin library
84 %package -n mms-plugin
85 License: Flora License v1.0
86 Summary: MMS plugin library
87 Requires: %{name} = %{version}-%{release}
88 Group: System/Libraries
89 Requires(post): /sbin/ldconfig
90 Requires(postun): /sbin/ldconfig
92 %description -n mms-plugin
93 Description: MMS plugin library
100 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
101 make %{?jobs:-j%jobs}
105 mkdir -p %{buildroot}/usr/share/license
109 mkdir -p %{buildroot}%{_libdir}/systemd/user/tizen-middleware.target.wants
110 install -m 0644 %SOURCE101 %{buildroot}%{_libdir}/systemd/user/
111 ln -s ../msg-service.service %{buildroot}%{_libdir}/systemd/user/tizen-middleware.target.wants/msg-service.service
113 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc3.d
114 ln -s %{_sysconfdir}/rc.d/init.d/msg-server %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
115 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc5.d
116 ln -s %{_sysconfdir}/rc.d/init.d/msg-server %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
118 mkdir -p %{buildroot}/opt/usr/data/msg-service
120 %post tools -p /sbin/ldconfig
121 %post -n sms-plugin -p /sbin/ldconfig
122 %post -n mms-plugin -p /sbin/ldconfig
127 if [ ! -f /opt/usr/dbspace/.msg_service.db ]
129 mkdir -p %{buildroot}/opt/usr/dbspace/
130 sqlite3 /opt/usr/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
132 CREATE TABLE MSG_CONVERSATION_TABLE ( CONV_ID INTEGER NOT NULL , UNREAD_CNT INTEGER DEFAULT 0 , SMS_CNT INTEGER DEFAULT 0 , MMS_CNT INTEGER DEFAULT 0 , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , MSG_DIRECTION INTEGER NOT NULL , DISPLAY_TIME INTEGER , DISPLAY_NAME TEXT , MSG_TEXT TEXT );
133 CREATE TABLE MSG_ADDRESS_TABLE ( ADDRESS_ID INTEGER PRIMARY KEY , CONV_ID INTEGER NOT NULL , ADDRESS_TYPE INTEGER , RECIPIENT_TYPE INTEGER , ADDRESS_VAL TEXT , CONTACT_ID INTEGER , DISPLAY_NAME TEXT , FIRST_NAME TEXT , LAST_NAME TEXT , IMAGE_PATH TEXT , SYNC_TIME DATETIME , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
134 CREATE TABLE MSG_FOLDER_TABLE ( FOLDER_ID INTEGER PRIMARY KEY , FOLDER_NAME TEXT NOT NULL , FOLDER_TYPE INTEGER DEFAULT 0 );
135 CREATE TABLE MSG_MESSAGE_TABLE ( MSG_ID INTEGER PRIMARY KEY , CONV_ID INTEGER NOT NULL , FOLDER_ID INTEGER NOT NULL , STORAGE_ID INTEGER NOT NULL , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , DISPLAY_TIME DATETIME , DATA_SIZE INTEGER DEFAULT 0 , NETWORK_STATUS INTEGER DEFAULT 0 , READ_STATUS INTEGER DEFAULT 0 , PROTECTED INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , MSG_DIRECTION INTEGER NOT NULL , SCHEDULED_TIME DATETIME , BACKUP INTEGER DEFAULT 0 , SUBJECT TEXT , MSG_DATA TEXT , THUMB_PATH TEXT , MSG_TEXT TEXT , ATTACHMENT_COUNT INTEGER DEFAULT 0 , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) , FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
136 CREATE TABLE MSG_SIM_TABLE ( MSG_ID INTEGER , SIM_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
137 CREATE TABLE MSG_PUSH_TABLE ( MSG_ID INTEGER , ACTION INTEGER , CREATED INTEGER , EXPIRES INTEGER , ID TEXT , HREF TEXT , CONTENT TEXT , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
138 CREATE TABLE MSG_CBMSG_TABLE ( MSG_ID INTEGER , CB_MSG_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
139 CREATE TABLE MSG_SYNCML_TABLE ( MSG_ID INTEGER , EXT_ID INTEGER NOT NULL , PINCODE INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
140 CREATE TABLE MSG_SMS_SENDOPT_TABLE ( MSG_ID INTEGER , DELREP_REQ INTEGER NOT NULL , KEEP_COPY INTEGER NOT NULL , REPLY_PATH INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
141 CREATE TABLE MSG_FILTER_TABLE ( FILTER_ID INTEGER PRIMARY KEY , FILTER_TYPE INTEGER NOT NULL , FILTER_VALUE TEXT NOT NULL , FILTER_ACTIVE INTEGER DEFAULT 0);
142 CREATE TABLE MSG_MMS_MESSAGE_TABLE ( MSG_ID INTEGER , TRANSACTION_ID TEXT , MESSAGE_ID TEXT , FWD_MESSAGE_ID TEXT , CONTENTS_LOCATION TEXT , FILE_PATH TEXT , VERSION INTEGER NOT NULL , DATA_TYPE INTEGER DEFAULT -1 , DATE DATETIME , HIDE_ADDRESS INTEGER DEFAULT 0 , ASK_DELIVERY_REPORT INTEGER DEFAULT 0 , REPORT_ALLOWED INTEGER DEFAULT 0 , READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 , ASK_READ_REPLY INTEGER DEFAULT 0 , READ INTEGER DEFAULT 0 , READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 , READ_REPORT_SENT INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , KEEP_COPY INTEGER DEFAULT 0 , MSG_SIZE INTEGER NOT NULL , MSG_CLASS INTEGER DEFAULT -1 , EXPIRY_TIME DATETIME , CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 , DELIVERY_TIME DATETIME , MSG_STATUS INTEGER DEFAULT -1 , FOREIGN KEY (MSG_ID) REFERENCES MSG_MESSAGE_TABLE (MSG_ID) );
143 CREATE TABLE MSG_MMS_PREVIEW_INFO_TABLE ( MSG_ID INTEGER, TYPE INTEGER, VALUE TEXT, COUNT INTEGER, PRIMARY KEY (MSG_ID, TYPE) ON CONFLICT REPLACE FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) ON DELETE CASCADE);
144 CREATE TABLE MSG_REPORT_TABLE ( MSG_ID INTEGER , ADDRESS_VAL TEXT , STATUS_TYPE INTEGER , STATUS INTEGER DEFAULT 0 , TIME DATETIME);
145 CREATE TABLE MSG_PUSHCFG_TABLE ( PUSH_ID INTEGER , CONTENT_TYPE TEXT, APP_ID TEXT, PKG_NAME TEXT, LAUNCH INTEGER, APPCODE INTEGER, SECURE INTEGER);
147 CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
148 CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
149 CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
151 INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
152 INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
153 INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
154 INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
155 INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
156 INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
157 INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
158 INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);
160 INSERT INTO MSG_PUSHCFG_TABLE VALUES (1, 'text/vnd.wap.si', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 1, 0);
161 INSERT INTO MSG_PUSHCFG_TABLE VALUES (2, 'application/vnd.wap.sic', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 2, 0);
162 INSERT INTO MSG_PUSHCFG_TABLE VALUES (3, 'text/vnd.wap.sl', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 3, 0);
163 INSERT INTO MSG_PUSHCFG_TABLE VALUES (4, 'application/vnd.wap.slc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 4, 0);
164 INSERT INTO MSG_PUSHCFG_TABLE VALUES (5, 'text/vnd.wap.co', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 5, 0);
166 INSERT INTO MSG_PUSHCFG_TABLE VALUES (6, 'application/vnd.wap.coc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 6, 0);
167 INSERT INTO MSG_PUSHCFG_TABLE VALUES (7, 'application/vnd.wap.mms-message', 'X-Wap-Application-Id: x-wap-application:mms.ua', '', 0, 7, 0);
168 INSERT INTO MSG_PUSHCFG_TABLE VALUES (8, 'application/vnd.wap.sia', 'X-Wap-Application-Id: x-wap-application:push.sia', '', 0, 8, 0);
169 INSERT INTO MSG_PUSHCFG_TABLE VALUES (9, 'application/vnd.syncml.dm+wbxml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 9, 0);
170 INSERT INTO MSG_PUSHCFG_TABLE VALUES (10, 'application/vnd.syncml.dm+xml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 10, 0);
172 INSERT INTO MSG_PUSHCFG_TABLE VALUES (11, 'application/vnd.syncml.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 11, 0);
173 INSERT INTO MSG_PUSHCFG_TABLE VALUES (12, 'application/vnd.syncml.ds.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.ds', '', 0, 12, 0);
174 INSERT INTO MSG_PUSHCFG_TABLE VALUES (13, 'application/vnd.syncml+wbxml', 'X-Wap-Application-Id:x-wap-application:push.syncml', '', 0, 13, 0);
175 INSERT INTO MSG_PUSHCFG_TABLE VALUES (14, 'application/vnd.wap.locc+wbxml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 14, 0);
176 INSERT INTO MSG_PUSHCFG_TABLE VALUES (15, 'application/vnd.wap.loc+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 15, 0);
178 INSERT INTO MSG_PUSHCFG_TABLE VALUES (16, 'application/vnd.oma.dd+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 16, 0);
179 INSERT INTO MSG_PUSHCFG_TABLE VALUES (17, 'application/vnd.oma.drm.message', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 17, 0);
180 INSERT INTO MSG_PUSHCFG_TABLE VALUES (18, 'application/vnd.oma.drm.content', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 18, 0);
181 INSERT INTO MSG_PUSHCFG_TABLE VALUES (19, 'application/vnd.oma.drm.rights+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 19, 0);
182 INSERT INTO MSG_PUSHCFG_TABLE VALUES (20, 'application/vnd.oma.drm.rights+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 20, 0);
184 INSERT INTO MSG_PUSHCFG_TABLE VALUES (21, 'application/vnd.oma.drm.ro+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 21, 0);
185 INSERT INTO MSG_PUSHCFG_TABLE VALUES (22, 'application/vnd.oma.drm.roap-pdu+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 22, 0);
186 INSERT INTO MSG_PUSHCFG_TABLE VALUES (23, 'application/vnd.oma.drm.roap-trigger+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 23, 0);
187 INSERT INTO MSG_PUSHCFG_TABLE VALUES (24, 'application/vnd.oma.drm.roap-trigger+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 24, 0);
188 INSERT INTO MSG_PUSHCFG_TABLE VALUES (25, 'text/vnd.wap.connectivity-xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 26, 0);
190 INSERT INTO MSG_PUSHCFG_TABLE VALUES (26, 'application/vnd.wap.connectivity-wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 27, 0);
191 INSERT INTO MSG_PUSHCFG_TABLE VALUES (27, 'application/x-wap-prov.browser-settings', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 28, 0);
192 INSERT INTO MSG_PUSHCFG_TABLE VALUES (28, 'application/x-wap-prov.browser-bookmarks', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 29, 0);
193 INSERT INTO MSG_PUSHCFG_TABLE VALUES (29, 'application/x-wap-prov.syncset+xml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 30, 0);
194 INSERT INTO MSG_PUSHCFG_TABLE VALUES (30, 'application/x-wap-prov.syncset+wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 31, 0);
196 INSERT INTO MSG_PUSHCFG_TABLE VALUES (31, 'text/vnd.wap.emn+xml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 32, 0);
197 INSERT INTO MSG_PUSHCFG_TABLE VALUES (32, 'application/vnd.wap.emn+wbxml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 33, 0);
198 INSERT INTO MSG_PUSHCFG_TABLE VALUES (33, 'application/vnd.wv.csp.cir', 'X-Wap-Application-Id: x-wap-application:wv.ua', '', 0, 34, 0);
199 INSERT INTO MSG_PUSHCFG_TABLE VALUES (34, 'application/vnd.omaloc-supl-init', 'X-Wap-Application-Id: x-oma-application:ulp.ua', '', 0, 44, 0);
200 INSERT INTO MSG_PUSHCFG_TABLE VALUES (35, 'application/vnd.wap.emn+wbxml', 'X-oma-docomo:xmd.mail.ua', '', 0, 45, 1);"
203 chown :6011 /opt/usr/dbspace/.msg_service.db
204 chown :6011 /opt/usr/dbspace/.msg_service.db-journal
205 chmod 660 /opt/usr/dbspace/.msg_service.db
206 chmod 660 /opt/usr/dbspace/.msg_service.db-journal
207 mkdir -p /opt/usr/data/msg-service
208 chgrp db_msg_service /opt/usr/data/msg-service
210 ########## Setting Config Value (Internal keys) ##########
212 # Message Server Status
213 vconftool set -t bool memory/msg/ready 0 -i -g 5000 -u $vcuid
216 vconftool set -t int db/msg/network_mode 2 -u $vcuid
219 vconftool set -t int db/msg/recv_sms 0 -u $vcuid
220 vconftool set -t int db/msg/recv_mms 0 -u $vcuid
222 ########## Setting Config Value (Private keys) ##########
224 vconftool set -t bool db/private/msg-service/general/keep_copy 1 -u $vcuid
225 vconftool set -t bool db/private/msg-service/general/auto_erase 0 -u $vcuid
226 vconftool set -t bool db/private/msg-service/general/block_msg 0 -u $vcuid
227 vconftool set -t int db/private/msg-service/general/contact_sync_time 0 -u $vcuid
230 vconftool set -t int db/private/msg-service/sms_send/dcs 3 -u $vcuid
231 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0 -u $vcuid
232 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0 -u $vcuid
233 vconftool set -t int db/private/msg-service/sms_send/save_storage 1 -u $vcuid
236 vconftool set -t int db/private/msg-service/smsc/total_count 1 -u $vcuid
237 vconftool set -t int db/private/msg-service/smsc/selected 0 -u $vcuid
239 vconftool set -t int db/private/msg-service/smsc/pid/0 1 -u $vcuid
240 vconftool set -t int db/private/msg-service/smsc/val_period/0 255 -u $vcuid
241 vconftool set -t string db/private/msg-service/smsc/name/0 "" -u $vcuid
242 vconftool set -t int db/private/msg-service/smsc/ton/0 1 -u $vcuid
243 vconftool set -t int db/private/msg-service/smsc/npi/0 1 -u $vcuid
244 vconftool set -t string db/private/msg-service/smsc/address/0 "" -u $vcuid
246 vconftool set -t int db/private/msg-service/smsc/pid/1 0 -u $vcuid
247 vconftool set -t int db/private/msg-service/smsc/val_period/1 0 -u $vcuid
248 vconftool set -t string db/private/msg-service/smsc/name/1 "" -u $vcuid
249 vconftool set -t int db/private/msg-service/smsc/ton/1 0 -u $vcuid
250 vconftool set -t int db/private/msg-service/smsc/npi/1 0 -u $vcuid
251 vconftool set -t string db/private/msg-service/smsc/address/1 "" -u $vcuid
253 vconftool set -t int db/private/msg-service/smsc/pid/2 0 -u $vcuid
254 vconftool set -t int db/private/msg-service/smsc/val_period/2 0 -u $vcuid
255 vconftool set -t string db/private/msg-service/smsc/name/2 "" -u $vcuid
256 vconftool set -t int db/private/msg-service/smsc/ton/2 0 -u $vcuid
257 vconftool set -t int db/private/msg-service/smsc/npi/2 0 -u $vcuid
258 vconftool set -t string db/private/msg-service/smsc/address/2 "" -u $vcuid
261 vconftool set -t int db/private/msg-service/mms_send/msg_class 0 -u $vcuid
262 vconftool set -t int db/private/msg-service/mms_send/priority 1 -u $vcuid
263 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0 -u $vcuid
264 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0 -u $vcuid
265 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0 -u $vcuid
266 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1 -u $vcuid
267 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1 -u $vcuid
268 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0 -u $vcuid
269 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0 -u $vcuid
270 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0 -u $vcuid
271 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1 -u $vcuid
272 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0 -u $vcuid
273 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0 -u $vcuid
274 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0 -u $vcuid
275 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0 -u $vcuid
276 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2 -u $vcuid
278 # MMS Receive Options
279 vconftool set -t int db/private/msg-service/mms_recv/home_network 0 -u $vcuid
280 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0 -u $vcuid
281 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1 -u $vcuid
282 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1 -u $vcuid
283 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0 -u $vcuid
284 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0 -u $vcuid
286 # MMS Receive Options
287 vconftool set -t int db/private/msg-service/mms_style/font_size 30 -u $vcuid
288 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0 -u $vcuid
289 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0 -u $vcuid
290 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0 -u $vcuid
291 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255 -u $vcuid
292 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255 -u $vcuid
293 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255 -u $vcuid
294 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255 -u $vcuid
295 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0 -u $vcuid
296 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0 -u $vcuid
297 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0 -u $vcuid
298 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255 -u $vcuid
299 vconftool set -t int db/private/msg-service/mms_style/page_dur 2 -u $vcuid
300 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0 -u $vcuid
301 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0 -u $vcuid
304 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1 -u $vcuid
305 vconftool set -t int db/private/msg-service/push_msg/service_load 1 -u $vcuid
308 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f -u $vcuid
309 vconftool set -t bool db/private/msg-service/cb_msg/save 1 -f -u $vcuid
310 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0 -u $vcuid
311 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0 -u $vcuid
312 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f -u $vcuid
313 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0 -u $vcuid
314 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0 -u $vcuid
315 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0 -u $vcuid
316 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0 -u $vcuid
317 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0 -u $vcuid
318 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0 -u $vcuid
319 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0 -u $vcuid
320 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0 -u $vcuid
321 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0 -u $vcuid
324 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number "5500" -f -u $vcuid
325 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count 0 -u $vcuid
328 vconftool set -t int db/private/msg-service/size_opt/msg_size 300 -u $vcuid
331 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0 -u $vcuid
332 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0 -u $vcuid
335 vconftool set -t int memory/private/msg-service/sim_changed 0 -i -u $vcuid
336 vconftool set -t string memory/private/msg-service/sim_imsi "" -i -u $vcuid
337 vconftool set -t bool memory/private/msg-service/national_sim 0 -i -u $vcuid
340 /bin/systemctl daemon-reload
341 if [ "$1" = "1" ]; then
342 systemctl stop msg-service.service
346 /bin/systemctl daemon-reload
347 if [ "$1" = "1" ]; then
348 systemctl stop msg-service.service
351 %postun -p /sbin/ldconfig
353 %postun tools -p /sbin/ldconfig
354 %postun -n sms-plugin -p /sbin/ldconfig
355 %postun -n mms-plugin -p /sbin/ldconfig
358 %manifest msg-service.manifest
359 %defattr(-,root,root,-)
360 %dir %attr(775,root,db_msg_service) /opt/usr/data/msg-service
361 %{_libdir}/libmsg_plugin_manager.so
362 %{_libdir}/libmsg_mapi.so.*
363 %{_libdir}/libmsg_framework_handler.so
364 %{_libdir}/libmsg_transaction_manager.so
365 %{_libdir}/libmsg_utils.so
366 %{_libdir}/libmsg_transaction_proxy.so
367 /usr/share/license/msg-service/LICENSE
370 %defattr(-,root,root,-)
371 %{_libdir}/libmsg_mapi.so
372 %{_libdir}/pkgconfig/msg-service.pc
373 %{_includedir}/msg-service/*
376 %manifest msg-service-tools.manifest
377 %defattr(-,root,root,-)
378 %{_bindir}/msg-helper
379 %{_bindir}/msg-server
380 %{_datadir}/media/Sherbet.wav
381 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
382 %{_sysconfdir}/rc.d/init.d/msg-server
383 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
384 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
385 %{_libdir}/systemd/user/msg-service.service
386 %{_libdir}/systemd/user/tizen-middleware.target.wants/msg-service.service
387 /usr/share/license/msg-service/LICENSE
390 %manifest sms-plugin.manifest
391 %defattr(-,root,root,-)
392 %{_libdir}/libmsg_sms_plugin.so
393 /usr/share/license/msg-service/LICENSE
396 %manifest mms-plugin.manifest
397 %defattr(-,root,root,-)
398 %{_libdir}/libmsg_mms_plugin.so
399 %{_libdir}/libmsg_mms_language_pack.so
400 /usr/share/license/msg-service/LICENSE
403 * Wed Oct 25 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
404 - New release version
406 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
408 - Modify transaction data size of sos recipient list.
410 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
411 - Fix contact sync defect.
414 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
415 - Change devman_haptic.h to devman_managed.h.
416 - Modify to set MSG_SERVER_READY before sim status check.
417 - Fix bug in sim message save related operations.
418 - Limit sim related APIs not to work on sim not available status.
419 - Modify indicator icon image path & related.
421 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
422 - Modify MAX_SEGMENT_NUM to 15.
423 - Modify MMplayer related to support interrupted event.
424 - Fix bug in storage change callback which could cause on submit request.
426 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
427 - Modify vconf key path for sos sending option.
429 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
430 - Storage change callback for scheduled message
431 - code chage to support glib2-2.32
432 - Apply Backup && Restore of Mms Type
434 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
435 - Update display time for scheduled message when it is sent.
437 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
438 - Comment the test app in CMakefile.
439 - Modify MMS BG color of vconf value.
440 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
441 - Add '-i' option for vconf keys of memory type
442 - Add smsc vconf keys(default value).
443 - To avoid msg incoming sound and notification on SOS
445 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
446 - Add '-i' option for vconf keys of memory type.
447 - Add smsc vconf keys(default value).
448 - To avoid msg incoming sound and notification on SOS state.
449 - Change BGcolor to black && font colore to white.
451 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
454 - Fix horizontality development problem.
455 - Remove vconf key for new message count. (db/badge/com.samsung.message)
456 - Change vconf key path of "mms_send/msg_class" to private.
458 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
461 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
462 - Modify to support new DRM service.
463 - Rename private vconf keys.
464 - Modify .postinst and .spec file to pre-install used vconf keys.
465 - Remove compile warnings.
466 - Fix bug in manual retrieve operation.
468 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
469 - Fix DB conflict which cause db lock.
470 - Fix bug in Find My Mobile function.
471 - Add '*' and '#' symbol as valid number.
473 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
474 - Change mobile tracker related vconf key define values.
475 - Apply MDM policy for allowing text messaging.
476 - Fix bug for getting thumbnail path.
477 - Enable functionality of scheduled message.
478 - Change alarm setting of scheduled message from volatile type to non-volatile.
479 - Fix error in search query.
481 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
482 - Change some thread list related APIs to support DB change.
483 - DB change to support multiple recipient.
485 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
486 - Modify to manage contact sync time by vconf.
487 - Use g_idle_add() routine for updating unread message count(vconf values).
488 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
489 - Fix bug for allocated size of replacing string.
490 - Resolve search problem for special characters.
493 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
494 - Remove unused vconf keys.
495 - Initialize SMSC selected_index.
496 - Remove systemd related.
498 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
499 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
500 - Fix S1-2397/2417/2418/2419.
501 - Remove sent status callback check during submit request.
502 - Modify offset and limit operation on search.
503 - Remove invalid folder and file.
504 - Change browser launching API from aul to service-capi.
505 - Remove unused file.
506 - Invalid type checking is fixed.
508 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
509 - Add #include <sys/stat.h> to support chmod related defines.
510 - Fix DRM content issue(unregistered mo content)
512 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
513 - Modify plugin configuration file location for FOTA.
514 - Remove the db query which create sample data.
516 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
517 - Update msg-service.spec for OBS.
518 - Fix TC execute failure.
519 - Fix S1-1419(Removed mms raw file issue after rebooting)